Table of Contents

Copyright and Trademark Information

Disclaimer Notice

U.S. Government Rights

Third-Party Software

Introduction to the ANSYS CFX Tutorials

Overview ................................................................. 1
Setting the Working Directory .................................... 1
Changing the Display Colors ...................................... 2

Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode

Introduction ................................................................ 3
Before You Begin ...................................................... 4
Tutorial 1 Features .................................................... 4
Overview of the Problem to Solve ............................... 5
Defining a Simulation in ANSYS CFX-Pre .................... 6
Obtaining a Solution Using ANSYS CFX-Solver Manager 12
Viewing the Results in ANSYS CFX-Post .................... 15

Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench

Introduction .............................................................. 31
Before You Begin ...................................................... 32
Tutorial 1a Features .................................................. 32
# Table of Contents: Tutorial 2: Flow in a Static Mixer (Refined Mesh)

Overview of the Problem to Solve ................................................................. 33
Defining a Simulation in ANSYS CFX-Pre .................................................... 34
Obtaining a Solution Using ANSYS CFX-Solver Manager .......................... 41
Viewing the Results in ANSYS CFX-Post ................................................... 43

## Tutorial 2:
### Flow in a Static Mixer (Refined Mesh)

Introduction ..................................................................................................... 59
Tutorial 2 Features .......................................................................................... 60
Overview of the Problem to Solve .................................................................. 60
Defining a Simulation using General Mode in ANSYS CFX-Pre ................... 61
Obtaining a Solution Using Interpolation with ANSYS CFX-Solver Manager 66
Viewing the Results in ANSYS CFX-Post ................................................... 68

## Tutorial 3:
### Flow in a Process Injection Mixing Pipe

Introduction ..................................................................................................... 77
Tutorial 3 Features .......................................................................................... 78
Overview of the Problem to Solve .................................................................. 78
Defining a Simulation using General Mode in ANSYS CFX-Pre ................... 79
Obtaining a Solution Using ANSYS CFX-Solver Manager .......................... 87
Viewing the Results in ANSYS CFX-Post ................................................... 88

## Tutorial 4:
### Flow from a Circular Vent

Introduction ..................................................................................................... 93
Tutorial 4 Features .......................................................................................... 94
Overview of the Problem to Solve .................................................................. 95
Defining a Steady-State Simulation in ANSYS CFX-Pre ............................... 95
Obtaining a Solution to the Steady-State Problem .................................... 99
Defining a Transient Simulation in ANSYS CFX-Pre .................................. 100
Obtaining a Solution to the Transient Problem ........................................ 104
Viewing the Results in ANSYS CFX-Post ................................................... 105

## Tutorial 5:
### Flow Around a Blunt Body

Introduction ..................................................................................................... 109
Tutorial 5 Features .......................................................................................... 109
Overview of the Problem to Solve .................................................................. 111
Defining a Simulation in ANSYS CFX-Pre ................................................... 111
## Tutorial 6: Buoyant Flow in a Partitioned Cavity

- Introduction .................................................. 127
- Tutorial 6 Features ........................................ 128
- Overview of the Problem to Solve ..................... 128
- Defining a Simulation in ANSYS CFX-Pre ............. 129
- Obtaining a Solution using ANSYS CFX-Solver Manager .................................................. 134
- Viewing the Results in ANSYS CFX-Post ............. 135

## Tutorial 7: Free Surface Flow Over a Bump

- Introduction .................................................. 139
- Tutorial 7 Features ........................................ 139
- Overview of the Problem to Solve ..................... 140
- Defining a Simulation in ANSYS CFX-Pre ............. 141
- Obtaining a Solution using ANSYS CFX-Solver Manager .................................................. 148
- Viewing the Results in ANSYS CFX-Post ............. 149
- Using a Supercritical Outlet Condition ............... 154

## Tutorial 8: Supersonic Flow Over a Wing

- Introduction .................................................. 155
- Tutorial 8 Features ........................................ 155
- Overview of the Problem to Solve ..................... 157
- Defining a Simulation in ANSYS CFX-Pre ............. 157
- Obtaining a Solution using ANSYS CFX-Solver Manager .................................................. 162
- Viewing the Results in ANSYS CFX-Post ............. 162

## Tutorial 9: Flow Through a Butterfly Valve

- Introduction .................................................. 165
- Tutorial 9 Features ........................................ 165
- Overview of the Problem to Solve ..................... 166
- Defining a Simulation in ANSYS CFX-Pre ............. 167
- Obtaining a Solution using ANSYS CFX-Solver Manager .................................................. 180
- Viewing the Results in ANSYS CFX-Post ............. 180

## Tutorial 10:
## Table of Contents: Tutorial 11: Non-Newtonian Fluid Flow in an Annulus

### Flow in a Catalytic Converter

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>185</td>
</tr>
<tr>
<td>Tutorial 10 Features</td>
<td>185</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>186</td>
</tr>
<tr>
<td>Defining a Simulation in ANSYS CFX-Pre</td>
<td>187</td>
</tr>
<tr>
<td>Obtaining a Solution using ANSYS CFX-Solver Manager</td>
<td>193</td>
</tr>
<tr>
<td>Viewing the Results in ANSYS CFX-Post</td>
<td>194</td>
</tr>
</tbody>
</table>

### Tutorial 11: Non-Newtonian Fluid Flow in an Annulus

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>199</td>
</tr>
<tr>
<td>Tutorial 11 Features</td>
<td>200</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>201</td>
</tr>
<tr>
<td>Defining a Simulation in ANSYS CFX-Pre</td>
<td>201</td>
</tr>
<tr>
<td>Obtaining a Solution using ANSYS CFX-Solver Manager</td>
<td>205</td>
</tr>
<tr>
<td>Viewing the Results in ANSYS CFX-Post</td>
<td>206</td>
</tr>
</tbody>
</table>

### Tutorial 12: Flow in an Axial Rotor/Stator

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>207</td>
</tr>
<tr>
<td>Tutorial 12 Features</td>
<td>208</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>209</td>
</tr>
<tr>
<td>Defining a Frozen Rotor Simulation in ANSYS CFX-Pre</td>
<td>210</td>
</tr>
<tr>
<td>Obtaining a Solution to the Frozen Rotor Model</td>
<td>214</td>
</tr>
<tr>
<td>Viewing the Frozen Rotor Results in ANSYS CFX-Post</td>
<td>215</td>
</tr>
<tr>
<td>Setting up a Transient Rotor-Stator Calculation</td>
<td>216</td>
</tr>
<tr>
<td>Obtaining a Solution to the Transient Rotor-Stator Model</td>
<td>219</td>
</tr>
<tr>
<td>Viewing the Transient Rotor-Stator Results in ANSYS CFX-Post</td>
<td>220</td>
</tr>
</tbody>
</table>

### Tutorial 13: Reacting Flow in a Mixing Tube

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>223</td>
</tr>
<tr>
<td>Tutorial 13 Features</td>
<td>223</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>224</td>
</tr>
<tr>
<td>Outline of the Process</td>
<td>224</td>
</tr>
<tr>
<td>Defining a Simulation in ANSYS CFX-Pre</td>
<td>224</td>
</tr>
<tr>
<td>Obtaining a Solution using ANSYS CFX-Solver Manager</td>
<td>225</td>
</tr>
<tr>
<td>Viewing the Results in ANSYS CFX-Post</td>
<td>227</td>
</tr>
</tbody>
</table>

### Tutorial 14:
Table of Contents: Tutorial 15: Multiphase Flow in Mixing Vessel

Conjugate Heat Transfer in a Heating Coil

Introduction ................................................................. 239
Tutorial 14 Features .................................................... 240
Overview of the Problem to Solve .................................. 241
Defining a Simulation in ANSYS CFX-Pre ......................... 241
Obtaining a Solution using ANSYS CFX-Solver Manager .... 246
Viewing the Results in ANSYS CFX-Post ......................... 246
Exporting the Results to ANSYS .................................... 247

Tutorial 15:
Multiphase Flow in Mixing Vessel

Introduction ................................................................. 251
Tutorial 15 Features .................................................... 252
Overview of the Problem to Solve .................................. 253
Defining a Simulation in ANSYS CFX-Pre ......................... 253
Obtaining a Solution using ANSYS CFX-Solver Manager .... 265
Viewing the Results in ANSYS CFX-Post ......................... 265

Tutorial 16:
Gas-Liquid Flow in an Airlift Reactor

Introduction ................................................................. 269
Tutorial 16 Features .................................................... 270
Overview of the Problem to Solve .................................. 270
Defining a Simulation in ANSYS CFX-Pre ......................... 271
Obtaining a Solution using ANSYS CFX-Solver Manager .... 277
Viewing the Results in ANSYS CFX-Post ......................... 278
Additional Fine Mesh Simulation Results ......................... 280

Tutorial 17:
Air Conditioning Simulation

Introduction ................................................................. 283
Tutorial 17 Features .................................................... 284
Overview of the Problem to Solve .................................. 285
Defining a Simulation in ANSYS CFX-Pre ......................... 285
Obtaining a Solution using ANSYS CFX-Solver Manager .... 295
Viewing the Results in ANSYS CFX-Post ......................... 295

Tutorial 18:
Combustion and Radiation in a Can Combustor

Introduction ................................................................. 299
### Table of Contents: Tutorial 19: Cavitation Around a Hydrofoil

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tutorial 18 Features</td>
<td>300</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>301</td>
</tr>
<tr>
<td>Using Eddy Dissipation and P1 Models</td>
<td>301</td>
</tr>
<tr>
<td>Defining a Simulation in ANSYS CFX-Pre</td>
<td>302</td>
</tr>
<tr>
<td>Obtaining a Solution using ANSYS CFX-Solver Manager</td>
<td>307</td>
</tr>
<tr>
<td>Viewing the Results in ANSYS CFX-Post</td>
<td>308</td>
</tr>
<tr>
<td>Laminar Flamelet and Discrete Transfer Models</td>
<td>311</td>
</tr>
<tr>
<td>Further Postprocessing</td>
<td>316</td>
</tr>
</tbody>
</table>

### Tutorial 19: Cavitation Around a Hydrofoil

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>317</td>
</tr>
<tr>
<td>Tutorial 19 Features</td>
<td>318</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>319</td>
</tr>
<tr>
<td>Creating an Initial Simulation</td>
<td>319</td>
</tr>
<tr>
<td>Obtaining an Initial Solution using ANSYS CFX-Solver Manager</td>
<td>323</td>
</tr>
<tr>
<td>Viewing the Results of the Initial Simulation</td>
<td>324</td>
</tr>
<tr>
<td>Preparing a Simulation with Cavitation</td>
<td>326</td>
</tr>
<tr>
<td>Obtaining a Cavitation Solution using ANSYS CFX-Solver Manager</td>
<td>328</td>
</tr>
<tr>
<td>Viewing the Results of the Cavitation Simulation</td>
<td>328</td>
</tr>
</tbody>
</table>

### Tutorial 20: Fluid Structure Interaction and Mesh Deformation

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>331</td>
</tr>
<tr>
<td>Tutorial 20 Features</td>
<td>332</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>333</td>
</tr>
<tr>
<td>Using CEL Expressions to Govern Mesh Deformation</td>
<td>334</td>
</tr>
<tr>
<td>Using a Junction Box Routine to Govern Mesh Deformation</td>
<td>343</td>
</tr>
</tbody>
</table>

### Tutorial 21: Oscillating Plate with Two-Way Fluid-Structure Interaction

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>353</td>
</tr>
<tr>
<td>Tutorial 21 Features</td>
<td>354</td>
</tr>
<tr>
<td>Overview of the Problem to Solve</td>
<td>354</td>
</tr>
<tr>
<td>Setting up the Solid Physics in Simulation (ANSYS Workbench)</td>
<td>355</td>
</tr>
<tr>
<td>Setting up the Fluid Physics and ANSYS Multi-field Settings in ANSYS CFX-Pre</td>
<td>358</td>
</tr>
<tr>
<td>Obtaining a Solution using ANSYS CFX-Solver Manager</td>
<td>364</td>
</tr>
<tr>
<td>Viewing Results in ANSYS CFX-Post</td>
<td>365</td>
</tr>
</tbody>
</table>

### Tutorial 22:
Tutorial 23: Aerodynamic & Structural Performance of a Centrifugal Compressor

Introduction ................................................................. 395
Tutorial 23 Features ...................................................... 396
Overview of the Problem to Solve .............................. 397
Reviewing the Centrifugal Compressor Design ............... 397
Creating the Mesh in ANSYS TurboGrid ...................... 398
Defining the Aerodynamic Simulation in ANSYS CFX-Pre . 401
Obtaining a Solution using ANSYS CFX-Solver Manager .... 403
Viewing the Results in ANSYS CFX-Post .................... 404
Importing Geometry into DesignModeler ................... 405
Simulating Structural Stresses Due to Pressure Loads .... 406
Simulating Structural Stresses Due to Rotation ............ 407
Introduction to the ANSYS CFX Tutorials

Overview

These tutorials are designed to introduce general techniques used in ANSYS CFX and provide tips on advanced modeling.

Earlier tutorials introduce general principles used in ANSYS CFX, including setting up the physical models, running ANSYS CFX-Solver and visualizing the results. The remaining tutorials highlight specialized features of ANSYS CFX.

Files required to complete each tutorial is listed in the introduction to the tutorial, and located in `<CFXROOT>/examples`, where `<CFXROOT>` is the installation directory.

Setting the Working Directory

One of the first things you must do when using ANSYS CFX is to set a working directory. The working directory is the default location for loading and saving files for a particular session or project.

The working directory is set according to how you run ANSYS CFX:

- **Workbench**
  Set the working directory by saving a project file.

- **Standalone**
  Set the working directory by entering it in CFX Launcher.
Changing the Display Colors

If viewing objects in ANSYS CFX becomes difficult due to contrast with the background, the colors can be altered for improved viewing. The color options are set in different places, depending on how you run ANSYS CFX, as follows:

- In standalone mode (i.e., after using CFX Launcher to launch ANSYS CFX-Pre or ANSYS CFX-Post):
  a. Select Edit > Options.
     The Options dialog box appears.
  b. Adjust the color settings under CFX-Pre > Viewer (for ANSYS CFX-Pre) or CFX-Post > Viewer (for ANSYS CFX-Post).
  c. Click OK.

- In ANSYS Workbench:
  a. Select Tools > Options from the Project page.
  b. Adjust the color settings under Common Settings > Graphics Style.
  c. Click OK.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode

Introduction

This tutorial simulates a static mixer consisting of two inlet pipes delivering water into a mixing vessel; the water exits through an outlet pipe. A general workflow is established for analyzing the flow of fluid into and out of a mixer.

This tutorial includes:

- Before You Begin (p. 4)
- Tutorial 1 Features (p. 4)
- Overview of the Problem to Solve (p. 5)
- Defining a Simulation in ANSYS CFX-Pre (p. 6)
- Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 12)
- Viewing the Results in ANSYS CFX-Post (p. 15)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

To learn how to perform these tasks in Workbench, see Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench (p. 31 in "ANSYS CFX Tutorials").
Before You Begin

Create a working directory for your files. Once this is done, copy the sample files used in this tutorial to your working directory from the installation folder for your software (<CFXROOT>/examples/ (for example, C:\Program Files\ANSYS Inc\v110\CFX\examples)) to avoid overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 7).

Sample files used by this tutorial are:

- StaticMixerMesh.gtm
- StaticMixer.pre

Tutorial 1 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>Quick Setup Wizard</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Animation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Contour</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outline Plot (Wireframe)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Point</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Streamline</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Using Quick Setup mode in ANSYS CFX-Pre to set up a problem.
- Modifying the outline plot in ANSYS CFX-Post.
- Using streamlines in ANSYS CFX-Post to trace the flow field from a point.
- Viewing temperature using colored planes and contours in ANSYS CFX-Post.
- Creating an animation and saving it to an MPEG file.
Overview of the Problem to Solve

This tutorial simulates a static mixer consisting of two inlet pipes delivering water into a mixing vessel; the water exits through an outlet pipe. A general workflow is established for analyzing the flow of fluid into and out of a mixer.

Water enters through both pipes at the same rate but at different temperatures. The first entry is at a rate of 2 m/s and a temperature of 315 K and the second entry is at a rate of 2 m/s at a temperature of 285 K. The radius of the mixer is 2 m.

Your goal in this tutorial is to understand how to use ANSYS CFX to determine the speed and temperature of the water when it exits the static mixer.

Figure 1  Static Mixer with 2 Inlet Pipes and 1 Outlet Pipe
Defining a Simulation in ANSYS CFX-Pre

Because you are starting with an existing mesh, you can immediately use ANSYS CFX-Pre to define the simulation. This is how ANSYS CFX-Pre will look with the imported mesh:

In the image above, the left pane of ANSYS CFX-Pre displays the Outline. When you double-click on items in the Outline, the Outline editor opens and can be used to create, modify, and view objects.

**Note:** In this documentation, the details view can also be referenced by the name of the object being edited, followed by the word “details view” (for example, if you double-click the Wireframe object, the Wireframe details view appears).

**Synopsis of Quick Setup Mode**

Quick Setup mode provides a simple wizard–like interface for setting up simple cases. This is useful for getting familiar with the basic elements of a CFD problem setup. This section describes using Quick Setup mode to develop a simulation in ANSYS CFX-Pre.

**Workflow Overview**

This tutorial follows the general workflow for Quick Setup mode:

1. Creating a New Simulation (p. 7)
2. Setting the Physics Definition (p. 7)
3. Importing a Mesh (p. 7)
4. Defining Model Data (p. 9)
5. Defining Boundaries (p. 9)
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Defining a Simulation in ANSYS CFX-Pre

6. Setting Boundary Data (p. 9)
7. Setting Flow Specification (p. 9)
8. Setting Temperature Specification (p. 10)
9. Reviewing the Boundary Condition Definitions (p. 10)
10. Creating the Second Inlet Boundary Definition (p. 10)
11. Creating the Outlet Boundary Definition (p. 10)
12. Moving to General Mode (p. 11)
13. Writing the Solver (.def) File (p. 11)

Playing a Session File
If you want to skip past these instructions and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the appropriate session file. For details, see Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 12). After you have played the session file, proceed to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 12).

Creating a New Simulation
Before importing and working with a mesh, a simulation needs to be started using Quick Setup mode.

Procedure
1. If required, launch ANSYS CFX-Pre.
2. Select File > New Simulation.
   The New Simulation File dialog box is displayed.
3. Select Quick Setup and click OK.
   Note: If this is the first time you are running this software, a message box will appear notifying you that automatic generation of the default domain is active. To avoid seeing this message again uncheck Show This Message Again.
4. Select File > Save Simulation As.
5. Under File name, type: StaticMixer
6. Click Save.

Setting the Physics Definition
You need to specify the fluids used in a simulation. A variety of fluids are already defined as library materials. For this tutorial you will use a prepared fluid, Water, which is defined to be water at 25°C.

Procedure
1. Ensure that Simulation Definition is displayed at the top of the details view.
2. Under Fluid select Water.

Importing a Mesh
At least one mesh must be imported before physics are applied.

Procedure
1. In Simulation Definition, under Mesh File, click Browse.
   The Import Mesh dialog box appears.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Defining a Simulation in ANSYS CFX-Pre

2. Under File type, select CFX Mesh (*gtm *cfx).
3. From your working directory, select StaticMixerMesh.gtm.
4. Click Open.
   The mesh loads.
5. Click Next.

Using the Viewer

Now that the mesh is loaded, take a moment to explore how you can use the viewer toolbar to zoom in or out and to rotate the object in the viewer.

Using the Zoom Tools

There are several icons available for controlling the level of zoom in the viewer.

1. Click Zoom Box.
2. Click and drag a rectangular box over the geometry.
3. Release the mouse button to zoom in on the selection.
   The geometry zoom changes to display the selection at a greater resolution.
4. Click Fit View to re-center and re-scale the geometry.

Rotating the geometry

If you need to rotate an object or to view it from a new angle, you can use the viewer toolbar.

1. Click Rotate on the viewer toolbar.
2. Click and drag within the geometry repeatedly to test the rotation of the geometry.
   The geometry rotates based on the direction of movement.
   Notice how the mouse cursor changes depending on where you are in the viewer:

3. Right-click a blank area in the viewer and select Predefined Camera > View Towards-X).
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z Up).
   A clearer view of the mesh is displayed.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Defining a Simulation in ANSYS CFX-Pre

Defining Model Data

You need to define the type of flow and the physical models to use in the fluid domain. You will specify the flow as steady state with turbulence and heat transfer. Turbulence is modeled using the $k$-$\varepsilon$ turbulence model and heat transfer using the thermal energy model. The $k$-$\varepsilon$ turbulence model is a commonly used model and is suitable for a wide range of applications. The thermal energy model neglects high speed energy effects and is therefore suitable for low speed flow applications.

Procedure

1. Ensure that **Physics Definition** is displayed.
2. Under **Model Data**, set **Reference Pressure** to 1 [atm]. All other pressure settings are relative to this reference pressure.
3. Set **Heat Transfer** to **Thermal Energy**.
4. Set **Turbulence** to **k-Epsilon**.
5. Click **Next**.

Defining Boundaries

The CFD model requires the definition of conditions on the boundaries of the domain.

Procedure

1. Ensure that **Boundary Definition** is displayed.
2. Delete **Inlet** and **Outlet** from the list by right-clicking each and selecting **Delete**.
3. Right-click in the blank area where **Inlet** and **Outlet** were listed, then select **New**.
4. Set **Name** to **in1**.
5. Click **OK**.

The boundary is created and, when selected, properties related to the boundary are displayed.

Setting Boundary Data

Once boundaries are created, you need to create associated data. Based on Figure 1, you will define the first inlet boundary condition’s velocity and temperature.

Procedure

1. Ensure that **Boundary Data** is displayed.
2. Set **Boundary Type** to **Inlet**.
3. Set **Location** to **in1**.

Setting Flow Specification

Once boundary data is defined, the boundary needs to have the flow specification assigned.

Procedure

1. Ensure that **Flow Specification** is displayed.
2. Set **Option** to **Normal Speed**.
3. Set **Normal Speed** to 2 [m s$^{-1}$].
Setting Temperature Specification

Once flow specification is defined, the boundary needs to have temperature assigned.

Procedure

1. Ensure that **Temperature Specification** is displayed.
2. Set **Static Temperature** to 315 [K].

Reviewing the Boundary Condition Definitions

Defining the boundary condition for in1 required several steps. Here the settings are reviewed for accuracy.

Based on Figure 1, the first inlet boundary condition consists of a velocity of 2 m/s and a temperature of 315 K at one of the side inlets.

Procedure

1. Review the boundary in1 settings for accuracy. They should be as follows:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>in1</td>
</tr>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td></td>
<td>Normal Speed</td>
<td>2 [m s^-1]</td>
</tr>
<tr>
<td>Temperature Specification</td>
<td>Static Temperature</td>
<td>315 [K]</td>
</tr>
</tbody>
</table>

Creating the Second Inlet Boundary Definition

Based on Figure 1, you know the second inlet boundary condition consists of a velocity of 2 m/s and a temperature of 285 K at one of the side inlets. You will define that now.

Procedure

1. Under **Boundary Definition**, right-click in the selector area and select New.
2. Create a new boundary named in2 with these settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>in2</td>
</tr>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td></td>
<td>Normal Speed</td>
<td>2 [m s^-1]</td>
</tr>
<tr>
<td>Temperature Specification</td>
<td>Static Temperature</td>
<td>285 [K]</td>
</tr>
</tbody>
</table>

Creating the Outlet Boundary Definition

Now that the second inlet boundary has been created, the same concepts can be applied to building the outlet boundary.

1. Create a new boundary named out with these settings:
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Defining a Simulation in ANSYS CFX-Pre

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>out</td>
</tr>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Average Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

2. Click **Next**.

Moving to General Mode

There are no further boundary conditions that need to be set. All 2D exterior regions that have not been assigned to a boundary condition are automatically assigned to the default boundary condition.

**Procedure**

1. Set **Operation** to **Enter General Mode** and click **Finish**.

   The three boundary conditions are displayed in the viewer as sets of arrows at the boundary surfaces. Inlet boundary arrows are directed into the domain. Outlet boundary arrows are directed out of the domain.

Setting Solver Control

Solver Control parameters control aspects of the numerical solution generation process. While an upwind advection scheme is less accurate than other advection schemes, it is also more robust. This advection scheme is suitable for obtaining an initial set of results, but in general should not be used to obtain final accurate results.

The time scale can be calculated automatically by the solver or set manually. The **Automatic** option tends to be conservative, leading to reliable, but often slow, convergence. It is often possible to accelerate convergence by applying a time scale factor or by choosing a manual value that is more aggressive than the **Automatic** option. In this tutorial, you will select a physical time scale, leading to convergence that is twice as fast as the **Automatic** option.

**Procedure**

1. Click **Solver Control**.
2. On the **Basic Settings** tab, set **Advection Scheme > Option** to **Upwind**.
3. Set **Convergence Control > Fluid Timescale Control > Timescale Control** to **Physical Timescale** and set the physical timescale value to 2 [s].
4. Click **OK**.

Writing the Solver (.def) File

The simulation file, **StaticMixer.cfx**, contains the simulation definition in a format that can be loaded by ANSYS CFX-Pre, allowing you to complete (if applicable), restore, and modify the simulation definition. The simulation file differs from the definition file in that it can be saved at any time while defining the simulation.

**Procedure**

1. Click **Write Solver File**.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Obtaining a Solution Using ANSYS

The Write Solver File dialog box is displayed.

2. Set File name to StaticMixer.def.

3. Ensure that Start Solver Manager is selected from the drop down menu located in the top-right corner of the dialog box.

4. Select Quit ANSYS CFX-Pre.
   
   This forces standalone ANSYS CFX-Pre to close after the definition file has been written.

5. Click Save.

6. If you are notified the file already exists, click Overwrite.
   
   This file is provided in the tutorial directory and may exist in your tutorial folder if you have copied it there.

7. If prompted, click Yes or Save & Quit to save StaticMixer.cfx.
   
   The definition file (StaticMixer.def) and the simulation file (StaticMixer.cfx) are created. ANSYS CFX-Solver Manager automatically starts and the definition file is set in the Define Run dialog box.

8. Proceed to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 12).

Playing the Session File and Starting ANSYS CFX-Solver Manager

Note: This task is required only if you are starting here with the session file that was provided in the examples directory. If you have performed all the tasks in the previous steps, proceed directly to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 12).

Events in ANSYS CFX-Pre can be recorded to a session file and then played back at a later date to drive ANSYS CFX-Pre. Session files have been created for each tutorial so that the problems can be set up rapidly in ANSYS CFX-Pre, if desired.

Procedure

1. If required, launch ANSYS CFX-Pre.

2. Select Session > Play Tutorial.

3. Select StaticMixer.pre.

4. Click Open.
   
   A definition file is written.

5. Select File > Quit.

6. Launch the ANSYS CFX-Solver Manager from CFX Launcher.

7. After the ANSYS CFX-Solver starts, select File > Define Run.

8. Under Definition File, click Browse.

9. Select StaticMixer.def, located in the working directory.


Obtaining a Solution Using ANSYS CFX-Solver Manager

ANSYS CFX-Solver Manager has a visual interface that displays a variety of results and should be used when plotted data needs to be viewed during problem solving.
Two windows are displayed when ANSYS CFX-Solver Manager runs. There is an adjustable split between the windows, which is oriented either horizontally or vertically depending on the aspect ratio of the entire ANSYS CFX-Solver Manager window (also adjustable).

One window shows the convergence history plots and the other displays text output from ANSYS CFX-Solver.

The text lists physical properties, boundary conditions and various other parameters used or calculated in creating the model. All the text is written to the output file automatically (in this case, StaticMixer_001.out).

Start the Run

The Define Run dialog box allows configuration of a run for processing by ANSYS CFX-Solver.

When ANSYS CFX-Solver Manager is launched automatically from ANSYS CFX-Pre, all of the information required to perform a new serial run (on a single processor) is entered automatically. You do not need to alter the information in the Define Run dialog box. This is a very quick way to launch into ANSYS CFX-Solver without having to define settings and values.

Procedure

1. Ensure that the Define Run dialog box is displayed.
2. Click Start Run.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Obtaining a Solution Using ANSYS

ANSYS CFX-Solver launches and a split screen appears and displays the results of the run graphically and as text. The panes continue to build as ANSYS CFX-Solver Manager operates.

Note: Once the second iteration appears, data begins to plot. Plotting may take a long time depending on the amount of data to process. Let the process run.

Move from ANSYS CFX-Solver to ANSYS CFX-Post

Once ANSYS CFX-Solver has finished, you can use ANSYS CFX-Post to review the finished results.

Procedure

1. When ANSYS CFX-Solver is finished, click Yes to post-process the results.

After a short pause, ANSYS CFX-Post starts and ANSYS CFX-Solver Manager closes.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Viewing the Results in ANSYS CFX-Post

Viewing the Results in ANSYS CFX-Post

When ANSYS CFX-Post starts, the viewer and Outline workspace are displayed.

The viewer displays an outline of the geometry and other graphic objects. You can use the mouse or the toolbar icons to manipulate the view, exactly as in ANSYS CFX-Pre.

Workflow Overview

This tutorial describes the following workflow for viewing results in ANSYS CFX-Post:

1. Setting the Edge Angle for a Wireframe Object (p. 16)
2. Creating a Point for the Origin of the Streamline (p. 17)
3. Creating a Streamline Originating from a Point (p. 18)
4. Rearranging the Point (p. 19)
5. Configuring a Default Legend (p. 19)
6. Creating a Slice Plane (p. 20)
7. Defining Slice Plane Geometry (p. 21)
8. Configuring Slice Plane Views (p. 21)
9. Rendering Slice Planes (p. 22)
10. Coloring the Slice Plane (p. 23)
11. Moving the Slice Plane (p. 23)
12. Adding Contours (p. 24)
13. Working with Animations (p. 25)
14. Showing the Animation Dialog Box (p. 25)
Setting the Edge Angle for a Wireframe Object

The outline of the geometry is called the wireframe or outline plot.

By default, ANSYS CFX-Post displays only some of the surface mesh. This sometimes means that when you first load your results file, the geometry outline is not displayed clearly. You can control the amount of the surface mesh shown by editing the Wireframe object listed in the Outline.

The check boxes next to each object name in the Outline control the visibility of each object. Currently only the Wireframe and Default Legend objects have visibility selected.

The edge angle determines how much of the surface mesh is visible. If the angle between two adjacent faces is greater than the edge angle, then that edge is drawn. If the edge angle is set to 0°, the entire surface mesh is drawn. If the edge angle is large, then only the most significant corner edges of the geometry are drawn.

For this geometry, a setting of approximately 15° lets you view the model location without displaying an excessive amount of the surface mesh.

In this module you can also modify the zoom settings and view of the wireframe.

Procedure

1. In the Outline, under User Locations and Plots, double-click Wireframe.
   Tip: While it is not necessary to change the view to set the angle, do so to explore the practical uses of this feature.

2. Right-click on a blank area anywhere in the viewer, select Predefined Camera from the shortcut menu and select Isometric View (Z up).

3. In the Wireframe details view, under Definition, click in the Edge Angle box. An embedded slider is displayed.

4. Type a value of 10 [degree].

5. Click Apply to update the object with the new setting.
6. Drag the embedded slider to set the **Edge Angle** value to approximately 45 \( \text{[degree]} \).
7. Click **Apply** to update the object with the new setting.
   Less of the outline of the geometry is displayed.
8. Type a value of 15 \( \text{[degree]} \).
9. Click **Apply** to update the object with the new setting.
10. Right-click on a blank area anywhere in the viewer, select **Predefined Camera** from the shortcut menu and select **View Towards -X**.

Creating a Point for the Origin of the Streamline

A *streamline* is the path that a particle of zero mass would follow through the domain.

**Procedure**

1. Select **Insert > Location > Point** from the main menu.
   You can also use the toolbars to create a variety of objects. Later modules and tutorials explore this further.
2. Click **OK**.
   This accepts the default name.
3. Under **Definition**, ensure that **Method** is set to **XYZ**.
4. Under **Point**, enter the following coordinates: \(-1, -1, 1\).
   This is a point near the first inlet.
5. Click **Apply**.
   The point appears as a symbol in the viewer as a crosshair symbol.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Viewing the Results in ANSYS CFX-Post

Creating a Streamline Originating from a Point

Where applicable, streamlines can trace the flow direction forwards (downstream) and/or backwards (upstream).

**Procedure**

1. From the main menu, select **Insert > Streamline**.
   You can also use the toolbars to create a variety of objects. Later modules and tutorials will explore this further.
2. Click **OK**.
   This accepts the default name.
3. Under **Definition**, in **Start From**, ensure that **Point 1** is set.
   Tip: To create streamlines originating from more than one location, click the ellipsis icon to the right of the **Start From** box. This displays the **Location Selector** dialog box, where you can use the <Ctrl> and <Shift> keys to pick multiple locators.
4. Click the **Color** tab.
5. Set **Mode** to **Variable**.
6. Set **Variable** to **Total Temperature**.
7. Set **Range** to **Local**.
8. Click **Apply**.
   The streamline shows the path of a zero mass particle from **Point 1**. The temperature is initially high near the hot inlet, but as the fluid mixes the temperature drops.
Rearranging the Point

Once created, a point can be rearranged manually or by setting specific coordinates.

*Tip:* In this module, you may choose to display various views and zooms from the *Predefined Camera* option in the shortcut menu (such as *Isometric View (Z up)*) or *View Towards -X*) and by using *Zoom Box* if you prefer to change the display.

**Procedure**

1. In *Outline*, under *User Locations and Plots* double-click *Point 1*. Properties for the selected user location are displayed.
2. Under *Point*, set these coordinates: -1, -2.9, 1.
3. Click *Apply*. The point is moved and the streamline redrawn.
4. In the selection tools, click *Single Select*.

While in this mode, the normal behavior of the left mouse button is disabled.
5. In the viewer, drag *Point 1* (appears as a yellow addition sign) to a new location within the mixer. The point position is updated in the details view and the streamline is redrawn at the new location. The point moves normal in relation to the viewing direction.
6. Click *Rotate*.

*Tip:* You can also click in the viewer area, and press the space bar to toggle between Select and Viewing Mode. A way to pick objects from Viewing Mode is to hold down <Ctrl> + <Shift> while clicking on an object with the left mouse button.
7. Under *Point*, reset these coordinates: -1, -1, 1.
8. Click *Apply*. The point appears at its original location.
9. Right-click a blank area in the viewer and select *Predefined Camera > View Towards -X*.

Configuring a Default Legend

You can modify the appearance of the default legend.

The default legend appears whenever a plot is created that is colored by a variable. The streamline color is based on temperature; therefore, the legend shows the temperature range. The color pattern on the legend’s color bar is banded in accordance with the bands in the plot.\(^1\)

---

1. An exception occurs when one or more bands in a contour plot represent values beyond the legend’s range. In this case, such bands are colored using a color that is extrapolated slightly past the range of colors shown in the legend. This can happen only when a user-specified range is used for the legend.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Viewing the Results in ANSYS CFX-Post

The default legend displays values for the last eligible plot that was opened in the details view. To maintain a legend definition during an ANSYS CFX-Post session, you can create a new legend by clicking Legend.

Because there are many settings that can be customized for the legend, this module allows you the freedom to experiment with them. In the last steps you will set up a legend, based on the default legend, with a minor modification to the position.

Tip: When editing values, you can restore the values that were present when you began editing by clicking Reset. To restore the factory-default values, click Default.

Procedure

1. Double click Default Legend View 1.

   The Definition tab of the default legend is displayed.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>Title Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Title</td>
<td>Streamline Temp.</td>
</tr>
<tr>
<td></td>
<td>Horizontal</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Location &gt; Y Justification</td>
<td>Bottom</td>
</tr>
</tbody>
</table>

3. Click Apply.

   The appearance and position of the legend changes based on the settings specified.

4. Modify various settings in Definition and click Apply after each change.

5. Select Appearance.

6. Modify a variety of settings in the Appearance and click Apply after each change.

7. Click Defaults.

8. Click Apply.

9. Under Outline, in User Locations and Plots, clear the check boxes for Point 1 and Streamline 1.

   Since both are no longer visible, the associated legend no longer appears.

Creating a Slice Plane

Defining a slice plane allows you to obtain a cross-section of the geometry.

In ANSYS CFX-Post you often view results by coloring a graphic object. The graphic object could be an isosurface, a vector plot, or in this case, a plane. The object can be a fixed color or it can vary based on the value of a variable.

You already have some objects defined by default (listed in the Outline). You can view results on the boundaries of the static mixer by coloring each boundary object by a variable.

To view results within the geometry (that is, on non-default locators), you will create new objects.

You can use the following methods to define a plane:

- Three Points: creates a plane from three specified points.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Viewing the Results in ANSYS CFX-Post

- Point and Normal: defines a plane from one point on the plane and a normal vector to the plane.
- YZ Plane, ZX Plane, and XY Plane: similar to Point and Normal, except that the normal is defined to be normal to the indicated plane.

Procedure
1. From the main menu, select Insert > Location > Plane or click Location > Plane.
2. In the New Plane window, type: Slice
3. Click OK.
   The Geometry, Color, Render and View tabs let you switch between settings.
4. Click the Geometry tab.

Defining Slice Plane Geometry
You need to choose the vector normal to the plane. You want the plane to lie in the x-y plane, hence its normal vector points along the z-axis. You can specify any vector that points in the z-direction, but you will choose the most obvious (0,0,1).

Procedure
1. If required, under Geometry, expand Definition.
2. Under Method select Point and Normal.
3. Under Point enter 0,0,1.
4. Under Normal enter 0,0,1.
5. Click Apply.
   Slice appears under User Locations and Plots. Rotate the view to see the plane.

Configuring Slice Plane Views
Depending on the view of the geometry, various objects may not appear because they fall in a 2D space that cannot be seen.

Procedure
1. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up).
2. Click **Zoom Box** 📸.
3. Click and drag a rectangular selection over the geometry.
4. Release the mouse button to zoom in on the selection.
5. Click **Rotate** 🔄.
6. Click and drag the mouse pointer down slightly to rotate the geometry towards you.
7. Select **Isometric View (Z up)** as described earlier.

### Rendering Slice Planes

Render settings determine how the plane is drawn.

**Procedure**

1. Select the **Render** tab.
2. Clear **Draw Faces**.
3. Select **Draw Lines**.
4. Under **Draw Lines** change **Color Mode** to **User Specified**.
5. Click the current color in **Line Color** to change to a different color.
   For a greater selection of colors, click the ellipse to use the **Select color** dialog box.
6. Click **Apply**.
7. Click **Zoom Box** 📸.
8. Zoom in on the geometry to view it in greater detail.
The line segments show where the slice plane intersects with mesh element faces. The end points of each line segment are located where the plane intersects mesh element edges.

9. Right-click a blank area in the viewer and select **Predefined Camera > View Towards -Z**.

The image shown below can be used for comparison with tutorial 2 (in the section **Creating a Slice Plane** (p. 68)), where a refined mesh is used.

![Slice Plane Image](image)

Coloring the Slice Plane

The **Color** panel is used to determine how the object faces are colored.

**Procedure**

1. Apply the following settings to **Slice**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable*</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

* You can specify the variable (in this case, temperature) used to color the graphic element. The **Constant** mode allows you to color the plane with a fixed color.

2. Click **Apply**.

Hot water (red) enters from one inlet and cold water (blue) from the other.

Moving the Slice Plane

The plane can be moved to different locations.
**Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Viewing the Results in ANSYS CFX-Post**

**Procedure**
1. Right-click a blank area in the viewer and select **Predefined Camera > Isometric View (Z up)** from the shortcut menu.
2. Click the **Geometry** tab.
   Review the settings in **Definition** under **Point** and under **Normal**.
3. Click **Single Select**.
4. Click and drag the plane to a new location that intersects the domain. As you drag the mouse, the viewer updates automatically. Note that **Point** updates with new settings.
5. Set **Point** settings to 0, 0, 1.
6. Click **Apply**.
7. Click **Rotate**.
8. Turn off visibility for **Slice** by clearing the check box next to **Slice** in the **Outline**.

**Adding Contours**

Contours connect all points of equal value for a scalar variable (for example, **Temperature**) and help to visualize variable values and gradients. Colored bands fill the spaces between contour lines. Each band is colored by the average color of its two bounding contour lines (even if the latter are not displayed).

**Procedure**
1. Select **Insert > Contour** from the main menu or click **Contour**.
   The **New Contour** dialog box is displayed.
2. Set **Name** to **Slice Contour**.
3. Click **OK**.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>Slice</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

5. Click **Apply**.

*Important:* The colors of 3D graphics object faces are slightly altered when lighting is on. To view colors with highest accuracy, clear **Lighting** under **Draw Faces** on the **Render** tab and click **Apply**.
Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode: Viewing the Results in ANSYS CFX-Post

The graphic element faces are visible, producing a contour plot as shown.

Note: Make sure that the checkbox next to Slice in the Outline is cleared.

Working with Animations

Animations build transitions between views for development of video files.

Workflow Overview

This tutorial follows the general workflow for creating a keyframe animation:
1. Showing the Animation Dialog Box (p. 25)
2. Creating the First Keyframe (p. 26)
3. Creating the Second Keyframe (p. 26)
4. Viewing the Animation (p. 27)
5. Modifying the Animation (p. 28)
6. Saving to MPEG (p. 29)

Showing the Animation Dialog Box

The Animation dialog box is used to define keyframes and to export to a video file.

Procedure

1. Select Tools > Animation or click Animation .

The Animation dialog box can be repositioned as required.
Creating the First Keyframe

Keyframes are required in order to produce an animation. You need to define the first viewer state, a second (and final) viewer state, and set the number of interpolated intermediate frames.

Procedure
1. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up).
2. In the Outline, under User Locations and Plots, clear the visibility of Slice Contour and select the visibility of Slice.
3. In the Animation dialog box, click New.
   A new keyframe named KeyframeNo1 is created. This represents the current image displayed in the viewer.

Creating the Second Keyframe

Keyframes are required in order to produce an animation.

Procedure
1. In the Outline, under User Locations and Plots, double-click Slice.
2. On the Geometry tab, set Point coordinate values to (0, 0, -1.99).
3. Click Apply.
   The slice plane moves to the bottom of the mixer.
4. In the Animation dialog box, click New.
   KeyframeNo2 is created and represents the image displayed in the Viewer.
5. Select KeyframeNo1.
6. Set # of Frames (located below the list of keyframes) to 20.
   This is the number of intermediate frames used when going from KeyframeNo1 to KeyframeNo2. This number is displayed in the Frames column for KeyframeNo1.
7. Press Enter.
   The Frame # column shows the frame in which each keyframe appears. KeyframeNo1 appears at frame 1 since it defines the start of the animation. KeyframeNo2 is at frame 22 since you have 20 intermediate frames (frames 2 to 21) in between KeyframeNo1 and KeyframeNo2.

Viewing the Animation

More keyframes could be added, but this animation has only two keyframes (which is the minimum possible).

Synopsis

The controls previously greyed-out in the Animation dialog box are now available. The number of intermediate frames between keyframes is listed beside the keyframe having the lowest number of the pair. The number of keyframes listed beside the last keyframe is ignored.

Procedure

1. Click Play the animation .
   The animation plays from frame 1 to frame 22. It plays relatively slowly because the slice plane must be updated for each frame.
Modifying the Animation

To make the plane sweep through the whole geometry, you will set the starting position of the plane to be at the top of the mixer. You will also modify the **Range** properties of the plane so that it shows the temperature variation better. As the animation is played, you can see the hot and cold water entering the mixer. Near the bottom of the mixer (where the water flows out) you can see that the temperature is quite uniform. The new temperature range lets you view the mixing process more accurately than the global range used in the first animation.

**Procedure**

1. Apply the following settings to **Slice**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Point</td>
<td>0, 0, 1.99</td>
</tr>
<tr>
<td>Color</td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td>Range</td>
<td>User Specified</td>
<td></td>
</tr>
<tr>
<td>Min</td>
<td>295 [K]</td>
<td></td>
</tr>
<tr>
<td>Max</td>
<td>305 [K]</td>
<td></td>
</tr>
</tbody>
</table>

2. Click **Apply**.

The slice plane moves to the top of the static mixer.

**Note:** Do not double click in the next step.

3. In the **Animation** dialog box, single click **(do not double-click)** KeyframeNo1 to select it. If you had double-clicked KeyFrameNo1, the plane and viewer states would have been redefined according to the stored settings for KeyFrameNo1. If this happens, click **Undo** and try again to select the keyframe.

4. Click **Set Keyframe**.

The image in the Viewer replaces the one previously associated with KeyframeNo1.

5. Double-click KeyFrameNo2.

The object properties for the slice plane are updated according to the settings in KeyFrameNo2.

6. Apply the following settings to **Slice**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td>Range</td>
<td>User Specified</td>
<td></td>
</tr>
<tr>
<td>Min</td>
<td>295 [K]</td>
<td></td>
</tr>
<tr>
<td>Max</td>
<td>305 [K]</td>
<td></td>
</tr>
</tbody>
</table>

7. Click **Apply**.

8. In the **Animation** dialog box, single-click KeyframeNo2.

9. Click **Set Keyframe** to save the new settings to KeyframeNo2.
Saving to MPEG

By defining the geometry and then saving to MPEG, the results can be saved to a video file.

**Procedure**

1. Click More Animation Options to view the additional options.
   - The Loop and Bounce radio buttons determine what happens when the animation reaches the last keyframe. When Loop is selected, the animation repeats itself the number of times defined by Repeat. When Bounce is selected, every other cycle is played in reverse order, starting with the second.
2. Click Save MPEG.
3. Click Browse next to Save MPEG.
4. Under File name type: StaticMixer.mpg
5. If required, set the path location to a different folder.
6. Click Save.
   - The MPEG file name (including path) is set. At this point, the animation has not yet been produced.
7. Click Previous Keyframe.
   - Wait a moment as the display updates the keyframe display.
8. Click Play the animation.
9. If prompted to overwrite an existing movie click Overwrite.
   - The animation plays and builds an MPEG file.
10. Click the Options button at the bottom of the Animation dialog box.
    - In Advanced, you can see that a Frame Rate of 24 frames per second was used to create the animation. The animation you produced contains a total of 22 frames, so it takes just under 1 second to play in a media player.
11. Click Cancel to close the dialog box.
12. Close the Animation dialog box.
13. Review the animation in third-party software as required.

Exiting ANSYS CFX-Post

When finished with ANSYS CFX-Post exit the current window:

1. When you are finished, select File > Quit to exit ANSYS CFX-Post.
2. Click Quit if prompted to save.
Tutorial 1a: 
Simulating Flow in a Static Mixer Using Workbench

Introduction

This tutorial simulates a static mixer consisting of two inlet pipes delivering water into a mixing vessel; the water exits through an outlet pipe. A general workflow is established for analyzing the flow of fluid into and out of a mixer.

This tutorial comprises:
- Before You Begin (p. 32)
- Tutorial 1a Features (p. 32)
- Overview of the Problem to Solve (p. 33)
- Defining a Simulation in ANSYS CFX-Pre (p. 34)
- Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 41)
- Viewing the Results in ANSYS CFX-Post (p. 43)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

To learn how to perform these tasks using CFX in Standalone mode, see Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode (p. 3 in "ANSYS CFX Tutorials").
Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Before You Begin

Before You Begin

Create a working directory for your files. Once this is done, copy the sample files used in this tutorial to your working directory from the installation folder for your software (<CFXROOT>/examples/ (for example, C:\Program Files\ANSYS Inc\v110\CFX\examples)) to avoid overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 35).

Sample files used by this tutorial are:
• StaticMixerMesh.gtm
• StaticMixer.pre

Tutorial 1a Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>Quick Setup Wizard</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Animation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Contour</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outline Plot (Wireframe)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Point</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Streamline</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:
• Using Quick Setup mode in ANSYS CFX-Pre to set up a problem.
• Modifying the outline plot in ANSYS CFX-Post.
• Using streamlines in ANSYS CFX-Post to trace the flow field from a point.
• Viewing temperature using colored planes and contours in ANSYS CFX-Post.
• Creating an animation and saving it to an MPEG file.
Overview of the Problem to Solve

This tutorial simulates a static mixer consisting of two inlet pipes delivering water into a mixing vessel; the water exits through an outlet pipe. A general workflow is established for analyzing the flow of fluid into and out of a mixer.

Water enters through both pipes at the same rate but at different temperatures. The first entry is at a rate of 2 m/s and a temperature of 315 K and the second entry is at a rate of 2 m/s at a temperature of 285 K. The radius of the mixer is 2 m.

Your goal in this tutorial is to understand how to use ANSYS CFX to determine the speed and temperature of the water when it exits the static mixer.

Figure 1 Static Mixer with 2 Inlet Pipes and 1 Outlet Pipe
Defining a Simulation in ANSYS CFX-Pre

Because you are starting with an existing mesh, you can immediately use ANSYS CFX-Pre to define the simulation. This is how ANSYS CFX-Pre will look with the imported mesh:

![Image of ANSYS CFX-Pre IDE](image)

In the image above, the left pane of ANSYS CFX-Pre displays the Outline. When you double-click on items in the Outline, the Outline editor opens and can be used to create, modify, and view objects.

**Note:** In this documentation, the details view can also be referenced by the name of the object being edited, followed by the word “details view” (for example, if you double-click the Wireframe object, the Wireframe details view appears).

**Synopsis of Quick Setup Mode**

Quick Setup mode provides a simple wizard-like interface for setting up simple cases. This is useful for getting familiar with the basic elements of a CFD problem setup. This section describes using Quick Setup mode to develop a simulation in ANSYS CFX-Pre.

**Workflow Overview**

This tutorial follows the general workflow for Quick Setup mode:

1. **Creating a New Simulation** (p. 35)
2. **Setting the Physics Definition** (p. 35)
3. **Importing a Mesh** (p. 36)
4. **Defining Model Data** (p. 37)
5. **Defining Boundaries** (p. 37)
Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Defining a Simulation in ANSYS CFX-Pre

6. Setting Boundary Data (p. 37)
7. Setting Flow Specification (p. 37)
8. Setting Temperature Specification (p. 38)
9. Reviewing the Boundary Condition Definitions (p. 38)
10. Creating the Second Inlet Boundary Definition (p. 38)
11. Creating the Outlet Boundary Definition (p. 39)
12. Moving to General Mode (p. 39)
13. Writing the Solver (.def) File (p. 40)

Playing a Session File

If you want to skip past these instructions and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the appropriate session file. For details, see Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 40). After you have played the session file, proceed to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 41).

Creating a New Simulation

Before importing and working with a mesh, a simulation needs to be started using Quick Setup mode.

Procedure

1. If required, launch ANSYS Workbench.
2. Click Empty Project.
   The Project page appears displaying an unsaved project.
3. Select File > Save or click Save.
4. If required, set the path location to the working folder you created for this tutorial.
5. Under File name, type StaticMixer
6. Click Save.
7. On the left-hand task bar under Advanced CFD, click Start CFX-Pre.
9. Select Quick Setup in the New Simulation File dialog box and click OK.
10. Select File > Save Simulation As.
11. Under File name, type StaticMixer
12. Click Save.

Setting the Physics Definition

You need to specify the fluids used in a simulation. A variety of fluids are already defined as library materials. For this tutorial you will use a prepared fluid, Water, which is defined to be water at 25°C.

Procedure

1. Ensure that Simulation Definition is displayed at the top of the Details view.
2. Under Fluid select Water.
Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Defining a Simulation in ANSYS CFX-Pre

Importing a Mesh

At least one mesh must be imported before physics are applied.

Procedure

1. In Simulation Definition, under Mesh File, click Browse.
   The Import Mesh dialog box appears.
2. Under File type, select CFX Mesh (*.gtm).
3. From your working directory, select StaticMixerMesh.gtm.
4. Click Open.
   The mesh loads.
5. Click Next.

Using the Viewer

Now that the mesh is loaded, take a moment to explore how you can use the viewer toolbar to zoom in or out and to rotate the object in the viewer.

Using the Zoom Tools

Using the Viewer

There are several icons available for controlling the level of zoom in the viewer.

Using the Zoom Tools

1. Click Zoom Box.
2. Click and drag a rectangular box over the geometry.
3. Release the mouse button to zoom in on the selection.
   The geometry zoom changes to display the selection at a greater resolution.
4. Click Fit View to re-center and re-scale the geometry.

Rotating the geometry

If you need to rotate an object or to view it from a new angle, you can use the viewer toolbar.

1. Click Rotate on the viewer toolbar.
2. Click and drag within the geometry repeatedly to test the rotation of the geometry.
   The geometry rotates based on the direction of movement.
   Notice how the mouse cursor changes depending on where you are in the viewer:

3. Right-click a blank area in the viewer and select Predefined Camera > View Towards-X).
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z Up).
   A clearer view of the mesh is displayed.

Defining Model Data

You need to define the type of flow and the physical models to use in the fluid domain. You will specify the flow as steady state with turbulence and heat transfer. Turbulence is modelled using the $k$-$\varepsilon$ turbulence model and heat transfer using the thermal energy model. The $k$-$\varepsilon$ turbulence model is a commonly used model and is suitable for a wide range of applications. The thermal energy model neglects high speed energy effects and is therefore suitable for low speed flow applications.

Procedure
1. Ensure that Physics Definition is displayed.
2. Under Model Data, set Reference Pressure to 1 [atm].
   All other pressure settings are relative to this reference pressure.
4. Set Turbulence to $k$-Epsilon.
5. Click Next.

Defining Boundaries

The CFD model requires the definition of conditions on the boundaries of the domain.

Procedure
1. Ensure that Boundary Definition is displayed.
2. Delete Inlet and Outlet from the list by right-clicking each and selecting Delete.
3. Right-click in the blank area where Inlet and Outlet were listed, then select New.
4. Set Name to: in1
5. Click OK.
   The boundary is created and, when selected, properties related to the boundary are displayed.

Setting Boundary Data

Once boundaries are created, you need to create associated data. Based on Figure 1, you will define the first inlet boundary condition to have a velocity of 2 m/s and a temperature of 315 K at one of the side inlets.

Procedure
1. Ensure that Boundary Data is displayed.
2. Set Boundary Type to Inlet.
3. Set Location to in1.

Setting Flow Specification

Once boundary data is defined, the boundary needs to have the flow specification assigned.
**Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Defining a Simulation in ANSYS CFX-Pre**

**Procedure**
1. Ensure that **Flow Specification** is displayed.
2. Set **Option** to **Normal Speed**.
3. Set **Normal Speed** to 2 [m s^{-1}].

**Setting Temperature Specification**

Once flow specification is defined, the boundary needs to have temperature assigned.

**Procedure**
1. Ensure that **Temperature Specification** is displayed.
2. Set **Static Temperature** to 315 [K].

**Reviewing the Boundary Condition Definitions**

Defining the boundary condition for **in1** required several steps. Here the settings are reviewed for accuracy.

Based on **Figure 1**, the first inlet boundary condition consists of a velocity of 2 m/s and a temperature of 315 K at one of the side inlets.

**Procedure**
1. Review the boundary **in1** settings for accuracy. They should be as follows:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>in1</td>
</tr>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td></td>
<td>Normal Speed</td>
<td>2 [m s^{-1}]</td>
</tr>
<tr>
<td>Temperature Specification</td>
<td>Static Temperature</td>
<td>315 [K]</td>
</tr>
</tbody>
</table>

**Creating the Second Inlet Boundary Definition**

Based on **Figure 1**, you know the second inlet boundary condition consists of a velocity of 2 m/s and a temperature of 285 K at one of the side inlets. You will define that now.

**Procedure**
1. Under **Boundary Definition**, right-click in the selector area and select **New**.
2. Create a new boundary named **in2** with these settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>in2</td>
</tr>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td></td>
<td>Normal Speed</td>
<td>2 [m s^{-1}]</td>
</tr>
<tr>
<td>Temperature Specification</td>
<td>Static Temperature</td>
<td>285 [K]</td>
</tr>
</tbody>
</table>
Creating the Outlet Boundary Definition

Now that the second inlet boundary has been created, the same concepts can be applied to building the outlet boundary.

1. Create a new boundary named `out` with these settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>out</td>
</tr>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Average Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

2. Click Next.

Moving to General Mode

There are no further boundary conditions that need to be set. All 2D exterior regions that have not been assigned to a boundary condition are automatically assigned to the default boundary condition.

**Procedure**

1. Set Operation to Enter General Mode and click Finish.

   The three boundary conditions are displayed in the viewer as sets of arrows at the boundary surfaces. Inlet boundary arrows are directed into the domain. Outlet boundary arrows are directed out of the domain.

Setting Solver Control

Solver Control parameters control aspects of the numerical solution generation process.

While an upwind advection scheme is less accurate than other advection schemes, it is also more robust. This advection scheme is suitable for obtaining an initial set of results, but in general should not be used to obtain final accurate results.

The time scale can be calculated automatically by the solver or set manually. The Automatic option tends to be conservative, leading to reliable, but often slow, convergence. It is often possible to accelerate convergence by applying a time scale factor or by choosing a manual value that is more aggressive than the Automatic option. In this tutorial, you will select a physical time scale, leading to convergence that is twice as fast as the Automatic option.

**Procedure**

1. Click Solver Control.
2. On the Basic Settings tab, set Advection Scheme > Option to Upwind.
3. Set Convergence Control > Fluid Timescale Control > Timescale Control to Physical Timescale and set the physical timescale value to 2 [s].
4. Click OK.
Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Defining a Simulation in ANSYS CFX-Pre

Writing the Solver (.def) File

The simulation file, StaticMixer.cfx, contains the simulation definition in a format that can be loaded by ANSYS CFX-Pre, allowing you to complete (if applicable), restore, and modify the simulation definition. The simulation file differs from the definition file in that it can be saved at any time while defining the simulation.

Procedure

1. Click Write Solver File.
   The Write Solver File dialog box is displayed.
2. Set File name to StaticMixer.def.
3. Ensure that Start Solver Manager is selected from the drop down menu located in the top-right corner of the dialog box.
4. Click Save.
5. If you are notified the file already exists, click Overwrite.
   This file is provided in the tutorial directory and may exist in your tutorial folder if you have copied it there.
6. If prompted, click Yes or Save & Quit to save StaticMixer.cfx.
   The definition file (StaticMixer.def) and the simulation file (StaticMixer.cfx) are created. ANSYS CFX-Solver Manager automatically starts and the definition file is set in the Define Run dialog box.
7. Proceed to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 41).

Playing the Session File and Starting ANSYS CFX-Solver Manager

Note: This task is required only if you are starting here with the session file that was provided in the examples directory. If you have performed all the tasks in the previous steps, proceed directly to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 41).

Events in ANSYS CFX-Pre can be recorded to a session file and then played back at a later date to drive ANSYS CFX-Pre. Session files have been created for each tutorial so that the problems can be set up rapidly in ANSYS CFX-Pre, if desired.

Procedure

1. If required, launch ANSYS Workbench.
2. Click Empty Project.
3. Select File > Save or click Save.
4. Under File name, type: StaticMixer
5. Click Save.
6. Click Start CFX-Pre.
7. Select Session > Play Tutorial.
8. Select StaticMixer.pre.
9. Click Open.
   A definition file is written.
10. Click the CFX-Solver tab.
12. Under Definition File, click Browse.
13. Select StaticMixer.def, located in the working directory.

**Obtaining a Solution Using ANSYS CFX-Solver Manager**

ANSYS CFX-Solver Manager has a visual interface that displays a variety of results and should be used when plotted data needs to be viewed during problem solving.

Two windows are displayed when ANSYS CFX-Solver Manager runs. There is an adjustable split between the windows, which is oriented either horizontally or vertically depending on the aspect ratio of the entire ANSYS CFX-Solver Manager window (also adjustable).

One window shows the convergence history plots and the other displays text output from ANSYS CFX-Solver.

The text lists physical properties, boundary conditions and various other parameters used or calculated in creating the model. All the text is written to the output file automatically (in this case, StaticMixer_001.out).

**Start the Run**

The **Define Run** dialog box allows configuration of a run for processing by ANSYS CFX-Solver.
Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Obtaining a Solution Using ANSYS CFX-Solver

When ANSYS CFX-Solver Manager is launched automatically from ANSYS CFX-Pre, all of the information required to perform a new serial run (on a single processor) is entered automatically. You do not need to alter the information in the Define Run dialog box. This is a very quick way to launch into ANSYS CFX-Solver without having to define settings and values.

Procedure
1. Ensure that the Define Run dialog box is displayed.
2. Click Start Run.
ANSYS CFX-Solver launches and a split screen appears and displays the results of the run graphically and as text. The panes continue to build as ANSYS CFX-Solver Manager operates.

Note: Once the second iteration appears, data begins to plot. Plotting may take a long time depending on the amount of data to process. Let the process run.

Move from ANSYS CFX-Solver to ANSYS CFX-Post

Once ANSYS CFX-Solver has finished, you can use ANSYS CFX-Post to review the finished results.

Procedure
1. When ANSYS CFX-Solver is finished, click Yes to post-process the results.

After a short pause, ANSYS CFX-Post starts and ANSYS CFX-Solver Manager closes.
When ANSYS CFX-Post starts, the viewer and Outline workspace are displayed.

The viewer displays an outline of the geometry and other graphic objects. You can use the mouse or the toolbar icons to manipulate the view, exactly as in ANSYS CFX-Pre.

Workflow Overview

This tutorial describes the following workflow for viewing results in ANSYS CFX-Post:

1. Setting the Edge Angle for a Wireframe Object (p. 44)
2. Creating a Point for the Origin of the Streamline (p. 45)
3. Creating a Streamline Originating from a Point (p. 46)
4. Rearranging the Point (p. 47)
5. Configuring a Default Legend (p. 47)
6. Creating a Slice Plane (p. 48)
7. Defining Slice Plane Geometry (p. 49)
8. Configuring Slice Plane Views (p. 49)
9. Rendering Slice Planes (p. 50)
10. Coloring the Slice Plane (p. 51)
11. Moving the Slice Plane (p. 51)
12. Adding Contours (p. 52)
13. Working with Animations (p. 53)
Setting the Edge Angle for a Wireframe Object

The outline of the geometry is called the wireframe or outline plot.

By default, ANSYS CFX-Post displays only some of the surface mesh. This sometimes means that when you first load your results file, the geometry outline is not displayed clearly. You can control the amount of the surface mesh shown by editing the Wireframe object listed in the Outline.

The check boxes next to each object name in the Outline control the visibility of each object. Currently only the Wireframe and Default Legend objects have visibility selected.

The edge angle determines how much of the surface mesh is visible. If the angle between two adjacent faces is greater than the edge angle, then that edge is drawn. If the edge angle is set to 0°, the entire surface mesh is drawn. If the edge angle is large, then only the most significant corner edges of the geometry are drawn.

For this geometry, a setting of approximately 15° lets you view the model location without displaying an excessive amount of the surface mesh.

In this module you can also modify the zoom settings and view of the wireframe.

**Procedure**

1. In the Outline, under User Locations and Plots, double-click Wireframe.  
   *Tip:* While it is not necessary to change the view to set the angle, do so to explore the practical uses of this feature.
2. Right-click on a blank area anywhere in the viewer, select Predefined Camera from the shortcut menu and select Isometric View (Z up).
3. In the Wireframe details view, under Definition, click in the Edge Angle box.  
   An embedded slider is displayed.
4. Type a value of 10 [degree].
5. Click Apply to update the object with the new setting.
Notice that more surface mesh is displayed.

6. Drag the embedded slider to set the **Edge Angle** value to approximately 45 [degree].
7. Click **Apply** to update the object with the new setting. 
   Less of the outline of the geometry is displayed.
8. Type a value of 15 [degree].
9. Click **Apply** to update the object with the new setting.
10. Right-click on a blank area anywhere in the viewer, select **Predefined Camera** from the shortcut menu and select **View Towards -X**.

Creating a Point for the Origin of the Streamline

A streamline is the path that a particle of zero mass would follow through the domain.

**Procedure**

1. Select **Insert > Location > Point** from the main menu.
   You can also use the toolbars to create a variety of objects. Later modules and tutorials explore this further.
2. Click **OK**.
   This accepts the default name.
3. Under **Definition**, ensure that **Method** is set to **XYZ**.
4. Under **Point**, enter the following coordinates: 
   
   -1, -1, 1.
   This is a point near the first inlet.
5. Click **Apply**.
   The point appears as a symbol in the viewer as a crosshair symbol.
Creating a Streamline Originating from a Point

Where applicable, streamlines can trace the flow direction forwards (downstream) and/or backwards (upstream).

Procedure

1. From the main menu, select **Insert > Streamline**. You can also use the toolbars to create a variety of objects. Later modules and tutorials will explore this further.
2. Click **OK**. This accepts the default name.
3. Under **Definition**, in **Start From**, ensure that **Point 1** is set. **Tip:** To create streamlines originating from more than one location, click the ellipsis icon to the right of the **Start From** box. This displays the **Location Selector** dialog box, where you can use the <Ctrl> and <Shift> keys to pick multiple locators.
4. Click the **Color** tab.
5. Set **Mode** to **Variable**.
6. Set **Variable** to **Total Temperature**.
7. Set **Range** to **Local**.
8. Click **Apply**. The streamline shows the path of a zero mass particle from **Point 1**. The temperature is initially high near the hot inlet, but as the fluid mixes the temperature drops.
Rearranging the Point

Once created, a point can be rearranged manually or by setting specific coordinates.

*Tip:* In this module, you may choose to display various views and zooms from the Predefined Camera option in the shortcut menu (such as Isometric View (Z up) or View Towards -X) and by using Zoom Box if you prefer to change the display.

**Procedure**

1. In Outline, under User Locations and Plots double-click Point 1. Properties for the selected user location are displayed.
2. Under Point, set these coordinates: -1, -2.9, 1.
3. Click Apply. The point is moved and the streamline redrawn.
4. In the selection tools, click Single Select.

While in this mode, the normal behavior of the left mouse button is disabled.

5. In the viewer, drag Point 1 (appears as a yellow addition sign) to a new location within the mixer. The point position is updated in the details view and the streamline is redrawn at the new location. The point moves normal in relation to the viewing direction.
6. Click Rotate.

*Tip:* You can also click in the viewer area, and press the space bar to toggle between Select and Viewing Mode. A way to pick objects from Viewing Mode is to hold down <Ctrl> + <Shift> while clicking on an object with the left mouse button.
7. Under Point, reset these coordinates: -1, -1, 1.
8. Click Apply. The point appears at its original location.
9. Right-click a blank area in the viewer and select Predefined Camera > View Towards -X.

Configuring a Default Legend

You can modify the appearance of the default legend.

The default legend appears whenever a plot is created that is colored by a variable. The streamline color is based on temperature; therefore, the legend shows the temperature range. The color pattern on the legend’s color bar is banded in accordance with the bands in the plot.

---

1. An exception occurs when one or more bands in a contour plot represent values beyond the legend’s range. In this case, such bands are colored using a color that is extrapolated slightly past the range of colors shown in the legend. This can happen only when a user-specified range is used for the legend.
The default legend displays values for the last eligible plot that was opened in the details view. To maintain a legend definition during an ANSYS CFX-Post session, you can create a new legend by clicking Legend. Because there are many settings that can be customized for the legend, this module allows you the freedom to experiment with them. In the last steps you will set up a legend, based on the default legend, with a minor modification to the position.

*Tip:* When editing values, you can restore the values that were present when you began editing by clicking Reset. To restore the factory-default values, click Default.

### Procedure

1. Double click Default Legend View 1. The Definition tab of the default legend is displayed.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>Title Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Title</td>
<td>Streamline Temp.</td>
</tr>
<tr>
<td></td>
<td>Horizontal</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Location &gt; Y Justification</td>
<td>Bottom</td>
</tr>
</tbody>
</table>

3. Click Apply.
   The appearance and position of the legend changes based on the settings specified.
4. Modify various settings in Definition and click Apply after each change.
5. Select Appearance.
6. Modify a variety of settings in the Appearance and click Apply after each change.
7. Click Defaults.
8. Click Apply.
9. Under Outline in User Locations and Plots, clear the check boxes for Point 1 and Streamline 1.
   Since both are no longer visible, the associated legend no longer appears.

### Creating a Slice Plane

Defining a slice plane allows you to obtain a cross-section of the geometry.

In ANSYS CFX-Post you often view results by coloring a graphic object. The graphic object could be an isosurface, a vector plot, or in this case, a plane. The object can be a fixed color or it can vary based on the value of a variable.

You already have some objects defined by default (listed in the Outline). You can view results on the boundaries of the static mixer by coloring each boundary object by a variable.

To view results within the geometry (that is, on non-default locators), you will create new objects.

You can use the following methods to define a plane:
- Three Points: creates a plane from three specified points.
Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Viewing the Results in ANSYS CFX-Post

- **Point and Normal**: defines a plane from one point on the plane and a normal vector to the plane.
- **YZ Plane, ZX Plane, and XY Plane**: similar to **Point and Normal**, except that the normal is defined to be normal to the indicated plane.

**Procedure**

1. From the main menu, select **Insert > Location > Plane** or click **Location > Plane**.
2. In the **New Plane** window, type: **Slice**
3. Click **OK**.
   
   The **Geometry, Color, Render, and View** tabs let you switch between settings.
4. Click the **Geometry** tab.

**Defining Slice Plane Geometry**

You need to choose the vector normal to the plane. You want the plane to lie in the x-y plane, hence its normal vector points along the z-axis. You can specify any vector that points in the z-direction, but you will choose the most obvious (0,0,1).

**Procedure**

1. If required, under **Geometry**, expand **Definition**.
2. Under **Method** select **Point and Normal**.
3. Under **Point** enter **0,0,1**.
4. Under **Normal** enter **0,0,1**.
5. Click **Apply**.
   
   **Slice** displays under **User Locations and Plots**. Rotate the view to see the plane.

**Configuring Slice Plane Views**

Depending on the view of the geometry, various objects may not appear because they fall in a 2D space that cannot be seen.

**Procedure**

1. Right-click a blank area in the viewer and select **Predefined Camera > Isometric View (Z up)**.
The slice is now visible in the viewer.

2. Click **Zoom Box**.
3. Click and drag a rectangular selection over the geometry.
4. Release the mouse button to zoom in on the selection.
5. Click **Rotate**.
6. Click and drag the mouse pointer down slightly to rotate the geometry towards you.
7. Select **Isometric View (Z up)** as described earlier.

**Rendering Slice Planes**

Render settings determine how the plane is drawn.

**Procedure**
1. In the **Details** pane for **Slice**, select the **Render** tab.
2. Clear **Draw Faces**.
3. Select **Draw Lines**.
4. Under **Draw Lines** change **Color Mode** to **User Specified**.
5. Click the current color in **Line Color** to change to a different color.
   For a greater selection of colors, click the ellipsis to use the **Select color** dialog box.
6. Click **Apply**.
7. Click **Zoom Box**.
8. Zoom in on the geometry to view it in greater detail.
The line segments show where the slice plane intersects with mesh element faces. The end points of each line segment are located where the plane intersects mesh element edges.

9. Right-click a blank area in the viewer and select **Predefined Camera > View Towards -Z**.

The image shown below can be used for comparison with tutorial 2 (in the section *Creating a Slice Plane* (p. 68)), where a refined mesh is used.

### Coloring the Slice Plane

The **Color** panel is used to determine how the object faces are colored.

**Procedure**

1. Apply the following settings to **Slice**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable*</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

* You can specify the variable (in this case, temperature) used to color the graphic element. The **Constant** mode allows you to color the plane with a fixed color.

2. Click **Apply**.

Hot water (red) enters from one inlet and cold water (blue) from the other.

### Moving the Slice Plane

The plane can be moved to different locations.
Tutorial 1a: Simulating Flow in a Static Mixer Using Workbench: Viewing the Results in ANSYS CFX-Post

Procedure

1. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up) from the shortcut menu.
2. Click the Geometry tab. Review the settings in Definition under Point and under Normal.
3. Click Single Select.
4. Click and drag the plane to a new location that intersects the domain. As you drag the mouse, the viewer updates automatically. Note that Point updates with new settings.
5. Set Point settings to 0, 0, 1.
6. Click Apply.
7. Click Rotate.
8. Turn off visibility for Slice by clearing the check box next to Slice in the Outline.

Adding Contours

Contours connect all points of equal value for a scalar variable (for example, Temperature) and help to visualize variable values and gradients. Colored bands fill the spaces between contour lines. Each band is colored by the average color of its two bounding contour lines (even if the latter are not displayed).

Procedure

1. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up) from the shortcut menu.
2. Select Insert > Contour from the main menu or click Contour. The New Contour dialog box is displayed.
3. Set Name to Slice Contour.
4. Click OK.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>Slice</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

6. Click Apply.

Important: The colors of 3D graphics object faces are slightly altered when lighting is on. To view colors with highest accuracy, on the Render tab under Draw Faces clear Lighting and click Apply.
The graphic element faces are visible, producing a contour plot as shown.

Working with Animations

Animations build transitions between views for development of video files.

Workflow Overview

This tutorial follows the general workflow for creating a keyframe animation:

1. Showing the Animation Dialog Box (p. 53)
2. Creating the First Keyframe (p. 53)
3. Creating the Second Keyframe (p. 54)
4. Viewing the Animation (p. 55)
5. Modifying the Animation (p. 56)
6. Saving to MPEG (p. 57)

Showing the Animation Dialog Box

The Animation dialog box is used to define keyframes and to export to a video file.

Procedure

1. Select Tools > Animation or click Animation .

   The Animation dialog box can be repositioned as required.

Creating the First Keyframe

Keyframes are required in order to produce an animation. You need to define the first viewer state, a second (and final) viewer state, and set the number of interpolated intermediate frames.
Tutotial 1a: Simulating Flow in a Static Mixer Using Workbench: Viewing the Results in ANSYS CFX-Post

Procedure

1. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up).
2. In the Outline, under User Locations and Plots, clear the visibility of Slice Contour and select the visibility of Slice.
3. Select Tools > Animation or click Animation .
   The Animation dialog box can be repositioned as required.
4. In the Animation dialog box, click New .
   A new keyframe named KeyframeNo1 is created. This represents the current image displayed in the viewer.

Creating the Second Keyframe

Keyframes are required in order to produce an animation.

Procedure

1. In the Outline, under User Locations and Plots, double-click Slice.
2. On the Geometry tab, set Point coordinate values to (0, 0, -1.99).
3. Click Apply.
   The slice plane moves to the bottom of the mixer.
4. In the Animation dialog box, click New .
   KeyframeNo2 is created and represents the image displayed in the Viewer.
5. Select KeyframeNo1.
6. Set # of Frames (located below the list of keyframes) to 20.
This is the number of intermediate frames used when going from KeyframeNo1 to KeyframeNo2. This number is displayed in the Frames column for KeyframeNo1.

7. Press Enter.

The Frame # column shows the frame in which each keyframe appears. KeyframeNo1 appears at frame 1 since it defines the start of the animation. KeyframeNo2 is at frame 22 since you have 20 intermediate frames (frames 2 to 21) in between KeyframeNo1 and KeyframeNo2.

Viewing the Animation

More keyframes could be added, but this animation has only two keyframes (which is the minimum possible).

The controls previously greyed-out in the Animation dialog box are now available. The number of intermediate frames between keyframes is listed beside the keyframe having the lowest number of the pair. The number of keyframes listed beside the last keyframe is ignored.

Procedure

1. Click Play the animation.

The animation plays from frame 1 to frame 22. It plays relatively slowly because the slice plane must be updated for each frame.
Modifying the Animation

To make the plane sweep through the whole geometry, you will set the starting position of the plane to be at the top of the mixer. You will also modify the Range properties of the plane so that it shows the temperature variation better. As the animation is played, you can see the hot and cold water entering the mixer. Near the bottom of the mixer (where the water flows out) you can see that the temperature is quite uniform. The new temperature range lets you view the mixing process more accurately than the global range used in the first animation.

Procedure

1. Apply the following settings to Slice

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Point</td>
<td>0, 0, 1.99</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td>Range</td>
<td>User Specified</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>295 [K]</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>305 [K]</td>
</tr>
</tbody>
</table>

2. Click Apply.

   The slice plane moves to the top of the static mixer.

Note: Do not double click in the next step.

3. In the Animation dialog box, single click (do not double-click) KeyframeNo1 to select it.

   If you had double-clicked KeyFrameNo1, the plane and viewer states would have been redefined according to the stored settings for KeyFrameNo1. If this happens, click Undo and try again to select the keyframe.

4. Click Set Keyframe.

   The image in the Viewer replaces the one previously associated with KeyframeNo1.

5. Double-click KeyframeNo2.

   The object properties for the slice plane are updated according to the settings in KeyFrameNo2.

6. Apply the following settings to Slice

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>295 [K]</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>305 [K]</td>
</tr>
</tbody>
</table>

7. Click Apply.

8. In the Animation dialog box, single-click KeyframeNo2.

9. Click Set Keyframe to save the new settings to KeyframeNo2.
Saving to MPEG

By defining the geometry and then saving to MPEG, the results can be saved to a video file.

**Procedure**

1. Click *More Animation Options* to view the additional options.
   
   The **Loop** and **Bounce** radio buttons determine what happens when the animation reaches the last keyframe. When **Loop** is selected, the animation repeats itself the number of times defined by **Repeat**. When **Bounce** is selected, every other cycle is played in reverse order, starting with the second.

2. Click **Save MPEG**.

3. Click *Browse* next to **Save MPEG**.

4. Under *File name* type: *StaticMixer.mpg*

5. If required, set the path location to a different folder.

6. Click **Save**.
   
   The MPEG file name (including path) is set. At this point, the animation has not yet been produced.

7. Click **Previous Keyframe**.
   
   Wait a moment as the display updates the keyframe display.

8. Click **Play the animation**.

9. If prompted to overwrite an existing movie click **Overwrite**.
   
   The animation plays and builds an MPEG file.

10. Click the **Options** button at the bottom of the **Animation** dialog box.
    
    In **Advanced**, you can see that a **Frame Rate** of 24 frames per second was used to create the animation. The animation you produced contains a total of 22 frames, so it takes just under 1 second to play in a media player.

11. Click **Cancel** to close the dialog box.

12. Close the **Animation** dialog box.

13. Review the animation in third-party software as required.

Exiting ANSYS CFX-Post

When finished with ANSYS CFX-Post, exit the current window:

1. Select **File > Close** to close the current file.

2. If prompted to save, click **Close**.

3. Return to the Project page. Select **File > Close Project**.

4. Select **No**, then close Workbench.
Tutorial 2:
Flow in a Static Mixer
(Refined Mesh)

Introduction

This tutorial includes:
• Tutorial 2 Features (p. 60)
• Overview of the Problem to Solve (p. 60)
• Defining a Simulation using General Mode in ANSYS CFX-Pre (p. 61)
• Obtaining a Solution Using Interpolation with ANSYS CFX-Solver (p. 66)
• Viewing the Results in ANSYS CFX-Post (p. 68)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
• Setting the Working Directory (p. 1)
• Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 61).

Sample files used by this tutorial are:
• StaticMixerRefMesh.gtm
• StaticMixerRef.pre
• StaticMixer.def
• StaticMixer_001.res
Tutorial 2 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Planevolume</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Spherevolume</td>
</tr>
<tr>
<td>Other</td>
<td></td>
<td>Viewing the Mesh</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Using the General Mode of ANSYS CFX-Pre (this mode is used for more complex cases).
- Rerunning a problem with a refined mesh.
- Importing CCL to copy the definition of a different simulation into the current simulation.
- Viewing the mesh with a Sphere volume locator and a Surface Plot.
- Using a Plane Volume locator and the Mesh Calculator to analyze mesh quality.

Overview of the Problem to Solve

In this tutorial, you use a refined mesh to obtain a better solution to the Static Mixer problem created in Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode (p. 3). You establish a general workflow for analyzing the flow of fluid into and out of a mixer. This tutorial uses a specific problem to teach the general approach taken when working with an existing mesh.

You start a new simulation in ANSYS CFX-Pre and import the refined mesh. This tutorial introduces General Mode—the mode used for most tutorials—in ANSYS CFX-Pre. The physics for this tutorial are the same as for Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode (p. 3); therefore, you can import the physics settings used in that tutorial to save time.
Defining a Simulation using General Mode in ANSYS CFX-Pre

After having completed meshing, ANSYS CFX-Pre is used as a consistent and intuitive interface for the definition of complex CFD problems.

Playing a Session File

If you want to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the appropriate session file. For details, see Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 65). After you have played the session file, proceed to Obtaining a Solution Using Interpolation with ANSYS CFX-Solver (p. 66).

Workflow Overview

This section provides a brief summary of the topics so that you can see the workflow:

1. Creating a New Simulation (p. 61)
2. Importing a Mesh (p. 62)
3. Importing CCL (p. 62)
4. Viewing Domain Settings (p. 63)
5. Viewing the Boundary Condition Setting (p. 64)
6. Defining Solver Parameters (p. 64)
7. Writing the Solver (.def) File (p. 64)

As an alternative to these steps, you can also review Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 65)

To begin this tutorial and create a new simulation in ANSYS CFX-Pre, continue from Creating a New Simulation (p. 61).

Creating a New Simulation

Before importing and working with a mesh, a simulation needs to be developed using General mode.

Note: Two procedures are documented. Depending on your installation of ANSYS CFX, follow either the Standalone procedure or the Workbench procedure.

Procedure in Standalone

1. If required, launch ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General in the New Simulation File dialog box and click OK.
4. Select File > Save Simulation As.
5. Under File name, type StaticMixerRef and click Save.
6. Proceed to Importing a Mesh (p. 62).

Procedure in Workbench

1. If required, launch ANSYS Workbench.
2. Click Empty Project.
Tutorial 2: Flow in a Static Mixer (Refined Mesh): Defining a Simulation using General Mode in ANSYS CFX-Pre

The Project page appears displaying an unsaved project.

3. Select File > Save or click Save.
4. If required, set the path location to your working folder.
5. Under File name, type StaticMixerRef and click Save.
6. Click Start CFX-Pre under Advanced CFD on the left hand task bar.
7. Select File > New Simulation.
8. Click General in the New Simulation File window, and then click OK.
9. Select File > Save Simulation As.
10. Under File name, type StaticMixerRef and click Save.

Importing a Mesh

At least one mesh must be imported before physics are applied.

An assembly is a group of mesh regions that are topologically connected. Each assembly can contain only one mesh, but multiple assemblies are permitted. The Mesh tree shows the regions in Assembly in a tree structure. The level below Assembly displays 3D regions and the level below each 3D region shows the 2D regions associated with it. The check box next to each item in the Mesh tree indicates the visibility status of the object in the viewer; you can click these to toggle visibility.

Procedure

1. Select File > Import Mesh or right-click Mesh and select Import Mesh.
2. In the Import Mesh dialog box, select StaticMixerRefMesh.gtm from your working directory.
   This is a mesh that is more refined than the one used in Tutorial 1.
3. Click Open.
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up) from the shortcut menu.

Importing CCL

Since the physics for this simulation is very similar to that for Tutorial 1, you can save time by importing the settings used there.

The CCL contains settings that reference mesh regions. For example, the outlet boundary condition references the mesh region named out. In this tutorial, the name of the mesh regions are the same as in Tutorial 1, so you can import the CCL without error.

The physics for a simulation can be saved to a CCL (CFX Command Language) file at any time by selecting File > Export CCL. However, a number of other files can also be used as sources to import CCL including:

- Simulation files (*.cfx)
- Results files (*.res)
- Definition files (*.def)

Note: If you import CCL that references non-existent mesh regions, you will get errors.
Procedure

1. Select File > Import CCL. The Import CCL dialog box appears.
2. Under Import Method, select Append. Replace is useful if you have defined physics and want to update or replace them with newly imported physics.
4. Select StaticMixer.def created in Tutorial 1. If you did not work through Tutorial 1, you can copy this file from the examples directory.
5. Click Open.
6. Select the Outline tab.

Tip: To select Outline you may need to click the navigation icons next to the tabs to move ‘forward’ or ‘backward’ through the various tabs.

The tree view displays a summary of the current simulation in a tree structure. Some items may be recognized from Tutorial 1—for example the boundary condition objects in1, in2, and out.

Viewing Domain Settings

It is useful to review the options available in General Mode.
Various domain settings can be set. These include:

- **General Options**
  Specifies the location of the domain, coordinate frame settings and the fluids/solids that are present in the domain. You also reference pressure, buoyancy and whether the domain is stationary or rotating. Mesh motion can also be set.

- **Fluid Models**
  Sets models that apply to the fluid(s) in the domain, such as heat transfer, turbulence, combustion, and radiation models. An option absent in Tutorial 1 is *Turbulent Wall Functions*, which is set to Scalable. Wall functions model the flow in the near-wall region. For the k-epsilon turbulence model, you should always use scalable wall functions.

- **Initialization**
  Sets the initial conditions for the current domain only. This is generally used when multiple domains exist to allow setting different initial conditions in each domain, but can also be used to initialize single-domain simulations. Global initialization allows the specification of initial conditions for all domains that do not have domain-specific initialization.

Procedure

1. On the Outline tree view, under Simulation, double-click Default Domain. The domain Default Domain is opened for editing.
2. Click General Options and review, but do not change, the current settings.
3. Click Fluid Models and review, but do not change, the current settings.
4. Click Initialization and review, but do not change, the current settings.
5. Click Close.
**Tutorial 2: Flow in a Static Mixer (Refined Mesh): Defining a Simulation using General Mode in ANSYS CFX-Pre**

**Viewing the Boundary Condition Setting**

For the k-epsilon turbulence model, you must specify the turbulent nature of the flow entering through the inlet boundary. For this simulation, the default setting of Medium (Intensity = 5%) is used. This is a sensible setting if you do not know the turbulence properties of the incoming flow.

**Procedure**
1. Under Default Domain, double-click in1.
2. Click the Boundary Details tab and review the settings for Flow Regime, Mass and Momentum, Turbulence and Heat Transfer.
3. Click Close.

**Defining Solver Parameters**

Solver Control parameters control aspects of the numerical-solution generation process. In Tutorial 1 you set some solver control parameters, such as Advection Scheme and Timescale Control, while other parameters were set automatically by ANSYS CFX-Pre.

In this tutorial, High Resolution is used for the advection scheme. This is more accurate than the Upwind Scheme used in Tutorial 1. You usually require a smaller timestep when using this model. You can also expect the solution to take a higher number of iterations to converge when using this model.

**Procedure**
1. Select Insert > Solver > Solver Control from the main menu or click Solver Control.
2. Apply the following Basic Settings
3. Click Apply.
4. Click the Advanced Options tab.
5. Ensure that Global Dynamic Model Control is selected.
6. Click OK.

**Writing the Solver (.def) File**

Once all boundaries are created you move from ANSYS CFX-Pre into ANSYS CFX-Solver.
Tutorial 2: Flow in a Static Mixer (Refined Mesh): Defining a Simulation using General Mode in ANSYS CFX-Pre

The simulation file—StaticMixerRef.cfx—contains the simulation definition in a format that can be loaded by ANSYS CFX-Pre, allowing you to complete (if applicable), restore, and modify the simulation definition. The simulation file differs from the definition file in two important ways:

- The simulation file can be saved at any time while defining the simulation.
- The definition file is an encapsulated set of meshes and CCL defining a solver run, and is a subset of the data in the simulation file.

Procedure

1. Click **Write Solver File**.
   The **Write Solver File** dialog box is displayed.
2. If required, set the path to your working directory.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>StaticMixerRef.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

   * If using ANSYS CFX-Pre in Standalone Mode.
4. Ensure **Start Solver Manager** is selected and click **Save**.
5. If you are notified that the file already exists, click **Overwrite**.
6. If prompted, click **Yes** or **Save & Quit** to save StaticMixerRef.cfx.
   The definition file (StaticMixerRef.def) and the simulation file (StaticMixerRef.cfx) are created. ANSYS CFX-Solver Manager automatically starts and the definition file is set in the **Definition File** box of **Define Run**.
7. Proceed to Obtaining a Solution Using Interpolation with ANSYS CFX-Solver (p. 66).

Playing the Session File and Starting ANSYS CFX-Solver Manager

If you have performed all the tasks in the previous steps, proceed directly to Obtaining a Solution Using Interpolation with ANSYS CFX-Solver (p. 66).

Two procedures are documented. Depending on your installation of ANSYS CFX follow either the standalone procedure or the ANSYS Workbench procedure.

Procedure in Standalone

1. If required, launch ANSYS CFX-Pre.
2. Select **Session > Play Tutorial**.
3. Select StaticMixerRef.pre.
4. Click **Open**.
   A definition file is written.
5. Select **File > Quit**.
6. Launch ANSYS CFX-Solver Manager from CFX Launcher.
7. After ANSYS CFX-Solver starts, select **File > Define Run**.
8. Under **Definition File**, click **Browse**.
9. Select StaticMixerRef.def, located in the working directory.
Tutorial 2: Flow in a Static Mixer (Refined Mesh): Obtaining a Solution Using Interpolation with ANSYS CFX-Solver


Procedure in ANSYS Workbench

1. If required, launch ANSYS Workbench.
2. Click Empty Project.
3. Select File > Save or click Save.
4. Under File name, type StaticMixerRef and click Save.
5. Click Start CFX-Pre.
6. Select Session > Play Tutorial.
7. Select StaticMixerRef.pre.
8. Click Open.
   A definition file is written.
9. Click the CFX-Solver tab.
10. Select File > Define Run.
11. Under Definition File, click Browse.
12. Select StaticMixerRef.def, located in the working directory.

Obtaining a Solution Using Interpolation with ANSYS CFX-Solver

Two windows are displayed when ANSYS CFX-Solver Manager runs. There is an adjustable split between the windows which is oriented either horizontally or vertically, depending on the aspect ratio of the entire ANSYS CFX-Solver Manager window (also adjustable).

Workflow Overview

This section provides a brief summary of the topics to follow as a general workflow:

1. Interpolating the Results and Starting the Run (p. 66)
2. Confirming Results (p. 67)
3. Moving from ANSYS CFX-Solver to ANSYS CFX-Post (p. 67)

Interpolating the Results and Starting the Run

In the ANSYS CFX-Solver Manager, Define Run is visible and Definition File has automatically been set to the definition file from ANSYS CFX-Pre: StaticMixerRef.def. You want to make use of the results from Tutorial 1, but the two meshes are not identical. The initial values file needs to have its data interpolated onto the new mesh associated with the definition file.

The ANSYS CFX-Solver supports automatic interpolation that will be used in the following steps:
Tutorial 2: Flow in a Static Mixer (Refined Mesh): Obtaining a Solution Using Interpolation with ANSYS CFX-Solver

The values from StaticMixer_001.res will be interpolated onto the definition file's mesh when the run is started. The results from StaticMixer_001.res will be used as the initial guess for this simulation (rather than Solver defaults) because you have set the initialization for all variables in ANSYS CFX-Pre to Automatic or Automatic with Value.

Procedure

1. Under Initial Values File, click Browse.
2. Select the results file from Tutorial 1: StaticMixer_001.res
   If you did not complete the first tutorial, you can use StaticMixer_001.res from your working directory.
3. Click Open.
4. Select Interpolate Initial Values onto Def File Mesh.
5. Click Start Run.

Note: The message Finished interpolation successfully appears relatively quickly. Convergence information is plotted once the second outer loop iteration is complete.

Confirming Results

When interpolation is successful, specific information appears in the text screen of ANSYS CFX-Solver.

To confirm that the interpolation was successful, look in the text pane in ANSYS CFX-Solver Manager. The following text appears before the convergence history begins:

+---------------------------------------------------------+
| Initial Conditions Supplied by Fields in the Input Files |
+---------------------------------------------------------+

This lists the variables that were interpolated from the results file. After the final iteration, a message similar to the following content appears:

CFD Solver finished: Tue Oct 19 08:06:45 2004
CFD Solver wall clock seconds: 1.7100E+02
Execution terminating:
all residual
are below their target criteria

This indicates that ANSYS CFX-Solver has successfully calculated the solution for the problem to the specified accuracy or has run out of coefficient loops.

Procedure

1. When the run finishes and asks if you want to post-process the results, click No to keep ANSYS CFX-Solver open. Review the results on the Out File tab for details on the run results.

Moving from ANSYS CFX-Solver to ANSYS CFX-Post

Once ANSYS CFX-Solver has finished, you can use ANSYS CFX-Post to review the finished results.

Procedure

1. Select Tools > Post–Process Results or click Post–Process Results in the toolbar.
2. If using ANSYS CFX-Solver in Standalone Mode, select Shut down Solver Manager. This forces Standalone ANSYS CFX-Solver to close when finished. This option is not required in Workbench.
3. Click OK.
Tutorial 2: Flow in a Static Mixer (Refined Mesh): Viewing the Results in ANSYS CFX-Post

After a short pause, ANSYS CFX-Post starts.

Viewing the Results in ANSYS CFX-Post

In the following sections, you will explore the differences between the mesh and the results from this tutorial and tutorial 1.

Creating a Slice Plane

More information exists for use by ANSYS CFX-Post in this tutorial than in Tutorial 1 because the slice plane is more detailed.

Once a new slice plane is created it can be compared with Tutorial 1. There are three noticeable differences between the two slice planes.

- Around the edges of the mixer geometry there are several layers of narrow rectangles. This is the region where the mesh contains prismatic elements (which are created as inflation layers). The bulk of the geometry contains tetrahedral elements.
- There are more lines on the plane than there were in Tutorial 1. This is because the slice plane intersects with more mesh elements.
- The curves of the mixer are smoother than in Tutorial 1 because the finer mesh better represents the true geometry.

Procedure

1. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up).
2. From the main menu, select Insert > Location > Plane or under Location, click Plane.
3. In the Insert Plane dialog box, type Slice and click OK.
   The Geometry, Color, Render and View tabs let you switch between settings.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Domains</td>
<td>Default Domain</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Method</td>
<td>XY Plane</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Z</td>
<td>1 [m]</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

5. Click Apply.
6. Right-click a blank area in the viewer and select Predefined Camera > View Towards -Z.
7. Click Zoom Box.
8. Zoom in on the geometry to view it in greater detail.
Tutorial 2: Flow in a Static Mixer (Refined Mesh): Viewing the Results in ANSYS CFX-Post

Compare the on-screen image with the equivalent picture from tutorial 1 (in the section Rendering Slice Planes (p. 22)).

Coloring the Slice Plane

Here, you will color the plane by temperature.

**Procedure**

1. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>Global</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

* A mode setting of *Constant* would allow you to color the plane with a fixed color.

2. Click **Apply**.

Loading Results from Tutorial 1 for Comparison

In ANSYS CFX-Post, you may load multiple results files into the same instance for comparison.

**Procedure**

1. To load the results file from Tutorial 1, select **File > Load Results** or click **Load Results**.

2. Be careful not to click **Open** until instructed to do so. In the **Load Results File** dialog box, select **StaticMixer_001.res** in the `<CFXROOT>\examples` directory or from your working directory if it has been copied.
3. On the right side of the dialog box, there are two frames. Under **Results file option**, select **Add to current results**.
4. Select the **Offset in Y direction** check box.
5. Under **Additional actions**, ensure that the **Clear user state before loading** check box is cleared.
6. Click **Open** to load the results.
   In the tree view, there is now a second group of domains, meshes and boundary conditions with the heading **StaticMixer_001**.
7. Double-click the Wireframe object under **User Locations and Plots**.
8. In the **Definition** tab, set **Edge Angle** to 5 [degree].
9. Click **Apply**.
10. Right-click a blank area in the viewer and select **Predefined Camera > Isometric View (Z up)**.
    Both meshes are now displayed in a line along the Y axis. Notice that one mesh is of a higher resolution than the other.
11. Set **Edge Angle** to 30 [degree].
12. Click **Apply**.

Creating a Second Slice Plane

**Procedure**
1. In the tree view, right-click the plane named **Slice** and select **Duplicate**.
2. Click **OK** to accept the default name **Slice 1**.
3. In the tree view, double-click the plane named **Slice 1**.
4. On the **Geometry** tab, set **Domains** to **Default Domain 1**.
5. On the **Color** tab, ensure that **Range** is set to **Global**.
6. Click **Apply**.
7. Double-click **Slice** and make sure that **Range** is set to **Global**.

Comparing Slice Planes using Multiple Views

**Procedure**
1. Select the option with the two vertical rectangles. Notice that the Viewer now has two separate views.

The visibility status of each object is maintained separately for each view or figure that can be displayed in a given viewport. This allows some planes to be shown while others are hidden.
2. Click in the viewport that is set to show View 1, then clear the visibility check box for Slice in the Outline tree view and ensure that the visibility check box for Slice 1 is selected.

3. Click in the viewport that is set to show View 2, then select the visibility check box for Slice and ensure that the visibility check box for Slice 1 is cleared.

4. In the tree view, double-click StaticMixer_001 and clear Apply Translation.

5. Click Apply.

6. In the viewer toolbar, click Synchronise Active Views.

   Notice that both views move in the same way and are zoomed in at the same level.

7. Right-click in the viewer and select Predefined Camera > View Towards -Z.

   Note the difference in temperature distribution.

8. To return to a single viewport, select the option with a single rectangle.

9. Right-click Slice 1 in the tree view and select Delete.

10. Ensure that the visibility check box for Slice is cleared.

11. Right-click StaticMixer_001 in the tree view and select Unload.

Viewing the Surface Mesh on the Outlet

In this part of the tutorial, you will view the mesh on the outlet. You will see five layers of inflated elements against the wall. You will also see the triangular faces of the tetrahedral elements closer to the center of the outlet.

**Procedure**

1. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up).

2. In the tree view, ensure that the visibility check box for StaticMixerRef_001 > Default Domain > out is selected, then double-click out to open it for editing.

   Since the boundary location geometry was defined in ANSYS CFX-Pre, the details view does not display a Geometry tab as it did for the planes.

3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Color Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Line Color</td>
<td>(Select any light color)</td>
</tr>
</tbody>
</table>

4. Click Apply.
Looking at the Inflated Elements in Three Dimensions

To show more clearly what effect inflation has on the shape of the elements, you will use volume objects to show two individual elements. The first element that will be shown is a normal tetrahedral element; the second is a prismatic element from an inflation layer of the mesh.

Leave the surface mesh on the outlet visible to help see how surface and volume meshes are related.

**Procedure**

1. From the main menu, select **Insert > Location > Volume** or, under **Location** click **Volume**.
2. In the **Insert Volume** dialog box, type **Tet Volume** and click **OK**.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Sphere</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Point</td>
<td>0.08, 0, -2</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Radius</td>
<td>0.14 [m]</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Mode</td>
<td>Below Intersection</td>
</tr>
<tr>
<td></td>
<td>Inclusive†</td>
<td>(Cleared)</td>
</tr>
<tr>
<td>Color</td>
<td>Color</td>
<td>Red</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces &gt; Transparency</td>
<td>0.3</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Width</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Color Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Color</td>
<td>Grey</td>
</tr>
</tbody>
</table>

* The z slider’s minimum value corresponds to the minimum z value of the entire geometry, which, in this case, occurs at the outlet.
† Only elements that are entirely contained within the sphere volume will be included.

4. Click **Apply** to create the volume object.
5. Right-click **Tet Volume** and choose **Duplicate**.
6. In the **Duplicate Tet Volume** dialog box, type **Prism Volume** and click **OK**.
7. Double-click **Prism Volume**.
8. Apply the following settings
Viewing the Surface Mesh on the Mixer Body

**Procedure**
1. Double-click the Default Domain Default object.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Line Width</td>
<td>2</td>
</tr>
</tbody>
</table>

3. Click **Apply**.

Viewing the Layers of Inflated Elements on a Plane

You will see the layers of inflated elements on the wall of the main body of the mixer. Within the body of the mixer, there will be many lines that are drawn wherever the face of a mesh element intersects the slice plane.

**Procedure**
1. From the main menu, select **Insert > Location > Plane** or under **Location**, click **Plane**.
2. In the **Insert Plane** dialog box, type **Slice 2** and click **OK**.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>YZ Plane</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; X</td>
<td>0 [m]</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

4. Click **Apply**.
5. Turn off the visibility of all objects except **Slice 2**.
6. To see the plane clearly, right-click in the viewer and select **Predefined Camera > View Towards -X**.

Viewing the Mesh Statistics

You can use the Report Viewer to check the quality of your mesh. For example, you can load a `.def` file into ANSYS CFX-Post and check the mesh quality before running the `.def` file in the solver.
**Tutorial 2: Flow in a Static Mixer (Refined Mesh): Viewing the Results in ANSYS CFX-Post**

**Procedure**

1. Click the **Report Viewer** tab (located below the viewer window).
   
   A report appears. Look at the table shown in the "Mesh Report" section.


3. In the **Mesh Report** details view, select **Statistics** > **Maximum Face Angle**.

4. Click **Refresh Preview**.

   Note that a new table, showing the maximum face angle for all elements in the mesh, has been added to the "Mesh Report" section of the report. The maximum face angle is reported as 148.95°.

   As a result of generating this mesh statistic for the report, a new variable, **Maximum Face Angle**, has been created and stored at every node. This variable will be used in the next section.

**Viewing the Mesh Elements with Largest Face Angle**

In this section, you will visualize the mesh elements that have a **Maximum Face Angle** value greater than 140°.

**Procedure**

1. Click the **3D Viewer** tab (located below the viewer window).

2. Right-click a blank area in the viewer and select **Predefined Camera** > **Isometric View (Z up)**.

3. In the **Outline** tree view, select the visibility check box of **Wireframe**.

4. From the main menu, select **Insert** > **Location** > **Volume** or under **Location**, click **Volume**.

5. In the **Insert Volume** dialog box, type **Max Face Angle Volume** and click **OK**.

6. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Isovolume</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Maximum Face Angle*</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Mode</td>
<td>Above Value</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Value</td>
<td>140 [degree]</td>
</tr>
<tr>
<td></td>
<td>Inclusive†</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* Select **Maximum Face Angle** from the larger list of variables available by clicking 
  ![ ] to the right of the **Variable** box.

† This includes any elements that have at least one node with a variable value greater than or equal to the given value.

7. Click **Apply**.

   The volume object appears in the viewer.
Viewing the Mesh Elements with Largest Face Angle Using a Point

Next, you will create a point object to show a node that has the maximum value of Maximum Face Angle. The point object will be represented by a 3D yellow crosshair symbol. In order to avoid obscuring the point object with the volume object, you may want to turn off the visibility of the latter.

Procedure

1. From the main menu, select **Insert > Location > Point** or under **Location**, click **Point**.
2. Click **OK** to use the default name.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Variable Maximum</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Location</td>
<td>Default Domain</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Maximum Face Angle</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>2</td>
</tr>
</tbody>
</table>

4. Click **Apply**.

Quitting ANSYS CFX-Post

Two procedures are documented. Depending on your installation of ANSYS CFX, follow either the standalone procedure or the ANSYS Workbench procedure.

**Procedure in Standalone**

1. When you are finished, select **File > Quit** to exit ANSYS CFX-Post.
2. Click **Quit** if prompted to save.

**Procedure in Workbench**

1. When you are finished, select **File > Close** to close the current file.
2. Click **Close** if prompted to save.
3. Return to the Project page. Select **File > Close Project**.
4. Select **No**, then close Workbench.
Tutorial 3: Flow in a Process Injection Mixing Pipe

Introduction

This tutorial includes:
- Tutorial 3 Features (p. 78)
- Overview of the Problem to Solve (p. 78)
- Defining a Simulation using General Mode in ANSYS CFX-Pre (p. 79)
- Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 87)
- Viewing the Results in ANSYS CFX-Post (p. 88)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 79).

Sample files referenced by this tutorial include:
- InjectMixer.pre
- InjectMixer_velocity_profile.csv
- InjectMixerMesh.gtm
Tutorial 3 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td>Boundary</td>
<td>Boundary Profile visualization</td>
<td></td>
</tr>
<tr>
<td>Conditions</td>
<td>Inlet (Profile)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Inlet (Subsonic)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Outlet (Subsonic)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall: No-Slip</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall: Adiabatic</td>
<td></td>
</tr>
<tr>
<td>CEL (CFX</td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>Expression</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Language</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>default Locators</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outline Plot (Wireframe)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Streamline</td>
</tr>
<tr>
<td>Other</td>
<td>Changing the Color Range</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Expression Details View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Legend</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Viewing the Mesh</td>
<td></td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Applying a profile boundary condition using data stored in a file.
- Visualizing the velocity on a boundary in ANSYS CFX-Pre.
- Using the CFX Expression Language (CEL) to describe temperature dependent fluid properties in ANSYS CFX-Pre.
- Using the k-epsilon turbulence model.
- Using streamlines in ANSYS CFX-Post to track flow through the domain.

Overview of the Problem to Solve

In this tutorial, you establish a general workflow for analyzing the flow of fluid into and out of an injection pipe. This tutorial is important because it uses a specific problem to teach the general approach taken when working with an existing mesh.
The injection mixing pipe, common in the process industry, is composed of two pipes: one with a larger diameter than the other. Analyzing and optimizing the mixing process is often critical for many chemical processes. CFD is useful not only in identifying problem areas (where mixing is poor), but also in testing new designs before they are implemented.

The geometry for this example consists of a circular pipe of diameter 1.0 m with a 90° bend, and a smaller pipe of diameter 0.3 m which joins with the main pipe at an oblique angle.

Defining a Simulation using General Mode in ANSYS CFX-Pre

After having completed meshing, ANSYS CFX-Pre is used as a consistent and intuitive interface for the definition of complex CFD problems.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select *Session > Play Tutorial* from the menu in ANSYS CFX-Pre, then run the appropriate session file. For details, see *Playing the Session File and Starting ANSYS CFX-Solver Manager* (p. 87). After you have played the session file, proceed to *Obtaining a Solution Using ANSYS CFX-Solver Manager* (p. 87).

Workflow Overview

This section provides a brief summary of the topics to follow as a general workflow:

1. Creating a New Simulation (p. 80)
2. Importing a Mesh (p. 80)
3. Setting Temperature-Dependent Material Properties (p. 81)
4. Plotting an Expression (p. 82)
Tutorial 3: Flow in a Process Injection Mixing Pipe: Defining a Simulation using General Mode in ANSYS CFX-Pre

5. Evaluating an Expression (p. 82)
6. Modify Material Properties (p. 82)
7. Creating the Domain (p. 82)
8. Creating the Side Inlet Boundary Conditions (p. 83)
9. Creating the Main Inlet Boundary Conditions (p. 84)
10. Creating the Main Outlet Boundary Condition (p. 85)
11. Setting Initial Values (p. 85)
12. Setting Solver Control (p. 85)
13. Writing the Solver (.def) File (p. 86)

Creating a New Simulation

Before importing and working with a mesh, a simulation needs to be started using General Mode.

**Note:** Two procedures are documented. Depending on your installation of ANSYS CFX follow either the Standalone procedure or the Workbench procedure.

**Procedure in Standalone**

1. If required, launch ANSYS CFX-Pre.
2. Select **File > New Simulation**.
3. Ensure **General** is selected and click **OK**.
4. Select **File > Save Simulation As**.
5. Under **File name**, type *InjectMixer*.
6. Click **Save**.
7. Proceed to Importing a Mesh (p. 80).

**Procedure in Workbench**

1. If required, launch ANSYS Workbench.
2. Click **Empty Project**.
   
   The Project page will appear displaying an unsaved project.
3. Select **File > Save** or click **Save**.
4. If required, set the path location to your working folder.
5. Under **File name**, type *InjectMixer*.
6. Click **Save**.
7. Click **Start CFX-Pre** under **Advanced CFD** on the left hand task bar.
8. Select **File > New Simulation**.
9. Click **General** in the **New Simulation File** window and then click **OK**.
10. Select **File > Save Simulation As**.
11. Under **File name**, type *InjectMixer*.
12. Click **Save**.

Importing a Mesh

An assembly is a group of mesh regions that are topologically connected. Each assembly can contain only one mesh, but multiple assemblies are permitted.
Procedure

1. Select File > Import Mesh.
2. From your tutorial directory, select InjectMixerMesh.gtm.
3. Click Open.
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Y up) from the shortcut menu.

Setting Temperature-Dependent Material Properties

You will create an expression for viscosity as a function of temperature and then use this expression to modify the properties of the library material: Water.

Viscosity will be made to vary linearly with temperature between the following conditions:

- \( \mu = 1.8 \times 10^{-3} \text{ N s m}^{-2} \) at \( T=275.0 \text{ K} \)
- \( \mu = 5.45 \times 10^{-4} \text{ N s m}^{-2} \) at \( T=325.0 \text{ K} \)

The variable \( T \) (Temperature) is an ANSYS CFX System Variable recognized by ANSYS CFX-Pre, denoting static temperature. All variables, expressions, locators, functions, and constants can be viewed by double-clicking the appropriate entry (such as Additional Variables or Expressions) in the tree view.

All expressions must have consistent units. You should be careful if using temperature in an expression with units other than \([\text{K}]\).

The Expressions tab lets you define, modify, evaluate, plot, copy, delete and browse through expressions used within ANSYS CFX-Pre.

Procedure

1. From the main menu, select Insert > Expressions, Functions and Variables > Expression.
2. In the New Expression dialog box, type Tupper.
3. Click OK.
   - The details view for the Tupper equation is displayed.
4. Under Definition, type 325 \([\text{K}]\).
5. Click Apply to create the expression.
   - The expression is added to the list of existing expressions.
7. In the New Expression dialog box, type Tlower.
8. Click OK.
9. Under Definition, type 275 \([\text{K}]\).
10. Click Apply to create the expression.
    - The expression is added to the list of existing expressions.
11. Create expressions for Visupper, Vislower and VisT using the following values:

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visupper</td>
<td>( 5.45 \times 10^{-4} \text{ N s m}^{-2} )</td>
</tr>
<tr>
<td>Vislower</td>
<td>( 1.8 \times 10^{-3} \text{ N s m}^{-2} )</td>
</tr>
<tr>
<td>VisT</td>
<td>( \text{Vislower} + (\text{Visupper-Vislower})^*(T-Tlower)/(Tupper-Tlower) )</td>
</tr>
</tbody>
</table>
Tutorial 3: Flow in a Process Injection Mixing Pipe: Defining a Simulation using General Mode in ANSYS CFX-Pre

Plotting an Expression

Procedure

1. Right-click \textit{\textsc{visT}} in the \textbf{Expressions} tree view, and then select \textbf{Edit}.

   The \textbf{Expressions} details view for \textit{\textsc{visT}} appears.

   \textit{Tip:} Alternatively, double-clicking the expression also opens the \textbf{Expressions} details view.

2. Click the \textbf{Plot} tab and apply the following settings

\begin{table}[h]
\centering
\begin{tabular}{|c|c|c|}
\hline
\textbf{Tab} & \textbf{Setting} & \textbf{Value} \\
\hline
Plot & Number of Points & 10 \\
 & \textsc{T} & (Selected) \\
 & \textsc{Start of Range} & 275 [K] \\
 & \textsc{End of Range} & 325 [K] \\
\hline
\end{tabular}
\end{table}

3. Click \textbf{Plot Expression}.

   A plot showing the variation of the expression \textit{\textsc{visT}} with the variable \textit{T} is displayed.

Evaluating an Expression

Procedure

1. Click the \textbf{Evaluate} tab.

2. In \textit{T}, type 300 [K].

   This is between the start and end range defined in the last module.

3. Click \textbf{Evaluate Expression}.

   The value of \textit{\textsc{visT}} for the given value of \textit{T} appears in the \textit{Value} field.

Modify Material Properties

Default material properties (such as those of \textit{\textsc{Water}}) can be modified when required.

Procedure

1. Click the \textbf{Outline} tab.

2. Double-click \textsc{\textit{Water}} under \textit{Materials} to display the \textbf{Basic Settings} tab.

3. Click the \textbf{Material Properties} tab.

4. Expand \textit{\textbf{Transport Properties}}.

5. Select \textbf{Dynamic Viscosity}.


7. Click \textbf{Enter Expression}.

8. Enter the expression \textit{\textsc{visT}} into the data box.

9. Click \textbf{OK}.

Creating the Domain

The domain will be set to use the thermal energy heat transfer model, and the \textit{k-\epsilon} (k-epsilon) turbulence model.
Both General Options and Fluid Models are changed in this module. The Initialization tab is for setting domain-specific initial conditions, which are not used in this tutorial. Instead, global initialization is used to set the starting conditions.

Procedure
1. Select Insert > Domain from the main menu or click Domain.
2. In the Insert Domain dialog box, type InjectMixer.
3. Click OK.
4. Apply the following settings.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>B1.P3</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Fluids List</td>
<td>Water</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reference Pressure</td>
<td>0 [atm]</td>
</tr>
</tbody>
</table>

5. Click Fluid Models.
6. Apply the following settings.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Heat Transfer &gt; Option</td>
<td>Thermal Energy</td>
</tr>
</tbody>
</table>

7. Click OK.

Creating the Side Inlet Boundary Conditions

The side inlet boundary condition needs to be defined.

Procedure
1. Select Insert > Boundary Condition from the main menu or click Boundary Condition.
2. Set Name to side inlet.
3. Click OK.
4. Apply the following settings.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>side inlet</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td></td>
<td>Normal Speed</td>
<td>5 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Static Temperature</td>
</tr>
<tr>
<td></td>
<td>Static Temperature</td>
<td>315 [K]</td>
</tr>
</tbody>
</table>

5. Click OK.
Tutorial 3: Flow in a Process Injection Mixing Pipe: Defining a Simulation using General Mode in ANSYS CFX-Pre

Creating the Main Inlet Boundary Conditions

The main inlet boundary condition needs to be defined. This inlet is defined using a velocity profile found in the example directory. Profile data needs to be initialized before the boundary condition can be created.

You will create a plot showing the velocity profile data, marked by higher velocities near the center of the inlet, and lower velocities near the inlet walls.

Procedure

1. Select **Tools > Initialize Profile Data**.
2. Under **Data File**, click **Browse**.
3. From your working directory, select **InjectMixer_velocity_profile.csv**.
4. Click **Open**.
5. Click **OK**.

   The profile data is read into memory.
6. Select **Insert > Boundary Condition** from the main menu or click **Boundary Condition**.
7. Set name **Name** to **main inlet**.
8. Click **OK**.
9. Apply the following settings:

```
<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>main inlet</td>
</tr>
<tr>
<td></td>
<td>Profile Boundary Conditions</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Profile Boundary Setup</td>
<td>main inlet</td>
</tr>
<tr>
<td></td>
<td>Profile Name</td>
<td>main inlet</td>
</tr>
</tbody>
</table>
```

10. Click **Generate Values**.

   This causes the profile values of U, V, W to be applied at the nodes on the main inlet boundary, and U, V, W entries to be made in **Boundary Details**. To later modify the velocity values at the main inlet and reset values to those read from the BC Profile file, revisit **Basic Settings** for this boundary condition and click **Generate Values**.
11. Apply the following settings:

```
<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td>Flow Regime &gt; Option</td>
<td>Subsonic</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Medium (Intensity = 5%)</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Static Temperature</td>
</tr>
<tr>
<td></td>
<td>Static Temperature</td>
<td>285 [K]</td>
</tr>
<tr>
<td>Plot Options</td>
<td>Boundary Contour</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Profile Variable</td>
<td>W</td>
</tr>
</tbody>
</table>
```

12. Click **OK**.
13. Zoom into the main inlet to view the inlet velocity contour.

Creating the Main Outlet Boundary Condition

In this module you create the outlet boundary condition. All other surfaces which have not been explicitly assigned a boundary condition will remain in the InjectMixer Default object, which is shown in the tree view. This boundary condition uses a No-Slip Adiabatic Wall by default.

**Procedure**

1. Select Insert > **Boundary Condition** from the main menu or click **Boundary Condition**.
2. Set **Name** to **outlet**.
3. Click **OK**.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>outlet</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Flow Regime &gt; Option</td>
<td>Subsonic</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Option</td>
<td>Average Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

5. Click **OK**.

Setting Initial Values

**Procedure**

1. Click **Global Initialization**.
2. Select **Turbulence Eddy Dissipation**.
3. Click **OK**.

Setting Solver Control

**Procedure**

1. Click **Solver Control**.
2. Apply the following settings
3. Click **OK**.

### Writing the Solver (.def) File

Once the problem has been defined you move from General Mode into ANSYS CFX-Solver.

**Procedure**

1. Click **Write Solver File**.

   The **Write Solver File** dialog box appears.

2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>InjectMixer.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

   * If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.

4. If you are notified the file already exists, click **Overwrite**.

   This file is provided in the tutorial directory and may exist in your working folder if you have copied it there.

5. If prompted, click **Yes** or **Save & Quit** to save **InjectMixer.cfx**.

   The definition file (**InjectMixer.def**), mesh file (**InjectMixer.gtm**) and the simulation file (**InjectMixer.cfx**) are created. ANSYS CFX-Solver Manager automatically starts and the definition file is set in the **Definition File** box of **Define Run**.

6. Proceed to **Obtaining a Solution Using ANSYS CFX-Solver Manager** (p. 87).
Playing the Session File and Starting ANSYS CFX-Solver Manager

If you have performed all the tasks in the previous steps, proceed directly to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 87).

Two procedures are documented. Depending on your installation of ANSYS CFX, follow either the standalone procedure or the ANSYS Workbench procedure.

### Procedure in Standalone

1. If required, launch ANSYS CFX-Pre.
2. Select **Session > Play Tutorial**.
3. Select **InjectMixer.pre**.
4. Click **Open**.
   
   A definition file is written.
5. Select **File > Quit**.
6. Launch ANSYS CFX-Solver Manager from CFX Launcher.
7. After ANSYS CFX-Solver starts, select **File > Define Run**.
8. Under **Definition File**, click **Browse**.
9. Select **InjectMixer.def**, located in the working directory.
10. Proceed to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 87).

### Procedure in ANSYS Workbench

1. If required, launch ANSYS Workbench.
2. Click **Empty Project**.
3. Select **File > Save** or click **Save**.
4. Under **Filename**, type **InjectMixer**.
5. Click **Save**.
6. Click **Start CFX-Pre**.
7. Select **Session > Play Tutorial**.
8. Select **InjectMixer.pre**.
9. Click **Open**.
   
   A definition file is written.
10. Click the **CFX-Solver** tab.
11. Select **File > Define Run**.
12. Under **Definition File**, click **Browse**.
13. Select **InjectMixer.def**, located in the working directory.

### Obtaining a Solution Using ANSYS CFX-Solver Manager

At this point, ANSYS CFX-Solver Manager is running, and the **Define Run** dialog box is displayed, with the definition file set.

1. Click **Start Run**.
2. Click **No** to close the message box that appears when the run ends.
Tutorial 3: Flow in a Process Injection Mixing Pipe: Viewing the Results in ANSYS CFX-Post

Moving from ANSYS CFX-Solver Manager to ANSYS CFX-Post

1. Select Tools > Post–Process Results or click Post–Process Results.
2. If using ANSYS CFX-Solver Manager in standalone mode, optionally select Shut down Solver Manager.
3. Click OK.

Viewing the Results in ANSYS CFX-Post

When ANSYS CFX-Post starts, the viewer and Outline workspace display by default.

Workflow Overview

This section provides a brief summary of the topics to follow as a general workflow:

1. Modifying the Outline of the Geometry (p. 88)
2. Creating and Modifying Streamlines (p. 88)
3. Modifying Streamline Color Ranges (p. 89)
4. Coloring Streamlines with a Constant Color (p. 89)
5. Duplicating and Modifying a Streamline Object (p. 90)
6. Examining Turbulent Kinetic Energy (p. 90)

Modifying the Outline of the Geometry

Throughout this and the following examples, use your mouse and the Viewing Tools toolbar to manipulate the geometry as required at any time.

Procedure

1. In the tree view, double click Wireframe.
2. Set the Edge Angle to 15 [degree].
3. Click Apply.

Creating and Modifying Streamlines

When you complete this module you will see streamlines (mainly blue and green) starting at the main inlet of the geometry and proceeding to the outlet. Above where the side pipe meets the main pipe, there is an area where the flow re-circulates rather than flowing roughly tangent to the direction of the pipe walls.

Procedure

1. Select Insert > Streamline from the main menu or click Streamline.
2. Under Name, type MainStream.
3. Click OK.
4. Apply the following settings
5. Click **Apply**.

6. Right-click a blank area in the viewer, select **Predefined Camera** from the shortcut menu, then select **Isometric View (Y up)**.

   The pipe is displayed with the main inlet in the bottom right of the viewer.

### Modifying Streamline Color Ranges

You can change the appearance of the streamlines using the **Range** setting on the **Color** tab.

**Procedure**

1. Under **User Locations and Plots**, modify the streamline object **MainStream** by applying the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Type</td>
<td>3D Streamline</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Start From</td>
<td>main inlet</td>
</tr>
</tbody>
</table>

   2. Click **Apply**.

   The color map is fitted to the range of velocities found along the streamlines. The streamlines therefore collectively contain every color in the color map.

   3. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>0.2 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>2.2 [m s^-1]</td>
</tr>
</tbody>
</table>

   **Note:** Portions of streamlines that have values outside the range shown in the legend are colored according to the color at the nearest end of the legend. When using tubes or symbols (which contain faces), more accurate colors are obtained with lighting turned off.

   4. Click **Apply**.

   The streamlines are colored using the specified range of velocity values.

### Coloring Streamlines with a Constant Color

1. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Constant</td>
</tr>
<tr>
<td></td>
<td>Color</td>
<td>(Green)</td>
</tr>
</tbody>
</table>
Duplicating and Modifying a Streamline Object

Any object can be duplicated to create a copy for modification without altering the original.

**Procedure**

1. Right-click `MainStream` and select `Duplicate` from the shortcut menu.
2. In the `Name` window, type `SideStream`.
3. Click `OK`.
4. Double click on the newly created streamline, `SideStream`.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Start From</td>
<td><code>side inlet</code></td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td><code>Constant</code></td>
</tr>
<tr>
<td></td>
<td>Color</td>
<td><code>(Red)</code></td>
</tr>
</tbody>
</table>

6. Click `Apply`.

Red streamlines appear, starting from the side inlet.

7. For better view, select **Isometric View (Y up)**.

Examining Turbulent Kinetic Energy

A common way of viewing various quantities within the domain is to use a slice plane, as demonstrated in this module.

**Note:** This module has multiple changes compiled into single steps in preparation for other tutorials that provide fewer specific instructions.

**Procedure**

1. Clear visibility for both the `MainStream` and the `SideStream` objects.
2. Create a plane named `Plane 1` that is normal to X and passing through the X = 0 Point. To do so, specific instructions follow.
   a. From the main menu, select `Insert > Location > Plane` and click `OK`.
   b. In the `Details` view set `Definition > Method` to `YZ Plane` and `X` to `0 [m]`.
   c. Click `Apply`.
3. Color the plane using the variable `Turbulence Kinetic Energy`, to show regions of high turbulence. To do so, apply the settings below.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td><code>Variable</code></td>
</tr>
<tr>
<td></td>
<td>Variable <code>Turbulence Kinetic Energy</code></td>
<td></td>
</tr>
</tbody>
</table>

4. Click `Apply`. 
5. Experiment with other variables to color this plane (for example, Temperature to show the temperature mixing of the two streams).

Commonly used variables are in the drop-down menu. A full list of available variables can be viewed by clicking next to the Variable data box.

Exiting ANSYS CFX-Post

When finished with ANSYS CFX-Post exit the current window.

Two procedures are documented. Depending on your installation of ANSYS CFX, follow either the Standalone procedure or the Workbench procedure.

**Procedure in Standalone**

1. When you are finished, select File > Quit to exit ANSYS CFX-Post.
2. Click Quit if prompted to save.

**Procedure in Workbench**

1. When you are finished, select File > Close to close the current file.
2. Click Close if prompted to save.
4. Select No, then close Workbench.
Tutorial 4: Flow from a Circular Vent

Introduction

This tutorial includes:
- Tutorial 4 Features (p. 94)
- Overview of the Problem to Solve (p. 95)
- Defining a Steady-State Simulation in ANSYS CFX-Pre (p. 95)
- Obtaining a Solution to the Steady-State Problem (p. 99)
- Defining a Transient Simulation in ANSYS CFX-Pre (p. 100)
- Obtaining a Solution to the Transient Problem (p. 104)
- Viewing the Results in ANSYS CFX-Post (p. 105)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 95).

Sample files referenced by this tutorial include:
- CircVent.pre
- CircVentIni.pre
- CircVentIni_001.res
- CircVentMesh.gtm
- CircVentIni.cfx
- CircVentIni.gtm
Tutorial 4 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Auto Time Scale</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient Example</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Animation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Isosurface</td>
</tr>
<tr>
<td></td>
<td>Other</td>
<td>Auto Annotation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MPEG Generation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Printing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Time Step Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Title/Text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient Animation</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Setting up a transient problem in ANSYS CFX-Pre.
- Using an opening type boundary condition in ANSYS CFX-Pre.
- Modeling smoke using additional variables in ANSYS CFX-Pre.
- Visualizing a smoke plume using an Isosurface in ANSYS CFX-Post.
- Creating an image for printing, and generating an MPEG file in ANSYS CFX-Post.
Overview of the Problem to Solve

In this example, a chimney stack releases smoke which is dispersed into the atmosphere with an oncoming side wind. Unlike previous tutorials, which were steady-state, this example is time-dependent. Initially, no smoke is being released. In the second part of the tutorial, the chimney starts to release smoke and it shows how the plume of smoke above the chimney develops with time.

Defining a Steady-State Simulation in ANSYS CFX-Pre

This section describes the step-by-step definition of the flow physics in ANSYS CFX-Pre for a steady-state simulation with no smoke being produced by the chimney. The results from this simulation will be used as the initial guess for the transient simulation.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: CircVentIni.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution to the Steady-State Problem (p. 99).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type CircVentIni.
6. Click Save.
Tutorial 4: Flow from a Circular Vent: Defining a Steady-State Simulation in ANSYS CFX-Pre

Importing the Mesh

1. Select File > Import Mesh.
2. From your working directory, select CircVentMesh.gtm.
3. Click Open.
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up) from the shortcut menu.

Creating an Additional Variable

In this tutorial, an additional variable (non-reacting scalar component) will be used to model the dispersion of smoke from the vent.

Note: While smoke is not required for the steady-state simulation, including it here prevents the user from having to set up timevalue interpolation in the transient simulation.

1. From the main menu, select Insert > Expressions, Functions and Variables > Additional Variable or click Additional Variable.
2. Under Name, type smoke.
3. Click OK.
4. Under Variable Type, select Volumetric.
5. Set Units to \([\text{kg m}^{-3}]\).
6. Click OK.

Creating the Domain

The fluid domain will be created that includes the additional variable.

To Create a New Domain

1. Select Insert > Domain from the main menu, or click Domain, then set the name to CircVent and click OK.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Fluids List</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Reference Pressure</td>
<td>0 [atm]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Additional Variable Details &gt; smoke</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Additional Variable Details &gt; smoke &gt; Kinematic Diffusivity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Additional Variable Details &gt; smoke &gt; Kinematic Diffusivity &gt; Kinematic Diffusivity</td>
<td>1.0E-5 [m^2 s^-1]</td>
</tr>
</tbody>
</table>
3. Click OK.
Creating the Boundary Conditions

This is an example of external flow, since fluid is flowing over an object and not through an enclosure such as a pipe network (which would be an example of internal flow). In such problems, some inlets will be made sufficiently large that they do not affect the CFD solution. However, the length scale values produced by the Default Intensity and AutoCompute Length Scale option for turbulence are based on inlet size. They are appropriate for internal flow problems and particularly, cylindrical pipes. In general, you need to set the turbulence intensity and length scale explicitly for large inlets in external flow problems. If you do not have a value for the length scale, you can use a length scale based on a typical length of the object, over which the fluid is flowing. In this case, you will choose a turbulence length scale which is one-tenth of the diameter of the vent.

**Note:** The boundary marker vectors used to display boundary conditions (Inlets, Outlets, Openings) are normal to the boundary surface regardless of the actual direction specification. To plot vectors in the direction of flow, select Boundary Vector under the Plot Options tab for the inlet boundary condition and clear Show Inlet Markers on the Boundary Marker Options tab of Labels and Markers (accessible by clicking Label and Marker Visibility).

For parts of the boundary where the flow direction changes, or is unknown, an opening boundary condition can be used. An opening boundary condition allows flow to both enter and leave the fluid domain during the course of the solution.

**Inlet Boundary**

1. Select Insert > Boundary Condition from the main menu or click Boundary Condition.
2. Under Name, type Wind.
3. Click OK.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Wind</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Cart. Vel. Components</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; U</td>
<td>1 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; V</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; W</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Intensity and Length Scale</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Value</td>
<td>0.05</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Eddy Len. Scale</td>
<td>0.25 [m]</td>
</tr>
<tr>
<td></td>
<td>Additional Variables &gt; smoke &gt; Option</td>
<td>Value</td>
</tr>
<tr>
<td></td>
<td>Additional Variables &gt; smoke &gt; Value</td>
<td>0 [kg m^-3]</td>
</tr>
</tbody>
</table>

5. Click OK.
Opening Boundary

1. Select Insert > Boundary Condition from the main menu or click Boundary Condition.
2. Under Name, type Atmosphere.
3. Click OK.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Atmosphere</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Opening Pres. and Dirn</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
<tr>
<td></td>
<td>Flow Direction &gt; Option</td>
<td>Normal to Boundary Condition</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Intensity and Length Scale</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Value</td>
<td>0.05</td>
</tr>
<tr>
<td></td>
<td>Turbulance &gt; Eddy Len. Scale</td>
<td>0.25 [m]</td>
</tr>
<tr>
<td></td>
<td>Additional Variables &gt; smoke &gt; Option</td>
<td>Value</td>
</tr>
<tr>
<td></td>
<td>Additional Variables &gt; smoke &gt; Value</td>
<td>0 [kg m^-3]</td>
</tr>
</tbody>
</table>

5. Click OK.

Inlet for the Vent

1. Select Insert > Boundary Condition from the main menu or click Boundary Condition.
2. Under Name, type Vent.
3. Click OK.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Vent</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>0.01 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Intensity and Eddy Viscosity Ratio</td>
</tr>
<tr>
<td></td>
<td>Additional Variables &gt; smoke &gt; Option</td>
<td>Value</td>
</tr>
<tr>
<td></td>
<td>Additional Variables &gt; smoke &gt; Value</td>
<td>0 [kg m^-3]</td>
</tr>
</tbody>
</table>

5. Click OK.

Setting Initial Values

1. Click Global Initialization.
2. Select Turbulence Eddy Dissipation.
3. Click OK.
Setting Solver Control

ANSYS CFX-Solver has the ability to calculate physical timestep size for steady-state problems. If you do not know the time step size to set for your problem, you can use the Auto Timescale option.

1. Click Solver Control.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Max. Iterations</td>
<td>75</td>
</tr>
</tbody>
</table>

3. Click OK.

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>CircVentIni.def</td>
</tr>
<tr>
<td>Quit CFX–Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. Quit ANSYS CFX-Pre, saving the simulation (.cfx) file.

Obtaining a Solution to the Steady-State Problem

When ANSYS CFX-Pre has shut down and ANSYS CFX-Solver Manager has started, you can obtain a solution to the CFD problem by using the following procedure.

1. Click Start Run.
   The residual plots for six equations will appear: U - Mom, V - Mom, W - Mom, P - Mass, K-TurbKE and E-Diss.K (the three momentum conservation equations, the mass conservation equation and equations for the turbulence kinetic energy and turbulence eddy dissipation). The Momentum and Mass tab contains four of the plots and the other two are under Turbulence Quantities. The variable smoke is also plotted but registers no values since it is not initialized.

2. Click No to close the completion message, since you do not need to view the results in ANSYS CFX-Post.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
   You will now reload the simulation into ANSYS CFX-Pre to define the transient simulation.
Defining a Transient Simulation in ANSYS CFX-Pre

In this part of the tutorial, you alter the simulation settings used for the steady-state calculation to set up the model for the transient calculation in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: CircVent.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution to the Transient Problem (p. 104).

Opening the Existing Simulation

1. Start ANSYS CFX-Pre.
2. Select File > Open Simulation.
3. If required, set the path location to the tutorial folder.
4. Select the simulation file CircVentIni.cfx.
5. Click Open.
6. Select File > Save Simulation As.
7. Change the name to CircVent.cfx.
8. Click Save.

Modifying the Simulation Type

In this step you will make the problem transient. Later, you will set the concentration of smoke to rise exponentially with time, so it is necessary to ensure that the interval between the timesteps is smaller at the beginning of the simulation than at the end.

1. Click Simulation Type.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Simulation Type &gt; Option</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Duration &gt; Total Time</td>
<td>30 [s]</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Steps &gt; Timesteps†</td>
<td>4<em>0.25, 2</em>0.5, 2<em>1.0, 13</em>2.0 [s]</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Initial Time &gt; Time</td>
<td>0 [s]</td>
</tr>
</tbody>
</table>

* Do NOT click Enter Expression to enter lists of values. Enter the list without the units, then set the units in the drop-down list.
† This list specifies 4 timesteps of 0.25 [s], then 2 timesteps of 0.5 [s], etc.
3. Click OK.
Modifying the Boundary Conditions

The only boundary condition which needs altering is the Vent boundary condition. In the steady-state calculation, this boundary had a small amount of air flowing through it. In the transient calculation, more air passes through the vent and there is a time-dependent concentration of smoke in the air. This is initially zero, but builds up to a larger value. The smoke concentration will be specified using the CFX Expression Language.

To Modify the Vent Inlet Boundary Condition

1. In the Outline workspace, expand the tree to Simulation > CircVent > Vent.
2. Right-click Vent and select Edit.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>0.2 (\text{m} \text{s}^{-1})</td>
</tr>
</tbody>
</table>

Leave the Vent details view open for now.

You are going to create an expression for smoke concentration. The concentration is zero for time \(t=0\) and builds up to a maximum of 1 \(\text{kg} \text{m}^{-3}\).

4. Create a new expression by selecting Insert > Expressions, Functions and Variables > Expression from the main menu. Set the name to TimeConstant.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>TimeConstant</td>
<td>3 (\text{s})</td>
</tr>
</tbody>
</table>

6. Click Apply to create the expression.
7. Create the following expressions with specific settings, remembering to click Apply after each is defined.

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>FinalConcentration</td>
<td>1 (\text{kg} \text{m}^{-3})</td>
</tr>
<tr>
<td>ExpFunction*</td>
<td>FinalConcentration*abs(1-exp(-t/TimeConstant))</td>
</tr>
</tbody>
</table>

* When entering this function, you can select most of the required items by right-clicking in the Definition window in the Expression details view instead of typing them. The names of the existing expressions are under the Expressions menu. The exp and abs functions are under Functions > CEL. The variable \(t\) is under Variables.

Note: The abs function takes the modulus (or magnitude) of its argument. Even though the expression \((1- \exp (-t/\text{TimeConstant}))\) can never be less than zero, the abs function is included to ensure that the numerical error in evaluating it near to zero will never make the expression evaluate to a negative number.

Next you will visualize how the expressions have scheduled the concentration of smoke issued from the vent.
Plotting Smoke Concentration

2. Apply the following settings
   - Click `Plot Expression`.
   - The button name then changes to Define Plot, as shown.
   - As can be seen, the smoke concentration rises exponentially, and reaches 90% of its final value at around 7 seconds.
3. Click Plot Expression.
   - The button name then changes to Define Plot, as shown.
   - In the next step, you will apply the expression `ExpFunction` to the additional variable `smoke` as it applies to the boundary `Vent`.
4. Click the Boundary: Vent tab.
   - In the next step, you will apply the expression `ExpFunction` to the additional variable `smoke` as it applies to the boundary `Vent`.
5. Apply the following settings
   - Click Enter Expression to enter text.
   - As can be seen, the smoke concentration rises exponentially, and reaches 90% of its final value at around 7 seconds.
6. Click OK.
Initialization Values

The steady state solution that you have finished calculating is used to supply the initial values to the ANSYS CFX-Solver. You can leave all of the initialization data set to Automatic and the initial values will be read automatically from the initial values file. Therefore, there is no need to revisit the initialization tab.

Modifying the Solver Control

1. Click Solver Control.
2. Set Convergence Control > Max. Coeff. Loops to 3.
3. Leave the other settings at their default values.
4. Click OK to set the solver control parameters.

Output Control

To allow results to be viewed at different timesteps, it is necessary to create transient results files at specified times. The transient results files do not have to contain all solution data. In this step, you will create minimal transient results files.

To Create Minimal Transient Results Files

1. From the main menu, select Insert > Solver > Output Control.
2. Click the Trn Results tab.
3. Click Add new item and then click OK to accept the default name for the object. This creates a new transient results object. Each object can result in the production of many transient results files.
4. Apply the following settings to Transient Results 1

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Selected Variables</td>
</tr>
<tr>
<td>Output Variables List‡</td>
<td>Pressure, Velocity, smoke</td>
</tr>
<tr>
<td>Output Frequency &gt; Option</td>
<td>Time List</td>
</tr>
<tr>
<td>Output Frequency &gt; Time List†</td>
<td>1, 2, 3 [s]</td>
</tr>
</tbody>
</table>

* Click the ellipsis icon to select items if they do not appear in the drop-down list. Use the <Ctrl> key to select multiple items.

‡ Do NOT click Enter Expression to enter lists of values. Enter the list without the units, then set the units in the drop-down list.

5. Click Apply.
6. Create a second item with the default name Transient Results 2 and apply the following settings to that item

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Selected Variables</td>
</tr>
<tr>
<td>Output Variables List</td>
<td>Pressure, Velocity, smoke</td>
</tr>
</tbody>
</table>
Tutorial 4: Flow from a Circular Vent: Obtaining a Solution to the Transient Problem

Writing the Solver (.def) File

1. Click **Write Solver File**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Frequency &gt; Option</td>
<td>Time Interval</td>
</tr>
<tr>
<td>Output Frequency &gt; Time Interval*</td>
<td>4 [s]</td>
</tr>
</tbody>
</table>

* A transient results file will be produced every 4 s (including 0 s) and at 1 s, 2 s and 3 s. The files will contain no mesh and data for only the three selected variables. This reduces the size of the minimal results files. A full results file is always written at the end of the run.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. Quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution to the Transient Problem

In this tutorial the ANSYS CFX-Solver will read the initial values for the problem from a file. For details, see Initialization Values (p. 103). You need to specify the file name.

**Define Run** will be displayed when the ANSYS CFX-Solver Manager launches. **Definition File** will already be set to the name of the definition file just written.

Notice that the text output generated by the ANSYS CFX-Solver will be more than you have seen for steady-state problems. This is because each timestep consists of several inner (coefficient) iterations. At the end of each timestep, information about various quantities is printed to the text output area.

The variable smoke is now plotted under the Additional Variables tab.

1. Under **Initial Values File**, click **Browse**.
2. Select **CircVentIni_001.res**, which is the results file of the steady-state problem with no smoke issuing from the chimney. If you have not run the first part of this tutorial, copy **CircVentIni_001.res** from the `<CFXROOT>/examples/` directory to your working directory.
3. Click **Open**.
4. Click **Start Run**.
5. You may see a notice that the mesh from the initial values file will be used. This mesh is the same as in the definition file. Click **OK** to continue.
6. When ANSYS CFX-Solver has finished, click Yes to post-process the results.

7. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

In this tutorial, you will view the dispersion of smoke from the vent over time. When ANSYS CFX-Post is loaded, the results that are immediately available are those at the final timestep; in this case, at $t = 30$ s (this is nominally designated Final State).

Creating an Isosurface

An isosurface is a surface of constant value of a variable. For instance, it could be a surface consisting of all points where the velocity is $1 \text{ m s}^{-1}$. In this case, you are going to create an isosurface of smoke density (smoke is the additional variable that you specified earlier).

1. Right-click on a blank area in the viewer and select Predefined Camera > Isometric View (Z up).

2. From the main menu, select Insert > Location > Isosurface or under Location, click Isosurface.

3. Click OK.

4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Variable</td>
<td>smoke</td>
</tr>
<tr>
<td>Value</td>
<td></td>
<td>0.005 $[\text{kg m}^{-3}]$</td>
</tr>
</tbody>
</table>

5. Click Apply.

   - A bumpy surface will be displayed, showing the smoke starting to emerge from the vent.
   - The surface is rough because the mesh is coarse. For a smoother surface, you would re-run the problem with a smaller mesh length scale.
   - The surface will be a constant color as the default settings on the Color tab were used.
   - When Color Mode is set to either Constant or Use Plot Variable for an isosurface, it appears as one color.

6. In Geometry, experiment by changing the Value so that you can see the shape of the plume more clearly.

   Zoom in and rotate the geometry, as required.

7. When you have finished, set the Value to $0.002$ $[\text{kg m}^{-3}]$.

8. Right-click on a blank spot in the viewer and select Predefined Camera > Isometric View (Z up).
 Viewing the Results at Different Timesteps

The **Timestep Selector** shows the **Time Step** (outer loop) number, the **Time Value** (simulated time in seconds) and the **Type** of results file that was saved at that timestep. You can see that **Partial** results files were saved (as requested in ANSYS CFX-Pre) for all timesteps except for the last one.

1. Click **Timestep Selector**.
2. Load the results for a time value of 2 s by double-clicking the appropriate row in the **Timestep Selector**.
   After a short pause, the **Current Timestep** (located just below the title bar of the **Timestep Selector**) will be updated with the new timestep number.
3. Load the time value of 4 s using the **Timestep Selector**.
   The smoke has now spread out even more, and is being carried by the wind.
4. Double-click some more time values to see how the smoke plume grows with time.
5. Finish by loading a time value of 1 s.

Generating Output Files

You can produce image output from ANSYS CFX-Post.

**Adding a title**

First, you will add text to the viewer so that the printed output has a title.

1. Select **Insert > Text** from the main menu or click **Create text**.
2. Click **OK**.
3. In the **Text String** box, enter the following text.

   *Isosurface showing smoke concentration of 0.002 kg/m^3 after*

   **Note:** Further text will be added at a later stage to complete this title.

4. Select **Embed Auto Annotation**.
5. Set **Type** to **Time Value**.
   In the text line, note that `<aa>` has been added to the end. This is where the time value will be placed.
6. Click **Apply** to create the title.
7. Click the **Location** tab to modify the position of the title.
   The default settings for text objects center text at the top of the screen. To experiment with the position of the text, change the settings on the **Location** tab.
8. Under **Appearance**, change **Color Mode** to **User Specified** and select a new color.
9. Click **Apply**.

**JPEG output**

ANSYS CFX-Post can produce hard-copy output in several different forms. In the next section you will print in JPEG format.

1. Ensure a time value of 1 s is loaded.
2. Select **File > Print**, or click **Print**.
3. Under **Format** select **JPEG**.
4. Click **Browse** next to the **File** data box.
5. Browse to the directory where you want the file saved.
6. Enter a name for the JPEG file.
7. Click **Save** to set the file name and directory.
   This sets the path and name for the file.
8. To print to the file, click **Print**.
   To view the file or make a hard copy, use an application that supports JPEG files.
9. Clear the visibility of the text object to hide it.

**To Generate an MPEG File**

You can generate an MPEG file to show the transient flow of the plume of smoke. To generate an MPEG file, you use the Animation dialog box in the same way as in Tutorial 1. However, to animate the plume of smoke, you need to animate over several timesteps.

**Note:** On the **Advanced** tab of Animation Options, there is a check box option called **Save frames as image files**. By selecting this option, the JPEG or PPM files used to encode each frame of the MPEG will persist after MPEG creation; otherwise, they are deleted.

**Setting Keyframes**

1. Click **Animation**.
2. Ensure that **Keyframe Animation** is selected.
3. Position the geometry so that you will be able to see the plume of smoke.
4. In the Animation dialog box, click **New** to create **KeyFrameNo1**.
5. Load the time value of 30 s using the **Timestep Selector**.
6. Click **New** in the Animation dialog box to create **KeyframeNo2**.

**Defining additional options**

During the production of a transient animation, various timesteps will be loaded and all objects will be updated to use the results from that timestep. Each frame of the animation must use one of the available timesteps.

In **Animation**, **Timestep** can be set to **Timestep Interpolation**, **TimeValue Interpolation** or **Sequential Interpolation**. This setting affects which timestep is loaded for each frame.

1. Click **More Animation Options** to show more animation settings.
2. Click **Options**.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options</td>
<td>Transient Case</td>
<td>TimeValue Interpolation</td>
</tr>
<tr>
<td></td>
<td>*</td>
<td>This causes each frame to use the transient file having the closest time value.</td>
</tr>
</tbody>
</table>

4. Click **OK**.
5. Single click **KeyframeNo1**, then set **# of Frames** to 27 and press <Enter>.
The animation now contains a total of 29 frames (27 intermediate frames plus the two keyframes).

6. Select **Save MPEG**.

7. Click **Browse** next to **Save MPEG**.

8. Under **File name**, type `CircVent.mpg`.

9. If required, set the path location to a different folder.

10. Click **Save**.

   The MPEG file name (including path) is set. At this point, the animation has not yet been produced.

11. Click **To Beginning**.

12. Click **Play the animation**.

   - The MPEG will be created as the animation proceeds.
   - This will be slow, since a timestep must be loaded and objects must be created for each frame.
   - To view the MPEG file, you need to use a viewer that supports the MPEG format.

13. When you have finished, quit ANSYS CFX-Post.
Tutorial 5: Flow Around a Blunt Body

Introduction

This tutorial includes:

- Tutorial 5 Features (p. 109)
- Overview of the Problem to Solve (p. 111)
- Defining a Simulation in ANSYS CFX-Pre (p. 111)
- Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 116)
- Viewing the Results in ANSYS CFX-Post (p. 119)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 111).

Sample files referenced by this tutorial include:

- BluntBody.pre
- BluntBodyDist.cse
- BluntBodyMesh.gtm

Tutorial 5 Features

This tutorial addresses the following features of ANSYS CFX.
In this tutorial you will learn about:

- Solving and post-processing a case where the geometry has been omitted on one side of a symmetry plane.
- Using free slip wall boundaries on the sides of and above the domain as a compromise between accurate flow modeling and computational grid size.
- Accurately modeling the near-wall flow using Shear Stress Transport (SST) turbulence model.
- Running the ANSYS CFX-Solver in parallel (optional).
- Creating vector plots in ANSYS CFX-Post with uniform spacing between the vectors.
- Creating a macro using power syntax in ANSYS CFX-Post.
Overview of the Problem to Solve

This example demonstrates external air flow over a generic vehicle body. Since both the geometry and the flow are symmetric about a vertical plane, only half of the geometry will be used to find the CFD solution.

Figure 1  External Air Flow Over a Generic Vehicle Body

Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: BluntBody.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution Using ANSYS CFX-Solver Manager (p. 116).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type BluntBody.
6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh.
2. Apply the following settings
Creating the Domain

The flow in the domain is expected to be turbulent and approximately isothermal. The Shear Stress Transport (SST) turbulence model with automatic wall function treatment will be used because of its highly accurate predictions of flow separation. To take advantage of the SST model, the boundary layer should be resolved with at least 10 mesh nodes. In order to reduce computational time, the mesh in this tutorial is much coarser than that.

This tutorial uses an ideal gas as the fluid whereas previous tutorials have used a specific fluid. When modeling a compressible flow using the ideal gas approximation to calculate density variations, it is important to set a realistic reference pressure. This is because some fluid properties depend on the absolute fluid pressure (calculated as the static pressure plus the reference pressure).

1. Click Domain, and set the name to BluntBody.
2. Apply the following settings to BluntBody:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>BluntBodyMesh.gtm</td>
</tr>
</tbody>
</table>

3. Click OK.

Creating Composite Regions

An imported mesh may contain many 2D regions. For the purpose of creating boundary conditions, it can sometimes be useful to group several 2D regions together and apply a single boundary condition to the composite 2D region. In this case, you are going to create a Union between two regions that both require a free slip wall boundary condition.

1. From the main menu, select Insert > Composite Region.
2. Set the name to FreeWalls and click OK.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Fluids List</td>
<td>Air Ideal Gas</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fluid Temperature</td>
<td>288 [K]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Shear Stress Transport</td>
</tr>
</tbody>
</table>

4. In the region list, hold down the <Ctrl> key and select Free1 and Free2.
Creating the Boundary Conditions

The simulation requires inlet, outlet, wall (no slip and free slip) and symmetry plane boundary conditions. The regions for these boundary conditions were defined when the mesh was created (except for the composite region just created for the free slip wall boundary condition).

**Inlet Boundary**

1. Click **Boundary Condition**.
2. Under **Name**, type **Inlet**.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Inlet</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Flow Regime &gt; Option</td>
<td>Subsonic</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>15 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Intensity and Length Scale</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Eddy Len. Scale</td>
<td>0.1 [m]</td>
</tr>
</tbody>
</table>

4. Click **OK**.

**Outlet Boundary**

1. Create a new boundary condition named **Outlet**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Outlet</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Free Slip Wall Boundary**

The top and side surfaces of the rectangular region will use free slip wall boundary conditions.

- On free slip walls the shear stress is set to zero so that the fluid is not retarded.
- The velocity normal to the wall is also set to zero.
- The velocity parallel to the wall is calculated during the solution.

This is not an ideal boundary condition for this situation since the flow around the body will be affected by the close proximity to the walls. If this case was modeling a wind tunnel experiment, the domain should model the size and shape of the wind tunnel and use no-slip walls. If this case was modeling a blunt body open to the atmosphere, a much larger domain should be used to minimize the effect of the walls.
You will apply a single boundary condition to both walls by using the composite region defined earlier.

1. Create a new boundary condition named **FreeWalls**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>FreeWalls</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence On Flow &gt; Option</td>
<td>Free Slip</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Symmetry Plane Boundary**

1. Create a new boundary condition named **SymP**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SymP</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Wall Boundary on the Blunt Body Surface**

1. Create a new boundary condition named **Body**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Body</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence On Flow &gt; Option</td>
<td>No Slip</td>
</tr>
</tbody>
</table>

3. Click **OK**.

The remaining 2D regions (in this case, just the low Z face) will be assigned the default boundary condition which is an adiabatic, no-slip wall condition. In this case, the name of the default boundary condition is **Default Boundary**. Although the boundary conditions **Body** and **Default Boundary** are identical (except for their locations), the **Body** boundary condition was created so that, during post-processing, its location can be conveniently distinguished from the other adiabatic, no-slip wall surfaces.

**Setting Initial Values**

1. Click **Global Initialization**.
2. Apply the following settings:
3. Click **OK**.

### Setting Solver Control

1. Click **Solver Control**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Components &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>15 ( \text{m s}^{-1} )</td>
</tr>
<tr>
<td></td>
<td>Components &gt; U</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>0 ( \text{m s}^{-1} )</td>
</tr>
<tr>
<td></td>
<td>Components &gt; V</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>0 ( \text{m s}^{-1} )</td>
</tr>
<tr>
<td></td>
<td>Components &gt; W</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Dissipation</td>
<td></td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Writing the Solver (.def) File

1. Click **Write Solver File**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>BluntBody.def</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.
Obtaining a Solution Using ANSYS CFX-Solver Manager

This tutorial introduces the parallel solver capabilities of ANSYS CFX.

**Note:** The results produced will be identical, whether produced by a parallel or serial run.

If you do not want to solve this tutorial in parallel (on more than one processor) or you do not have a license to run the ANSYS CFX-Solver in parallel, proceed to **Obtaining a Solution in Serial** (p. 116).

If you do not know if you have a license to run the ANSYS CFX-Solver in parallel, you should either ask your system administrator, or query the license server (see the ANSYS, Inc. Licensing Guide (which is installed with the ANSYS License Manager) for details). Alternatively proceed to **Obtaining a Solution in Serial** (p. 116).

If you would like to solve this tutorial in parallel on the same machine, proceed to **Obtaining a Solution with Local Parallel** (p. 117).

If you would like to solve this tutorial in parallel across different machines, proceed to **Obtaining a Solution with Distributed Parallel** (p. 117).

### Obtaining a Solution in Serial

When ANSYS CFX-Pre has shut down and ANSYS CFX-Solver Manager has started, you can obtain a solution to the CFD problem by using the following procedure.

1. Click **Start Run**.
2. Click **Yes** to process the results in ANSYS CFX-Post.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

   Continue this tutorial from **Viewing the Results in ANSYS CFX-Post** (p. 119).

### Obtaining a Solution in Parallel

#### Background to Parallel Running in ANSYS CFX

Using the parallel capability of the ANSYS CFX-Solver allows you to divide a large CFD problem so that it can run on more than one processor/machine at once. This saves time and, when multiple machines are used, avoids problems which arise when a CFD calculation requires more memory than a single machine has available. The partition (division) of the CFD problem is automatic.

A number of events occur when you set up a parallel run and then ask the ANSYS CFX-Solver to calculate the solution:

- Your mesh will be divided into the number of partitions that you have chosen.
- The ANSYS CFX-Solver runs separately on each of the partitions on the selected machine(s).
- The results that one ANSYS CFX-Solver process calculates affects the other ANSYS CFX-Solver processes at the interface between the different sections of the mesh.
- All of the ANSYS CFX-Solver processes are required to communicate with each other and this is handled by the **master process**.
Tutorial 5: Flow Around a Blunt Body: Obtaining a Solution Using ANSYS CFX-Solver Manager

Obtaining a Solution with Local Parallel

- The master process always runs on the machine that you are logged into when the parallel run starts. The other ANSYS CFX-Solver processes are slave processes and may be run on other machines.
- After the problem has been solved, a single results file is written. It will be identical to a results file from the same problem run as a serial process, with one exception: an extra variable Real partition number will be available for the parallel run. This variable will be used later in this tutorial during post processing.

To run in local parallel mode, the machine you are on must have more than one processor.

In ANSYS CFX-Solver Manager, the Define Run dialog box should already be open.

1. Leave Type of Run set to Full.
   If Type of Run was instead set to Partitioner Only, your mesh would be split into a number of partitions but would not be run in the ANSYS CFX-Solver afterwards.
2. Set Run Mode to PVM Local Parallel.
   This is the recommended method for most applications.
3. If required, click Add Partition + to add more partitions.
   By default, 2 partitions are assigned.
4. Select Show Advanced Controls.
5. Click the Partitioner tab at the top of the dialog box.
6. Use the default MeTiS partitioner.
   Your model will be divided into two sections, with each section running in its own ANSYS CFX-Solver process. The default is the MeTiS partitioner because it produces more efficient partitions than either Recursive Coordinate Bisection or User Specified Direction.
7. Click Start Run.
8. Click Post–Process Results.
9. If using ANSYS CFX-Solver in Standalone Mode, select Shut down Solver Manager, and then click OK.

Continue this tutorial from Text Output when Running in Parallel (p. 118).

Obtaining a Solution with Distributed Parallel

Before running in Distributed Parallel mode, please ensure that your system has been configured as described in the installation documentation.

In ANSYS CFX-Solver Manager, the Define Run dialog box should already be open.

1. Leave Type of Run set to Full.
   If Type of Run was instead set to Partitioner Only, your mesh would be split into a number of partitions but would not be run in the ANSYS CFX-Solver afterwards.
2. Set Run Mode to PVM Distributed Parallel.
   The name of the machine that you are currently logged into should be in the Host Name list. You are going to run with two partitions on two different machines, so another machine must be added.
3. Click Insert Host to specify a new host machine.
The Select Parallel Hosts dialog box is displayed. This is where you choose additional machines to run your processes.

Your system administrator should have set up a hosts file containing a list of the machines that are available to run the parallel ANSYS CFX-Solver.

The Host Name column displays names of available hosts.

The second column shows the number of processors on that machine.

The third shows the relative processor speed: a processor on a machine with a relative speed of 1 would typically be twice as fast as a machine with a relative speed of 0.5.

The last column displays operating system information.

This information is read from the hosts file; if any information is missing or incorrect your system administrator should correct the hosts file.

Note: The # processors, relative speed and system information does not have to be specified to be able to run on a host.

4. Select the name of another machine in the Host Name list.
   Select a machine that you can log into.

5. Click Add.
   The name of the machine is added to the Host Name column.

Note: Ensure that the machine that you are currently logged into is in the Hosts Name list in the Define Run dialog box.

6. Close the Select Parallel Hosts dialog box.

7. Select Show Advanced Controls.

8. Click the Partitioner tab at the top of the dialog box.

9. Use the default MeTiS partitioner.

   Your model will be divided into two sections, with each section running in its own ANSYS CFX-Solver process. The default is the MeTiS partitioner because it produces more efficient partitions than either Recursive Coordinate Bisection or User Specified Direction.

10. Click Start Run to begin the parallel run.

11. Click OK on the pop-up message.

12. Click Yes to post-process the results when the completion message appears at the end of the run.

13. Close ANSYS CFX-Solver Manager.

Text Output when Running in Parallel

The text output area shows what is being written to the output file. You will see information similar to the following:

+--------------------------------------------------------------------+
|                          Job Information                           |
+--------------------------------------------------------------------+
| Run mode:       partitioning run                                  |
| Host computer:  fastmachine1                                     |
| Job started:    Wed Nov 28 15:18:40 2005                         |
Tutorial 5: Flow Around a Blunt Body: Viewing the Results in ANSYS CFX-Post

This tells you that the information following is concerned with the partitioning. After the partitioning job has finished, you will find:

CPU-Time requirements:
- Preparations 1.46E+00 seconds
- Low-level mesh partitioning 1.00E-01 seconds
- Global partitioning information 3.10E-01 seconds
- Vertex, element and face partitioning information 1.60E-01 seconds
- Element and face set partitioning information 5.00E-02 seconds
- Summed CPU-time for mesh partitioning 2.08E+00 seconds

This marks the end of the partitioning job. The ANSYS CFX-Solver now begins to solve your parallel run:

Run mode: parallel run (PVM)
Host computer: fastmachine1
Par. Process: Master running on mesh partition: 1
Job started: Thu Nov 28 15:19:20 2005
Host computer: slowermachine
Par. Process: Slave running on mesh partition: 2
Job started: Thu Nov 28 15:24:55 2005

The machine that you are logged into runs the master process, and controls the overall simulation. The second machine selected will run the slave process. If you had more than two processes, each additional process is run as a slave process.

The master process in this example is running on the mesh partition number 1 and the slave is running on partition number 2. You can find out which nodes and elements are in each partition by using ANSYS CFX-Post later on in the tutorial.

When the ANSYS CFX-Solver finishes, the output file displays the job information and a pop-up message to indicate completion of the run.

Viewing the Results in ANSYS CFX-Post

In this tutorial, a vector plot is created in ANSYS CFX-Post. This will let you see how the flow behaves around the body. You will also use symmetry planes and learn more about manipulating the geometry view in the viewer.

Using Symmetry Planes

Earlier in this tutorial you used a symmetry plane boundary condition because the entire blunt body is symmetrical about a plane. Due to this symmetry, it was necessary to use only half of the full geometry to calculate the CFD results. However, for visualization purposes, it is helpful to use the full blunt body. ANSYS CFX-Post is able to recreate the full data set from the half that was originally calculated. This is done by creating an Instance Transform object.
Manipulating the Geometry

You need to manipulate the geometry so that you will be able to see what happens when you use the symmetry plane. The ANSYS CFX-Post features that you have used in earlier tutorials will not be described in detail. New features will be described in detail.

1. Right-click a blank area in the viewer and select Predefined Camera > View Towards +X.

Creating an Instance Transform

Instance Transforms are used to visualize a full geometry representation in cases where the simulation took advantage of symmetry to solve for only part of the geometry. There are three types of transforms that you can use: Rotation, Translation, Reflection. In this tutorial, you will create a Reflection transform located on a plane.

1. Click Location > Plane and set the name to Reflection Plane.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>ZX Plane</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(cleared)</td>
</tr>
</tbody>
</table>

3. Click Apply.

   This creates a plane in the same location as the symmetry plane defined in ANSYS CFX-Pre. Now the instance transform can be created using this Plane:

4. From the main menu, select Insert > Instance Transform and accept the default name.
5. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>Instancing Info From Domain</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Apply Rotation</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Apply Reflection</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Apply Reflection &gt; Plane</td>
<td>Reflection Plane</td>
</tr>
</tbody>
</table>

6. Click Apply.

Using the Reflection Transform

You can use the transform when creating or editing graphics objects. For example, you can modify the Wireframe view to use it as follows:

1. Under the Outline tab, in User Locations and Plots, apply the following settings to Wireframe:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Apply Instancing Transform &gt; Transform</td>
<td>Instance Transform 1</td>
</tr>
</tbody>
</table>

2. Click Apply.

3. Zoom so that the geometry fills the Viewer.

   You will see the full blunt body.
Creating Vectors

You are now going to create a vector plot to show velocity vectors behind the blunt body. You need to first create an object to act as a locator, which, in this case, will be a sampling plane. Then, create the vector plot itself.

Creating the Sampling Plane

A sampling plane is a plane with evenly spaced sampling points on it.

1. Right-click a blank area in the viewer and select \textit{Predefined Camera > View Towards +Y}. This ensures that the changes can be seen.
2. Create a new plane named \textit{Sample}.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Point and Normal</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Point</td>
<td>6, -0.001, 1</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Normal</td>
<td>0, 1, 0</td>
</tr>
<tr>
<td>Plane Bounds &gt; Type</td>
<td>Rectangular</td>
<td></td>
</tr>
<tr>
<td>Plane Bounds &gt; X Size</td>
<td>2.5 [m]</td>
<td></td>
</tr>
<tr>
<td>Plane Bounds &gt; Y Size</td>
<td>2.5 [m]</td>
<td></td>
</tr>
<tr>
<td>Plane Type</td>
<td>Sample</td>
<td></td>
</tr>
<tr>
<td>Plane Type &gt; X Samples</td>
<td>20</td>
<td></td>
</tr>
<tr>
<td>Plane Type &gt; Y Samples</td>
<td>20</td>
<td></td>
</tr>
</tbody>
</table>

4. Click \textit{Apply}.

You can zoom in on the sampling plane to see the location of the sampling points (where lines intersect). There are a total of 400 (20 * 20) sampling points on the plane. A vector can be created at each sampling point.

5. Hide the plane by clearing the visibility check box next to \textit{Sample}.

Creating a Vector Plot Using Different Sampling Methods

1. Click \textit{Vector} and accept the default name.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>Sample</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Sampling</td>
<td>Vertex</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.25</td>
</tr>
</tbody>
</table>

3. Click \textit{Apply}.

4. Zoom until the vector plot is roughly the same size as the viewer. You should be able to see a region of recirculation behind the blunt body.
5. Ignore the vertices on the sampling plane and increase the density of the vectors by applying the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Sampling</td>
<td>Equally Spaced</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; # of Points</td>
<td>1000</td>
</tr>
</tbody>
</table>

6. Click **Apply**.

7. Change the location of the Vector plot by applying the following setting:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>SymP</td>
</tr>
</tbody>
</table>

8. Click **Apply**.

### Creating a Pressure Plot

1. Apply the following settings to the boundary condition named **Body**:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Pressure</td>
</tr>
<tr>
<td>View</td>
<td>Apply Instancing Transform &gt; Transform</td>
<td>Instance Transform 1</td>
</tr>
</tbody>
</table>

2. Click **Apply**.

3. Apply the following settings to **SymP**:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Line</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

4. Click **Apply**.

You will be able to see the mesh around the blunt body, with the mesh length scale decreasing near the body, but still coarse in the region of recirculation. By zooming in, you will be able to see the layers of inflated elements near the body.

### Creating Surface Streamlines

In order to show the path of air along the surface of the blunt body, surface streamlines can be made as follows:

1. Clear the visibility of **Body**, **SymP** and **Vector 1**.
2. Create a new plane named **Starter**.
3. Apply the following settings
4. Click **Apply**.
The plane appears just upstream of the blunt body.

5. Clear the visibility check box for the plane.
   This hides the plane from view, although the plane still exists.

6. Click **Streamline** and click **OK** to accept the default name.

7. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>YZ Plane</td>
</tr>
<tr>
<td></td>
<td>X</td>
<td>-0.1 [m]</td>
</tr>
</tbody>
</table>

8. **Apply** the following settings.
The surface streamlines appear on half of the surface of the blunt body. They start near the upstream end because the starting points were formed by projecting nodes from the plane to the blunt body.

**Moving Objects**

In ANSYS CFX-Post, you can reposition some locator objects directly in the viewer by using the mouse.

1. Select the visibility check box for the plane named **Starter**.

2. Select the **Single Select** mouse pointer from the **Selection Tools** toolbar.

3. In the viewer, click the **Starter** plane to select it, then use the left mouse button to drag it along the X axis.
   Notice that the streamlines are redrawn as the plane moves.

**Creating a Surface Plot of y+**

The velocity next to a no-slip wall boundary changes rapidly from a value of zero at the wall to the free stream value a short distance away from the wall. This layer of high velocity gradient is known as the boundary layer. Many meshes are not fine enough near a wall to accurately resolve the velocity profile in the boundary layer. Wall functions can be used in these cases to apply an assumed functional shape of the velocity profile. Other grids are fine enough that they do not require wall functions, and application of the latter has little effect.
The majority of cases fall somewhere in between these two extremes, where the boundary layer is partially resolved by nodes near the wall and wall functions are used to supplement accuracy where the nodes are not sufficiently clustered near the wall. One indicator of the closeness of the first node to the wall is the dimensionless wall distance \( y^+ \). It is good practice to examine the values of \( y^+ \) at the end of your simulation. At the lower limit, a value of \( y^+ \) less than or equal to 11 indicates that the first node is within the laminar sublayer of the boundary flow. Values larger than this indicate that an assumed logarithmic shape of the velocity profile is being used to model the boundary layer portion between the wall and the first node. Ideally you should confirm that there are several nodes (3 or more) resolving the boundary layer profile. If this is not observed, it is highly recommended that more nodes be added near the wall surfaces in order to improve simulation accuracy. In this tutorial, a coarse mesh is used to reduce the run time. Thus, the grid is far too coarse to resolve any of the boundary layer profile, and the solution is not highly accurate.

**Surface Plot of \( y^+ \)**

A surface plot is one which colors a surface according to the values of a variable: in this case, \( y^+ \). A surface plot of \( y^+ \) can be obtained as follows:

1. Clear the visibility of all previous plots.
2. Under the **Outline** tab, apply the following settings to **BluntBodyDefault**:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>( Yplus^* )</td>
</tr>
<tr>
<td>View</td>
<td>Apply Instancing Transform &gt; Transform</td>
<td>Instance Transform 1</td>
</tr>
</tbody>
</table>

* Click the ellipsis icon to the right of the **Variable** dropdown menu to view a full list of variables, including \( Yplus \).

3. Click **Apply**.
4. Under the **Outline** tab, apply the following settings to **Body**:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>( Yplus^* )</td>
</tr>
<tr>
<td>View</td>
<td>Apply Instancing Transform &gt; Transform</td>
<td>Instance Transform 1</td>
</tr>
</tbody>
</table>

* Click the ellipsis icon to the right of the **Variable** dropdown menu to view a full list of variables, including \( Yplus \).

5. Click **Apply**.
Demonstrating Power Syntax

This section demonstrates a power syntax macro used to evaluate the variation of any variable in the direction of the x-axis. This is an example of power syntax programming in ANSYS CFX-Post.

Synopsis

A macro containing CCL and power syntax will be loaded by playing a session file. This macro will be executed by entering a line of power syntax in the Command Editor dialog box. The macro tells ANSYS CFX-Post to create slice planes, normal to the X axis, at 20 evenly-spaced locations from the beginning to the end of the domain. On each plane, it measures and prints the minimum, maximum, and average values for a specified variable (using conservative values). The planes are colored using the specified variable.

Note: The ANSYS CFX-Post engine can respond to CCL commands issued directly, or to commands issued using the graphical user interface. The Command Editor dialog box can be used to enter any valid CCL command directly.

Procedure

1. Play the session file named BluntBodyDist.cse.
2. Right-click a blank area in the viewer and select Predefined Camera > View Towards -X.
3. Select Tools > Command Editor from the menu bar.
4. Type the following line into the Command Editor dialog box (the quotation marks and the semi-colon are required):
   !BluntBodyDist("Velocity u");
5. Click Process.

   The minimum, maximum and average values of the variable at each X location are written to the file BluntBody.txt. The results can be viewed by opening the file in a text editor.

   You can also run the macro with a different variable.

   To view the content of the session file (which contains explanatory comments), open the session file in a text editor. It contains all of the CCL and power syntax commands and will provide a better understanding of how the macro works.

Viewing the Mesh Partitions (Parallel Only)

If you solved this tutorial in parallel, then an additional variable named Real partition number will be available in ANSYS CFX-Post

1. Create an Isosurface of Real partition number equal to 1.
2. Create a second Isosurface of Real partition number equal to 1.999.

   The two Isosurfaces show the edges of the two partitions. The gap between the two plots shows the overlap nodes. These were contained in both partitions 1 and 2.

   When you have finished looking at the results, quit ANSYS CFX-Post.
Tutorial 5: Flow Around a Blunt Body: Viewing the Results in ANSYS CFX-Post
Tutorial 6: Buoyant Flow in a Partitioned Cavity

Introduction

This tutorial includes:

- Tutorial 6 Features (p. 128)
- Overview of the Problem to Solve (p. 128)
- Defining a Simulation in ANSYS CFX-Pre (p. 129)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 134)
- Viewing the Results in ANSYS CFX-Post (p. 135)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 129).

Sample files referenced by this tutorial include:

- Buoyancy2D.geo
- Buoyancy2D.pre
Tutorial 6 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre User Mode</td>
<td>General Mode</td>
<td></td>
</tr>
<tr>
<td>Simulation Type</td>
<td>Transient</td>
<td></td>
</tr>
<tr>
<td>Fluid Type</td>
<td>General Fluid</td>
<td></td>
</tr>
<tr>
<td>Domain Type</td>
<td>Single Domain</td>
<td></td>
</tr>
<tr>
<td>Turbulence Model</td>
<td>Laminar</td>
<td></td>
</tr>
<tr>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
<td></td>
</tr>
<tr>
<td>Buoyant Flow</td>
<td>Boundary Conditions</td>
<td>Symmetry Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Fixed Temperature</td>
</tr>
<tr>
<td>Output Control</td>
<td>Transient Example</td>
<td></td>
</tr>
<tr>
<td>Timestep</td>
<td>Transient Results File</td>
<td></td>
</tr>
</tbody>
</table>

ANSYS CFX-Post Plots Default Locators

Report

Other Time Step Selection

Transient Animation

In this tutorial you will learn about:

- Using CFX-4 Mesh Import.
- Setting up a time dependent (transient) simulation.
- Modeling buoyant flow.

Overview of the Problem to Solve

This tutorial demonstrates the capability of ANSYS CFX in modeling buoyancy-driven flows which require the inclusion of gravitational effects.
The model is a 2D partitioned cavity containing air. The bottom of the cavity is kept at a constant temperature of 75°C, while the top is held constant at 5°C. The cavity is also tilted at an angle of 30 degrees to the horizontal. A transient simulation is set up to see how the flow develops starting from stationary conditions. Since you are starting from stationary conditions, there is no need to solve a steady-state simulation for use as the initial guess.

The mesh for the cavity was created in CFX-4 and has been provided.

**Defining a Simulation in ANSYS CFX-Pre**

You are going to import a hexahedral mesh originally generated in CFX-4. The mesh contains labelled regions which will enable you to apply the relevant boundary conditions for this problem.

**Playing a Session File**

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select **Session > Play Tutorial** from the menu in ANSYS CFX-Pre, then run the session file: **Buoyancy2D.pre**. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 134).

**Creating a New Simulation**

1. Start ANSYS CFX-Pre.
2. Create a new simulation using **General Mode**.
3. Select **File > Save Simulation As** and set **File name** to **Buoyancy2D**.
4. Click **Save**.

**Importing the Mesh**

1. Right-click **Mesh** and select **Import Mesh**. The **Import Mesh** dialog box appears.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>CFX-4</td>
</tr>
<tr>
<td>File name</td>
<td>Buoyancy2D.geo*</td>
</tr>
</tbody>
</table>

* This file is in your tutorial directory.

3. Click **Open**.

**Simulation Type**

The default units and coordinate frame settings are suitable for this tutorial, but the simulation type needs to be set to transient.

You will notice physics validation messages as the case is set to **Transient**. These errors will be fixed in the later part of the tutorial.

1. Click **Simulation Type**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Simulation Type &gt; Option</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Duration</td>
<td>2 [s]</td>
</tr>
<tr>
<td></td>
<td>Total Time*</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Steps</td>
<td>0.025 [s]</td>
</tr>
<tr>
<td></td>
<td>Timesteps†</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Initial Time</td>
<td>0 [s]</td>
</tr>
<tr>
<td></td>
<td>Time 0 [s]</td>
<td></td>
</tr>
</tbody>
</table>

* This is the total duration, in real time, for the simulation
† This is the interval from one step, in real time, to the next. The simulation will continue, moving forward in time by 0.025 s, until the total time has been reached

3. Click **OK**.
Creating the Domain

You will model the cavity as if it were tilted at an angle of 30°. You can do this by specifying horizontal and vertical components of the gravity vector, which are aligned with the default coordinate axes, as shown in the diagram above.

To Create a New Domain

1. Click Domain, and set the name to Buoyancy2D.
2. Apply the following settings to Buoyancy2D

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Fluids List</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Option</td>
<td>Buoyant</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity X Dirn.</td>
<td>-4.9 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Y Dirn.</td>
<td>-8.5 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Z Dirn.</td>
<td>0.0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Buoy. Ref. Temp.</td>
<td>40 [°C]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>None (Laminar)</td>
</tr>
</tbody>
</table>

* This produces a gravity vector which simulates the tilt of the cavity
† Do not forget to change the units. This is just an approximate representative domain temperature.

Initialization will be set up using Global Initialization, so there is no need to visit the Initialization tab.
3. Click OK.
Creating the Boundary Conditions

**Hot and Cold Wall Boundary**

You will create a wall boundary condition with a fixed temperature of 75°C on the bottom surface of the cavity, as follows:

1. Create a new boundary condition named `hot`.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>WALLHOT</td>
</tr>
<tr>
<td>Boundary</td>
<td>Heat Transfer &gt; Option</td>
<td>Temperature</td>
</tr>
<tr>
<td>Details</td>
<td>Heat Transfer &gt; Fixed Temperature</td>
<td>75°C</td>
</tr>
</tbody>
</table>

3. Click **OK**.
4. Create a new boundary condition named `cold`.
5. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>WALLCOLD</td>
</tr>
<tr>
<td>Boundary</td>
<td>Heat Transfer &gt; Option</td>
<td>Temperature</td>
</tr>
<tr>
<td>Details</td>
<td>Heat Transfer &gt; Fixed Temperature</td>
<td>5°C</td>
</tr>
</tbody>
</table>

6. Click **OK**.

**Symmetry Plane Boundary**

A single symmetry plane boundary condition can be used for the front and back of the cavity.

1. Create a new boundary condition named `SymP`.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SYMMET1, SYMMET2*</td>
</tr>
</tbody>
</table>

* Use the `<Ctrl>` key to select more than one region.

3. Click **OK**.

The default adiabatic wall boundary condition will automatically be applied to the remaining boundaries.

**Setting Initial Values**

You should set initial settings using the **Automatic with Value** option when defining a transient simulation. Using this option, the first run will use the specified initial conditions while subsequent runs will use results file data for initial conditions.
1. Click Global Initialization.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Components &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>0 [m s^{-1}]</td>
</tr>
<tr>
<td></td>
<td>Components &gt; U</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>0 [m s^{-1}]</td>
</tr>
<tr>
<td></td>
<td>Components &gt; V</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>0 [m s^{-1}]</td>
</tr>
<tr>
<td></td>
<td>Components &gt; W</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Static Pressure &gt;</td>
<td>0 [Pa]</td>
</tr>
<tr>
<td></td>
<td>Relative Pressure</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Temperature &gt;</td>
<td>5 [°C]</td>
</tr>
<tr>
<td></td>
<td>Temperature</td>
<td></td>
</tr>
</tbody>
</table>

3. Click OK.

**Setting Output Control**

1. Click Output Control.
2. Click the Trn Results tab.
3. Create a new Transient Results item with the default name.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trn Results</td>
<td>Transient Results &gt; Transient Results 1</td>
<td>Selected Variables</td>
</tr>
<tr>
<td></td>
<td>&gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transient Results &gt; Transient Results 1</td>
<td>Pressure, Temperature,</td>
</tr>
<tr>
<td></td>
<td>&gt; Output Variables List*</td>
<td>Velocity</td>
</tr>
<tr>
<td></td>
<td>Transient Results &gt; Transient Results 1</td>
<td>Time Interval</td>
</tr>
<tr>
<td></td>
<td>&gt; Output Frequency &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transient Results &gt; Transient Results 1</td>
<td>0.1 [s]</td>
</tr>
<tr>
<td></td>
<td>&gt; Output Frequency &gt; Time Interval</td>
<td></td>
</tr>
</tbody>
</table>

* Click the ellipsis icon to select items if they do not appear in the drop-down list. Use the <Ctrl> key to select multiple items.

5. Click OK.

**Setting Solver Control**

1. Click Solver Control.
2. Apply the following settings
Tutorial 6: Buoyant Flow in a Partitioned Cavity: Obtaining a Solution using ANSYS CFX-Solver Manager

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Buoyancy2D.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

When ANSYS CFX-Pre has shut down and ANSYS CFX-Solver Manager has started, you can obtain a solution to the CFD problem by using the following procedure.

Note: Recall that the output displayed on the Out File tab of the ANSYS CFX-Solver Manager is more complicated for transient problems than for steady-state problems. Each timestep consists of several iterations, and after the timestep, information about various quantities is printed.

1. Click Start Run.
2. Click Yes to post-process the results when the completion message appears at the end of the run.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
Viewing the Results in ANSYS CFX-Post

In this section, you will create a report in ANSYS CFX-Post. You will also make an animation to see changes in temperature with time.

Simple Report

First, you will view a report that is created with little effort:

1. Click the Report Viewer tab. Note that the report loads with some automatically-generated statistical information.
2. In the Outline tree view, under Report, experiment with the various settings for Mesh Report, Physics Report and other report objects. These settings control the report contents. On the Report Viewer tab, you can click Refresh to see the changes to your report.

Plots

Here, you will create the following objects in preparation for generating a more customized report:

- Contour plot of temperature
- Point locators (for observing temperature)
- Comment
- Figure showing the contour plot and point locator
- Time chart showing the temperature at the point locator
- Table

Contour Plot

1. Click the 3D Viewer tab and right-click a blank area of the viewer, then select Predefined Camera > View Towards -Z.
2. Select Insert > Contour from the main menu.
3. Accept the default name by clicking OK.
4. Set Locations to SymP.
5. Set Variable to Temperature.
6. Click Apply.

The contour plot shows the temperature at the end of the simulation, since ANSYS CFX-Post loads values for the last timestep by default. You can load different timesteps using the Timestep Selector dialog box, accessible by selecting Tools > Timestep Selector from the main menu.

Point Locators

1. From the main menu, select Insert > Location > Point.
2. Accept the default name by clicking OK.
3. Set Method to XYZ.
4. Set Point coordinates to 0.098, 0.05, 0.00125.
5. Click Apply.

Note the location of Point 1 in the viewer.
6. Right-click the Point 1 object in the tree view and select **Duplicate** from the shortcut menu.
7. Accept the default name by clicking **OK**.
8. Right-click the Point 2 object in the tree view and select **Edit** from the shortcut menu.
9. Change the x-coordinate to 0.052.
10. Click **Apply**.

   Note the location of Point 2 in the viewer.

**Comment**

1. Click **Create comment**.
2. Accept the default name by clicking **OK**.

   A comment object appears in the tree view, under the **Report** object.

3. Set **Heading** to **Buoyant Flow in a Partitioned Cavity**.
4. In the large text box, type:

   This is a sample paragraph.

**Figure**

1. Click the **3D Viewer** tab.
2. Select **Insert > Figure** from the main menu.
3. Accept the default name by clicking **OK**.

   The **Make copies of objects** check box determines whether or not the objects that are visible in the viewer are copied. If objects are copied, then the copies are used in the figure instead of the originals. Since you are not using multiple views or figures, the check box setting does not matter.

   A figure object will appear under the **Report** branch in the tree view.

**Time Chart**

1. Select **Insert > Chart** from the main menu.
2. Accept the default name by clicking **OK**.
3. Set **Title** to **Temperature versus Time**.
4. Set **Type** to **Time**.
5. Click the **Chart Line 1** tab.
6. Set **Line Name** to **Temperature at Point 1**.
7. Set **Method** to **Point**.
8. Set **Location** to **Point 1**.
9. Set **Time Variable > Variable** to **Temperature**.
10. Click **Apply**.

   A chart object will appear under the **Report** branch in the tree view. The chart itself will appear in the **Chart Viewer** tab. It may take some time for the chart to appear because every transient results file will be loaded in order to generate the time chart.

11. Click **New Line** (on the **Chart Line 1** tab).
12. Set **Line Name** to **Temperature at Point 2**.
13. Set **Location** to **Point 2** and **Time Variable > Variable** to **Temperature**.
14. Click **Apply**.

   A second chart line will appear in the chart, representing the temperature at Point 2.

**Table**

1. Select **Insert > Table** from the main menu.
2. Accept the default name by clicking **OK**.
   A table object will appear under the **Report** branch in the tree view.
3. Set the following:

<table>
<thead>
<tr>
<th>Cell</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1</td>
<td>Location</td>
</tr>
<tr>
<td>A2</td>
<td>Point 1</td>
</tr>
<tr>
<td>A3</td>
<td>Point 2</td>
</tr>
<tr>
<td>B1</td>
<td>Temperature</td>
</tr>
<tr>
<td>B2</td>
<td>=probe(Temperature)@Point 1</td>
</tr>
<tr>
<td>B3</td>
<td>=probe(Temperature)@Point 2</td>
</tr>
</tbody>
</table>

The table shows temperatures at the end of the simulation, since ANSYS CFX-Post loads values for the last timestep by default. You can load different timesteps using the **Timestep Selector** dialog box, accessible by selecting **Tools > Timestep Selector**.

**Customized Report**

Right-click the **Report** object and select **Refresh** from the shortcut menu. Look at the report in the **Report Viewer** tab. Note that, in addition to the automatically-generated objects that you saw earlier when creating a simple report, this report also includes the customized figure, time chart and table described above.

**Animations**

Use the animation feature to see the changing temperature field. The animation feature was used in **Tutorial 4: Flow from a Circular Vent** (p. 93).

**Completion**

When you have finished, quit ANSYS CFX-Post.
Tutorial 7: Free Surface Flow Over a Bump

Introduction

This tutorial includes:

• Tutorial 7 Features (p. 139)
• Overview of the Problem to Solve (p. 140)
• Defining a Simulation in ANSYS CFX-Pre (p. 141)
• Obtaining a Solution using ANSYS CFX-Solver Manager (p. 148)
• Viewing the Results in ANSYS CFX-Post (p. 149)
• Using a Supercritical Outlet Condition (p. 154)

If this is the first tutorial you are working with, it is important to review the following topics before beginning.

• Setting the Working Directory (p. 1)
• Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 141).

Sample files referenced by this tutorial include:

• Bump2D.pre
• Bump2DExpressions.ccl
• Bump2Dpatran.out

Tutorial 7 Features

This tutorial addresses the following features of ANSYS CFX:
In this tutorial you will learn about:
- Mesh import in PATRAN Neutral format.
- Setting up a 2D problem.
- Setting up appropriate boundary conditions for a free surface simulation. (Free surface simulations are more sensitive to incorrect boundary and initial guess settings than other more basic models.)
- Mesh adaption to refine the mesh where the volume fraction gradient is greatest. (This aids in the development of a sharp interface between the liquid and gas.)

## Overview of the Problem to Solve

This tutorial demonstrates the simulation of a free surface flow.

The geometry consists of a 2D channel in which the bottom of the channel is interrupted by a semi-circular bump of radius 30 mm. The flow upstream of the bump is subcritical. The downstream conditions are not known but can be estimated using an analytical 1D calculation or data tables for flow over a bump.
Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: Bump2D.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 148).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type Bump2D.
6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh. The Import Mesh dialog box appears.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>PATRAN Neutral</td>
</tr>
<tr>
<td>File name</td>
<td>Bump2Dpatran.out</td>
</tr>
</tbody>
</table>

3. Click Open.
4. Right-click a blank area in the viewer and select Predefined Camera > View Towards -Z from the shortcut menu.

Viewing the Region Labels

1. Click Label and Marker Visibility.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label Options</td>
<td>Show Labels</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Show Labels &gt; Show Primitive3D Labels</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Show Labels &gt; Show Primitive2D Labels</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

3. Click OK.
Creating Expressions for Initial and Boundary Conditions

Simulation of free surface flows usually requires defining boundary and initial conditions to set up appropriate pressure and volume fraction fields. You will need to create expressions using CEL (CFX Expression Language) to define these conditions.

In this simulation, the following conditions are set and require expressions:

- An inlet boundary where the volume fraction above the free surface is 1 for air and 0 for water, and below the free surface is 0 for air and 1 for water.
- A pressure-specified outlet boundary, where the pressure above the free surface is constant and the pressure below the free surface is a hydrostatic distribution. This requires you to know the approximate height of the fluid at the outlet. In this case, an analytical solution for 1D flow over a bump was used. The simulation is not sensitive to the exact outlet fluid height, so an approximation is sufficient. You will examine the effect of the outlet boundary condition in the post-processing section and confirm that it does not affect the validity of the results. It is necessary to specify such a boundary condition to force the flow downstream of the bump into the supercritical regime.
- An initial pressure field for the domain with a similar pressure distribution to that of the outlet boundary.

Either create expressions using the Expressions workspace or import expressions from a file.

1. Right-click Expressions in the tree view and select Insert > Expression.
2. Set the name to UpH and click OK.
3. Set Definition to 0.069 [m], and then click Apply.
4. Use the same method to create the expressions listed in the table below. These are expressions for the downstream free surface height, the density of the fluid, the upstream volume fractions of air and water, the upstream pressure distribution, the downstream volume fractions of air and water, and the downstream pressure distribution.

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>DownH</td>
<td>0.022 [m]</td>
</tr>
<tr>
<td>DenH</td>
<td>998 [kg m^-3]</td>
</tr>
<tr>
<td>UpVF Air</td>
<td>step((y-UpH)/1[m])</td>
</tr>
<tr>
<td>UpVF Water</td>
<td>1-UpVF Air</td>
</tr>
<tr>
<td>UpPres</td>
<td>DenH<em>g</em>UpVF Water*(UpH-y)</td>
</tr>
<tr>
<td>DownVF Air</td>
<td>step((y-DownH)/1[m])</td>
</tr>
<tr>
<td>DownVF Water</td>
<td>1-DownVF Air</td>
</tr>
<tr>
<td>DownPres</td>
<td>DenH<em>g</em>DownVF Water*(DownH-y)</td>
</tr>
</tbody>
</table>

5. Proceed to Creating the Domain (p. 143).
Reading Expressions From a File

1. Copy the file Bump2DExpressions.ccl to your working directory from the ANSYS CFX examples directory.
2. Select File > Import CCL.
3. When Import CCL appears, ensure that Append is selected.
4. Select Bump2DExpressions.ccl.
5. Click Open.
6. After the file has been imported, use the Expression tree view to view the expressions that have been created.

Creating the Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.
2. Double click Default Domain and apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Fluids List</td>
<td>Air at 25 C, Water</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Option</td>
<td>Buoyant</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity X Dirn.</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Y Dirn.*</td>
<td>-g</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Z Dirn.†</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Buoy. Ref. Density†</td>
<td>1.185 [kg m^-3]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Ref Location &gt; Option</td>
<td>Automatic</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Multiphase Options &gt; Homogeneous Model‡</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Multiphase Options &gt; Free Surface Model &gt; Option</td>
<td>Standard</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fluid Temperature</td>
<td>25 C</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>k-Epsilon</td>
</tr>
</tbody>
</table>

* You need to click Enter Expression beside the field first.
‡ Always set Buoyancy Reference Density to the density of the least dense fluid in free surface calculations.
† The homogeneous model solves for a single solution field. This is only appropriate in some simulations.

3. Click OK.

Creating the Boundary Conditions

Inlet Boundary

1. Create a new boundary condition named inflow.
2. Apply the following settings
3. Click **OK**.

**Outlet Boundary**

1. Create a new boundary condition named **outflow**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Basic Settings</strong></td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>OUTFLOW</td>
</tr>
<tr>
<td><strong>Boundary Details</strong></td>
<td>Flow Regime &gt; Option</td>
<td>Subsonic</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Option</td>
<td>Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>DownPres</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Symmetry Boundary**

1. Create a new boundary condition named **front**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Basic Settings</strong></td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>FRONT</td>
</tr>
</tbody>
</table>

3. Click **OK**.
4. Create a new boundary condition named **back**.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Basic Settings</strong></td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>BACK</td>
</tr>
</tbody>
</table>
6. Click **OK**.

### Wall and Opening Boundaries

1. Create a new boundary condition named `top`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>TOP</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass And Momentum &gt; Option</td>
<td>Static Pres. (Entrain)</td>
</tr>
<tr>
<td></td>
<td>Mass And Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Zero Gradient</td>
</tr>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt; Volume Fraction &gt; Volume Fraction</td>
<td>1.0</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Water &gt; Volume Fraction &gt; Volume Fraction</td>
<td>0.0</td>
</tr>
</tbody>
</table>

3. Click **OK**.

4. Create a new boundary condition named `bottom`.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>BOTTOM1, BOTTOM2, BOTTOM3</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence on Flow &gt; Option</td>
<td>No Slip</td>
</tr>
<tr>
<td></td>
<td>Wall Roughness &gt; Option</td>
<td>Smooth Wall</td>
</tr>
</tbody>
</table>

6. Click **OK**.

### Setting Initial Values

1. Click **Global Initialization**
2. Apply the following settings
Tutorial 7: Free Surface Flow Over a Bump: Defining a Simulation in ANSYS CFX-Pre

3. Click **OK**.

Setting Mesh Adaption Parameters

1. Click **Mesh Adaption**
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Activate Adaption</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Save Intermediate Files</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Adaption Criteria &gt; Variables List</td>
<td>Air at 25 C.Volume Fraction</td>
</tr>
<tr>
<td></td>
<td>Adaption Criteria &gt; Max. Num. Steps</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>Adaption Criteria &gt; Option</td>
<td>Multiple of Initial Mesh</td>
</tr>
<tr>
<td></td>
<td>Adaption Criteria &gt; Node Factor</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Adaption Convergence Criteria &gt; Max. Iter. per Step</td>
<td>100</td>
</tr>
<tr>
<td>Advanced Options</td>
<td>Node Alloc. Param.</td>
<td>1.6</td>
</tr>
<tr>
<td></td>
<td>Number of Levels</td>
<td>2</td>
</tr>
</tbody>
</table>

3. Click **OK**.
Setting Solver Control

Important: Setting **Max Iterations** to 200 and **Number of Adaption Levels** to 2 with a maximum of 100 timesteps each, results in a total maximum number of timesteps of 400 (2*100+200=400).

1. Click **Solver Control**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Max. Iterations</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Control &gt; Timescale Control</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Control &gt; Physical Timescale</td>
<td>0.25 [s]</td>
</tr>
<tr>
<td>Advanced Options</td>
<td>Multiphase Control</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Multiphase Control &gt; Volume Fraction</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Coupling</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Multiphase Control &gt; Volume Fraction</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Coupling &gt; Option</td>
<td>Coupled</td>
</tr>
</tbody>
</table>

**Note:** The options selected above activate the Coupled Volume Fraction solution algorithm. This algorithm typically converges better than the Segregated Volume Fraction algorithm for buoyancy-driven problems such as this tutorial, which requires a 0.05 [s] timescale using the Segregated Volume Fraction algorithm compared with 0.25 [s] for the Coupled Volume Fraction algorithm.

**Note:**
3. Click **OK**.

Writing the Solver (.def) File

1. Click **Write Solver File**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Bump2D.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.
Obtaining a Solution using ANSYS CFX-Solver Manager

When ANSYS CFX-Pre has shut down and ANSYS CFX-Solver Manager has started, the solution will be obtained.

Within 100 iterations, the first adaption step will be performed. Information will be written to the OUT file, containing the number of elements refined and the size of the new mesh. After mesh refinement, there will be a jump in the residual levels. This is because the solution from the old mesh is interpolated on to the new mesh. A new residual plot will also appear for the W-Mom-Bulk equation. Hexahedral mesh elements are refined orthogonally, so the mesh is no longer 2D (it is more than 1 element thick in the z-direction).

Convergence to the target residual level has been achieved. It is common for convergence in a residual sense to be difficult to obtain in a free surface simulation. This is due to the presence of small waves at the surface preventing the residuals from dropping to the target level. This is more frequently a problem in the subcritical flow regime, as the waves can travel upstream. In the supercritical regime, the waves tend to get carried downstream and out the domain.

To satisfy convergence in these cases, monitor the value of a global quantity, (for example, drag for flow around a ship's hull) to see when a steady state value is reached.

Where there is no obvious global quantity to monitor, you should view the results to see where the solution is changing. You can do this by running transient for a few timesteps, starting from a results file that you think is converged, or by writing some backup results files at different timesteps.

In both cases look to see where the results are changing (this could be due to the presence of small transient waves). Also confirm that the value of quantities that you are interested in (for example, downstream fluid height for this case) has reached a steady state value.

1. Click Start Run.
2. Click Yes to post-process the results when the completion message appears at the end of the run.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
Viewing the Results in ANSYS CFX-Post

1. Select **View Towards -Z** by right-clicking on a blank area in the viewer and selecting **Predefined Camera > View Towards -Z**.
2. Zoom in so the geometry fills the Viewer.
3. In the tree view under Bump2D, edit **front**.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Water.Volume Fraction</td>
</tr>
</tbody>
</table>

5. Click **Apply**.
6. Clear the check box next to **front**.

Creating Velocity Vector Plots

The next step involves creating a sampling plane to display velocity vectors for **Water**.

1. Create a new plane named **Plane 1**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>XY Plane</td>
</tr>
<tr>
<td></td>
<td>Plane Bounds &gt; Type</td>
<td>Rectangular</td>
</tr>
<tr>
<td></td>
<td>Plane Bounds &gt; X Size</td>
<td>1.25 [m]</td>
</tr>
<tr>
<td></td>
<td>Plane Bounds &gt; Y Size</td>
<td>0.3 [m]</td>
</tr>
<tr>
<td></td>
<td>Plane Bounds &gt; X Angle</td>
<td>0 [degree]</td>
</tr>
<tr>
<td></td>
<td>Plane Type</td>
<td>Sample</td>
</tr>
<tr>
<td></td>
<td>X Samples</td>
<td>160</td>
</tr>
<tr>
<td></td>
<td>Y Samples</td>
<td>40</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

3. Click **Apply**.
4. Clear the check box next to **Plane 1**.
5. Create a new vector named **Vector 1**.
6. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>Plane 1</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Water.Velocity</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.5</td>
</tr>
</tbody>
</table>
7. Click **Apply**.
8. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Variable</td>
<td>Air at 25 C. Superficial Velocity</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.15</td>
</tr>
<tr>
<td></td>
<td>Normalize Symbols</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

9. Click **Apply**.

**Viewing Mesh Refinement**

In this section, you will view the surface mesh on one of the symmetry boundaries, create volume objects to show where the mesh was modified, and create a vector plot to visualize the added mesh nodes.

1. Clear the check box next to **Vector 1**.
2. Zoom in so the geometry fills the **Viewer**.
3. In **Outline** under **Default Domain**, edit **front**.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Constant</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

5. Click **Apply**.

- The mesh has been refined near the free surface.
- In the transition region between different levels of refinement, tetrahedral and pyramidal elements are used since it is not possible to recreate hexahedral elements in ANSYS CFX. Near the inlet, the aspect ratio of these elements increases.
Avoid performing mesh refinement on high-aspect-ratio hex meshes, as this will produce high aspect ratio tetrahedral-elements, resulting in poor mesh quality.

Figure 1 Mesh around the bump

6. Create a new volume named first refinement elements.
7. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Isovolume</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Refinement Level</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Mode</td>
<td>At Value</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Value</td>
<td>1</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Width</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Color Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Color</td>
<td>(Green)</td>
</tr>
</tbody>
</table>

8. Click Apply.
You will see a band of green which indicates the elements that include nodes added during the first mesh adaption.
9. Create a new volume named second refinement elements.
10. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Isovolume</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Refinement Level</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Mode</td>
<td>At Value</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Value</td>
<td>2</td>
</tr>
<tr>
<td>Color</td>
<td>Color</td>
<td>White</td>
</tr>
</tbody>
</table>
Tutorial 7: Free Surface Flow Over a Bump: Viewing the Results in ANSYS CFX-Post

11. Click Apply.  
   You will see a band of white (with black lines) which indicates the elements that include nodes added during the second mesh adaption.

12. Zoom in to a region where the mesh has been refined.  
   The Refinement Level variable holds an integer value at each node, which is either 0, 1 or 2 (since you used a maximum of two adaption levels).  
   The nodal values of refinement level will be visualized next.

13. Create a new vector named Vector 2.

14. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Width</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Color Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Color</td>
<td>(Black)</td>
</tr>
</tbody>
</table>

15. Click Apply.  
   Blue nodes (Refinement Level 0 according to the color legend) are part of the original mesh.  
   Green nodes (Refinement Level 1) were added during the first adaption step. Red nodes (Refinement Level 2) were added during the second adaption step. Note that some elements contain combinations of blue, green, and red nodes.

Creating a Chart

Next, you will create a chart to show how the height of the free surface varies along the length of the channel. To do this, you will need a Polyline which follows the free surface. You can create the Polyline from the intersecting line between one of the Symmetry planes and an Isosurface which shows the free surface. First you must create the Isosurface.

1. Clear the visibility check boxes for all of the objects except Wireframe.  
2. Create a new isosurface named Isosurface 1.  
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Location</td>
<td>Bump2D</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable*</td>
<td>(Any Vector Variable)</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Refinement Level</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol</td>
<td>Cube</td>
</tr>
<tr>
<td></td>
<td>Symbol Size</td>
<td>0.02</td>
</tr>
<tr>
<td></td>
<td>Normalize Symbols</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* The variable’s magnitude and direction do not matter since you will change the vector symbol to a cube with a normalized size.
Creating isosurfaces using this method is a good way to visualize a free surface in a 3D simulation.

5. Right-click any blank area in the viewer, select Predefined Camera, then select Isometric View (Y up).

These steps explain creating a Polyline which follows the free surface:

1. Clear the visibility check box for Isosurface 1.
2. Create a new polyline named Polyline 1.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Method</td>
<td>Boundary Intersection</td>
</tr>
<tr>
<td></td>
<td>Boundary List</td>
<td>front</td>
</tr>
<tr>
<td></td>
<td>Intersect With</td>
<td>Isosurface 1</td>
</tr>
</tbody>
</table>

4. Click Apply.

A green line is displayed that follows the high-Z edge of the isosurface.

Creating a Chart to Show the Height of the Surface

1. Create a new chart named Chart 1.
2. The Chart Viewer tab is selected.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Line 1</td>
<td>Line Name</td>
<td>free surface height</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Polyline 1</td>
</tr>
<tr>
<td></td>
<td>X Axis &gt; Variable</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Y Axis &gt; Variable</td>
<td>Y</td>
</tr>
<tr>
<td></td>
<td>Appearance &gt; Symbols</td>
<td>Rectangle</td>
</tr>
<tr>
<td>Chart</td>
<td>Title</td>
<td>Free Surface Height for Flow over a Bump</td>
</tr>
</tbody>
</table>

3. Click Apply.

As discussed in Creating Expressions for Initial and Boundary Conditions (p. 142), an approximate outlet elevation is imposed as part of the boundary condition, even though the flow is supercritical. The chart illustrates the effect of this, in that the water level rises just before the exit plane. It is evident from this plot that imposing the elevation does not affect the upstream flow.
Tutorial 7: Free Surface Flow Over a Bump: Using a Supercritical Outlet Condition

The chart shows a wiggle in the elevation of the free surface interface at the inlet. This is related to an overspecification of conditions at the inlet, since both the inlet velocity and elevation were specified. For a subcritical inlet, only the velocity or the total energy should be specified. The wiggle is due to a small inconsistency between the specified elevation and the elevation computed by the solver to obtain critical conditions at the bump. The wiggle is analogous to one found if pressure and velocity were both specified at a subsonic inlet, in a converging-diverging nozzle with choked flow at the throat.

Further Post-processing

You may wish to create some plots using the \texttt{<Fluid>.Superficial Velocity} variables. This is the fluid volume fraction multiplied by the fluid velocity and is sometimes called the volume flux. It is useful to use this variable for vector plots in separated multiphase flow, as you will only see a vector where a significant amount of that phase exists.

Using a Supercritical Outlet Condition

For supercritical free surface flows, the supercritical outlet boundary condition is usually the most appropriate boundary condition for the outlet, since it does not rely on the specification of the outlet pressure distribution (which depends on an estimate of the free surface height at the outlet). The supercritical outlet boundary condition requires a relative pressure specification for the gas only; no pressure information is required for the liquid at the outlet. For this tutorial, the relative gas pressure at the outlet should be set to 0 [Pa]. The supercritical outlet condition may admit multiple solutions. To find the supercritical solution, it is often necessary to start with a static pressure outlet condition (as previously done in this tutorial) or an average static pressure condition where the pressure is set consistent with an elevation to drive the solution into the supercritical regime. The outlet condition can then be changed to the supercritical option.
Tutorial 8: Supersonic Flow Over a Wing

Introduction

This tutorial includes:
- Tutorial 8 Features (p. 155)
- Overview of the Problem to Solve (p. 157)
- Defining a Simulation in ANSYS CFX-Pre (p. 157)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 162)
- Viewing the Results in ANSYS CFX-Post (p. 162)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 157).

Sample files referenced by this tutorial include:
- WingSPS.pre
- WingSPSMesh.out

Tutorial 8 Features

This tutorial addresses the following features of ANSYS CFX.
Tutorial 8: Supersonic Flow Over a Wing: Tutorial 8 Features

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>Ideal Gas</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>Shear Stress Transport</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Total Energy</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Supersonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Domain Interfaces</td>
<td>Fluid-Fluid (No Frame Change)</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Auto Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Contour</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Default Locators</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Vector</td>
</tr>
<tr>
<td></td>
<td>Other</td>
<td>Variable Details View</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Setting up a supersonic flow simulation.
- Using the Shear Stress Transport turbulence model to accurately resolve flow around the wing surface.
- Defining custom vector variables for use in visualizing pressure distribution.
Overview of the Problem to Solve

This example demonstrates the use of ANSYS CFX in simulating supersonic flow over a symmetric NACA0012 airfoil at 0° angle of attack. A 2D section of the wing is modeled. A 2D hexahedral mesh is provided that is imported into ANSYS CFX-Pre.

Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: WingSPS.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 162).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type WingSPS.
6. Click Save.
Importing the Mesh

1. Right-click Mesh and select Import Mesh. The Import Mesh dialog box appears.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>PATRAN Neutral</td>
</tr>
<tr>
<td>File name</td>
<td>WingSPSMesh.out</td>
</tr>
</tbody>
</table>

3. Click Open.
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Y up) from the shortcut menu.

Creating the Domain

Creating a New Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.
2. Double click it and apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>WING</td>
</tr>
<tr>
<td></td>
<td>Fluids List</td>
<td>Air Ideal Gas</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure*</td>
<td>1 [atm]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Total Energy†</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Shear Stress Transport</td>
</tr>
</tbody>
</table>

* When using an ideal gas, it is important to set an appropriate reference pressure since some properties depend on the absolute pressure level.
† The Total Energy model is appropriate for high speed flows since it includes kinetic energy effects.

3. Click OK.

Creating the Boundary Conditions

Inlet Boundary

1. Create a new boundary condition named Inlet.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>INLET</td>
</tr>
</tbody>
</table>
### Tutorial 8: Supersonic Flow Over a Wing: Defining a Simulation in ANSYS CFX-Pre

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td>Flow Regime &gt; Option</td>
<td>Supersonic</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Option</td>
<td>Cart. Vel. &amp; Pressure</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; U</td>
<td>600 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; V</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; W</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Rel. Static Pres.</td>
<td>0 [Pa]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Intensity and Length Scale</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Value</td>
<td>0.01</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Eddy Len. Scale</td>
<td>0.02 [m]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>300 [K]</td>
</tr>
</tbody>
</table>

3. Click OK.

**Outlet Boundary**

1. Create a new boundary condition named Outlet.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>OUTLET</td>
</tr>
<tr>
<td>Boundary</td>
<td>Flow Regime &gt; Option</td>
<td>Supersonic</td>
</tr>
</tbody>
</table>

3. Click OK.

**Symmetry Plane Boundary**

1. Create a new boundary condition named SymP1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SIDE1</td>
</tr>
</tbody>
</table>

3. Click OK.
4. Create a new boundary condition named SymP2.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SIDE2</td>
</tr>
</tbody>
</table>

6. Click OK.
7. Create a new boundary condition named Bottom.
8. Apply the following settings
9. Click **OK**.

### Free Slip Boundary

1. Create a new boundary condition named *Top*.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>BOTTOM</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Wall Boundary

1. Create a new boundary condition named *WingSurface*.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>TOP</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence on Flow</td>
<td>Free Slip</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Creating Domain Interfaces

The imported mesh contains three regions which will be connected with domain interfaces.

1. Create a new domain interface named *Domain Interface 1*.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Type</td>
<td>Fluid Fluid</td>
</tr>
<tr>
<td>Interface Side 1 &gt; Region List</td>
<td>Primitive 2D A*</td>
<td></td>
</tr>
<tr>
<td>Interface Side 2 &gt; Region List</td>
<td>Primitive 2D, Primitive 2D B</td>
<td></td>
</tr>
</tbody>
</table>

* Click the ellipsis (…) icon to select items if they do not appear in the drop-down list.

3. Click **OK**.
Setting Initial Values

For high speed compressible flow, the ANSYS CFX-Solver usually requires sensible initial conditions to be set for the velocity field.

1. Click **Global Initialization**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>600 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Temperature &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Temperature</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

3. Click **OK**.

Setting Solver Control

The residence time for the fluid is approximately:

\[
70 \text{ [m]} / 600 \text{ [m s}^{-1}\text{]} = 0.117 \text{ [s]}
\]

In the next step, you will start with a conservative time scale that gradually increases towards the fluid residence time as the residuals decrease. A user specified maximum time scale can be combined with an auto timescale in ANSYS CFX-Pre.

1. Click **Solver Control**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Fluid Timescale</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Control &gt; Maximum Timescale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale</td>
<td>0.1 [s]</td>
</tr>
<tr>
<td></td>
<td>Control &gt; Maximum Timescale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maximum Timescale &gt; Maximum Timescale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Convergence Criteria &gt; Residual Target</td>
<td>1.0e-05</td>
</tr>
</tbody>
</table>

3. Click **OK**.

Writing the Solver (.def) File

Since this tutorial uses domain interfaces and the **Summarize Interface Data** toggle was selected, an information window is displayed that informs you of the connection type used for each domain interface.
Tutorial 8: Supersonic Flow Over a Wing: Obtaining a Solution using ANSYS CFX-Solver Manager

1. Click Write Solver File.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>WingSPS.def</td>
</tr>
<tr>
<td>Summarize Interface Data</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Quit CFX–Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. The Interface Summary dialog box is displayed. This displays information related to the summary of interface connections. Click OK.
5. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

When ANSYS CFX-Pre has shut down, and the ANSYS CFX-Solver Manager has started, obtain a solution to the CFD problem by following the instructions below.

1. In the ANSYS CFX-Solver Manager, click Start Run.
2. Click Yes to post-process the results when the completion message appears at the end of the run.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

The following topics will be discussed:

- Displaying Mach Information (p. 162)
- Displaying Pressure Information (p. 163)
- Displaying Temperature Information (p. 163)
- Displaying Pressure With User Vectors (p. 163)

Displaying Mach Information

The first view configured shows that the bulk of the flow over the wing has a Mach Number of over 1.5.

1. Select View Towards -Z by typing <Shift>+<Z>.
2. Zoom in so the geometry fills the Viewer.
3. Create a new contour named SymP2Mach.
4. Apply the following settings
5. Click **Apply**.
6. Clear the check box next to **SymP2Mach**.

**Displaying Pressure Information**

You will now create a contour plot that shows the pressure field.

1. Create a new contour named **SymP2Pressure**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>SymP2</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Mach Number</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td># of Contours</td>
<td>21</td>
</tr>
</tbody>
</table>

3. Click **Apply**.
4. Clear the check box next to **SymP2Pressure**.

**Displaying Temperature Information**

You can confirm that a significant energy loss occurs around the wing leading edge by plotting temperature on **SymP2**. The temperature at the wing tip is approximately 180 K higher than the inlet temperature.

1. Create a new contour named **SymP2Temperature**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>SymP2</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Pressure</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>Global</td>
</tr>
</tbody>
</table>

3. Click **Apply**.
4. Clear the check box next to **SymP2Temperature**.

**Displaying Pressure With User Vectors**

You can also try creating a user vector to show the pressure acting on the wing:
1. Create a new variable named **Variable 1**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Name</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable 1 Vector</td>
<td>(Selected)</td>
<td></td>
</tr>
<tr>
<td>X Expression</td>
<td>(Pressure+101325[Pa])*Normal X</td>
<td></td>
</tr>
<tr>
<td>Y Expression</td>
<td>(Pressure+101325[Pa])*Normal Y</td>
<td></td>
</tr>
<tr>
<td>Z Expression</td>
<td>(Pressure+101325[Pa])*Normal Z</td>
<td></td>
</tr>
</tbody>
</table>

3. Click **Apply**.
4. Create a new vector named **Vector 1**.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>WingSurface</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Variable 1</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.04</td>
</tr>
</tbody>
</table>

6. Click **Apply**.
7. Zoom in on the wing in order to see the created vector plot.
Tutorial 9: Flow Through a Butterfly Valve

Introduction

This tutorial includes:

- Tutorial 9 Features (p. 165)
- Overview of the Problem to Solve (p. 166)
- Defining a Simulation in ANSYS CFX-Pre (p. 167)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 180)
- Viewing the Results in ANSYS CFX-Post (p. 180)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 167).

Sample files referenced by this tutorial include:

- PipeValve.pre
- PipeValve_inlet.F
- PipeValveMesh.gtm
- PipeValveUserF.pre

Tutorial 9 Features

This tutorial addresses the following features of ANSYS CFX.
Overview of the Problem to Solve

In industry, pumps and compressors are commonplace. An estimate of the pumping requirement can be calculated based on the height difference between source and destination and head loss estimates for the pipe and any obstructions/joints along the way.
Investigating the detailed flow pattern around a valve or joint however, can lead to a better understanding of why these losses occur. Improvements in valve/joint design can be simulated using CFD, and implemented to reduce pumping requirement and cost.

Flows can also contain particulates that affect the flow and cause erosion to pipe and valve components. The particle tracking capability of ANSYS CFX can be used to simulate these effects.

In this example, water flows through a 20 mm radius pipe with a rough internal surface. The equivalent sand grain roughness is 0.2 mm. The flow is controlled by a butterfly valve, which is set at an angle of 55° to the vertical axis. The velocity profile is assumed to be fully developed at the pipe inlet. The flow contains sand particles ranging in size from 50 to 500 microns.

Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run one of the following session files available for this tutorial:

- **PipeValve.pre** sets the inlet velocity profile using a CEL (ANSYS CFX Expression Language) expression.
- **PipeValveUserF.pre** sets the inlet velocity profile using a User CEL Function that is defined by a Fortran subroutine. This session file requires that you have the required Fortran compiler installed and set in your system path. For details on which Fortran compiler is required for your platform, see the applicable ANSYS, Inc. installation guide. If you are not sure which Fortran compiler is installed on your system, try running the `cfx5mkext` command (found in `<CFXROOT>/bin`) from the command line and read the output messages.
Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type PipeValve.
6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>PipeValveMesh.gtm</td>
</tr>
</tbody>
</table>
3. Click Open.

Defining the Properties of Sand

The material properties of the sand particles used in the simulation need to be defined. Heat transfer and radiation modeling are not used in this simulation, so the only property that needs to be defined is the density of the sand.

To calculate the effect of the particles on the continuous fluid, between 100 and 1000 particles are usually required. However, if accurate information about the particle volume fraction or local forces on wall boundaries is required, then a much larger number of particles needs to be modeled.

When you create the domain, choose either full coupling or one-way coupling between the particle and continuous phase. Full coupling is needed to predict the effect of the particles on the continuous phase flow field but has a higher CPU cost than one-way coupling.

One-way coupling simply predicts the particle paths during post-processing based on the flow field, but without affecting the flow field.

To optimise CPU usage, you can create two sets of identical particles. The first set will be fully coupled and between 100 and 1000 particles will be used. This allows the particles to influence the flow field. The second set will use one-way coupling but a much higher number of particles will be used. This provides a more accurate calculation of the particle volume fraction and local forces on walls.

1. Click Material, then create a new material named Sand Fully Coupled.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Material Group</td>
<td>Particle Solids</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Material Properties</td>
<td>Thermodynamic Properties &gt; Equation of</td>
<td>2300 [kg m^-3]</td>
</tr>
<tr>
<td></td>
<td>State &gt; Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Specific Heat</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Capacity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Specific Heat</td>
<td>0 [J kg^-1 K^-1]^*</td>
</tr>
<tr>
<td></td>
<td>Capacity &gt; Specific Heat Capacity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Reference</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>State &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Reference</td>
<td>Specified Point</td>
</tr>
<tr>
<td></td>
<td>State &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Reference</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>State &gt; Ref. Temperature</td>
<td></td>
</tr>
</tbody>
</table>

^* This value is not used because heat transfer is not modeled in this tutorial.

3. Click OK.
4. Under Materials, right-click Sand Fully Coupled and select Duplicate from the shortcut menu.
5. Name the duplicate Sand One Way Coupled.
6. Click OK.

Sand One Way Coupled is created with properties identical to Sand Fully Coupled.

Creating the Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.
2. Double click Default Domain and apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Fluids List</td>
<td>Water</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Particle Tracking</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Particle Tracking &gt; Particles List</td>
<td>Sand Fully Coupled, Sand One Way Coupled</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>k-Epsilon^*</td>
</tr>
</tbody>
</table>
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Details</td>
<td>Sand Fully Coupled</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Morphology &gt; Option</td>
<td>Solid Particles</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Morphology &gt; Particle Diameter Distribution</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Option</td>
<td>Normal in Diameter by Mass</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Minimum Diameter</td>
<td>50e-6 [m]</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Maximum Diameter</td>
<td>500e-6 [m]</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Mean Diameter</td>
<td>250e-6 [m]</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Std. Deviation</td>
<td>70e-6 [m]</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Erosion Model</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Erosion Model &gt; Option</td>
<td>Finnie</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Erosion Model &gt; Vel. Power Factor</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Erosion Model &gt; Reference Velocity</td>
<td>1 [m s^-1]</td>
</tr>
</tbody>
</table>

* The turbulence model only applies to the continuous phase and not the particle phases.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Details</td>
<td>Sand One Way Coupled</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Morphology &gt; Option</td>
<td>Solid Particles</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Morphology &gt; Particle Diameter Distribution</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Option</td>
<td>Normal in Diameter by Mass</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Minimum Diameter</td>
<td>50e-6 ([\text{m}])</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Maximum Diameter</td>
<td>500e-6 ([\text{m}])</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Mean Diameter</td>
<td>250e-6 ([\text{m}])</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Morphology &gt; Particle Diameter Distribution &gt; Std. Deviation</td>
<td>70e-6 ([\text{m}])</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Erosion Model</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Erosion Model &gt; Option</td>
<td>Finnie</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Erosion Model &gt; Vel. Power Factor</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Erosion Model &gt; Reference Velocity</td>
<td>1 ([\text{m s}^{-1}])</td>
</tr>
</tbody>
</table>

5. Click OK.
Creating the Inlet Velocity Profile

In previous tutorials you have often defined a uniform velocity profile at an inlet boundary. This means that the inlet velocity near to the walls is the same as that at the center of the inlet. If you look at the results from these simulations, you will see that downstream of the inlet, a boundary layer will develop, so that the downstream near wall velocity is much lower than the inlet near wall velocity.

You can simulate an inlet more accurately by defining an inlet velocity profile, so that the boundary layer is already fully developed at the inlet. The one seventh power law will be used in this tutorial to describe the profile at the pipe inlet. The equation for this is:

\[ U = W_{\text{max}} \left( 1 - \frac{r}{R_{\text{max}}} \right)^{\frac{1}{7}} \]  

(Eqn. 1)

where \( W_{\text{max}} \) is the pipe centerline velocity, \( R_{\text{max}} \) is the pipe radius, and \( r \) is the distance from the pipe centerline.

A non uniform (profile) boundary condition can be created by:

- Creating an expression using CEL that describes the inlet profile.
  OR
- Creating a User CEL Function which uses a user subroutine (linked to the ANSYS CFX-Solver during execution) to describe the inlet profile.
  OR
- Loading a BC profile file (a file which contains profile data).

Profiles created from data files are not used in this tutorial, but are used in the tutorial Tutorial 3: Flow in a Process Injection Mixing Pipe (p. 77).

In this tutorial, you use one of the first two methods listed above to define the velocity profile for the inlet boundary condition. The results from each method will be identical.

Using a CEL expression is the easiest way to create the profile. The User CEL Function method is more complex but is provided as an example of how to use this feature. For more complex profiles, it may be necessary to use a User CEL Function or a BC profile file.

To use the User CEL Function method, continue with this tutorial from User CEL Function Method for the Inlet Velocity Profile (p. 173). Note that you will need access to a Fortran compiler to be able to complete the tutorial by the User CEL Function method.

To use the expression method, continue with the tutorial from this point.

1. Create the following expressions.

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rmax</td>
<td>20 [mm]</td>
</tr>
<tr>
<td>Wmax</td>
<td>5 [m s^-1]</td>
</tr>
<tr>
<td>Wprof</td>
<td>( W_{\text{max}} \times \text{abs}(1-r/R_{\text{max}})^{0.143} )</td>
</tr>
</tbody>
</table>
In the definition of $W_{ prof }$, the variable $r$ (radius) is a ANSYS CFX System Variable defined as:

$$
    r = \sqrt{x^2 + y^2}
$$

(Eqn. 2)

In this equation, $x$ and $y$ are defined as directions 1 and 2 (X and Y for Cartesian coordinate frames) respectively, in the selected reference coordinate frame.

You should now continue with the tutorial from Creating the Boundary Conditions (p. 175).

The Fortran subroutine has already been written for this tutorial.

**Important:** You must have the required Fortran compiler installed and set in your system path in order to run this part of the tutorial. If you do not have a Fortran compiler, you should use the expression method for defining the inlet velocity, as described in Expression Method for the Inlet Velocity Profile (p. 172). For details on which Fortran compiler is required for your platform, see the applicable ANSYS, Inc. installation guide. If you are not sure which Fortran compiler is installed on your system, try running the `cfx5mkext` command (found in `<CFXROOT>/bin`) from the command line and read the output messages.

### Compiling the Subroutine

1. Copy the subroutine `PipeValve_inlet.F` to your working directory. It is located in the `<CFXROOT>/examples/` directory.
2. Examine the contents of this file in any text editor to gain a better understanding of this subroutine.
   
   This file was created by modifying the `ucf_template.F` file, which is available in the `<CFXROOT>/examples/` directory.
   
   You can compile the subroutine and create the required library files used by the ANSYS CFX-Solver at any time before running the ANSYS CFX-Solver. The operation is performed at this point in the tutorial so that you have a better understanding of the values you need to specify in ANSYS CFX-Pre when creating a User CEL Function. The `cfx5mkext` command is used to create the required objects and libraries as described below.
3. From the main menu, select **Tools > Command Editor**.
4. Type the following in the **Command Editor** dialog box (make sure you do not miss the semi-colon at the end of the line):

   ```
   ! system ('cfx5mkext PipeValve_inlet.F') < 1 or die;
   ```

   • This is equivalent to executing the following at an OS command prompt:

   ```
   cfx5mkext PipeValve_inlet.F
   ```

   • The `>` indicates that the following line is to be interpreted as power syntax and not CCL. Everything after the `>` symbol is processed as Perl commands.

   • `system` is a Perl function to execute a system command.

   • The `< 1 or die` will cause an error message to be returned if, for some reason, there is an error in processing the command.
5. Click **Process** to compile the subroutine.
The output produced when this command is executed will be printed to your terminal window.

**Note:** You can use the `-double` option (that is, `cfx5mkext -double PipeValve_inlet.F`) to compile the subroutine for use with double precision.

A subdirectory will have been created in your working directory whose name is system dependent (for example, on IRIX it is named `irix`). This subdirectory contains the shared object library.

**Note:** If you are running problems in parallel over multiple platforms then you will need to create these subdirectories using the `cfx5mkext` command for each different platform.

- You can view more details about the `cfx5mkext` command by running `cfx5mkext -help`.
- You can set a Library Name and Library Path using the `-name` and `-dest` options respectively.
- If these are not specified, the default Library Name is that of your Fortran file and the default Library Path is your current working directory.

6. Close the **Command Editor** dialog box.

### Creating the Input Arguments

Next, you will create some values that will be used as input arguments when the subroutine is called.

1. Click **Expression**.
2. Set **Name** to `Wmax`, and then click **OK**.
3. Type `5 [m s^-1]` into the **Definition** box, and then click **Apply**.
   
The expression will be listed in the **Expressions** tree view.
4. Use the same method to create an expression named `Rmax` defined to be `20 [mm].`

### Creating the User CEL Function

Two steps are required to define a User CEL Function that uses the compiled Fortran subroutine. First, a User Routine that points to the Fortran subroutine will be created. Then a User CEL Function that points to the User Routine will be created.

1. From the main toolbar, click **User Routine**.
2. Set **Name** to `WprofRoutine`, and then click **OK**.
   
The **User Routine** details view appears.
3. Set **Option** to User CEL Function.
4. Set **Calling Name** to `inlet_velocity`.
   
   - This is the name of the subroutine within the Fortran file.
   - Always use lower case letters for the calling name, even if the subroutine name in the Fortran file is in upper case.
5. Set **Library Name** to `PipeValve_inlet`.
   
   - This is the name passed to the `cfx5mkext` command by the `-name` option.
   - If the `-name` option is not specified, a default is used.
6. Set **Library Path** to the directory where the `cfx5mkext` command was executed (usually the current working directory). For example:

   - UNIX: `/home/user/cfx/tutorials/PipeValve`
   - Windows: `c:\user\cfx\tutorials\PipeValve`

   This can be accomplished quickly by clicking **Browse** (next to **Library Path**), browsing to the appropriate folder in **Select Directory** (not necessary if selecting the working directory), and clicking **OK** (in **Select Directory**).

7. Click **OK** to complete the definition of the user routine.

8. Click **User Function**.

9. Set **Name** to `WprofFunction`, and then click **OK**. The **Function** details view appears.

   **Important:** You must not use the same name for the function and the routine.

10. Set **Option** to **User Function**.

11. Set **User Routine Name** to `WprofRoutine`.

12. Set **Argument Units** to `[m s^-1], [m], [m]`. These are the units for the three input arguments: `Wmax`, `r`, and `Rmax`.

   Set **Result Units** to `[m s^-1]`, since the result will be a velocity for the inlet.

   1. Click **OK** to complete the User Function specification.

   You can now use the user function (`WprofFunction`) in place of a velocity value by entering the expression `WprofFunction(Wmax, r, Rmax)` (although it only makes sense for the W component of the inlet velocity in this tutorial).

   In the definition of `WprofFunction`, the variable `r` (radius) is a system variable defined as:

   \[
   r = \sqrt{x^2 + y^2} \quad \text{(Eqn. 3)}
   \]

   In this equation, `x` and `y` are defined as directions 1 and 2 (X and Y for Cartesian coordinate frames) respectively, in the selected reference coordinate frame.

---

**Creating the Boundary Conditions**

**Inlet Boundary**

1. Create a new boundary condition named `inlet`.

2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>inlet</td>
</tr>
</tbody>
</table>
### Tutorial 9: Flow Through a Butterfly Valve: Defining a Simulation in ANSYS CFX-Pre

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Boundary Details</strong></td>
<td>Mass And Momentum &gt; Option</td>
<td>Cart. Vel. Components</td>
</tr>
<tr>
<td></td>
<td>Mass And Momentum &gt; U</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Mass And Momentum &gt; V</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Mass And Momentum &gt; W</td>
<td>Wprof -OR- WprofFunction(Wmax, r, Rmax)††</td>
</tr>
<tr>
<td><strong>Fluid Values†</strong></td>
<td>Boundary Conditions</td>
<td>Sand Fully Coupled</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Particle Behavior &gt; Define Particle Behavior</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Mass and Momentum &gt; Option</td>
<td>Cart. Vel. Components††</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Mass And Momentum &gt; U</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Mass And Momentum &gt; V</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Mass And Momentum &gt; W</td>
<td>Wprof -OR- WprofFunction(Wmax, r, Rmax)††</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Particle Position &gt; Option</td>
<td>Uniform Injection</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Particle Position &gt; Number of Positions &gt; Option</td>
<td>Direct Specification</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Particle Position &gt; Number of Positions &gt; Number</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td>Sand Fully Coupled &gt; Particle Mass Flow &gt; Mass Flow Rate</td>
<td>0.01 [kg s(^{-1})]</td>
</tr>
<tr>
<td><strong>Fluid Values</strong></td>
<td>Boundary Conditions</td>
<td>Sand One Way Coupled</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Particle Behavior &gt; Define Particle Behavior</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Mass and Momentum &gt; Option</td>
<td>Cart. Vel. Components††</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Mass And Momentum &gt; U</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Mass And Momentum &gt; V</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Mass And Momentum &gt; W</td>
<td>Wprof -OR- WprofFunction(Wmax, r, Rmax)††</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Particle Position &gt; Option</td>
<td>Uniform Injection</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Particle Position &gt; Number of Positions &gt; Option</td>
<td>Direct Specification</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Particle Position &gt; Number of Positions &gt; Number</td>
<td>5000</td>
</tr>
<tr>
<td></td>
<td>Sand One Way Coupled &gt; Particle Mass Flow Rate &gt; Mass Flow Rate</td>
<td>0.01 [kg s(^{-1})]</td>
</tr>
</tbody>
</table>
3. Click OK.

One-way coupled particles are tracked as a function of the fluid flow field. The latter is not influenced by the one-way coupled particles. The fluid flow will therefore be influenced by the 0.01 [kg s^{-1}] flow of two-way coupled particles, but not by the 0.01 [kg s^{-1}] flow of one-way coupled particles.

### Outlet Boundary

1. Create a new boundary condition named \texttt{outlet}.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>outlet</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Flow Regime &gt; Option</td>
<td>Subsonic</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Option</td>
<td>Average Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

3. Click OK.

### Symmetry Plane Boundary

1. Create a new boundary condition named \texttt{symP}.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>symP</td>
</tr>
</tbody>
</table>

3. Click OK.

### Pipe Wall Boundary

1. Create a new boundary condition named \texttt{pipe wall}.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>pipe wall</td>
</tr>
</tbody>
</table>
### Tutorial 9: Flow Through a Butterfly Valve: Defining a Simulation in ANSYS CFX-Pre

**Editing the Default Boundary Condition**

1. In the Outline tree view, edit the boundary condition named **Default Domain**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td>Wall Roughness &gt; Option</td>
<td>Rough Wall</td>
</tr>
<tr>
<td></td>
<td>Roughness Height</td>
<td>0.2 [mm]*</td>
</tr>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Sand Fully Coupled</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Sand Fully Coupled &gt;</td>
<td>Restitution Coefficient</td>
</tr>
<tr>
<td></td>
<td>Velocity &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Sand Fully Coupled &gt;</td>
<td>0.8</td>
</tr>
<tr>
<td></td>
<td>Velocity &gt; Perpendicular Coeff.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Sand Fully Coupled &gt;</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Velocity &gt; Parallel Coeff.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Sand One Way Coupled</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Sand One Way Coupled &gt;</td>
<td>Restitution Coefficient</td>
</tr>
<tr>
<td></td>
<td>Velocity &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Sand One Way Coupled &gt;</td>
<td>0.8</td>
</tr>
<tr>
<td></td>
<td>Velocity &gt; Perpendicular Coeff.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td></td>
</tr>
</tbody>
</table>

* Make sure that you change the units to millimetres. The thickness of the first element should be of the same order as the roughness height.

3. Click **OK**.

### Setting Initial Values

1. Click **Global Initialization**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Sand Fully Coupled</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Sand Fully Coupled &gt;</td>
<td>0.9</td>
</tr>
<tr>
<td></td>
<td>Velocity &gt; Perpendicular Coeff.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Sand One Way Coupled</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Sand One Way Coupled &gt;</td>
<td>0.9</td>
</tr>
<tr>
<td></td>
<td>Velocity &gt; Perpendicular Coeff.</td>
<td></td>
</tr>
</tbody>
</table>

3. Click **OK**.
### Tutorial 9: Flow Through a Butterfly Valve: Defining a Simulation in ANSYS CFX-Pre

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option &gt; U</td>
<td>0 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option &gt; V</td>
<td>0 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option &gt; W</td>
<td>Wprof - OR - WprofFunction(Wmax, r, Rmax)</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* Use Enter Expression to enter Wprof if using the Expression method; enter WprofFunction(Wmax, r, Rmax) if using the User CEL Function method.

3. Click **OK**.

### Setting Solver Control

1. Click **Solver Control**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Advection Scheme &gt; Option</td>
<td>Specified Blend Factor</td>
</tr>
<tr>
<td></td>
<td>Advection Scheme &gt; Blend Factor</td>
<td>0.75</td>
</tr>
<tr>
<td>Particle Control</td>
<td>Particle Integration &gt; Maximum Tracking Time</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Particle Integration &gt; Maximum Tracking Time &gt; Value</td>
<td>10 [s]</td>
</tr>
<tr>
<td></td>
<td>Particle Integration &gt; Maximum Tracking Distance</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Particle Integration &gt; Maximum Tracking Distance &gt; Value</td>
<td>10 [m]</td>
</tr>
<tr>
<td></td>
<td>Particle Integration &gt; Max. Num. Integration Steps</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Particle Integration &gt; Max. Num. Integration Steps &gt; Value</td>
<td>10000</td>
</tr>
<tr>
<td></td>
<td>Particle Integration &gt; Max. Particle Intg. Time Step</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Particle Integration &gt; Max. Particle Intg. Time Step &gt; Value</td>
<td>1e+10 [s]</td>
</tr>
</tbody>
</table>
3. Click **OK**.
Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>PipeValve.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

When ANSYS CFX-Pre has shut down and ANSYS CFX-Solver Manager has started, you can obtain a solution to the CFD problem by using the following procedure.

Note: If you followed the User CEL Function method, and you wish to run this tutorial in distributed parallel on machines with different architectures, you must first compile the PipeValve_inlet.F subroutine on all architectures.

1. Ensure the Define Run dialog box is displayed and click Start Run.
2. Click Yes to post-process the results when the completion message appears at the end of the run.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

In this section, you will first plot erosion on the valve surface and side walls due to the sand particles. You will then create an animation of particle tracks through the domain.

Erosion Due to Sand Particles

An important consideration in this simulation is erosion to the pipe wall and valve due to the sand particles. A good indication of erosion is given by the Erosion Rate Density parameter, which corresponds to pressure and shear stress due to the flow.

1. Edit the object named Default Domain Default.
2. Apply the following settings using the Ellipses as required for selections
**Tutorial 9: Flow Through a Butterfly Valve: Viewing the Results in ANSYS CFX-Post**

3. Click **Apply**.

As can be seen, the highest values occur on the edges of the valve where most particles strike. Erosion of the low Z side of the valve would occur more quickly than for the high Z side.

### Particle Tracks

Default particle track objects are created at the start of the session. One particle track is created for each set of particles in the simulation. You are going to make use of the default object for **Sand Fully Coupled**.

The default object draws 10 tracks as lines from the inlet to outlet. Info shows information about the total number of tracks, index range and the track numbers which are drawn.

1. Edit the object named **Res PT for Sand Fully Coupled**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
</tbody>
</table>
|       | Variable         | **Sand One Way Coupled.Erosion Rate Density**
| Range | User Specified   |                                |
| Min   | 0 [kg m⁻² s⁻¹]   |                                |
| Max   | 25 [kg m⁻² s⁻¹]† |                                |

* This is statistically better than **Sand Fully Coupled.Erosion Rate Density** since many more particles were calculated for **Sand One Way Coupled**.

† This range is used to gain a better resolution of the wall shear stress values around the edge of the valve surfaces.

3. Click **Apply**.

### Erosion on the Pipe Wall

The User Specified range for coloring will be set to resolve areas of stress on the pipe wall near of the valve.

1. Clear the check box next to **Res PT for Sand Fully Coupled**.
2. Clear the check box next to **Default Domain Default**.
3. Edit the object named **pipe wall**.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Max Tracks</td>
<td>20</td>
</tr>
</tbody>
</table>
5. Click Apply.

### Particle Track Symbols

1. Clear visibility for all objects except Wireframe.
2. Edit the object named Res PT for Sand Fully Coupled.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Sand One Way Coupled:Erosion Rate Density</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>0 [kg m⁻² s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>25 [kg m⁻² s⁻¹]</td>
</tr>
</tbody>
</table>

5. Click Apply.

Symbols are placed at the start of each track.

### Creating a Particle Track Animation

The following steps describe how to create a particle tracking animation using Quick Animation. Similar effects can be achieved in more detail using the Keyframe Animation option, which allows full control over all aspects on an animation.

1. Select Tools > Animation or click Animation.
2. Select Quick Animation.
3. Select Res PT for Sand Fully Coupled:
4. Click Options to display the Animation Options dialog box, then clear Override Symbol Settings to ensure the symbol type and size are kept at their specified settings for the animation playback. Click OK.

**Note:** The arrow pointing downward in the bottom right corner of the Animation Window will reveal the Options button if it is not immediately visible.
5. Select **Loop**.
6. Deselect **Repeat forever** and ensure **Repeat** is set to 1.
7. Select **Save MPEG**.
8. Click **Browse** and enter `tracks.mpg` as the file name.
9. Click **Play the animation**.
10. If prompted to overwrite an existing movie, click **Overwrite**.
   The animation plays and builds an `.mpg` file.
11. Close the **Animation** dialog box.

### Performing Quantitative Calculations

On the outlet boundary condition you created in ANSYS CFX-Pre, you set the **Average Static Pressure** to 0.0 [Pa]. To see the effect of this:

1. From the main menu select **Tools > Function Calculator**.
   The **Function Calculator** is displayed. It allows you to perform a wide range of quantitative calculations on your results.

   **Note:** You should use Conservative variable values when performing calculations and Hybrid values for visualization purposes. Conservative values are set by default in ANSYS CFX-Post but you can manually change the setting for each variable in the Variables Workspace, or the settings for all variables by using the Function Calculator.

2. Set **Function** to `maxVal`.
3. Set **Location** to `outlet`.
4. Set **Variable** to `Pressure`.
5. Click **Calculate**.
   The result is the maximum value of pressure at the outlet.
6. Perform the calculation again using `minVal` to obtain the minimum pressure at the outlet.
7. Select `areaAve`, and then click **Calculate**.
   • This calculates the area weighted average of pressure.
   • The average pressure is approximately zero, as specified by the boundary condition.

### Other Features

The geometry was created using a symmetry plane. You can display the other half of the geometry by creating a YZ Plane at X = 0 and then editing the **Default Transform Object** to use this plane as a reflection plane.

1. When you have finished viewing the results, quit ANSYS CFX-Post.
Tutorial 10:
Flow in a Catalytic Converter

Introduction

This tutorial includes:

- Tutorial 10 Features (p. 185)
- Overview of the Problem to Solve (p. 186)
- Defining a Simulation in ANSYS CFX-Pre (p. 187)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 193)
- Viewing the Results in ANSYS CFX-Post (p. 194)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 187).

Sample files referenced by this tutorial include:

- CatConv.pre
- CatConvHousing.hex
- CatConvMesh.gtm

Tutorial 10 Features

This tutorial addresses the following features of ANSYS CFX.
Overview of the Problem to Solve

Catalytic converters are used on most vehicles on the road today. They reduce harmful emissions from internal combustion engines (such as oxides of nitrogen, hydrocarbons, and carbon monoxide) that are the result of incomplete combustion. Most new catalytic
converters are the honeycomb ceramic type and are usually coated with platinum, rhodium, or palladium. The exhaust gases flow through the honeycomb structure and a pressure gradient is established between the inlet and outlet.

In this tutorial, a catalytic converter is modeled without chemical reactions in order to determine the pressure drop. The inlet flange (joining the pipe to the catalyst) is designed to distribute exhaust gas evenly across the catalyst material.

A hexahedral mesh for the housing, which was created in ICEM-Hexa, is provided. The different meshes are connected together in ANSYS CFX-Pre. You will import each mesh then create a domain, which spans all of them. Within the converter, a subdomain is added to model a honeycomb structure using a directional loss model. The physics is then specified in the same way as for other tutorials.

### Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

**Playing a Session File**

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select **Session > Play Tutorial** from the menu in ANSYS CFX-Pre, then run the session file: *catConv.pre*. After you have played the session file as described in earlier tutorials under **Playing the Session File and Starting ANSYS CFX-Solver Manager** (p. 87), proceed to **Obtaining a Solution using ANSYS CFX-Solver Manager** (p. 193).

**Creating a New Simulation**

1. Start ANSYS CFX-Pre.
2. Select **File > New Simulation**.
3. Select **General** and click **OK**.
4. Select **File > Save Simulation As**.
5. Under **File name**, type **CatConv**.
6. Click **Save**.

### Importing the Meshes

The catalytic converter is comprised of three distinct parts:

- The inlet section (pipe and flange).
- The outlet section (pipe and flange).
- The catalyst (or monolith).

Next you will import a generic inlet/outlet section and the catalyst housing from provided files.

#### Housing Section

The first mesh that you will import is the hexahedral mesh for the catalyst housing, created in ICEM-Hexa, named **CatConvHousing.hex**. This mesh was created using units of centimetres; however, the units are not stored with the mesh file for this type of mesh. You must set the mesh import units to cm when importing the mesh into ANSYS CFX-Pre so that the mesh remains the intended size. The imported mesh has a width in the x-direction of 21 cm and a length in the z-direction of 20 cm.

1. Right-click **Mesh** and select **Import Mesh**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>All Types</td>
</tr>
<tr>
<td>Definition &gt; Mesh Format</td>
<td>ICEM CFD</td>
</tr>
<tr>
<td>File name</td>
<td>CatConvHousing.hex</td>
</tr>
<tr>
<td>Definition &gt; Mesh Units</td>
<td>cm</td>
</tr>
</tbody>
</table>

3. Click **Open**.

#### Pipe and Flange Section

This mesh was created in units of centimetres. When importing GTM files, ANSYS CFX-Pre uses the units used in the mesh file.

1. Right-click **Mesh** and select **Import Mesh** to import the second section.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>CFX Mesh (gtm)</td>
</tr>
<tr>
<td>File name</td>
<td>CatConvMesh.gtm</td>
</tr>
</tbody>
</table>

3. Click **Open**.

You only need to import this mesh once, as you will be copying and rotating the flange through 180 degrees in the next step to create the inlet side pipe and flange.
Applying a Transform

The pipe and flange are located at the outlet end of the housing. The flange will be rotated about an axis that points in the y-direction and is located at the center of the housing.

1. Right-click **CatConvMesh.gtm** and select **Transform Mesh**. The **Mesh Transformation Editor** dialog box appears.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>Apply Rotation &gt; Rotation Option</td>
<td>Rotation Axis</td>
</tr>
<tr>
<td></td>
<td>Apply Rotation &gt; From</td>
<td>0, 0, 0.16</td>
</tr>
<tr>
<td></td>
<td>Apply Rotation &gt; To</td>
<td>0, 1, 0.16*</td>
</tr>
<tr>
<td></td>
<td>Apply Rotation &gt; Rotation Angle</td>
<td>180 [degree]</td>
</tr>
<tr>
<td></td>
<td>Multiple Copies</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Multiple Copies &gt; # of Copies</td>
<td>1</td>
</tr>
</tbody>
</table>

* This specifies an axis located at the center of the housing parallel to the y-axis.

3. Click **OK**.

Creating a Union Region

Three separate regions now exist, but since there is no relative motion between each region, you only need to create a single domain. This can be done by simply using all three regions in the domain **Location** list or, as in this case, by using the **Region** details view to create a union of the three regions.

1. Create a new composite region named **CatConverter**.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Dimension (Filter)</td>
<td>3D</td>
</tr>
<tr>
<td></td>
<td>Region List</td>
<td>B1.P3, B1.P3 2, LIVE</td>
</tr>
</tbody>
</table>

3. Click **OK**.

Creating the Domain

For this simulation you will use an isothermal heat transfer model and assume turbulent flow.

1. Click **Domain** and set the name to **CatConv**.

2. Apply the following settings
Creating a Subdomain to Model the Catalyst Structure

The catalyst-coated honeycomb structure will be modeled using a subdomain with a directional source of resistance.

For quadratic resistances, the pressure drop is modeled using:

\[
\frac{\partial p}{\partial x_i} = -K_Q |U_i| U_i
\]

(Eqn. 1)

where \( K_Q \) is the quadratic resistance coefficient, \( U_i \) is the local velocity in the \( i \) direction, and \( \frac{\partial p}{\partial x_i} \) is the pressure drop gradient in the \( i \) direction.

3. Click OK.

### Creating a Subdomain to Model the Catalyst Structure

### For quadratic resistances, the pressure drop is modeled using:

\[
\frac{\partial p}{\partial x_i} = -K_Q |U_i| U_i
\]

(Eqn. 1)

where \( K_Q \) is the quadratic resistance coefficient, \( U_i \) is the local velocity in the \( i \) direction, and \( \frac{\partial p}{\partial x_i} \) is the pressure drop gradient in the \( i \) direction.

1. Select **Insert > Subdomain** from the main menu or click **Subdomain**.
2. In the **Insert Subdomain** dialog box, type **catalyst**.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Location</td>
<td>LIVE*</td>
</tr>
<tr>
<td>Sources†</td>
<td>Sources</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Momentum Source/Porous Loss</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Momentum Source/Porous Loss &gt; Directional Loss</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* This is the entire housing section.
† Used to set sources of momentum, resistance and mass for the subdomain (Other sources are available for different problem physics).

4. Apply the following settings in the **Directional Loss** section:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Streamwise Direction &gt; X Component</td>
<td>0</td>
</tr>
<tr>
<td>Streamwise Direction &gt; Y Component</td>
<td>0</td>
</tr>
<tr>
<td>Streamwise Direction &gt; Z Component</td>
<td>1</td>
</tr>
</tbody>
</table>
5. Click OK.

Creating Boundary Conditions

**Inlet Boundary**
1. Create a new boundary condition named **Inlet**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>PipeEnd 2</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>25 [m s(^{-1})]</td>
</tr>
</tbody>
</table>

3. Click OK.

**Outlet Boundary**
1. Create a new boundary condition named **Outlet**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>PipeEnd</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

3. Click OK.

The remaining surfaces are automatically grouped into the default no slip wall boundary condition.

Creating the Domain Interfaces

Domain interfaces are used to define the connecting boundaries between meshes where the faces do not match or when a frame change occurs. Meshes are 'glued' together using the General Grid Interface (GGI) functionality of ANSYS CFX. Different types of GGI connections can be made. In this case, you require a simple Fluid-Fluid Static connection (no Frame Change). Other options allow you to change reference frame across the interface or create a periodic boundary with dissimilar meshes on each periodic face.

Two Interfaces are required, one to connect the inlet flange to the catalyst housing and one to connect the outlet flange to the catalyst housing.
Inlet Pipe / Housing Interface

1. Create a new domain interface named InletSide.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Side 1 &gt; Region List</td>
<td>FlangeEnd</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Region List</td>
<td>INLET</td>
</tr>
</tbody>
</table>

3. Click OK.

Outlet Pipe / Housing Interface

1. Create a new domain interface named OutletSide.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Side 1 &gt; Region List</td>
<td>FlangeEnd</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Region List</td>
<td>OUTLET</td>
</tr>
</tbody>
</table>

3. Click OK.

Setting Initial Values

A sensible guess for the initial velocity is to set it to the expected velocity through the catalyst housing. As the inlet velocity is 25 [m s\(^{-1}\)] and the cross sectional area of the inlet and housing are known, you can apply conservation of mass to obtain an approximate velocity of 2 [m s\(^{-1}\)] through the housing.

1. Click Global Initialization.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>-2 [m s(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

3. Click OK.

Setting Solver Control

Assuming velocities of 25 [m s\(^{-1}\)] in the inlet and outlet pipes, and 2 [m s\(^{-1}\)] in the catalyst housing, an approximate fluid residence time of 0.1 [s] can be calculated. A sensible timestep of 0.04 [s] (1/4 to 1/2 of the fluid residence time) will be applied.
Tutorial 10: Flow in a Catalytic Converter: Obtaining a Solution using ANSYS CFX-Solver Manager

For the convergence criteria, an RMS value of at least 1e-05 is usually required for adequate convergence, but the default value is sufficient for demonstration purposes.

1. Click Solver Control.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Fluid Timescale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Control &gt; Timescale Control</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Control &gt; Physical Timescale</td>
<td>0.04 [s]</td>
</tr>
</tbody>
</table>

3. Click OK.

Writing the Solver (.def) File

While writing the solver file, you will use the **Summarize Interface Data** option to display information about the connection type used for each domain interface.

1. Click Write Solver File.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>CatConv.def</td>
</tr>
<tr>
<td>Summarize Interface Data</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Quit CFX–Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. Once ANSYS CFX-Solver Manager launches, return to ANSYS CFX-Pre.
   The **Interface Summary** dialog box is displayed. This displays information related to the summary of interface connections.
5. Click **OK**.
6. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

When ANSYS CFX-Pre has shut down and the ANSYS CFX-Solver Manager has started, you can obtain a solution to the CFD problem by following the instructions below:

1. Ensure **Define Run** is displayed.
2. Click **Start Run**.
   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
Tutorial 10: Flow in a Catalytic Converter: Viewing the Results in ANSYS CFX-Post

3. Click Yes to post-process the results.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

When ANSYS CFX-Post opens, you will need to experiment with the Edge Angle setting for the Wireframe object in order to view an appropriate amount of the mesh.

Under the Outline tab, several interface boundaries are available. The two connections between the catalyst housing mesh and the mesh for the inlet and outlet pipes have two interface boundaries each, one for each side of the connection.

1. Zoom in so the geometry fills the viewer.
2. In the Outline tree view, edit InletSide Side 1.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Color Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Color</td>
<td>(Red)</td>
</tr>
</tbody>
</table>

4. Click Apply.
5. In the Outline tree view, edit InletSide Side 2.
6. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Color Mode</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Draw Lines &gt; Line Color</td>
<td>(Green)</td>
</tr>
</tbody>
</table>

7. Click Apply.
8. In the Outline tree view, clear Wireframe to hide it.
9. Right-click a blank area in the viewer and select Predefined Camera > View Towards -Z.

You should now have a clear view of the tetrahedral / prism and hexahedral mesh on each side of the interface. The General Grid Interface (GGI) capability of ANSYS CFX was used to produce a connection between these two dissimilar meshes before the solution was calculated. Notice that there are more tetrahedral / prism elements than hexahedral elements and that the extent of the two meshes is not quite the same (this is most noticeable on the curved edges). The extent of each side of the interface does not have to match to allow a GGI connection to be made.
Creating User Locations and Plots

1. In the Outline tree view, select Wireframe to show it.
2. In the Outline tree view, clear both InletSide Side 1 and InletSide Side 2.

Creating a Slice Plane

1. Create a new plane named Plane 1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>ZX Plane</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
<td>Pressure</td>
</tr>
</tbody>
</table>

3. Click Apply.
4. Right-click a blank area in the viewer and select Predefined Camera > View Towards -Y.

Creating a Contour Plot

The pressure falls steadily throughout the main body of the catalytic converter. You can confirm this with a contour plot.

1. Clear Plane 1 in the Outline tab.
2. Create a new contour plot named Contour 1.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>Plane 1</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
<td>Pressure</td>
</tr>
<tr>
<td># of Contours</td>
<td></td>
<td>30</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

4. Click Apply.

Creating a Vector Plot Using the Slice Plane

1. Create a new vector plot named Vector 1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>Plane 1</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.1</td>
</tr>
<tr>
<td></td>
<td>Normalize Symbols</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

3. Click Apply.
Notice the flow separates from the walls, where the inlet pipe expands into the flange, setting up a recirculation zone. The flow is uniform through the catalyst housing.

Suppose for now that you want to see if the pressure drop is linear by plotting a line graph of pressure against the z-coordinate. In this case you will use ANSYS CFX-Post to produce the graph, but you could also export the data, then read it into any standard plotting package. Graphs are produced using the chart object, but before you can create the chart you must define the points at which you require the data. To define a set of points in a line, you can use the polyline object.

Creating a Polyline

The **Method** used to create the *polyline* can be From File, Boundary Intersection or From Contour. If you select From File, you must specify a file containing point definitions in the required format.

In this tutorial, you will use the **Boundary Intersection** method. This creates a polyline from the intersecting line between a boundary object and a location (e.g., between a wall and a plane). The points on the polyline are where the intersecting line cuts through a surface mesh edge.

You will be able to see the polyline following the intersecting line between the wall, inlet and outlet boundaries and the slice plane.

1. In the Outline tree view, clear Contour 1 and Vector 1.
2. Create a new polyline named Polyline 1.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Method</td>
<td>Boundary Intersection</td>
</tr>
<tr>
<td></td>
<td>Boundary List</td>
<td>CatConv Default, Inlet, Outlet*</td>
</tr>
<tr>
<td></td>
<td>Intersect With</td>
<td>Plane 1</td>
</tr>
<tr>
<td>Color</td>
<td>Color</td>
<td>(Yellow)</td>
</tr>
<tr>
<td>Render</td>
<td>Line Width</td>
<td>3</td>
</tr>
</tbody>
</table>

* Click the ellipsis icon to select multiple items using the <Ctrl> key.

4. **Click Apply**.
5. Right-click a blank area in the viewer and select **Predefined Camera > Isometric View (Y up)**.

Creating a Chart

Now that a polyline has been defined, a chart can be created. Charts are defined by creating chart line objects. A chart line is listed in the tree view beneath the chart object to which it belongs.

1. Create a new chart named Chart 1.
2. Apply the following settings
3. Click **Apply**.

Through the main body of the catalytic converter you can see that the pressure drop is linear. This is in the region from approximately $Z=0.05$ to $Z=0.25$. The two lines show the pressure on each side of the wall. You can see a noticeable difference in pressure between the two walls on the inlet side of the housing (at around $Z=0.25$).

4. If required, in the **Outline** tree view, select **Contour 1, Polyline 1, and Vector 1**.

5. Click the **3D Viewer** tab, then right-click a blank area and select **Predefined Camera > View Towards +Y**.

You should now see that the flow enters the housing from the inlet pipe at a slight angle, producing a higher pressure on the high X wall of the housing.

6. Under **Report**, expand **Chart 1**, and edit **Chart Line 1**.

7. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Line 1</td>
<td>Line Name</td>
<td>Pressure Drop</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Polyline 1</td>
</tr>
<tr>
<td></td>
<td>X Axis &gt; Variable</td>
<td>Z</td>
</tr>
<tr>
<td></td>
<td>Y Axis &gt; Variable</td>
<td>Pressure</td>
</tr>
<tr>
<td>Appearance</td>
<td>Sizes &gt; Symbols</td>
<td>Rectangle</td>
</tr>
</tbody>
</table>

3. **Click Apply**.

**Exporting Data**

1. From the main menu, select **File > Export**.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options</td>
<td>Locations</td>
<td>Polyline 1</td>
</tr>
<tr>
<td></td>
<td>Export Geometry Information</td>
<td>(Selected) *</td>
</tr>
<tr>
<td></td>
<td>Select Variables</td>
<td>Pressure</td>
</tr>
<tr>
<td>Formatting</td>
<td>Precision</td>
<td>3</td>
</tr>
</tbody>
</table>

3. **Click Save**.
The file `export.csv` will be written to the current working directory. This file can be opened in any text editor. You can use the exported data file to plot charts in other software.

4. When finished, quit ANSYS CFX-Post.
Tutorial 11:
Non-Newtonian Fluid Flow in an Annulus

Introduction

This tutorial includes:

- Tutorial 11 Features (p. 200)
- Overview of the Problem to Solve (p. 201)
- Defining a Simulation in ANSYS CFX-Pre (p. 201)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 205)
- Viewing the Results in ANSYS CFX-Post (p. 206)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 201).

Sample files referenced by this tutorial include:

- NonNewton.pre
- NonNewtonMesh.gtm
Tutorial 11 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>Laminar</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Symmetry Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Moving</td>
</tr>
<tr>
<td></td>
<td>CEL (CFX Expression Language)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Auto Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Sampling Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Vector</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Using CFX Expression Language (CEL) to define the properties of a shear-thickening fluid.
- Using the Moving Wall feature to apply a rotation to the fluid at a wall boundary.
Overview of the Problem to Solve

In this example a non-Newtonian, shear-thickening liquid rotates in a 2D eccentric annular pipe gap. The motion, shown by the arrow, is brought about solely by viscous fluid interactions caused by the rotation of the inner pipe.

Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: NonNewton.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 205).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type NonNewton.
6. Click Save.
Tutorial 11: Non-Newtonian Fluid Flow in an Annulus: Defining a Simulation in ANSYS CFX-Pre

Importing the Mesh

1. Right-click Mesh and select Import Mesh.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>NonNewtonMesh.gtm</td>
</tr>
</tbody>
</table>

3. Click Open.

Creating an Expression for Shear Rate Dependent Viscosity

You can use an expression to define the dependency of fluid properties on other variables. In this case, the fluid does not obey the simple linear Newtonian relationship between shear stress and shear strain rate. The general relationship for the fluid you will model is given by:

\[ \mu = K \gamma^n \]  

(Eqn. 1)

where \( \gamma \) is the shear strain rate and \( K \) and \( n \) are constants. For your fluid, \( n = 1.5 \) and this results in shear-thickening behavior of the fluid, i.e., the viscosity increases with increasing shear strain rate. The shear strain rate is available as a ANSYS CFX-Pre System Variable (\( sstrnr \)).

In order to describe this relationship using CEL, the dimensions must be consistent on both sides of the equation. Clearly this means that \( K \) must have dimensions and requires units to satisfy the equation. If the units of viscosity are kg m\(^{-1}\) s\(^{-1}\), and those of \( \gamma \) are s\(^{-1}\), then the expression is consistent if the units of \( K \) are kg m\(^{-1}\) s\(^{-0.5}\).

1. Create the following expressions, remembering to click Apply after each is defined.

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>K</td>
<td>10.0 ([\text{kg m}^{-1} \text{s}^{-0.5}])</td>
</tr>
<tr>
<td>n</td>
<td>1.5</td>
</tr>
</tbody>
</table>

You should bound the viscosity to ensure that it remains physically meaningful. To do so, you will create two additional parameters that will be used to guarantee the value of the shear strain rate.

2. Create the following expressions for upper and lower bounds.

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>UpperS</td>
<td>100 ([\text{s}^{-1}])</td>
</tr>
<tr>
<td>LowerS</td>
<td>1.0E-3 ([\text{s}^{-1}])</td>
</tr>
<tr>
<td>ViscEqn</td>
<td>(K^*(\min(\text{UpperS},\max(sstrnr,\text{LowerS}))^{(n-1)}))</td>
</tr>
</tbody>
</table>

3. Close the Expressions tab.
Creating a New Fluid

1. Create a new material named \textit{myfluid}.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Thermodynamic State</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Material Properties</td>
<td>Equation of State &gt; Molar Mass</td>
<td>1 , [kg , kmol^{-1}] \dagger</td>
</tr>
<tr>
<td></td>
<td>Equation of State &gt; Density</td>
<td>1.0E+4 , [kg , m^{-3}]</td>
</tr>
<tr>
<td></td>
<td>Specific Heat Capacity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Specific Heat Capacity &gt; Specific Heat Capacity</td>
<td>0 , [J , kg^{-1} , K^{-1}] \dagger</td>
</tr>
<tr>
<td></td>
<td>Reference State</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Reference State &gt; Option</td>
<td>Specified Point</td>
</tr>
<tr>
<td></td>
<td>Reference State &gt; Ref. Temperature</td>
<td>25 , [C]</td>
</tr>
<tr>
<td></td>
<td>Reference State &gt; Reference Pressure</td>
<td>1 , [atm]</td>
</tr>
<tr>
<td>Transport Properties &gt; Dynamic Viscosity</td>
<td>(Selected)</td>
<td></td>
</tr>
<tr>
<td>Transport Properties &gt; Dynamic Viscosity &gt; Dynamic Viscosity</td>
<td>ViscEqn</td>
<td></td>
</tr>
</tbody>
</table>

\dagger \textit{This is not the correct Molar Mass value, but this material property will not be used by the ANSYS CFX-Solver for this case. In other cases it will be used.}

\dagger \textit{This is not the correct value for specific heat, but this property will not be used in the ANSYS CFX-Solver.}

3. Click \textbf{OK}.

Creating the Domain

1. Click \textit{Domain} \begin{image} image.png \end{image} and set the name to NonNewton.
2. Apply the following settings to NonNewton

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Fluids List</td>
<td>myfluid</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 , [atm]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fluid Temperature</td>
<td>25 , [C]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>None (Laminar)</td>
</tr>
</tbody>
</table>

3. Click \textbf{OK}.

Creating the Boundary Conditions

\textbf{Wall Boundary} 1. Create a new boundary condition named rotwall.
2. Apply the following settings
Tutorial 11: Non-Newtonian Fluid Flow in an Annulus: Defining a Simulation in ANSYS CFX-Pre

### Symmetry Plane Boundary

1. Create a new boundary condition named **SymP1**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SymP1</td>
</tr>
</tbody>
</table>

3. Click **OK**.

4. Create a new boundary condition named **SymP2**.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SymP2</td>
</tr>
</tbody>
</table>

6. Click **OK**.

The outer annulus surfaces will default to the no-slip stationary wall boundary condition.

### Setting Initial Values

A reasonable initial guess for the velocity field is a value of zero throughout the domain.

1. Click **Global Initialization**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>Automatic with</td>
</tr>
<tr>
<td></td>
<td>Components &gt; Option</td>
<td>Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Components &gt; U</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Components &gt; V</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Components &gt; W</td>
<td></td>
</tr>
</tbody>
</table>

3. Click **OK**.
Setting Solver Control

1. Click Solver Control.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Advection Scheme &gt; Option</td>
<td>Specific Blend Factor</td>
</tr>
<tr>
<td></td>
<td>Advection Scheme &gt; Blend Factor</td>
<td>1*</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Max. Iterations</td>
<td>50</td>
</tr>
<tr>
<td></td>
<td>Convergence Criteria &gt; Residual Target</td>
<td>1e-05</td>
</tr>
</tbody>
</table>

* This is the most accurate but least robust advection scheme.

3. Click OK.

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>NonNewton.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

When ANSYS CFX-Pre has shut down and the ANSYS CFX-Solver Manager has started, you can obtain a solution to the CFD problem by following the instructions below:

1. Ensure Define Run is displayed.
2. Click Start Run.
   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
3. Click Yes to post-process the results.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
Viewing the Results in ANSYS CFX-Post

In this tutorial you have used CEL to create an expression for the dynamic viscosity. If you now perform calculations or color graphics objects using the Dynamic Viscosity variable, its values will have been calculated from the expression you defined in ANSYS CFX-Pre.

These steps instruct the user on how to create a vector plot to show the velocity values in the domain.

1. Right-click a blank area in the viewer and select **Predefined Camera > View Towards -Z** from the shortcut menu.
2. Create a new plane named **Plane 1**.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Point and Normal</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Point</td>
<td>0, 0, 0.02</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Normal</td>
<td>0, 0, 1</td>
</tr>
<tr>
<td></td>
<td>Plane Bounds &gt; Type</td>
<td>Circular</td>
</tr>
<tr>
<td></td>
<td>Plane Bounds &gt; Radius</td>
<td>0.3 [m]</td>
</tr>
<tr>
<td></td>
<td>Plane Type</td>
<td>Sample</td>
</tr>
<tr>
<td></td>
<td>Plane Type &gt; R Samples</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td>Plane Type &gt; Theta Samples</td>
<td>24</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces (Cleared)</td>
<td></td>
</tr>
</tbody>
</table>

4. Click **Apply**.
5. Create a new vector plot named **Vector 1**.
6. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>Plane 1</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Velocity</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>3</td>
</tr>
</tbody>
</table>

7. Click **Apply**.
8. Try creating some plots of your own, including one that shows the variation of dynamic viscosity.
9. When you have finished, quit ANSYS CFX-Post.
Tutorial 12:
Flow in an Axial Rotor/Stator

Introduction

This tutorial includes:

- Tutorial 12 Features (p. 208)
- Overview of the Problem to Solve (p. 209)
- Defining a Frozen Rotor Simulation in ANSYS CFX-Pre (p. 210)
- Obtaining a Solution to the Frozen Rotor Model (p. 214)
- Viewing the Frozen Rotor Results in ANSYS CFX-Post (p. 215)
- Setting up a Transient Rotor-Stator Calculation (p. 216)
- Obtaining a Solution to the Transient Rotor-Stator Model (p. 219)
- Viewing the Transient Rotor-Stator Results in ANSYS CFX-Post (p. 220)

If this is the first tutorial you are working with it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 211).

Sample files referenced by this tutorial include:

- Axial.pre
- AxialIni.pre
- AxialIni_001.res
- rotor.grd
- stator.gtm
Tutorial 12 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>Turbo Wizard</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>Ideal Gas</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Multiple Domain</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Rotating Frame of Reference</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Total Energy</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td>Domain Interfaces</td>
<td>Frozen Rotor</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Periodic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient Rotor Stator</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient Example</td>
</tr>
<tr>
<td></td>
<td>Transient Results File</td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Solver Manager</td>
<td>Restart</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parallel Processing</td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Animation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Isosurface</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Surface Group</td>
</tr>
<tr>
<td>Turbo Post</td>
<td>Other</td>
<td>Changing the Color Range</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Chart Creation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Instancing Transformation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MPEG Generation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Quantitative Calculation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Time Step Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient Animation</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Using the Turbo Wizard in ANSYS CFX-Pre to quickly specify a turbomachinery application.
- Multiple Frames of Reference and Generalized Grid Interface.
- Using a Frozen Rotor interface between the rotor and stator domains.
- Modifying an existing simulation.
- Setting up a transient calculation.
- Using a Transient Rotor-Stator interface condition to replace a Frozen Rotor interface.
Overview of the Problem to Solve

The following tutorial demonstrates the versatility of GGI and MFR in ANSYS CFX-Pre by combining two dissimilar meshes. The first mesh to be imported (the rotor) was created in CFX-TASCflow. This is combined with a second mesh (the stator) which was created using ANSYS CFX-Mesh.

The geometry to be modeled consists of a single stator blade passage and two rotor blade passages. The rotor rotates about the Z-axis while the stator is stationary. Periodic boundaries are used to allow only a small section of the full geometry to be modeled.

At the change in reference frame between the rotor and stator, two different interface models are considered. First a solution is obtained using a Frozen Rotor model. After viewing the results from this simulation, the latter is modified to use a transient rotor-stator interface model. The Frozen Rotor solution is used as an initial guess for the transient rotor-stator simulation.
The full geometry contains 60 stator blades and 113 rotor blades. To help you visualize how the modeled geometry fits into the full geometry, the following figure shows approximately half of the full geometry. The Inflow and Outflow labels show the location of the modeled section in.

As previously indicated, the modeled geometry contains two rotor blades and one stator blade. This is an approximation to the full geometry since the ratio of rotor blades to stator blades is close to, but not exactly, 2:1. In the stator blade passage a 6° section is being modeled (360°/60 blades), while in the rotor blade passage a 6.372° section is being modeled (2*360°/113 blades). This produces a pitch ratio at the interface between the stator and rotor of 0.942. As the flow crosses the interface it is scaled to allow this type of geometry to be modeled. This results in an approximation of the inflow to the rotor passage. Furthermore, the flow across the interface will not appear continuous due to the scaling applied.

The periodic boundary conditions will introduce an additional approximation since they cannot be periodic when a pitch change occurs.

You should always try to obtain a pitch ratio as close to 1 as possible in your model to minimize approximations, but this must be weighed against computational resources. A full machine analysis can be performed (modeling all rotor and stator blades) which will always eliminate any pitch change, but will require significant computational time. For this rotor/stator geometry, a 1/4 machine section (28 rotor blades, 15 stator blades) would produce a pitch change of 1.009, but this would require a model about 15 times larger than in this tutorial example.

**Defining a Frozen Rotor Simulation in ANSYS CFX-Pre**

The following sections describe the simulation setup in ANSYS CFX-Pre.
Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select **Session > Play Tutorial** from the menu in ANSYS CFX-Pre, then run the session file: *AxialIni.pre*. After you have played the session file as described in earlier tutorials under **Playing the Session File and Starting ANSYS CFX-Solver Manager** (p. 87), proceed to **Obtaining a Solution to the Frozen Rotor Model** (p. 214).

Creating a New Simulation

This tutorial will use the Turbomachinery wizard in ANSYS CFX-Pre. This pre-processing mode is designed to simplify the setup of turbomachinery simulations.

1. Start ANSYS CFX-Pre.
2. Select **File > New Simulation**.
3. Select **Turbomachinery** and click **OK**.
4. Select **File > Save Simulation As**.
5. Under **File name**, type *AxialIni*.
6. Click **Save**.

Basic Settings

1. Set **Machine Type** to **Axial Turbine**.
2. Click **Next**.

Component Definition

Two new components are required. As they are created, meshes are imported.

1. Right-click in the blank area and select **New Component** from the shortcut menu.
2. Create a new component of type **Stationary**, named **S1**.
3. Apply the following setting:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mesh &gt; File</td>
<td>stator.gtm*</td>
</tr>
</tbody>
</table>

   * You may have to select the **CFX Mesh** option under **File Type**.

4. Create a new component of type **Rotating**, named **R1**.
5. Apply the following settings.
**Note:** The components must be ordered as above (stator then rotor) in order for the interface to be created correctly. The order of the two components can be changed by right clicking on $S_1$ and selecting **Move Component Up**.

When a component is defined, Turbo Mode will automatically select a list of regions that correspond to certain boundary condition types. This information should be reviewed in the **Region Information** section to ensure that all is correct. This information will be used to help set up boundary conditions and interfaces. The upper case turbo regions that are selected (e.g., **HUB**) correspond to the region names in the CFX-TASCflow grd file. CFX-TASCflow turbomachinery meshes use these names consistently.

6. Click **Next**.

### Physics Definition

In this section, you will set properties of the fluid domain and some solver parameters.

1. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physics Definition</td>
<td>Fluid</td>
<td>Air Ideal Gas</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Model Data &gt; Reference Pressure</td>
<td>0.25 [atm]</td>
</tr>
<tr>
<td></td>
<td>Model Data &gt; Heat Transfer</td>
<td>Total Energy</td>
</tr>
<tr>
<td></td>
<td>Model Data &gt; Turbulence</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Boundary Templates &gt; P-Total Inlet Mass Flow Outlet</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Boundary Templates &gt; P-Total</td>
<td>0 [atm]</td>
</tr>
<tr>
<td></td>
<td>Boundary Templates &gt; T-Total</td>
<td>340 [K]</td>
</tr>
<tr>
<td></td>
<td>Boundary Templates &gt; Mass Flow Rate</td>
<td>0.06 [kg s$^{-1}$]</td>
</tr>
<tr>
<td></td>
<td>Interface &gt; Default Type</td>
<td>Frozen Rotor</td>
</tr>
<tr>
<td></td>
<td>Solver Parameters &gt; Convergence Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Solver Parameters &gt; Physical Timescale</td>
<td>0.002 [s$^{-1}$]</td>
</tr>
</tbody>
</table>

* This time scale is approximately equal to $1 / \omega$, which is often appropriate for rotating machinery applications.

2. Click **Next**.
Interface Definition

ANSYS CFX-Pre will try to create appropriate interfaces using the region names presented previously in the Region Information section. In this case, you should see that a periodic interface has been generated for both the rotor and the stator. These are required when modeling a small section of the true geometry. An interface is also required to connect the two components together across the frame change.

1. Review the various interfaces but do not change them.
2. Click Next.

Boundary Definition

ANSYS CFX-Pre will try to create appropriate boundary conditions using the region names presented previously in the Region Information section. In this case, you should see a list of boundary conditions that have been generated. They can be edited or deleted in the same way as the interface connections that were set up earlier.

1. Review the various boundary definitions but do not change them.
2. Click Next.

Final Operations

1. Set Operation to Enter General Mode.
2. Click Finish.

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>AxialIni.def</td>
</tr>
<tr>
<td>Quit CFX-Pre</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

You should see ANSYS CFX-Solver Manager appear.
Obtaining a Solution to the Frozen Rotor Model

Compared to previous tutorials, the mesh for this tutorial contains many more nodes (although it is still too coarse to perform a high quality CFD simulation). This results in a corresponding increase in solution time for the problem. Solving this problem in parallel is recommended, if possible. Your machine should have a minimum of 256MB of memory to run this tutorial.

More detailed information about setting up ANSYS CFX to run in parallel is available. For details, see Tutorial 5: Flow Around a Blunt Body (p. 109).

You can solve this example using Serial, Local Parallel or Distributed Parallel.

- **Obtaining a Solution in Serial** (p. 214)
- **Obtaining a Solution With Local Parallel** (p. 214)
- **Obtaining a Solution with Distributed Parallel** (p. 215)

**Obtaining a Solution in Serial**

If you do not have a license to run ANSYS CFX in parallel you can run in serial by clicking the **Start Run** button when ANSYS CFX-Solver Manager has opened up. Solution time in serial is approximately 45 minutes on a 1GHz processor.

1. Click **Start Run** on the **Define Run** dialog box.
   - ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
2. Click **Yes** to start ANSYS CFX-Post.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

When you are finished, proceed to Viewing the Frozen Rotor Results in ANSYS CFX-Post (p. 215).

**Obtaining a Solution With Local Parallel**

To run in local parallel, the machine you are on must have more than one processor.

1. Set **Run Mode** to PVM Local Parallel in the **Define Run** dialog box.
   - This is the recommended method for most applications.
2. If required, click **Add Partition** to add more partitions.
   - By default, 2 partitions are assigned.
3. Click **Start Run**.
4. Click **Yes** to post-process the results when the completion message appears at the end of the run.
5. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

When you are finished, proceed to Viewing the Frozen Rotor Results in ANSYS CFX-Post (p. 215).
Obtaining a Solution with Distributed Parallel

1. Set Run Mode to PVM Distributed Parallel in the Define Run dialog box. One partition should already be assigned to the host that you are logged into.
2. Click Insert Host to specify a new parallel host.
3. In Select Parallel Hosts, select another host name (this should be a machine that you can log into using the same user name).
4. Click Add, and then Close.
   The names of the two selected machines should be listed in the Host Name column of the Define Run dialog box.
5. Click Start Run.
6. Click Yes to post-process the results when the completion message appears at the end of the run.
7. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Frozen Rotor Results in ANSYS CFX-Post

The Turbo-Post feature will be demonstrated in the following sections. This feature is designed to greatly reduce the effort taken to post-process turbomachinery simulations.

Initializing Turbo-Post

To initialize Turbo-Post, the properties of each component must be entered. This includes entering information about the inlet, outlet, hub, shroud, blade and periodic regions.

1. Click the Turbo tab.
   The Turbo Initialization dialog box is displayed, and asks you whether you want to auto-initialize all components.

Note: If you do not see the Turbo Initialization dialog box, or as an alternative to using that dialog box, you can initialize all components by clicking the Initialize All Components button which is visible initially by default, or after double-clicking the Initialization object in the Turbo tree view.
2. Click Yes.
   The Turbo tree view shows the two components in domains R1 and S1. In this case, the initialization works without problems. If there was a problem initializing a component, this would be indicated in the tree view.

Viewing Three Domain Passages

Next, you will create an instancing transformation to plot three blade passages for the stator and six blade passages for the rotor.

The instancing properties of each domain have already been entered during Initialization. In the next steps, you will create a surface group plot to color the blade and hub surfaces with the same variable.
Tutorial 12: Flow in an Axial Rotor/Stator: Setting up a Transient Rotor-Stator Calculation

1. From the main menu, select **Insert > Location > Surface Group**.
2. Click **OK**.
   The default name is accepted.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Locations</td>
<td>R1 Blade, R1 Hub, S1 Blade, S1 Hub</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Pressure</td>
</tr>
</tbody>
</table>

4. Click **Apply**.
5. Click the **Turbo** tab.
6. Open **Plots > 3D View** for editing.
7. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D View</td>
<td>Instancing &gt; Domain</td>
<td>R1</td>
</tr>
<tr>
<td></td>
<td>Instancing &gt; # of Copies</td>
<td>3</td>
</tr>
</tbody>
</table>

8. Click **Apply**.
9. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D View</td>
<td>Instancing &gt; Domain</td>
<td>S1</td>
</tr>
<tr>
<td></td>
<td>Instancing &gt; # of Copies</td>
<td>3</td>
</tr>
</tbody>
</table>

10. Click **Apply**.

Blade Loading Turbo Chart

In this section, you will create a plot of pressure around the stator blade at a given spanwise location.

1. In the **Turbo** tree view, double-click **Blade Loading**.
   This profile of the pressure curve is typical for turbomachinery applications.
   When you are finished viewing the chart, quit ANSYS CFX-Post.

Setting up a Transient Rotor-Stator Calculation

This section describes the step-by-step definition of the flow physics in ANSYS CFX-Pre. The existing frozen-rotor simulation is modified to define the transient rotor-stator simulation. If you have not already completed the frozen-rotor simulation, please refer to **Defining a Frozen Rotor Simulation in ANSYS CFX-Pre** (p. 210) before proceeding with the transient rotor-stator simulation.
Tutorial 12: Flow in an Axial Rotor/Stator: Setting up a Transient Rotor-Stator Calculation

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: Axial.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution to the Transient Rotor-Stator Model (p. 219).

Note: The session file creates a new simulation named Axial.cfx and will not modify the existing database. It also copies the required initial values files from the examples directory to the current working directory.

Opening the Existing Simulation

This step involves opening the original simulation and saving it to a different location.

1. Start ANSYS CFX-Pre.
2. Open the results file named AxialIni_001.res.
3. Save the simulation as Axial.cfx in your working directory.

Modifying the Physics Definition

You need to modify the domain to define a transient simulation. You are going to run for a time interval such that the rotor blades pass through 1 pitch (6.372°) using 10 timesteps. This is generally too few timesteps to obtain high quality results, but is sufficient for tutorial purposes. The timestep size is calculated as follows:

Rotational Speed = 523.6 rad/s
Rotor Pitch Modelled = 2*(2π/113) = 0.1112 rad
Time to pass through 1 pitch = 0.1112/523.6 = 2.124e-4 s

Since 10 time steps are used over this interval each timestep should be 2.124e-5 s.

1. Click Next. Component Definition is displayed.
2. Click Next. Physics Definition is displayed.
3. Apply the following settings.
1. Click **Output Control**.
2. Click the **Trn Results** tab.
3. Create a new transient result with the name **Transient Results 1**.
4. Apply the following settings to **Transient Results 1**.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td>Selected Variables</td>
</tr>
<tr>
<td><strong>Output Variables List</strong></td>
<td>Pressure, Velocity, Velocity in Stn Frame</td>
</tr>
<tr>
<td><strong>Output Frequency &gt; Option</strong></td>
<td>Time Interval</td>
</tr>
<tr>
<td><strong>Output Frequency &gt; Time Interval</strong></td>
<td>2.124e-5 [s]</td>
</tr>
</tbody>
</table>

* Use the <Ctrl> key to select more than one variable.

5. Click **OK**.

### Writing the Solver (.def) File

1. Click **Write Solver File**.
A warning will appear, due to a lack of initial values.

2. Click **Yes**.
   Initial values are required, but will be supplied later using a results file.

3. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Axial.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

4. Ensure **Start Solver Manager** is selected and click **Save**.

5. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

### Obtaining a Solution to the Transient Rotor-Stator Model

When the ANSYS CFX-Solver Manager has started you will need to specify an initial values file before starting the ANSYS CFX-Solver.

#### Serial Solution

If you do not have a license, or do not want to run ANSYS CFX in parallel, you can run it in serial. Solution time in serial is similar to the first part of this tutorial.

1. Under **Initial Values File**, click **Browse**.
2. Select AxialIni_001.res.
3. Click **Open**.
4. Click **Start Run**.
5. You may see a notice that the mesh from the initial values file will be used. This mesh is the same as in the definition file. Click **OK** to continue.
   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
6. Click **Yes** to post-process the results when the completion message appears at the end of the run.
7. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
   When you are finished, continue with **Monitoring the Run** (p. 220).

#### Parallel Solution

You can solve this example using either local parallel or distributed parallel, in the same way as in the first part of this tutorial. For details, see **Obtaining a Solution to the Frozen Rotor Model** (p. 214).
Monitoring the Run

During the solution, look for the additional information that is provided for transient rotor-stator runs. Each time the rotor is rotated to its next position, the number of degrees of rotation and the fraction of a pitch moved is given. You should see that after 10 timesteps the rotor has been moved through 1 pitch.

Viewing the Transient Rotor-Stator Results in ANSYS CFX-Post

To examine the transient interaction between the rotor and stator, you are going to create a blade-to-blade animation of pressure. A turbo surface will be used as the basis for this plot.

Initializing Turbo-Post

1. Click the Turbo tab. The Turbo Initialization dialog box is displayed, and asks you whether you want to auto-initialize all components.

   Note: If you do not see the Turbo Initialization dialog box, or as an alternative to using that dialog box, you can initialize all components by clicking the Initialize All Components button which is visible initially by default, or after double-clicking the Initialization object in the Turbo tree view.

2. Click Yes. Both components (domains) are now being initialized based on the automatically selected turbo regions. When the process is complete, a green turbine icon appears next to each component entry in the list. Also, the viewer displays a green background mesh for each initialized component.

3. Double-click Component 1 (S1) and review the automatically-selected turbo regions.

Displaying a Surface of Constant Span

1. In the Turbo tree view, double-click Blade-to-Blade. A surface of constant span appears, colored by pressure. This object can be edited and then redisplayed using the details view.

Using Multiple Turbo Viewports

1. In the Turbo tree view, double-click Initialization.

2. Click Three Views. Left view is 3D View, top right is Blade-to-Blade and bottom right is Meridional view.

3. Click Single View.

Creating a Turbo Surface Midway Between the Hub and Shroud

1. Create a Turbo Surface from the Insert drop down menu with a Constant Span and value of 0.5.
2. Under the Color panel select Variable and set it to Pressure with a user specified range of -10000 [Pa] to -7000 [Pa].

Setting up Instancing Transformations

Next, you will use instancing transformations to view a larger section of the model. The properties for each domain have already been entered during the initialization phase, so only the number of instances needs to be set.

1. In the Turbo tree view, double-click the 3D View object.
2. In the Instancing section of the form, set # of Copies to 6 for R1.
3. Click Apply.
4. In the Instancing section of the form, set # of Copies to 6 for S1.
5. Click Apply.
6. Return to the Outline tab and ensure that the turbo surface is visible again.

Creating a Transient Animation

Start by loading the first timestep:

1. Click Timestep Selector.
2. Select time value 0.
3. Click Apply to load the timestep.
   The rotor blades move to their starting position. This is exactly 1 pitch from the previous position so the blades will not appear to move.
5. Position the geometry as shown below, ready for the animation. During the animation the rotor blades will move to the right. Make sure you have at least two rotor blades out of view to the left side of the viewer. They will come into view during the animation.

6. In the toolbar at the top of the window click Animation.
7. In the Animation dialog box, click New to create KeyFrameNo1.
8. Highlight KeyFrameNo1, then set # of Frames to 9.
9. Use the Timestep Selector to load the final timestep.
10. In the Animation dialog box, click New to create KeyframeNo2.

11. Click More Animation Options to expand the Animation dialog box.

12. Click Options and set Transient Case to TimeValue Interpolation. Click OK.

The animation now contains a total of 11 frames (9 intermediate frames plus the two Keyframes), one for each of the available time values.

13. In the expanded Animation dialog box, select Save MPEG.

14. Click Browse, next to the Save MPEG box and then set the file name to an appropriate file name.

15. If frame 1 is not loaded (shown in the F: text box at the bottom of the Animation dialog box), click To Beginning to load it.

Wait for ANSYS CFX-Post to finish loading the objects for this frame before proceeding.

16. Click Play the animation.

   • It takes a while for the animation to complete.
   • To view the MPEG file, you will need to use a media player that supports the MPEG format.

You will be able to see from the animation, and from the plots created previously, that the flow is not continuous across the interface. This is because a pitch change occurs. The relatively coarse mesh and the small number of timesteps used in the transient simulation also contribute to this. The movie was created with a narrow pressure range compared to the global range which exaggerates the differences across the interface.

Further Postprocessing

You can use the Turbo Calculator to produce a report on the performance of the turbine.

1. Edit the Gas Turbine Performance macro in the Turbo tree view.

2. Set Ref Radius to 0.4575 and leave other settings at their default values.

3. Click Calculate.

Tutorial 13:
Reacting Flow in a Mixing Tube

Introduction

This tutorial includes:

- Tutorial 13 Features (p. 223)
- Overview of the Problem to Solve (p. 224)
- Outline of the Process (p. 224)
- Defining a Simulation in ANSYS CFX-Pre (p. 225)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 237)
- Viewing the Results in ANSYS CFX-Post (p. 237)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 225).

Sample files referenced by this tutorial include:

- Reactor.pre
- ReactorExpressions.ccl
- ReactorMesh.gtm

Tutorial 13 Features

This tutorial addresses the following features of ANSYS CFX.
Overview of the Problem to Solve

Reaction engineering is one of the main core components in the chemical industry. Optimizing reactor design leads to higher yields, lower costs and, as a result, higher profit. This example demonstrates the capability of ANSYS CFX in modeling basic reacting flows using a multicomponent fluid model.

Outline of the Process

The model is a mixing tube into which acid and alkali are injected through side holes. The reaction to be modeled is:

\[ \text{H}_2\text{SO}_4 + 2\text{NaOH} \rightarrow \text{Na}_2\text{SO}_4 + 2\text{H}_2\text{O} \]  

(Eqn. 1)

The tube is modeled as an axisymmetric section.
The reaction between acid and alkali is represented as a single step irreversible liquid-phase reaction

\[ A + B \rightarrow C \]  

(Eqn. 2)

Reagent A (dilute sulphuric acid) is injected through a ring of holes near the start of the tube. As it flows along the tube it reacts with Reagent B (dilute sodium hydroxide) which is injected through a further two rings of holes downstream. The product, C, remains in solution.

The composition and pH of the mixture within the tube are principal quantities of interest to be predicted by the model.

The flow is assumed to be fully turbulent and turbulence is assumed to have a significant effect on the process. The process is also exothermic.

---

**Defining a Simulation in ANSYS CFX-Pre**

The following sections describe the simulation setup in ANSYS CFX-Pre.

**Playing a Session File**

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select *Session > Play Tutorial* from the menu in ANSYS CFX-Pre, then run the session file: `Reactor.pre`. After you have played the session file as described in earlier tutorials under *Playing the Session File and Starting ANSYS CFX-Solver Manager* (p. 87), proceed to *Obtaining a Solution using ANSYS CFX-Solver Manager* (p. 237).

**Creating a New Simulation**

1. Start ANSYS CFX-Pre.
2. Select *File > New Simulation*.
3. Select *General* and click *OK*.
4. Select *File > Save Simulation As*.
5. Under *File name*, type `Reactor`.
6. Click *Save*.

**Importing the Mesh**

1. Right-click *Mesh* and select *Import Mesh*.
2. Apply the following settings
Creating a Multicomponent Fluid

In addition to providing template fluids, ANSYS CFX allows you to create custom fluids for use in all your ANSYS CFX models. These fluids may be defined as a pure substance, but may also be defined as a mixture, consisting of a number of transported fluid components. This type of fluid model is useful for applications involving mixtures, reactions, and combustion.

In order to define custom fluids, ANSYS CFX-Pre provides the Material details view. This tool allows you to define your own fluids as pure substances, fixed composition mixtures or variable composition mixtures using a range of template property sets defined for common materials.

The mixing tube application requires a fluid made up from four separate materials (or components). The components are the reactants and products of a simple chemical reaction together with a neutral carrier liquid. You are first going to define the materials that take part in the reaction (acid, alkali and product) as pure substances. The neutral carrier liquid is water; this material is already defined since it is commonly used. Finally, you will create a variable composition mixture consisting of these four materials. This is the fluid that you will use in your simulation. A variable composition mixture (as opposed to a fixed composition mixture) is required because the proportion of each component will change throughout the simulation due to the reaction.

**Acid properties**

1. Create a new material named `acid`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>Pure Substance</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State &gt;...</td>
<td>Liquid</td>
</tr>
</tbody>
</table>
3. Click OK.

### Alkali properties

1. Create a new material named `alkali`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Basic Settings</strong></td>
<td>Option</td>
<td>Pure Substance</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State &gt; Thermodynamic State</td>
<td>Liquid</td>
</tr>
<tr>
<td><strong>Material Properties</strong></td>
<td>Thermodynamic Properties &gt; Equation of State</td>
<td>20.42 [kg kmol^-1]</td>
</tr>
<tr>
<td></td>
<td>&gt; Molar Mass</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Equation of State</td>
<td>1130 [kg m^-3]</td>
</tr>
<tr>
<td></td>
<td>&gt; Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Specific Heat</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Capacity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Specific Heat</td>
<td>4190 [J kg^-1 K^-1]</td>
</tr>
<tr>
<td></td>
<td>Capacity &gt; Specific Heat Capacity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Dynamic Viscosity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Dynamic Viscosity &gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Dynamic Viscosity &gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dynamic Viscosity</td>
<td>0.001 [kg m^-1 s^-1]</td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Thermal Conductivity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Thermal Conductivity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Thermal Conductivity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Thermal Conductivity</td>
<td>0.6 [W m^-1 K^-1]</td>
</tr>
</tbody>
</table>

3. Click OK.
Tutorial 13: Reacting Flow in a Mixing Tube: Defining a Simulation in ANSYS CFX-Pre

**Product of the reaction properties**

1. Create a new material named `product`.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>Pure Substance</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State &gt; Thermodynamic State</td>
<td>Liquid</td>
</tr>
<tr>
<td>Material Properties</td>
<td>Thermodynamic Properties &gt; Equation of State</td>
<td>21.51 [kg kmol⁻¹]</td>
</tr>
<tr>
<td></td>
<td>&gt; Molar Mass</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Equation of State</td>
<td>1190 [kg m⁻³]</td>
</tr>
<tr>
<td></td>
<td>&gt; Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Specific Heat</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Capacity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Thermodynamic Properties &gt; Specific Heat</td>
<td>4190 [J kg⁻¹ K⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Capacity &gt; Specific Heat Capacity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Dynamic Viscosity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Dynamic Viscosity</td>
<td>0.001 [kg m⁻¹ s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>&gt; Dynamic Viscosity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Thermal Conductivity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Thermal Conductivity</td>
<td>0.6 [W m⁻¹ K⁻¹]</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Fluid properties**

1. Create a new material named `mixture`.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>Variable Composition Mixture</td>
</tr>
<tr>
<td></td>
<td>Material Group</td>
<td>User, Water Data</td>
</tr>
<tr>
<td></td>
<td>Materials List</td>
<td>Water, acid, alkali, product</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State &gt; Thermodynamic State</td>
<td>Liquid</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Creating an Additional Variable to Model pH**

You are going to use an additional variable to model the distribution of pH in the mixing tube. You can create additional variables and use them in selected fluids in your domain.

1. Create a new additional variable named `MixturePH`.
2. Apply the following settings:
3. Click OK.
This additional variable is now available for use when you create or modify a domain.

### Defining the Reaction

Reactions and reaction kinetics can be modeled using CFX Expression Language (CEL), together with appropriate settings for Component sources. This section shows you how to develop an Eddy Break Up (EBU) type term using CEL to simulate the reaction between acid and alkali.

#### Reaction Source Terms

The reaction and reaction rate are modeled using a basic Eddy Break Up formulation for the component and energy sources, so that, for example, the transport equation for mass fraction of acid is

\[
dt \left( \rho m_f_{\text{acid}} \right) + \nabla \cdot \left( \rho U m_f_{\text{acid}} \right) - \nabla \cdot \left( \rho D_i \nabla m_f_{\text{acid}} \right) \\
= -4\rho \frac{e}{k} \min \left( m_f_{\text{acid}}, \frac{m_f_{\text{alkali}}}{i} \right)
\]  

(Eqn. 3)

where \( m_f \) is mass fraction, \( D_i \) is the kinematic diffusivity (set above) and \( i \) is the stoichiometric ratio. The right hand side represents the source term applied to the transport equation for the mass fraction of acid. The left hand side consists of the transient, advection and diffusion terms.

For acid-alkali reactions, the stoichiometric ratio is usually based on volume fractions. To correctly model the reaction using an Eddy Break Up formulation based on mass fractions, you must calculate the stoichiometric ratio based on mass fractions.

In this tutorial the reaction is modeled by introducing source terms for the acid, alkali and product components. You can now also model this type of flow more easily using a reacting mixture as your fluid. There is also a tutorial example using a reacting mixture. For details, see Tutorial 18: Combustion and Radiation in a Can Combustor (p. 299).

#### Technical Note (Reference Only)

In ANSYS CFX, Release 11.0, a source is fully specified by an expression for its value \( S \).

A source coefficient \( C \) is optional, but can be specified to provide convergence enhancement or stability for strongly-varying sources. The value of \( C \) may affect the rate of convergence but should not affect the converged results.
If no suitable value is available for $C$, the solution time scale or timestep can still be reduced to help improve convergence of difficult source terms.

**Important:** $C$ must never be positive.

An optimal value for $C$ when solving an individual equation for a positive variable $\phi$ with a source $S$ whose strength decreases with increasing $\phi$ is

$$C = \frac{\partial S}{\partial \phi}$$  \hspace{1cm} (Eqn. 4)

Where this derivative cannot be computed easily,

$$C = \frac{S}{\phi}$$  \hspace{1cm} (Eqn. 5)

may be sufficient to ensure convergence.

Another useful recipe for $C$ is

$$C = -\frac{\rho}{\tau}$$  \hspace{1cm} (Eqn. 6)

where $\tau$ is a local estimate for the source time scale. Provided that the source time scale is not excessively short compared to flow or mixing time scales, this may be a useful approach for controlling sources with positive feedback ($\partial S/\partial \phi > 0$) or sources that do not depend directly on the solved variable $\phi$.

### Calculating pH

The pH (or acidity) of the mixture is a function of the mass fraction of acid, alkali and product. For the purposes of this calculation, acid is assumed to be dilute and fully dissociated into its respective ions ($H^+$ and $X^-$); alkali is assumed to be dilute and fully dissociated into its respective ions ($Y^+$ and $OH^-$); product is assumed to be a salt solution including further $H^+$ and $OH^-$ ions in a stoichiometric ratio.

The concentrations of hydrogen and hydroxyl ions can be calculated from the mass fractions of the components using the following expressions:

$$[H^+]_{\text{acid}} = \alpha \rho \left( mf_{\text{acid}} + \frac{mf_{\text{prod}}}{1 + i} \right) = [X^-]$$  \hspace{1cm} (Eqn. 7)

$$[OH^-]_{\text{alkali}} = \beta \rho \left( mf_{\text{alkali}} + \frac{imf_{\text{prod}}}{1 + i} \right) = [Y^+]$$  \hspace{1cm} (Eqn. 8)
where $\alpha$ and $\beta$ are the $X^-$ ion and $Y^+$ ion concentrations in the acid and alkali respectively. For this problem, $\alpha$ is set to 1.0E-05 kmole $X^-$ per kg of acid, and $\beta = \alpha/i$.

Applying charge conservation and equilibrium conditions,

\[
[H^+] + [Y^+] = [X^-] + [OH^-] \quad \text{(Eqn. 9)}
\]

\[
[H^+][OH^-] = K_W \quad \text{(Eqn. 10)}
\]

gives the following quadratic equation for free hydrogen ion concentration:

\[
[H^+]([H^+] + [Y^+] - [X^-]) = K_W \quad \text{(Eqn. 11)}
\]

\[
[H^+]^2 + ([Y^+] - [X^-])[H^+] - K_W = 0 \quad \text{(Eqn. 12)}
\]

\[
pH = -\log_{10}[H^+] \quad \text{(Eqn. 13)}
\]

where $K_W$ is the equilibrium constant (1.0 x 10E-14 kmoles$^2$ m$^{-6}$).

The quadratic equation can be solved for $[H^+]$ using the equation

\[
[H^+] = \frac{-b + \sqrt{b^2 - 4ac}}{2a} \quad \text{where} \ a = 1, \ b = [Y^+] - [X^-] \ \text{and} \ c = -K_W.
\]

You can create the expressions required to model the reaction sources and pH by either reading them in from a file or by defining them in the Expressions workspace. Note that the expressions used here do not refer to a particular fluid since there is only a single fluid. In a multiphase simulation you must prefix variables with a fluid name, for example $Mixture.\ acid.\ mfe$ instead of $\ acid.\ mfe$.

In this tutorial the expressions can be imported from a file to avoid typing them.

### Creating the Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.
2. Double click Default Domain and apply the following settings

---

**Tutorial 13: Reacting Flow in a Mixing Tube: Defining a Simulation in ANSYS CFX-Pre**

Page 231

Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.
3. Use the same **Option** and **Kinematic Diffusivity** settings for alkali and product as you have just set for acid.

4. For **Water**, set **Option** to **Constraint** as follows:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Models</td>
<td>Component Details</td>
<td>Water</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; Water &gt; Option</td>
<td>Constraint</td>
</tr>
</tbody>
</table>

One component must always use **Constraint**. This is the component used to balance the mass fraction equation; the sum of the mass fractions of all components of a fluid must equal unity.

5. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Models</td>
<td>Additional Variable Details &gt; MixturePH</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Additional Variable Details &gt; MixturePH &gt; Option</td>
<td>Algebraic Equation</td>
</tr>
<tr>
<td></td>
<td>Additional Variable Details &gt; MixturePH &gt; Value</td>
<td>pH</td>
</tr>
</tbody>
</table>

6. Click **OK**.

Creating a Subdomain to Model the Chemical Reactions

To provide the correct modeling for the chemical reaction you need to define sources for the fluid components acid, alkali, and product. To do this, you need to create a subdomain where the relevant sources can be specified. In this case, sources need to be provided within the entire domain of the mixing tube since the reaction occurs throughout the domain.

1. Create a new subdomain named **sources**.
2. Apply the following settings:
3. Click **OK**.

Creating the Boundary Conditions

**Water Inlet Boundary**

1. Create a new boundary condition named `InWater`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sources</td>
<td>Sources</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>acid.mf</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; acid.mf</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; acid.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; acid.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; acid.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; alkali.mf</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; alkali.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; alkali.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; alkali.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; Energy</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; Energy &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; product.mf</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; product.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; product.mf &gt; Source</td>
</tr>
<tr>
<td>Sources</td>
<td>Sources &gt; Equation Sources</td>
<td>Sources &gt; product.mf &gt; Source</td>
</tr>
</tbody>
</table>

3. Leave mass fractions for all components set to zero. Since **Water** is the constraint fluid, it will be automatically given a mass fraction of 1 on this inlet.

4. Click **OK**.

**Acid Inlet Boundary**

1. Create a new boundary condition named `InAcid`.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td>Basic Settings</td>
<td>Location</td>
<td>InWater</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>2 [m s^-1]</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Heat Transfer &gt; Option</td>
<td>Static Temperature</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>300 [K]</td>
</tr>
</tbody>
</table>
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>InAcid</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>2 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Static Temperature</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>Component Details</td>
<td>acid</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; acid &gt; Mass Fraction</td>
<td>1.0</td>
</tr>
<tr>
<td></td>
<td>Component Details</td>
<td>alkali</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; alkali &gt; Mass Fraction</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Component Details</td>
<td>product</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; product &gt; Mass Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click OK.

Alkali Inlet Boundary

The inlet area for the alkali is twice that of the acid and it also enters at a higher velocity. The result is an acid-to-alkali volume inflow ratio of 1:2.667. Recall that a stoichiometric ratio of 2.7905 was specified based on mass fractions. When the density of the acid (1080 [kg m⁻³]) and alkali (1130 [kg m⁻³]) are considered, the acid-to-alkali mass flow ratio can be calculated as 1:2.7905. You are therefore providing enough acid and alkali to produce a neutral solution if they react together completely.

1. Create a new boundary condition named InAlkali.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>InAlkali</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>2.667 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Static Temperature</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; acid</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; acid &gt; Mass Fraction</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; alkali</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; alkali &gt; Mass Fraction</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; product</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; product &gt; Mass Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click OK.

Outlet Boundary

1. Create a new boundary condition named out.
2. Apply the following settings
3. Click **OK**.

**Symmetry Boundary**

1. Create a new boundary condition named `sym1`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>sym1</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

3. Click **OK**.
4. Create a new boundary condition named `sym2`.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>sym2</td>
</tr>
</tbody>
</table>

6. Click **OK**.

The default adiabatic wall boundary condition will automatically be applied to the remaining unspecified boundary.

**Setting Initial Values**

The values for `acid`, `alkali` and `product` will be initialized to 0. Since `Water` is the constrained component, it will make up the remaining mass fraction which, in this case, is 1.

1. Click **Global Initialization**
2. Apply the following settings
3. Click **OK**.

### Setting Solver Control

1. Click **Solver Control**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>2 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation &gt; Option</td>
<td>Automatic</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details &gt; acid</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details &gt; acid &gt; Mass Fraction</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details &gt; alkali</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details &gt; alkali &gt; Mass Fraction</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details &gt; product</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details &gt; product &gt; Mass Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

### Tab | Setting | Value |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Advection Scheme &gt; Option</td>
<td>Specific Blend Factor</td>
</tr>
<tr>
<td></td>
<td>Advection Scheme &gt; Blend Factor</td>
<td>0.75</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Max. Iterations</td>
<td>50</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Timescale Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Physical Timescale</td>
<td>0.01 [s] *</td>
</tr>
</tbody>
</table>

* The length of mixing tube is 0.06 [m] and inlet velocity is 2 [m s^-1]. An estimate of the dynamic time scale is 0.03 [s]. An appropriate timestep would be 1/4 to 1/2 of this value.
Tutorial 13: Reacting Flow in a Mixing Tube: Obtaining a Solution using ANSYS CFX-Solver Manager

3. Click **OK**.

**Note:** At this point, you might see a physics validation message regarding a change in the advection scheme. This change will not affect the outcome of the simulation; you will still be able to run this simulation in the ANSYS CFX-Solver.

Writing the Solver (.def) File

1. Click **Write Solver File**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Reactor.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

When the ANSYS CFX-Solver Manager has started, obtain a solution to the CFD problem by following the instructions below.

Using the double precision ANSYS CFX-Solver executable is recommended for this case:

1. Ensure **Define Run** is displayed.
2. Select **Show Advanced Controls**. On the **Solver** tab, select **Double Precision** under **Executable Settings**.
3. Click **Start Run**.
   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
4. Click **Yes** to post-process the results.
5. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

Try the following:

- Create an XY plane through Z = 0 colored by MixturePH. The lower and upper bounds depend on the precision setting used in the ANSYS CFX-Solver should approximately range from 2 to 15 (single) or 2 to 11 (double).
Tutorial 13: Reacting Flow in a Mixing Tube: Viewing the Results in ANSYS CFX-Post

Figure 1 shows two planes colored by MixturePH, with the plane on the right having a more accurate solution throughout the domain.

Figure 1  Comparison of Single and Double Precision Results for pH Variance

- View the acid, alkali and product mass fractions on the same plane.
- Create isosurfaces of Turbulence Kinetic Energy and Turbulence Eddy Dissipation.
Tutorial 14: Conjugate Heat Transfer in a Heating Coil

Introduction

This tutorial includes:
- Tutorial 14 Features (p. 240)
- Overview of the Problem to Solve (p. 241)
- Defining a Simulation in ANSYS CFX-Pre (p. 241)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 246)
- Viewing the Results in ANSYS CFX-Post (p. 246)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 241).

Sample files referenced by this tutorial include:
- HeatingCoil.pre
- HeatingCoil_001.res
- HeatingCoilMesh.gtm
Tutorial 14 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Multiple Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Conjugate Heat Transfer</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Subdomains</td>
<td>Energy Source</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td>CEL (CFX Expression Language)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Cylinder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Default Locators</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Isosurface</td>
</tr>
<tr>
<td></td>
<td>Other</td>
<td>Changing the Color Range</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Expression Details View</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Lighting Adjustment</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Variable Details View</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Creating and using a solid domain as a heater coil in ANSYS CFX-Pre.
- Modeling conjugate heat transfer in ANSYS CFX-Pre.
- Specifying a subdomain to specify a heat source.
- Creating a cylinder locator using CEL in ANSYS CFX-Post.
- Examining the temperature distribution which is affected by heat transfer from the coil to the fluid.
Overview of the Problem to Solve

This example demonstrates the capability of ANSYS CFX in modeling conjugate heat transfer. In this example, part of the model of a simple heat exchanger is used to model the transfer of heat from a solid to a fluid. The model consists of a fluid domain and a solid domain. The fluid domain is an annular region through which water flows at a constant rate. The heater is a solid copper coil modeled as a constant heat source.

![Diagram of a heating coil model]

This tutorial also includes an optional step that demonstrates the use of the CFX to ANSYS Data Transfer Tool to export thermal and mechanical stress data for analysis in ANSYS. A results file is provided in case you wish to skip the model creation and solution steps within ANSYS CFX.

Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: HeatingCoil.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 246).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type HeatingCoil.
Tutorial 14: Conjugate Heat Transfer in a Heating Coil: Defining a Simulation in ANSYS CFX-Pre

6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh.
2. Apply the following settings
   
<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>HeatingCoilMesh.gtm</td>
</tr>
</tbody>
</table>

3. Click Open.
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up) from the shortcut menu.

Creating the Domains

This simulation requires both a fluid and a solid domain. First, you will create a fluid domain for the annular region of the heat exchanger.

Creating a Fluid Domain

The fluid domain will include the region of fluid flow but exclude the solid copper heater.

1. Click Domain [ ] and set the name to FluidZone.
2. Apply the following settings to FluidZone
   
<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>B1,P3*</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Fluids List</td>
<td>Water</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td>Initialization</td>
<td>Domain Initialization</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Domain Initialization &gt; Initial Conditions</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Domain Initialization &gt; Initial Conditions &gt; Turbulence</td>
<td>Eddy Dissipation</td>
</tr>
</tbody>
</table>

* This region name may be different depending on how the mesh was created. You should pick the region that forms the exterior surface of the volume surrounding the coil.

3. Click OK.

Creating a Solid Domain

Since you know that the copper heating element will be much hotter than the fluid, you can initialize the temperature to a reasonable value. The initialization option that is set when creating a domain applies only to that domain.

1. Create a new domain named SolidZone.
2. Apply the following settings
Creating a Subdomain to Specify a Thermal Energy Source

To allow a thermal energy source to be specified for the copper heating element, you need to create a subdomain.

1. Create a new subdomain named **Heater** in the domain **SolidZone**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>B2.P3</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Domain Type</td>
<td>Solid Domain</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Solids List</td>
<td>Copper</td>
</tr>
<tr>
<td>Solid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td>Initialization</td>
<td>Domain Initialization</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Domain Initialization &gt; Initial Conditions</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Domain Initialization &gt; Initial Conditions &gt; Temperature &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Domain Initialization &gt; Initial Conditions &gt; Temperature &gt; Temperature</td>
<td>550 [K]</td>
</tr>
</tbody>
</table>

3. Click **OK**.

Creating the Boundary Conditions

**Inlet Boundary** You will now create an inlet boundary condition for the cooling fluid (Water).

1. Create a new boundary condition named **inflow** in the domain **FluidZone**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>inflow</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>0.4 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>300 [K]</td>
</tr>
</tbody>
</table>

3. Click **OK**.
Opening boundary

The opening boundary condition type is used in this case because at some stage during the solution, the coiled heating element will cause some recirculation at the exit. At an opening boundary you need to set the temperature of fluid that enters through the boundary. In this case it is useful to base this temperature on the fluid temperature at the outlet, since you expect the fluid to be flowing mostly out through this opening.

1. Create a new expression named \textit{OutletTemperature}.
2. Set \textit{Definition} to \texttt{areaAve(T)@REGION:outflow}
3. Click \textit{Apply}.
4. Create a new boundary condition named \textit{outflow} in the domain \textit{FluidZone}.
5. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>outflow</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Opening Pres. and Dirn</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Static Temperature</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>\textit{OutletTemperature}</td>
</tr>
</tbody>
</table>

6. Click \textit{OK}.

The default adiabatic wall boundary condition will automatically be applied to the remaining unspecified external boundaries of the fluid domain. The default Fluid-Solid Interface boundary condition (flux conserved) will be applied to the surfaces between the solid domain and the fluid domain.

Creating the Domain Interface

If you have the \textit{Generate Default Domain Interfaces} option turned on (from \textit{Edit > Options > CFX-Pre}), then you will see that an interface called \textit{Default Fluid Solid Interface} already exists, and is listed in the \textit{Outline} tree view. If this is the case, you can optionally skip the following instructions for creating a domain interface (since the domain interface set here will have the same settings as, and will automatically replace, the default domain interface).

If you have the \textit{Generate Default Domain Interfaces} option turned off, then there is no domain interface defined at this point. In this case, create a domain interface using \textit{either one} of the following methods (the result is the same):

1. Right click \textit{Simulation} in the \textit{Outline} tree view and ensure that \textit{Automatic Default Interfaces} is selected. An interface named \textit{Default Fluid Solid Interface} should now appear under the \textit{Simulation} branch.

Creating a Default Domain Interface Manually

1. Double click \textit{Default Fluid Solid Interface} and apply the following settings:
Click **OK**.

### Setting Solver Control

1. Click **Solver Control**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Fluid Timescale Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Physical Timescale Control</td>
<td>2 [s]</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Physical Timescale Control</td>
<td>2 [s]</td>
</tr>
</tbody>
</table>

For the **Convergence Criteria**, an RMS value of at least 1e-05 is usually required for adequate convergence, but the default value is sufficient for demonstration purposes.

3. Click **OK**.

### Writing the Solver (.def) File

1. Click **Write Solver File**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>HeatingCoil.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

## Obtaining a Solution using ANSYS CFX-Solver Manager

While the calculations proceed, you can see residual output for various equations in both the text area and the plot area. Use the tabs to switch between different plots (e.g., Heat Transfer, Turbulence Quantities, etc.) in the plot area. You can view residual plots for the fluid and solid domains separately by editing the Workspace Properties.

1. Ensure Define Run is displayed.
2. Click Start Run.
   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
3. Click Yes to post-process the results.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

## Viewing the Results in ANSYS CFX-Post

The following topics will be discussed:

- Creating a Cylindrical Locator (p. 246)
- Specular Lighting (p. 247)
- Moving the Light Source (p. 247)

### Creating a Cylindrical Locator

Next, you will create a cylindrical locator close to the outside wall of the annular domain. This can be done by using an expression to specify radius and locating a particular radius with an isosurface.

**Expression**

1. Create a new expression named expradius.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>((x^2 + y^2)^{0.5})</td>
</tr>
</tbody>
</table>

3. Click Apply.

**Variable**

1. Create a new variable named radius.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expression</td>
<td>expradius</td>
</tr>
</tbody>
</table>

---

*ANSYS CFX Tutorials. ANSYS CFX Release 11.0. © 1996-2006 ANSYS Europe, Ltd. All rights reserved. Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.*
3. Click **Apply**.

**Isosurface of the variable**

1. Create a new isosurface named **Isosurface 1**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>radius</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Value</td>
<td>0.8 [m]*</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Temperature</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>302 [K]</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* The maximum radius is 1 m, so a cylinder locator at a radius of 0.8 m is suitable.

3. Click **Apply**.

**Specular Lighting**

Specular lighting is on by default. Specular lighting allows glaring bright spots on the surface of an object, depending on the orientation of the surface and the position of the light.

1. Apply the following settings to **Isosurface 1**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces &gt; Specular</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

2. Click **Apply**.

**Moving the Light Source**

To move the light source, click within the 3-D Viewer, then press and hold <Shift> while pressing the arrow keys left, right, up or down.

*Tip:* If using the Standalone version, you can move the light source by positioning the mouse pointer in the viewer, holding down the <Ctrl> key, and dragging using the right mouse button.

**Exporting the Results to ANSYS**

This optional step involves generating an ANSYS .cfx data file from the results generated in ANSYS CFX-Solver. The .cfx file could then be used with the ANSYS Multi-field solver to measure the combined effects of thermal and mechanical stresses on the solid heating coil.

There are two possible ways to export data to ANSYS:
Tutorial 14: Conjugate Heat Transfer in a Heating Coil: Exporting the Results to ANSYS

- Use ANSYS CFX-Solver Manager to export data. For details, see Exporting Data from ANSYS CFX-Solver Manager (p. 248).
- Use ANSYS CFX-Post to export data. This involves:
  a. Importing a surface mesh from ANSYS into ANSYS CFX-Post, and associating the surface with the corresponding 2D region in the ANSYS CFX-Solver results file.
  b. Exporting the data to a file containing SFE commands that represent surface element thermal or mechanical stress values.
  c. Loading the commands created in the previous step into ANSYS and visualizing the loads.

Exporting Data from ANSYS CFX-Solver Manager

Since the heat transfer in the solid domain was calculated in ANSYS CFX, the 3D thermal data will be exported to ANSYS Element Type as 3D Thermal (70) data. The mechanical stresses are calculated on the liquid side of the liquid-solid interface. These values will be exported to ANSYS Element Type as 2D Stress (154) data.

**Thermal Data**

1. Start ANSYS CFX-Solver Manager.
2. Select Tools > Export to ANSYS MultiField. Export to ANSYS MultiField Solver dialog box appears.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Results File</td>
<td>HeatingCoil_001.res</td>
</tr>
<tr>
<td>Export File</td>
<td>HeatingCoil_001_ansysfsi_70.csv</td>
</tr>
<tr>
<td>Domain Name &gt; Domain</td>
<td>SolidZone</td>
</tr>
<tr>
<td>Domain Name &gt; Boundary*</td>
<td>*</td>
</tr>
<tr>
<td>Export Options &gt; ANSYS Element Type</td>
<td>3D Thermal (70)</td>
</tr>
</tbody>
</table>

* Leave Boundary empty.

4. Click Export. When the export is complete, click OK to acknowledge the message and continue with the next steps to export data for Mechanical Stresses.

**Mechanical Stresses**

1. Apply the following settings in the Export to ANSYS MultiField Solver dialog box (see Step 2 above):

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Results File</td>
<td>HeatingCoil_001.res</td>
</tr>
<tr>
<td>Export File</td>
<td>HeatingCoil_001_ansysfsi_154.csv</td>
</tr>
<tr>
<td>Domain Name &gt; Domain</td>
<td>FluidZone</td>
</tr>
<tr>
<td>Domain Name &gt; Boundary</td>
<td>FluidZone Default</td>
</tr>
<tr>
<td>Export Options &gt; ANSYS Element Type</td>
<td>2D Stress (154)</td>
</tr>
</tbody>
</table>

2. Click Export.
You now have two exported files that can be loaded into ANSYS Multiphysics. When you are finished, close ANSYS CFX-Solver Manager and ANSYS CFX-Post.
Tutorial 15: Multiphase Flow in Mixing Vessel

Introduction

This tutorial includes:

- Tutorial 15 Features (p. 252)
- Overview of the Problem to Solve (p. 253)
- Defining a Simulation in ANSYS CFX-Pre (p. 253)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 265)
- Viewing the Results in ANSYS CFX-Post (p. 265)

If this is the first tutorial you are working with it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 253).

Sample files referenced by this tutorial include:

- MixerImpellerMesh.gtm
- MixerTank.geo
- MultiphaseMixer.pre
Tutorial 15 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Multiple Domain</td>
</tr>
<tr>
<td></td>
<td>Rotating Frame of Reference</td>
<td></td>
</tr>
<tr>
<td>Turbulence Model</td>
<td>Dispersed Phase Zero Equation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Fluid-Dependant Turbulence Model</td>
<td></td>
</tr>
<tr>
<td></td>
<td>k-Epsilon</td>
<td></td>
</tr>
<tr>
<td>Heat Transfer</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td>Buoyant Flow</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multiphase</td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Degassing)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Thin Surface</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: (Slip Depends on Volume Fraction)</td>
</tr>
<tr>
<td>Domain Interfaces</td>
<td>Frozen Rotor</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Periodic</td>
<td></td>
</tr>
<tr>
<td>Output Control</td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Default Locators</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Isosurface</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td>Other</td>
<td>Quantitative Calculation</td>
<td></td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Importing meshes that have CFX-4 and ANSYS CFX .def/.res file formats.
- Setting up a simulation using multiple frames of reference.
- Connecting two domains (one for the impeller and one for the tank) via Frozen Rotor interfaces.
- Modeling rotational periodicity using periodic boundary conditions.
- Using periodic GGI interfaces where the mesh does not map exactly.
- Using thin surfaces for the blade and baffle surfaces.
- Setting up a multiphase flow problem.
Overview of the Problem to Solve

This example simulates the mixing of two fluids in a mixing vessel. The geometry consists of a mixing tank vessel containing four baffles. A rotating impeller blade is connected to a shaft which runs vertically through the vessel. Air is injected into the vessel through an inlet pipe located below the impeller blade at a speed of 5 m/s.

Figure 1 Cut-away diagram of Mixing Vessel

The figure above shows the full geometry, with part of the tank walls and one baffle cut away. The symmetry of the vessel allows a 1/4 section of the full geometry to be modeled.

Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: MultiphaseMixer.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 265).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select **File > New Simulation**.
3. Select **General** and click **OK**.
4. Select **File > Save Simulation As**.
5. Under **File name**, type **MultiphaseMixer**.
6. Click **Save**.

### Importing the Meshes

In this tutorial, a CFX-4 mesh is imported using advanced options. These options control how the CFX-4 mesh is imported into ANSYS CFX.

By creating 3D regions on fluid regions, you prevent import of **USER3D** and **POROUS** regions. Turn off this option if you do not need these regions for sub-domains. This will simplify the regions available in ANSYS CFX-Pre. In this case, the mesh file contains **USER3D** regions that were created as a location for a thin surface and you do not need them for defining any subdomains.

#### Importing the Mixer Tank Mesh

1. Right-click **Mesh** and select **Import Mesh**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>CFX-4 (*geo)</td>
</tr>
<tr>
<td>File name</td>
<td>MixerTank.geo</td>
</tr>
<tr>
<td>Advanced Options &gt; Create 3D Regions on &gt; Fluid Regions (USER3D, POROUS)</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

3. Click **Open**.

#### Importing the Impeller Mesh

1. Right-click **Mesh** and select **Import Mesh** to import the second mesh.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File type</td>
<td>CFX Mesh (*gtm)</td>
</tr>
<tr>
<td>File name</td>
<td>MixerImpellerMesh.gtm</td>
</tr>
</tbody>
</table>

3. Click **Open**.

4. Right-click a blank area in the viewer and select **Predefined Camera > Isometric View (X up)** to view the mesh assemblies.

#### Transforming the Impeller Mesh

In the next step you will move the impeller mesh to its correct position.

1. Right-click **MixerImpellerMesh.gtm** and select **Transform Mesh**. The **Mesh Transformation Editor** dialog box appears.
2. Apply the following settings
### Viewing the Mesh at the Tank Periodic Boundary

1. Click **Label and Marker Visibility**.
2. Apply the following setting:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label Options</td>
<td>Show Labels</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

3. Click **OK**.

4. In the **Outline** workspace, expand **MixerImpellerMesh.gtm** and **MixerTank.geo** to view associated 2D primitives.

5. Under **MixerTank.geo > Principal 3D regions > Primitive 3D**, click the **primitive region** **BLKBDY_TANK_PER2**.

You can now see the mesh on one of the periodic regions of the tank. To reduce the solution time for this tutorial, the mesh used is very coarse. This is not a suitable mesh to obtain accurate results, but it is sufficient for demonstration purposes.

**Note:** If you do not see the surface mesh, highlighting may be turned off. If highlighting is disabled, toggle **Highlight**. The default highlight type will show the surface mesh for any selected regions. If you see a different highlighting type, you can alter it by selecting **Edit > Options** and browsing to **CFX-Pre > Viewer**.

### Creating the Domains

#### Rotating Domain for the Impeller

1. Click **Domain** and set the name to **impeller**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>Transformation</td>
<td>Translation</td>
</tr>
<tr>
<td></td>
<td>Apply Translation &gt; Method</td>
<td>Deltas</td>
</tr>
<tr>
<td></td>
<td>Apply Translation &gt; Dx, Dy, Dz</td>
<td>0.275, 0, 0</td>
</tr>
</tbody>
</table>

3. Click **OK**.
<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>Main</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Fluids List</td>
<td>Air at 25 C, Water</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Option</td>
<td>Buoyant</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity X Dirn.</td>
<td>-9.81 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Y Dirn.</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Z Dirn.</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Buoy. Ref. Density†</td>
<td>997 [kg m^-3]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Domain Motion &gt; Option</td>
<td>Rotating</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Domain Motion &gt; Angular Velocity</td>
<td>84 [rev min^-1]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Domain Motion &gt; Axis Definition &gt; Rotation Axis</td>
<td>Global X</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Multiphase Options &gt; Homogeneous Model</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Multiphase Options &gt; Allow Musig Fluids</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Multiphase Options &gt; Free Surface Model &gt; Option</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Homogeneous Model</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fluid Temperature</td>
<td>25 [°C]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Homogeneous Model</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Fluid Dependent</td>
</tr>
<tr>
<td>Fluid Details</td>
<td>Fluid Details</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Fluid Details &gt; Air at 25 C &gt; Morphology &gt; Option</td>
<td>Dispersed Fluid</td>
</tr>
<tr>
<td></td>
<td>Fluid Details &gt; Air at 25 C &gt; Morphology &gt; Mean Diameter</td>
<td>3 [mm]</td>
</tr>
<tr>
<td>Fluid Pairs</td>
<td>Fluid Pairs</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Surface Tension Coefficient</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Surface Tension Coefficient &gt; Surf. Tension Coeff.</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Momentum Transfer &gt; Drag Force &gt; Option</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Momentum Transfer &gt; Drag Force &gt; Volume Fraction Correction Exponent</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Momentum Transfer &gt; Drag Force &gt; Volume Fraction Correction Exponent &gt; Value</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Momentum Transfer &gt; Non-drag forces &gt; Turbulent Dispersion Force &gt; Option</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Momentum Transfer &gt; Non-drag forces &gt; Turbulent Dispersion Force &gt; Dispersion Coeff.</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Air at 25 C</td>
<td>Water &gt; Turbulence Transfer &gt; Option</td>
</tr>
</tbody>
</table>
3. Click OK.

**Stationary Domain for the Main Tank**

Next, you will create a stationary domain for the main tank by copying the properties of the existing fluid domain.

1. Right-click *impeller* and select *Duplicate* from the shortcut menu.
2. Set the name of this domain to *tank* and open it for editing.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>Primitive 3D</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Domain Motion &gt;</td>
<td>Stationary</td>
</tr>
<tr>
<td></td>
<td>Option</td>
<td></td>
</tr>
</tbody>
</table>

4. Click OK.

**Creating the Boundary Conditions**

The following boundary conditions that define the problem will be set:

- An inlet through which air enters the mixer.
- A degassing outlet, so that only the gas phase can leave the domain.
- Thin surfaces for the baffle and impeller blade.
- A wall for the hub and shaft in the rotating domain. This will be stationary relative to the rotating domain.
- A wall for the shaft in the stationary domain. This will be rotating relative to the stationary domain.
- Periodic domain interfaces for the periodic faces of the tank and impeller.

Periodic domain interfaces can either be one-to-one or GGI interfaces. One-to-one transformations occur for topologically similar meshes whose nodes match within a given tolerance. One-to-one periodic interfaces are more accurate and reduce CPU and memory requirements.

When the default wall boundary condition is generated, the internal 2D regions of an imported mesh are ignored, while the regions that form domain boundaries are included.

**Air Inlet Boundary**

1. Create a new boundary condition in the domain *tank* named *Airin*.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>INLET_DIPTUBE</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Fluid Dependent</td>
</tr>
</tbody>
</table>
### Tutorial 15: Multiphase Flow in Mixing Vessel: Defining a Simulation in ANSYS CFX-Pre

**Degassing Outlet Boundary**

1. Create a new boundary condition in the domain tank named **LiquidSurface**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt; Velocity &gt; Normal Speed</td>
<td>5 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt; Volume Fraction &gt; Volume Fraction</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Water</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Water &gt; Velocity &gt; Normal Speed</td>
<td>5 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Water &gt; Volume Fraction &gt; Volume Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Thin Surface for the Baffle**

In ANSYS CFX-Pre, thin surfaces can be created by specifying wall boundary conditions on both sides of internal 2D regions. Both sides of the baffle regions will be specified as walls in this case.

1. Create a new boundary condition in the domain tank named **Baffle**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>WALL_LIQUID_SURFACE</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Degassing Condition</td>
</tr>
</tbody>
</table>

3. Click **OK**.

---

*The **WALL_BAFFLES** region includes the surfaces on both sides of the baffle (you can confirm this by examining **WALL_BAFFLES** in the region selector). Therefore, you do not need to use the **Create Thin Surface Partner** option.

†. The **Free Slip** condition can be used for the gas phase since the contact area with the walls is near zero for low gas phase volume fractions.
### Wall Boundary Condition for the Shaft

The next stage involves setting up a boundary condition for the shaft, which exists in the tank (stationary domain). These regions are connected to the shaft in the impeller domain. Since the tank domain is not rotating, you need to specify a moving wall to account for the rotation of the shaft.

Part of the shaft is located directly above the air inlet, so the volume fraction of air in this location will be high and the assumption of zero contact area for the gas phase is not physically correct. In this case, a no slip boundary condition is more appropriate than a free slip condition for the air phase. When the volume fraction of air in contact with a wall is low, a free slip condition is more appropriate for the air phase.

In cases where it is important to correctly model the dispersed phase slip properties at walls for all volume fractions, you can declare both fluids as no slip, but set up an expression for the dispersed phase wall area fraction. The expression should result in an area fraction of zero for dispersed phase volume fractions from 0 to 0.3, for example, and then linearly increase to an area fraction of 1 as the volume fraction increases to 1.

1. Create a new boundary condition in the domain *tank* named *TankShaft*.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>WALL_SHAFT, WALL_SHAFT_CENTER</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence On Flow &gt; Option</td>
<td>Fluid Dependent</td>
</tr>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt;</td>
<td>No Slip</td>
</tr>
<tr>
<td></td>
<td>Wall Influence on Flow &gt; Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt;</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Wall Influence on Flow &gt; Wall Velocity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt;</td>
<td>Rotating Wall</td>
</tr>
<tr>
<td></td>
<td>Wall Influence on Flow &gt; Wall Velocity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt;</td>
<td>84 [rev min-1]*</td>
</tr>
<tr>
<td></td>
<td>Wall Influence on Flow &gt; Wall Velocity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt;</td>
<td>Global X</td>
</tr>
<tr>
<td></td>
<td>Wall Influence on Flow &gt; Wall Velocity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall Influence on Flow &gt; Wall Velocity</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Axis Definition &gt; Rotation Axis</td>
<td></td>
</tr>
</tbody>
</table>

* Note the unit.

3. Select *Water* and set the same values as for *Air at 25 C*.
4. Click OK.

### Required Boundary Conditions in the Impeller Domain

1. Create a new boundary condition in the domain *impeller* named *Blade*.
2. Apply the following settings.
3. Click OK.
You will see in the tree view that a boundary named Blade Other Side has automatically been created.

4. Create a new boundary condition in the domain impeller named HubShaft.

5. Apply the following settings

6. Click OK.

Modifying the Default Wall Boundary Condition

1. On the tree view, open tank Default for editing.
2. Apply the following settings
3. Click **OK**.

   It is not necessary to set the default boundary in the impeller domain since the remaining surfaces will be assigned interface conditions in the next section.

### Creating the Domain Interfaces

**Impeller Domain**

1. Create a new domain interface named **ImpellerPeriodic**.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Type</td>
<td>Fluid Fluid</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Domain (Filter)</td>
<td>impeller</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Region List</td>
<td>Periodic1</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Domain (Filter)</td>
<td>impeller</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Region List</td>
<td>Periodic2</td>
</tr>
<tr>
<td>Interface Models</td>
<td>Option</td>
<td>Rotational Periodicity</td>
</tr>
<tr>
<td></td>
<td>&gt; Axis Definition &gt; Rotation Axis</td>
<td>Global X</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Tank Domain**

1. Create a new domain interface named **TankPeriodic**.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Type</td>
<td>Fluid Fluid</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Domain (Filter)</td>
<td>tank</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Region List</td>
<td>BLKBDY_TANK_PER1</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Domain (Filter)</td>
<td>tank</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Region List</td>
<td>BLKBDY_TANK_PER2</td>
</tr>
<tr>
<td>Interface Models</td>
<td>Option</td>
<td>Rotational Periodicity</td>
</tr>
<tr>
<td></td>
<td>&gt; Axis Definition &gt; Rotation Axis</td>
<td>Global X</td>
</tr>
</tbody>
</table>

3. Click **OK**.
Next, you will create three Frozen Rotor interfaces for the regions connecting the two domains. In this case three separate interfaces are created. You should not try to create a single domain interface for multiple surfaces that lie in different planes.

1. Create a new domain interface named **Top**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Type</td>
<td>Fluid</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Domain (Filter)</td>
<td>impeller</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Region List</td>
<td>Top</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Domain (Filter)</td>
<td>tank</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Region List</td>
<td>BLKBDY_TANK_TOP</td>
</tr>
<tr>
<td></td>
<td>Interface Models &gt; Frame Change/Mixing</td>
<td>Frozen Rotor</td>
</tr>
<tr>
<td></td>
<td>Model &gt; Option</td>
<td></td>
</tr>
</tbody>
</table>

3. Click **OK**.

4. Create a new domain interface named **Bottom**.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Type</td>
<td>Fluid</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Domain (Filter)</td>
<td>impeller</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Region List</td>
<td>Bottom</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Domain (Filter)</td>
<td>tank</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Region List</td>
<td>BLKBDY_TANK_BOT</td>
</tr>
<tr>
<td></td>
<td>Interface Models &gt; Frame Change/Mixing</td>
<td>Frozen Rotor</td>
</tr>
<tr>
<td></td>
<td>Model &gt; Option</td>
<td></td>
</tr>
</tbody>
</table>

6. Click **OK**.

7. Create a new domain interface named **Outer**.
8. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Interface Type</td>
<td>Fluid</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Domain (Filter)</td>
<td>impeller</td>
</tr>
<tr>
<td></td>
<td>Interface Side 1 &gt; Region List</td>
<td>Outer</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Domain (Filter)</td>
<td>tank</td>
</tr>
<tr>
<td></td>
<td>Interface Side 2 &gt; Region List</td>
<td>BLKBDY_TANK_OUTER</td>
</tr>
<tr>
<td></td>
<td>Interface Models &gt; Frame Change/Mixing</td>
<td>Frozen Rotor</td>
</tr>
<tr>
<td></td>
<td>Model &gt; Option</td>
<td></td>
</tr>
</tbody>
</table>

9. Click **OK**.
Setting Initial Values

The initialization for volume fraction is 0 for air and automatic for water. Therefore, the initial volume fraction for water will be set to 1 so that the sum of the two fluid volume fractions is 1.

It is important to understand how the velocity is initialized in this tutorial. Here, both fluids use Automatic for the Cartesian Velocity Components. When the Automatic option is used, the initial velocity field will be based on the velocity values set at inlets, openings, and outlets. In this tutorial, the only boundary that has a set velocity value is the inlet, which specifies a velocity of 5 [m s\(^{-1}\)] for both phases. Without setting the Velocity Scale parameter, the resulting initial guess would be a uniform velocity of 5 [m s\(^{-1}\)] in the X-direction throughout the domains for both phases. This is clearly not suitable since the water phase is enclosed by the tank. When the boundary velocity conditions are not representative of the expected domain velocities, the Velocity Scale parameter should be used to set a representative domain velocity. In this case the velocity scale for water is set to zero, causing the initial velocity for the water to be zero. The velocity scale is not set for air, resulting in an initial velocity of 5 [m s\(^{-1}\)] in the X-direction for the air. This should not be a problem since the initial volume fraction of the air is zero everywhere.

1. Click Global Initialization.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Settings</td>
<td>Fluid Specific Initialization</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td>Fluid Specific Initialization</td>
<td>Air at 25 C</td>
<td>Initial Conditions</td>
</tr>
<tr>
<td>Fluid Specific Initialization</td>
<td>Air at 25 C</td>
<td>Initial Conditions</td>
</tr>
<tr>
<td>Fluid Specific Initialization</td>
<td>Water</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization</td>
<td>Water</td>
<td>Initial Conditions</td>
</tr>
<tr>
<td>Fluid Specific Initialization</td>
<td>Water</td>
<td>Initial Conditions</td>
</tr>
<tr>
<td>Fluid Specific Initialization</td>
<td>Water</td>
<td>Initial Conditions</td>
</tr>
</tbody>
</table>

3. Click OK.

Setting Solver Control

Generally, two different time scales exist for multiphase mixers. The first is a small time scale based on the rotational speed of the impeller, typically taken as \(1 / \omega\), resulting in a time scale of 0.11 s for this case. The second time scale is usually larger and based on the recirculation time of the continuous phase in the mixer.
Using a timestep based on the rotational speed of the impeller will be more robust, but convergence will be slow since it takes time for the flow field in the mixer to develop. Using a larger timestep reduces the number of iterations required for the mixer flow field to develop, but reduces robustness. You will need to experiment to find an optimum timestep.

**Note:** You may find it useful to monitor the value of an expression during the solver run so that you can view the volume fraction of air in the tank (the gas hold up). The gas hold up is often used to judge convergence in these types of simulations by converging until a steady-state value is achieved. You could create the following expressions:

\[
\text{TankAirHoldUp} = \text{volumeAve(Air at 25 C.vf)}@\text{tank} \\
\text{ImpellerAirHoldUp} = \text{volumeAve(Air at 25 C.vf)}@\text{impeller} \\
\text{TotalAirHoldUp} = (\text{volume()}@\text{tank} \times \text{TankAirHoldUp} + \text{volume()}@\text{impeller} \times \text{ImpellerAirHoldUp}) / (\text{volume()}@\text{tank} + \text{volume()}@\text{impeller})
\]

and then monitor the value of **TotalAirHoldUp**.

1. Click **Solver Control**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Timescale Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Physical Timescale</td>
<td>2 [s]</td>
</tr>
</tbody>
</table>

* This is an aggressive timestep for this case.

3. Click **OK**.

### Setting Output Control

In the next step, you will choose to write additional data to the results file which allows force and torque calculations to be performed in post-processing.

1. Click **Output Control**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Results</td>
<td>Output Boundary Flows</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Output Boundary Flows &gt; Boundary Flows</td>
<td>All</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Writing the Solver (.def) File

Since this tutorial uses domain interfaces and you choose to summarize the interface data, an information window is displayed that informs you of the connection type used for each domain interface.

1. Click **Write Solver File**.
2. Apply the following settings:
3. Ensure **Start Solver Manager** is selected and click **Save**. If you are notified the file already exists, click **Overwrite**. A message about interface connections appears.

4. Click **OK**.

5. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

### Obtaining a Solution using ANSYS CFX-Solver Manager

The ANSYS CFX-Solver Manager will be launched after ANSYS CFX-Pre has closed down. You will be able to obtain a solution to the CFD problem by following the instructions below.

1. Ensure **Define Run** is displayed.

2. Click **Start Run**.

   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system.

   After a run has finished, examine some of the information printed at the end of the OUT file.

   A common quantity of interest is the mass balance; this compares the amount of fluid leaving the domain to the amount entering.

   - You usually want the **Global Imbalance, in %**: to be less than 0.1 % in a converged solution.

   - For a single phase calculation, the mass balance is the **P-Mass** equation.

   - For a multiphase calculation, examine the information given for the **P-Vol** equation.

   - This is not the volumetric flow balance information, but is the summation of the phasic continuity mass balance information.

3. Click **Yes** to post-process the results when the completion message appears at the end of the run.

4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

### Viewing the Results in ANSYS CFX-Post

When ANSYS CFX-Post has started you will be able to see the mixer geometry in the Viewer. You will create some plots showing how effective mixing has occurred. You will also calculate the torque and power required by the impeller.
Visualizing the Mixing Process

Creating a plane
1. Create a new plane named Plane 1.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>Three Points</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Point 1</td>
<td>1, 0, 0</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Point 2</td>
<td>0, 1, -0.9</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Point 3</td>
<td>0, 0, 0</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Air at 25 C.Volume Fraction</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>0.04</td>
</tr>
</tbody>
</table>

3. Click Apply.
4. Observe the plane, then apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Variable</td>
<td>Air at 25 C.Shear Strain Rate</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>0 [s^-1]</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>15 [s^-1]</td>
</tr>
</tbody>
</table>

5. Click Apply.
Areas of high shear strain rate or shear stress are typically also areas where the highest mixing occurs.
6. Observe the plane, then apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Variable</td>
<td>Pressure</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>Local</td>
</tr>
</tbody>
</table>

7. Click Apply.
Note that the hydrostatic contribution to pressure is excluded due to the use of an appropriate buoyancy reference density. If you plot the variable called Absolute Pressure, you will see the true pressure including the hydrostatic contribution.

Creating a vector
1. Create a new vector named Vector 1.
2. Apply the following settings:
3. Observe the vector plot, then change the variable to Air at 25 C.Velocity in Stn Frame. Observe this as well, then clear the visibility of Vector 1.

4. Modify the tank Default object.

5. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>Plane 1</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Water.Velocity in Stn Frame*</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.2</td>
</tr>
<tr>
<td></td>
<td>Normalize Symbols</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* Using this variable, instead of Water.Velocity, results in the velocity vectors appearing to be continuous at the interface between the rotating and stationary domains. Velocity variables that do not include a frame specification always use the local reference frame.

3. Observe the vector plot, then change the variable to Air at 25 C.Velocity in Stn Frame. Observe this as well, then clear the visibility of Vector 1.

4. Modify the tank Default object.

5. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Water.Wall Shear</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>Local</td>
</tr>
</tbody>
</table>

The legend for this plot shows the range of wall shear values. The global maximum wall shear is much higher than the maximum value on the default walls. The global maximum values occur on the TankShaft boundary directly above the inlet. Although these values are very high, the shear force exerted on this boundary will be small since the contact area fraction of water here is very small.

Calculating Power and Torque Required by Impeller

1. Select Tools > Function Calculator from the main menu or click Show Function Calculator from the main toolbar.

2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td>Function</td>
<td>torque</td>
</tr>
<tr>
<td>Calculator</td>
<td>Location</td>
<td>Blade</td>
</tr>
<tr>
<td></td>
<td>Axis</td>
<td>Global X</td>
</tr>
<tr>
<td></td>
<td>Fluid</td>
<td>All Fluids</td>
</tr>
</tbody>
</table>

3. Click Calculate to find the torque required to rotate Blade about the X-axis.

4. Repeat the calculation setting Location to Blade Other Side.

The sum of these two results is the torque required by the single impeller blade, approximately 70 [N m]. This must be multiplied by the number of blades in the full geometry to obtain the total torque required by the impeller; the result is a value of approximately 282 [N m]. You could also include the results from the locations HubShaft and TankShaft; however in this case their contributions are negligible.
The power requirement is simply the required torque multiplied by the rotational speed (8.8 rad/s): Power = 282*8.8 = 2482 [W].

Remember that this value is the power requirement for the work done on the fluid only, it does not account for any mechanical losses, efficiencies etc. Also note that the accuracy of these results is significantly affected by the coarseness of the mesh. You should not use a mesh of this length scale to obtain accurate quantitative results.
Tutorial 16: Gas-Liquid Flow in an Airlift Reactor

Introduction

This tutorial includes:

- Tutorial 16 Features (p. 270)
- Overview of the Problem to Solve (p. 270)
- Defining a Simulation in ANSYS CFX-Pre (p. 271)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 277)
- Viewing the Results in ANSYS CFX-Post (p. 278)
- Additional Fine Mesh Simulation Results (p. 280)

If this is the first tutorial you are working with it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 271). Sample files referenced by this tutorial include:

- BubbleColumn.pre
- BubbleColumnMesh.gtm
Tutorial 16 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>Dispersed Phase Zero Equation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fluid-Dependent Turbulence Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Buoyant Flow</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Multiphase</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Degassing)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Symmetry Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Thin Surface</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: (Slip Depends on Volume Fraction)</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Default Locators</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Vector</td>
</tr>
<tr>
<td></td>
<td>Other</td>
<td>Changing the Color Range</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Symmetry</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:
- Setting up a multiphase flow involving air and water
- Using a fluid dependent turbulence model to set different turbulence options for each fluid.
- Specifying buoyant flow.
- Specifying a degassing outlet boundary condition to allow air, but not water, to escape from the boundary.

Overview of the Problem to Solve

This tutorial demonstrates the Eulerian–Eulerian multiphase model in ANSYS CFX. The tutorial simulates a bubble column with an internal tube (draft tube) used to direct recirculation of the flow. This configuration is known as an airlift reactor. Bubble columns are tall gas-liquid contacting vessels and are often used in processes where gas absorption is important (e.g., bioreactors to dissolve oxygen in broths) and to limit the exposure of micro-organisms to excessive shear, imparted by mechanically driven mixers.
This example models the dispersion of air bubbles in water. The gas is supplied through a sparger at the bottom of the vessel and the rising action of the bubbles provides gentle agitation of the liquid.

Simple bubble columns that are without the draft tube tend to develop irregular flow patterns and poor overall mixing. The draft tube in the airlift reactor helps establish a regular flow pattern in the column and achieve better uniformity of temperature, concentration and pH in the liquid phase, but sometimes at the expense of decreased mass transfer from the gas to the liquid.

This tutorial also demonstrates the use of thin surfaces. Thin surfaces are internal two dimensional wall boundaries used to model thin three dimensional features (e.g., baffles, guide vanes within ducts, etc.).

The airlift reactor that is modeled here is very similar to the laboratory bench scale prototype used by García-Calvo and Letón.

If you are interested, a formal analysis of this simulation involving a finer mesh is available at the end of this tutorial. For details, see Additional Fine Mesh Simulation Results (p. 280).

## Defining a Simulation in ANSYS CFX-Pre

The following sections describe the simulation setup in ANSYS CFX-Pre.

### Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select **Session > Play Tutorial** from the menu in ANSYS CFX-Pre, then run the session file: **BubbleColumn.pre**. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 277).

### Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select **File > New Simulation**.
3. Select **General** and click **OK**.
4. Select **File > Save Simulation As**.
5. Under **File name**, type **BubbleColumn**.
6. Click **Save**.

### Importing the Mesh

1. Right-click **Mesh** and select **Import Mesh**.
2. Apply the following settings
Creating the Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.

2. Double click Default Domain and apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>B1.P3, B2.P3</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Fluids List</td>
<td>Air at 25 C, Water</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Option</td>
<td>Buoyant</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity X Dirn.</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Y Dirn.</td>
<td>-9.81 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Z Dirn.</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Buoy. Ref. Density*</td>
<td>997 [kg m^-3]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Multiphase Options &gt; Homogeneous Model</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Multiphase Options &gt; Allow Musig Fluids</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td>Free Surface Model &gt; Option</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fluid Temperature</td>
<td>25 C</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Fluid Dependent</td>
</tr>
<tr>
<td>Fluid Details</td>
<td>Fluid Details</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Fluid Details &gt; Air at 25 C &gt; Morphology &gt; Option</td>
<td>Dispersed Fluid</td>
</tr>
<tr>
<td></td>
<td>Fluid Details &gt; Air at 25 C &gt; Morphology &gt; Mean Diameter</td>
<td>6 [mm]</td>
</tr>
</tbody>
</table>
Creating the Boundary Conditions

For this simulation of the airlift reactor, the boundary conditions required are:

- An inlet for air on the sparger.
- A degassing outlet for air at the liquid surface.
- A thin surface wall for the draft tube.
- An exterior wall for the outer wall, base and sparger tube.
- Symmetry planes for the cross sections.

**Inlet Boundary**

There are an infinite number of inlet velocity/volume fraction combinations that will produce the same mass inflow of air. The combination chosen gives an air inlet velocity close to the terminal rise velocity. Since the water inlet velocity is zero, you can adjust its volume fraction until the required mass flow rate of air is obtained for a given air inlet velocity.

1. Create a new boundary condition named **Sparger**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Sparger</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass And Momentum &gt; Option</td>
<td>Fluid Dependent</td>
</tr>
</tbody>
</table>
3. Click **OK**.

### Outlet Boundary

The top of the reactor will be a degassing boundary, which is classified as an outlet boundary.

1. Create a new boundary condition named **Top**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Top</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Degassing Condition</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Thin Surface Draft Tube Boundary

Thin surfaces are created by specifying a wall boundary condition on both sides of an internal region. If only one side has a boundary condition then the ANSYS CFX-Solver will fail. To assist with this, you can select only one side of a thin surface and then enable the **Create Thin Surface Partner** toggle. ANSYS CFX-Pre will then try to automatically create another boundary condition for the other side.

1. Create a new boundary condition named **Draft Tube**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Draft Tube</td>
</tr>
<tr>
<td>Thin Surfaces &gt;</td>
<td>Create Thin Surface Partner</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence On Flow &gt; Option</td>
<td>Fluid Dependent</td>
</tr>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt; Wall Influence On Flow &gt; Option</td>
<td>Free Slip</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Water</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Water &gt; Wall Influence On Flow &gt; Option</td>
<td>No Slip</td>
</tr>
</tbody>
</table>
3. Click OK.

A boundary condition named DraftTube Other Side will now be created automatically.

### Symmetry Plane Boundary

In this step you will create symmetry plane boundary conditions on the Symmetry1 and Symmetry2 locators, one for each of the two vertical cross sections of the reactor sector.

1. Create a new boundary condition named SymP1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Symmetry1</td>
</tr>
</tbody>
</table>

3. Click OK.

4. Create a new boundary condition named SymP2.
5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Symmetry2</td>
</tr>
</tbody>
</table>

6. Click OK.

The remaining external regions are assigned to the default wall boundary condition. This needs to be modified to set the Air phase to Free Slip.

1. In the Outline workspace, open Default Domain Default for editing.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td>Wall Influence on Flow &gt; Option</td>
<td>Fluid Dependent</td>
</tr>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions &gt; Air at 25 C &gt; Wall Influence on Flow &gt; Option</td>
<td>Free Slip</td>
</tr>
</tbody>
</table>

3. Click OK.

The boundary condition specifications are now complete.

### Setting Initial Values

It often helps to set an initial velocity for a dispersed phase that is different to that of the continuous phase. This results in a non-zero drag between the phases which can help stability at the start of a simulation.

For some bubble column problems, improved convergence can be obtained by using CEL (CFX Expression Language) to specify a non zero volume fraction, for air in the riser and a zero value in the downcomer. This should be done if two solutions are possible (for example, if the flow could go up the downcomer and down the riser).
1. Click **Global Initialization**.

Since a single pressure field exists for a multiphase calculation you do not set pressure values on a per fluid basis.

2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Settings</td>
<td>Fluid Specific Initialization</td>
<td>Air at 25 C</td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Air at 25 C</td>
<td>(Selected)</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Air at 25 C &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Air at 25 C &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>0 [m s^{-1}]</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Air at 25 C &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0.3 [m s^{-1}]</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Air at 25 C &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s^{-1}]</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization</td>
<td>Water *</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water</td>
<td>(Selected)</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>0 [m s^{-1}]</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0 [m s^{-1}]</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s^{-1}]</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Turbulence Kinetic Energy &gt; Option</td>
<td>Automatic</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Turbulence Eddy Dissipation</td>
<td>(Selected)</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Turbulence Eddy Dissipation &gt; Option</td>
<td>Automatic</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Volume Fraction &gt; Option</td>
<td>Automatic with Value</td>
<td></td>
</tr>
<tr>
<td>Fluid Specific Initialization &gt; Water &gt; Initial Conditions &gt; Volume Fraction</td>
<td>Volume Fraction 1 †</td>
<td></td>
</tr>
</tbody>
</table>

* Since there is no water entering or leaving the domain, a stationary initial guess is recommended.

† The volume fractions must sum to unity over all fluids. Since a value has been set for water, the volume fraction of air will be calculated as the remaining difference, in this case, 0.

3. Click **OK**.
Tutorial 16: Gas-Liquid Flow in an Airlift Reactor: Obtaining a Solution using ANSYS CFX-Solver Manager

Setting Solver Control

If you are using a maximum edge length of 0.005 m or less to produce a finer mesh, use a Target Residual of 1.0E-05 to obtain a more accurate solution.

1. Click Solver Control.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Timescale Control</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Physical Timescale Control</td>
<td>1 [s]</td>
</tr>
</tbody>
</table>

3. Click OK.

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>BubbleColumn.def</td>
</tr>
<tr>
<td>Quit CFX–Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

The ANSYS CFX-Solver Manager will be launched after ANSYS CFX-Pre has closed down. You will be able to obtain a solution to the CFD problem by following the instructions below.

Note: If a fine mesh is used for a formal quantitative analysis of the flow in the reactor, the solution time will be significantly longer than for the coarse mesh. You can run the simulation in parallel to reduce the solution time. For details, see Obtaining a Solution in Parallel (p. 116).

1. Ensure Define Run is displayed.
2. Click Start Run.

ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed stating that the simulation has completed.
Tutorial 16: Gas-Liquid Flow in an Airlift Reactor: Viewing the Results in ANSYS CFX-Post

3. Click Yes to post-process the results when the completion message appears at the end of the run.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

The following topics will be discussed:
- Creating Velocity Vector Plots (p. 278)
- Viewing Volume Fractions (p. 279)
- Displaying the Entire Airlift Reactor Geometry (p. 280)

Creating Velocity Vector Plots

Because the simulation in this tutorial is conducted on a coarse grid, the results are only suitable for a qualitative demonstration of the multiphase capability of ANSYS CFX, Release 11.0. You will first examine the distribution of velocities and fluid volume fraction by creating the following plots. The results will then be verified to check if the values are reasonable.

1. Right-click a blank area in the viewer and select Predefined Camera > View Towards -Z.
2. Zoom in as required.
3. Turn on the visibility of SymP1.
4. Apply the following settings to SymP1.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Air at 25 C.Volume Fraction</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>0.025</td>
</tr>
</tbody>
</table>

5. Click Apply. Observe the volume fraction values throughout the domain.
6. Turn off the visibility of SymP1.
7. Create a new vector named Vector 1.
8. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>SymP1</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Water.Velocity</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.3</td>
</tr>
</tbody>
</table>

9. Click Apply.
10. Create a new vector plot named Vector 2.
11. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>SymP1</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Variable</td>
<td>Air at 25 C.Velocity</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>0.3</td>
</tr>
</tbody>
</table>

12. Click **Apply**.
13. Compare the vector fields by toggling the visibility of each and zooming in as needed.

### Viewing Volume Fractions

In creating the geometry for the airlift reactor, a thin surface was used to model the draft tube. You will next plot the volume fraction of air on the thin surface.

1. Right-click on a blank area in the viewer, and select **Predefined Camera > Isometric View (Y up)**.
2. Zoom in as required.
3. Turn off the visibility of any vector plots and turn on the visibility of **DraftTube**.
4. Modify **DraftTube** by applying the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>Air at 25 C.Volume Fraction</td>
</tr>
<tr>
<td></td>
<td>Range</td>
<td>User Specified</td>
</tr>
<tr>
<td></td>
<td>Min</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Max</td>
<td>0.02</td>
</tr>
</tbody>
</table>

5. Click **Apply**.
   - This boundary represents one side of the thin surface. When viewing plots on thin surfaces, you must ensure that you are viewing the correct side of the thin surface.
   - The plot just created is displaying the volume fraction for air in the downcomer region of the airlift reactor. If you rotate the geometry you will see that the same plot is visible from both sides of the thin surface.
   - You will make use of the face culling feature which turns off the visibility of the plot on one side of the thin surface. In this case, you need to turn off the “front” faces.

6. Modify **DraftTube** by applying the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces &gt; Face Culling</td>
<td>Front Faces</td>
</tr>
</tbody>
</table>

7. Click **Apply**.
8. Rotate the image in the viewer to see the effect of face culling on **DraftTube**. You should see that the color appears only on one side: the downcomer side.
9. Turn on the visibility of **DraftTube Other Side**.
10. Color the DraftTube Other Side object using the same color settings as for DraftTube.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td>Variable</td>
<td>Air at 25°C Volume Fraction</td>
<td>User Specified</td>
</tr>
<tr>
<td>Range</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Min</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Max</td>
<td>0.02</td>
<td></td>
</tr>
</tbody>
</table>

11. Modify DraftTube Other Side by applying the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Render</td>
<td>Draw Faces &gt; Face Culling</td>
<td>Front Faces</td>
</tr>
</tbody>
</table>

This will create a plot of air volume fraction on the riser side of the bubble column.

12. Click Apply.

Rotating the geometry will now show correct plots of the air volume fraction on each side of the draft tube.

To see why face culling was needed to prevent interference between the plots on each side of the draft tube, try turning off face culling for DraftTube and watch the effect on the riser side (Results may vary, which is why face culling was used to prevent interference.).

Displaying the Entire Airlift Reactor Geometry

Display the entire airlift reactor geometry by expanding User Locations and Plots and double-clicking the Default Transform object:

1. Apply the following settings to Default Transform:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Definition</td>
<td>Instancing Info From Domain</td>
<td>(Cleared)</td>
</tr>
<tr>
<td></td>
<td># of Copies</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>Apply Rotation &gt; Axis</td>
<td>Y</td>
</tr>
<tr>
<td></td>
<td>Apply Rotation &gt; # of Passages</td>
<td>12</td>
</tr>
</tbody>
</table>

2. Click Apply.

Additional Fine Mesh Simulation Results

A formal analysis of this airlift reactor was carried out on a finer grid (having 21000+ nodes and a maximum edge length of 0.005 m).
The analysis showed a region of air bubble recirculation at the top of the reactor on the downcomer side. This was confirmed by zooming in on a vector plot of Air at 25 C.Velocity on SymP1 near the top of the downcomer. A similar plot of Water.Velocity revealed no recirculation of the water.

Other results of the simulation:

- Due to their large 0.006 m diameter, the air bubbles quickly attained a significant terminal slip velocity (i.e., the terminal velocity relative to water). The resulting terminal slip velocity, obtained using the Grace drag model, is consistent with the prediction by Maneri and Mendelson and the prediction by Baker and Chao. These correlations predict a terminal slip velocity of about 0.23 m s\(^{-1}\) to 0.25 m s\(^{-1}\) for air bubbles of the diameter specified.

- The values of gas holdup (the average volume fraction of air in the riser), the superficial gas velocity (the rising velocity, relative to the reactor vessel, of gas bubbles in the riser, multiplied by the gas holdup), and the liquid velocity in the downcomer agree with the results reported by García-Calvo and Letón, for gas holdup values of 0.03 or less. At higher values of gas holdup, the multifluid model does not account for pressure-volume work transferred from gas to liquid due to isothermal expansion of the bubbles. The simulation therefore tends to under-predict both the superficial gas velocity in the riser, and the liquid velocity in the downcomer for gas holdup values greater than 0.03.

**Note:** Multiphase results files contain the vector variable Fluid.Superficial Velocity defined as Fluid.Volume Fraction multiplied by Fluid.Velocity. This is sometimes also referred to as the fluid volume flux. The components of this vector variable are available as scalar variables (e.g., Fluid.Superficial Velocity X).

Many reference texts on bubble columns cite the Hughmark correlation as a standard for gas hold up and superficial gas velocity in bubble columns. However, the Hughmark correlation should not be used when liquid flow is concurrent with gas at velocities exceeding 0.1 m s\(^{-1}\). In the airlift reactor described in this tutorial, the liquid velocity in the riser clearly exceeds 0.2 m s\(^{-1}\) and the Hughmark correlation is therefore not applicable.
Tutorial 17: Air Conditioning Simulation

Introduction

This tutorial includes:
- Tutorial 17 Features (p. 284)
- Overview of the Problem to Solve (p. 285)
- Defining a Simulation in ANSYS CFX-Pre (p. 285)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 295)
- Viewing the Results in ANSYS CFX-Post (p. 295)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 285).

Sample files referenced by this tutorial include:
- HVAC.pre
- HVAC_expressions.ccl
- HVACMesh.gtm
- TStat_Control.F

Note: You must have a Fortran compiler installed on your system to perform this tutorial.
This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Radiation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Buoyant Flow</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Boundary Profile Visualization</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Inlet (Profile)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Fixed Temperature</td>
</tr>
<tr>
<td>Output Control</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CEL (CFX Expression Language)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User Fortran</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Timestep</td>
<td></td>
<td>Transient Example</td>
</tr>
<tr>
<td>Transient Results File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Animation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Isosurface</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Point</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td>Other</td>
<td></td>
<td>Auto Annotation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Changing the Color Range</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Legend</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MPEG Generation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Time Step Selection</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Title/Text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transient Animation</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Using the Monte Carlo radiation model with a directional source of radiation.
- Setting a monitor point to observe the temperature at a prescribed location.
Overview of the Problem to Solve

This tutorial demonstrates a simple air conditioning case in a room. The room contains windows and an inlet vent for cooled air. The windows are set up to include heat and radiation sources that act to raise the temperature of the room. The inlet vent introduces cool air into the room to lower the temperature to a set level. The room also contains an outlet vent, which removes ambient air from the room.

Defining a Simulation in ANSYS CFX-Pre

This section describes the step-by-step definition of the flow physics in ANSYS CFX-Pre.

Important: You must have the required Fortran compiler installed and set in your system path in order to run this tutorial. For details on which Fortran compiler is required for your platform, see the applicable ANSYS, Inc. installation guide. If you are not sure which Fortran compiler is installed on your system, try running the `cfx5mkext` command (found in `<CFXROOT>/bin`) from the command line and read the output messages.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: `HVAC.pre`.

After performing this step, you can continue from Obtaining a Solution using ANSYS CFX-Solver Manager (p. 295).
Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type HVAC.
6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>HVACMesh.gtm</td>
</tr>
</tbody>
</table>

3. Click Open.
4. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z up) from the shortcut menu.

Creating Expressions

This tutorial requires some CEL expressions. In this tutorial, a transient simulation will be performed over 3 minutes 45 seconds with 3 second timesteps for a total of 75 timesteps. Expressions will be used to enter these values. The expressions are also used to calculate the inlet temperature of air under different conditions.

As the air conditioner will remove a specified amount of heat, the inlet vent temperature is a function of the outlet vent temperature. A CEL function is used to find the outlet temperature. A User CEL Function is used to simulate behavior of a thermostat that turns on cold air when the temperature (measured at a particular location) is above 22 °C (295.15 K) and turns off the cold air when the temperature falls below 20 °C (293.15 K).

Note: The expression for TSensor requires a monitor point named Thermometer to provide room temperature feedback to the thermostat. This will be set up later.

Importing the Expressions

1. Select File > Import CCL.
2. Select the file HVAC_expressions.ccl.
3. Click Open.

The expression for ACon requires a User CEL Function that indicates the thermostat output: whether the air conditioner should be on or off. This will be set up next.
Expressions are used to simulate guiding vanes at the inlet, as the following diagram shows:

The two x locations indicated on the diagram correspond to the x values across the width of the inlet vent. When x is 0.05, the z component of velocity will be -1 and the x component will be zero. When x is 0.15, the x component of velocity will be 0.5 and the z component will be -0.5. The x component of velocity varies linearly with x. The following expression can be used to calculate the x component of velocity:

\[
X_{\text{CompInlet}} = 0.5 \times \frac{x - 0.05}{0.1} = 5(x - 0.05) \quad \text{(Eqn. 1)}
\]

\[
Z_{\text{CompInlet}} = -1 + X_{\text{CompInlet}}
\]

### Setting up the Thermostat

A Fortran subroutine that simulates the thermostat has already been written for this tutorial.

### Compiling the Subroutine

You can compile the subroutine and create the required library file used by ANSYS CFX-Solver at any time before running the ANSYS CFX-Solver. The operation is performed at this point in the tutorial so that you have a better understanding of the values you need to specify in ANSYS CFX-Pre when creating a User CEL Function. The `cfx5mkext` command is used to compile the subroutine as described below.

**Important:** You must have the required Fortran compiler installed and set in your system path in order to run the `cfx5mkext` command successfully. For details on which Fortran compiler is required for your platform, see the applicable ANSYS, Inc. installation guide. If you are not sure which Fortran compiler is installed on your system, try running the `cfx5mkext` command (found in `<CFXROOT>/bin`) from the command line and read the output messages.

1. Copy the subroutine `TStat_Control.F` to your working directory (if you have not already done so).
2. Examine the contents of this file in any text editor to gain a better understanding of this subroutine.
   
   This file was created by modifying the `ucf_template.F` file, which is available in the `<CFXROOT>/examples/` directory.
3. Select **Tools > Command Editor**.

4. Type the following command in the **Command Editor** dialog box (make sure you do not miss the semi-colon at the end of the line):

```
! system ('cfx5mkext TStat_Control.F') < 1 or die 'cfx5mkext failed';
```

- This is equivalent to executing the following at an OS command prompt:

```
cfx5mkext TStat_Control.F
```

- The `!` indicates that the following line is to be interpreted as power syntax and not CCL. Everything after the `!` symbol is processed as Perl commands.
- `system` is a Perl function to execute a system command.
- The `< 1 or die` will cause an error message to be returned if, for some reason, there is an error in processing the command.

5. Click **Process** to compile the subroutine.

**Note:** You can use the `-double` option (i.e., `cfx5mkext -double TStat_Control.F`) to compile the subroutine for use with double precision ANSYS CFX-Solver executables.

A subdirectory will have been created in your working directory whose name is system dependent (e.g., on IRIX it is named `irix`). This subdirectory contains the shared object library.

**Note:** If you are running problems in parallel over multiple platforms then you will need to create these subdirectories using the `cfx5mkext` command for each different platform.

- You can view more details about the `cfx5mkext` command by running `cfx5mkext -help`.
- You can set a Library Name and Library Path using the `-name` and `-dest` options respectively.
- If these are not specified, the default Library Name is that of your Fortran file and the default Library Path is your current working directory.

1. Close the **Command Editor** dialog box.

### Creating the User CEL Function

A User CEL Function is required to link the subroutine into ANSYS CFX. The complete definition for the function is defined in two steps. First, a user routine that contains the calling name, library name, and library path is created. Then, a user function that points to the user routine, and also contains the argument and result units, is defined.

1. From the main menu, select **Insert > Expressions, Functions and Variables > User Routine** or click **User Routine**.

2. Set the name to **Thermostat Routine**.

3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>User CEL Function</td>
</tr>
<tr>
<td></td>
<td>Calling Name</td>
<td>ac_on*</td>
</tr>
<tr>
<td></td>
<td>Library Name</td>
<td>TStat_Control†</td>
</tr>
<tr>
<td></td>
<td>Library Path</td>
<td>(Working Directory)‡</td>
</tr>
</tbody>
</table>
4. Click OK.
5. Create a new user function named Thermostat Function by selecting Insert > Expressions, Functions and Variables > User Function from the main menu.
6. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>User Function</td>
</tr>
<tr>
<td></td>
<td>Argument Units</td>
<td>[K], [K], [K], [ ]*</td>
</tr>
<tr>
<td></td>
<td>Result Units</td>
<td>[ ]†</td>
</tr>
</tbody>
</table>

* These are the units for the four input arguments: TSensor, TSet, TTol, and aitern.
† The result will be a dimensionless integer flag of values 1 or 0.

7. Click OK.
The function you have just prepared is called during the evaluation of the expression for ACOn (that you imported earlier). The expression is:

\[
\text{Thermostat Function}(\text{TSensor}, \text{TSet}, \text{TTol}, \text{aitern})
\]

It evaluates to 1 or 0, depending on whether the air conditioner should be on (1) or off (0).

**Setting the Simulation Type**

1. Click Simulation Type.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Simulation Type &gt; Option</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Duration &gt; Total Time</td>
<td>tTotal</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Steps &gt; Timesteps</td>
<td>tStep</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Initial Time &gt; Time</td>
<td>0 [s]</td>
</tr>
</tbody>
</table>

3. Click OK.

**Creating the Domain**

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.
2. Double click Default Domain and apply the following settings:
### Setting Boundary Conditions

In this section you will define the locations and values of the boundary conditions.

#### Inlet Boundary

1. Create a new boundary condition named *Inlet*.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>B1.P3</td>
</tr>
<tr>
<td></td>
<td>Fluids List</td>
<td>Air Ideal Gas</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Option</td>
<td>Buoyant</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity X Dirn.</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Y Dirn.</td>
<td>0 [m s^-2]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Gravity Z Dirn.</td>
<td>-g</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Buoyancy &gt; Buoy. Ref. Density</td>
<td>1.2 [kg m^-3]</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Thermal Radiation Model &gt; Option</td>
<td>Monte Carlo</td>
</tr>
</tbody>
</table>

3. Click **OK**.

#### Outlet Boundary

1. Create a new boundary condition named *VentOut*.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Inlet</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Mass Flow Rate</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Mass Flow Rate</td>
<td>MassFlow</td>
</tr>
<tr>
<td></td>
<td>Flow Direction &gt; Option</td>
<td>Cartesian Components</td>
</tr>
<tr>
<td></td>
<td>Flow Direction &gt; X Component</td>
<td>XCompInlet</td>
</tr>
<tr>
<td></td>
<td>Flow Direction &gt; Y Component</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Flow Direction &gt; Z Component</td>
<td>ZCompInlet</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>Tin</td>
</tr>
<tr>
<td>Plot Options</td>
<td>Boundary Vector</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Note:** Ignore the physics errors that appear. They will be fixed by setting up the rest of the simulation. The error you see is due to a reference to *Thermometer* which has not been set up yet. This will be done as part of the output control.
Window Boundary

3. Click OK.

To model incoming radiation at the window boundaries, a directional radiation source will be created. The windows will also contribute heat to the room via a fixed temperature of 26 [°C].

1. Create a new boundary condition named \textit{Windows}.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>VentOut</td>
</tr>
<tr>
<td>Boundary</td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Window1, Window2</td>
</tr>
<tr>
<td>Boundary</td>
<td>Heat Transfer &gt; Option</td>
<td>Temperature</td>
</tr>
<tr>
<td>Details</td>
<td>Heat Transfer &gt; Fixed Temperature</td>
<td>26 [°C]</td>
</tr>
</tbody>
</table>

4. Create a new radiation source item by clicking Add New Item and accepting the default name.

5. Apply the following settings to Radiation Source 1

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Directional Radiation Flux</td>
</tr>
<tr>
<td>Radiation Flux</td>
<td>600 [W m$^{-2}$]</td>
</tr>
<tr>
<td>Direction &gt; Option</td>
<td>Cartesian Components</td>
</tr>
<tr>
<td>Direction &gt; X Component</td>
<td>0.33</td>
</tr>
<tr>
<td>Direction &gt; Y Component</td>
<td>0.33</td>
</tr>
<tr>
<td>Direction &gt; Z Component</td>
<td>-0.33</td>
</tr>
</tbody>
</table>

6. Apply the following setting

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plot</td>
<td>Options</td>
<td>Boundary Vector</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Selected)</td>
</tr>
</tbody>
</table>
7. Click OK.

The directional source of radiation is displayed.

**Default Wall Boundary**

The default boundary condition for any undefined surface in ANSYS CFX-Pre is a no-slip, smooth, adiabatic wall. For radiation purposes, the default wall is assumed to be a perfectly absorbing and emitting surface (emissivity = 1), and this will be preserved when setting up the boundary condition.

In this tutorial, a fixed temperature of 26 °C will be assumed to exist at the wall during the simulation. A more detailed analysis would model heat transfer through the walls, but as this tutorial is designed only for demonstration purposes, a fixed temperature wall is sufficient.

1. Modify the boundary condition named Default Domain Default.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary</td>
<td>Heat Transfer &gt; Option</td>
<td>Temperature</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fixed Temperature</td>
<td>26 [C]</td>
</tr>
</tbody>
</table>

3. Click OK.

This setting will include the Door region, which will be modeled as a wall (closed door) for simplicity. Since the region is part of the entire default boundary, it will not appear in the wireframe when the results file is opened in ANSYS CFX-Post (but can still be viewed in the Regions list).

**Setting Initial Values**

1. Click Global Initialization
2. Apply the following settings
### Setting Solver Control

1. Click **Solver Control**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Transient Scheme &gt; Option</td>
<td>Second Order Backward Euler</td>
</tr>
<tr>
<td>Convergence Control</td>
<td>Max. Coeff. Loops</td>
<td>3</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Setting Output Control

Transient results files will be set up to record transient values of a chosen set of variables. Monitor points will be created to show the on/off status of the air conditioner, the temperature at the inlet, the temperature at the outlet, and the temperature at a prescribed thermometer location.
1. Click **Output Control**.
2. Click **Trn Results**.
3. Create a new **Transient Results** item by clicking **Add New Item** and accept the default name.
4. Apply the following settings to **Transient Results 1**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Selected Variables</td>
</tr>
<tr>
<td>Output Variables List</td>
<td>Pressure, Radiation Intensity, Temperature, Velocity</td>
</tr>
<tr>
<td>Output Variables Operators</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Output Variables Operators &gt; Output Var. Operators</td>
<td>All*</td>
</tr>
<tr>
<td>Output Frequency &gt; Option</td>
<td>Time Interval</td>
</tr>
<tr>
<td>Output Frequency &gt; Time Interval</td>
<td>tStep</td>
</tr>
</tbody>
</table>

* This causes the gradients of the selected variables to be written to the transient files, along with other information.

5. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor</td>
<td>Monitor Options</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

6. Create a new **Monitor Points and Expressions** item named **Temp at Inlet**.
7. Apply the following settings to **Temp at Inlet**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Expression</td>
</tr>
<tr>
<td>Expression Value</td>
<td>TIn</td>
</tr>
</tbody>
</table>

8. Create a new **Monitor Points and Expressions** item named **Thermometer**.
9. Apply the following settings to **Thermometer**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Variable List</td>
<td>Temperature</td>
</tr>
<tr>
<td>Cartesian Coordinates</td>
<td>2.95, 1.5, 1.25</td>
</tr>
</tbody>
</table>

10. Create a new **Monitor Points and Expressions** item named **Temp at VentOut**.
11. Apply the following settings to **Temp at VentOut**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Expression</td>
</tr>
<tr>
<td>Expression Value</td>
<td>TVentOut</td>
</tr>
</tbody>
</table>
Tutorial 17: Air Conditioning Simulation: Obtaining a Solution using ANSYS CFX-Solver Manager

12. Create a new **Monitor Points and Expressions** item named **ACOnStatus**.
13. Apply the following settings to **ACOnStatus**:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Expression</td>
</tr>
<tr>
<td>Expression Value</td>
<td>ACOn</td>
</tr>
</tbody>
</table>

14. Click **OK**.

Writing the Solver (.def) File

1. Click **Write Solver File**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>HVAC.def</td>
</tr>
<tr>
<td>Quit CFX–Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using ANSYS CFX-Solver Manager

When ANSYS CFX-Pre has shut down and the ANSYS CFX-Solver Manager has started, obtain a solution to the CFD problem by following the instructions below.

1. Click **Start Run**.
2. When the **User Points** tab appears, click it to view the value of the temperature at **VentOut** as the solution progresses.
3. Click **Yes** to post-process the results when the completion message appears at the end of the run.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

The temperature of air in the house is distributed in both space and time. While the transient behavior of the temperature field can easily be shown with an animation, it is not easy to visualize a complicated 3D distribution. In order to show the key features of the temperature field, graphic objects will be produced on strategically-placed locators; Plane locators will be used to show contour plots of temperature, while Isosurfaces will be used sparingly to show the general shape of thermal plumes.
Creating Graphics Objects

Plane locators will be placed vertically through the vents and horizontally above the floor.

**Plane Locators**
1. Load the res file (HVAC_001.res) if you did not elect to load the results directly from the ANSYS CFX-Solver Manager.
2. Right-click a blank area in the viewer, select **Predefined Camera > Isometric View (Z up)**.
3. Create a ZX-Plane named **Plane 1** with \( Y = 1.5 \) [m]. Color it by **Temperature** using a user specified range from 19 [C] to 23 [C], and clear **Lighting**.
4. Create an XY Plane named **Plane 2** with \( Z = 0.35 \) [m]. Color it using the same settings as for the first plane, and clear **Lighting**.

**Isosurface Locator**
1. Click **Timestep Selector**.
   The **Timestep Selector** appears.
2. Double-click the value (12s) in the **Timestep Selector**.
   The Timestep is set to 12s so that the cold plume is visible.
3. Create an isosurface named **Cold Plume** which is a surface of **Temperature** = 19 [C]. Use conservative values for **Temperature**.
4. Color the isosurface by **Temperature** and use the same range as for the planes. Although the color of the isosurface will not show variation (by definition), it will be consistent with the other graphic objects.
5. On the **Render** tab for the isosurface, set **Transparency** to 0.5, and clear **Lighting**.
6. Click **Apply**.
   **Note:** The isosurface will not be visible in some timesteps, but you will be able to see it when playing the animation (a step carried out later).

**Adjusting the Legend**
The legend title should not name the locator of any particular object since all objects are colored by the same variable and use the same range.
1. In the tree view, double-click Default Legend View 1.
2. In the **Definition** tab, change **Title Mode** to **Variable**.
   This will remove the locator name from the legend.
3. Click the **Appearance** tab, then:
   a. Change **Precision** to 2, Fixed.
   b. Change **Text Height** to 0.03.
4. Click **Apply**.
   A label will be used to show the simulation time and the temperature of the thermometer which controls the thermostat. This will be especially useful for the animation which is created later in this tutorial.
Before creating the label, you will need to support the expression for $\text{TSensor}$ by creating a point called $\text{Thermometer}$ at the location of the sensor thermometer. This point will replace the monitor point called $\text{Thermometer}$ which was used during the solver run, but no longer exists.

**Note:** The actual thermometer data generated during the run was stored in the results file, but is not easily accessible, and cannot currently be used in an auto-annotation label.

### Creating a Point for the Thermometer
1. From the main menu, select **Insert > Location > Point.**
2. Set **Name** to **Thermometer**.
3. Set **Point** to $(2.95, 1.5, 1.25)$.
4. Click **Apply**.

Now the expression $\text{TSensor}$ will once again measure temperature at the prescribed location.

### Creating the Text Label
1. Click **Text**.
2. Accept the default name and click **OK**.
3. Set **Text String** to **Time Elapsed**.
4. Select **Embed Auto Annotation**.
   The full text string should now be **Time Elapsed: <aa>**. The `<aa>` represents the location where the auto annotation will be substituted.
5. Set **Type** to **Time Value**.
   This will show the amount of simulated time that has passed in the simulation.
6. Click **More**.
   This adds a second line of text to the text object.
7. Set **Text String** to **Sensor Temperature**.
8. Select **Embed Auto Annotation**.
9. Set **Type** to **Expression**.
10. Set **Expression** to $\text{TSensor}$.
11. Click the **Appearance** tab, change **Height** to 0.03, then click **Apply**.
    Ensure the visibility check box next to **Text 1** is selected. A label appears at the top of the figure. The large font is used so that the text will be clearly visible in the animation which will be produced in the next section.

### Creating an Animation
1. Ensure that the view is set to **Isometric View (Z up)**.
2. Click **Timestep Selector**.
   The **Timestep Selector** appears.
3. Double-click the first time value (0 s) in the **Timestep Selector**.
4. Click **Animation** found in the toolbar.
   The **Animation** dialog box appears.
5. In the **Animation** dialog box:
Tutorial 17: Air Conditioning Simulation: Viewing the Results in ANSYS CFX-Post

a. Click New to create KeyframeNo1.

b. Highlight KeyframeNo1, change # of Frames to 200, then press <Enter> while in the # of Frames box.

Tip: Be sure to press <Enter> and confirm that the new number appears in the list before continuing.

This will place 200 intermediate frames between the first and (yet to be created) second key frames, for a total of 202 frames. This will produce an animation lasting about 8.8 s since the frame rate will be 24 frames per second. Since there are 76 unique frames, each frame will be shown at least once.

6. Load the last time value (225 s) using the Timestep Selector dialog box.

7. In the Animation dialog box:

a. Click New to create KeyframeNo2.

The # of Frames parameter has no effect for the last keyframe, so leave it at the default value.

b. Click More Animation Options to expand the Animation dialog box.

c. Select Save MPEG.

d. Specify a file name for the MPEG file.

e. Click the Options button.

f. Change MPEG Size to 720 x 480 (or a similar resolution).

g. Click the Advanced tab, and note the Quality setting.

If your MPEG player does not play the MPEG, you can try using the Low or Custom quality settings.

h. Click OK.

i. Click To Beginning to rewind the active key frame to KeyframeNo1.

j. Click Save animation state and save the animation to a file. This will enable you to quickly restore the animation in case you want to make changes. Animations are not restored by loading ordinary state files (those with the .cst extension).

8. Click Play the animation.

9. If prompted to overwrite an existing movie, click Overwrite.

The animation plays and builds an .mpg file.

10. When you have finished, quit ANSYS CFX-Post.

Further Steps

1. This tutorial uses an aggressive value for the flow rate of air, a coarse mesh, and the timesteps are too large for a satisfactory analysis. Running this tutorial with a finer mesh, a flow rate of air that is closer to 5 changes of air per hour (0.03 m³ s⁻¹), and smaller timesteps will produce more accurate results.

2. Running the simulation for a longer total time period will allow you to see more on/off cycles of the thermostat.
Tutorial 18: Combustion and Radiation in a Can Combustor

Introduction

This tutorial includes:

- Tutorial 18 Features (p. 300)
- Overview of the Problem to Solve (p. 301)
- Using Eddy Dissipation and P1 Models (p. 301)
- Defining a Simulation in ANSYS CFX-Pre (p. 302)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 307)
- Viewing the Results in ANSYS CFX-Post (p. 308)
- Laminar Flamelet and Discrete Transfer Models (p. 311)
- Further Postprocessing (p. 316)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 302).

Sample files referenced by this tutorial include:

- CombustorMesh.gtm
- CombustorEDM.pre
- CombustorFlamelet.pre
- CombustorEDM.cfx
Tutorial 18：Combustion and Radiation in a Can Combustor: Tutorial 18 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>Reacting Mixture</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Combustion</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Radiation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Thin Surface</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Outline Plot (Wireframe)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sampling Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Vector</td>
</tr>
<tr>
<td></td>
<td>Other</td>
<td>Changing the Color Range</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Color map</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Legend</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Quantitative Calculation</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Creating thin surfaces for the inlet vanes.
- Using a Reacting Mixture.
- Using the Eddy Dissipation Combustion Model.
- Using the Flamelet Model.
- Changing the Combustion model in a simulation.
- Using the P1 Radiation Model in ANSYS CFX-Pre.
- Using the Discrete Transfer Radiation Model in ANSYS CFX-Pre.
- Using the NOx model in ANSYS CFX-Pre.
- Changing object color maps in ANSYS CFX-Post to prepare a greyscale image.
Overview of the Problem to Solve

The can combustor is a feature of the gas turbine engine. Arranged around a central annulus, can combustors are designed to minimize emissions, burn very efficiently and keep wall temperatures as low as possible. This tutorial is designed to give a qualitative impression of the flow and temperature distributions. The basic geometry is shown below with a section of the outer wall cut away.

Using Eddy Dissipation and P1 Models

This tutorial demonstrates two different combustion and radiation model combinations. The first uses the Eddy Dissipation Combustion model with the P1 Radiation model; the NOx model is also included. The second uses the Laminar Flamelet model with the Discrete Transfer Radiation model. If you wish to use the Flamelet Combustion model and Discrete Transfer Radiation model, see Laminar Flamelet and Discrete Transfer Models (p. 311), otherwise continue from this point.
Defining a Simulation in ANSYS CFX-Pre

You will define a domain that includes a variable composition mixture. These mixtures are used to model combusting and reacting flows in ANSYS CFX.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: CombustorEDM.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 307).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type CombustorEDM.
6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh.
2. Apply the following setting

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>CombustorMesh.gtm</td>
</tr>
</tbody>
</table>

3. Click Open.

Creating a Reacting Mixture

To allow combustion modeling, you must create a variable composition mixture.

To create the variable composition mixture

1. Create a new material named Methane Air Mixture.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>Reacting Mixture</td>
</tr>
<tr>
<td>Material Group</td>
<td>Gas Phase Combustion</td>
<td></td>
</tr>
<tr>
<td>Reactions List</td>
<td>Methane Air WD1 NO PDF</td>
<td></td>
</tr>
</tbody>
</table>
3. Click OK.

Creating the Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.

2. Double click Default Domain and apply the following settings.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Locations</td>
<td>B152, B153, B154, B155, B156</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Fluids List</td>
<td>Methane Air Mixture</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]†</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Reaction or Combustion &gt; Option</td>
<td>Eddy Dissipation</td>
</tr>
<tr>
<td></td>
<td>Reaction or Combustion &gt; Eddy Dissipation Model Coefficient B</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Reaction or Combustion &gt; Eddy Dissipation Model Coefficient B &gt; EDM Coeff. B</td>
<td>0.5†</td>
</tr>
<tr>
<td></td>
<td>Thermal Radiation Model &gt; Option</td>
<td>P 1</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; N2</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; N2 &gt; Option</td>
<td>Constraint</td>
</tr>
</tbody>
</table>

* It is important to set a realistic reference pressure in this tutorial because the components of Methane Air Mixture are ideal gases.
† This includes a simple model for partial premixing effects by turning on the Product Limiter. When it is selected, non-zero initial values are required for the products. The products limiter is not recommended for multi-step eddy dissipation reactions, and so is set for this single step reaction only.

3. Click OK.
Creating the Boundary Conditions

**Fuel Inlet Boundary**

1. Create a new boundary condition named `fuelin`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td>Location</td>
<td>fuelin</td>
<td></td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>40 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>Component Details</td>
<td>CH4</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; CH4 &gt; Mass Fraction</td>
<td>1</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Bottom Air Inlet Boundary**

Two separate boundary conditions will be applied for the incoming air. The first is at the base of the can combustor. The can combustor employs vanes downstream of the fuel inlet to give the incoming air a swirling velocity.

1. Create a new boundary condition named `airin`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td>Location</td>
<td>airin</td>
<td></td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>10 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>Component Details</td>
<td>O2</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; O2 &gt; Mass Fraction</td>
<td>0.232*</td>
</tr>
</tbody>
</table>

* The remaining mass fraction at the inlet will be made up from the constraint component, N2.

3. Click **OK**.

**Side Air Inlet Boundary**

The secondary air inlets are located on the side of the vessel and introduce extra air to aid combustion.

1. Create a new boundary condition named `secairin`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td>Location</td>
<td>secairin</td>
<td></td>
</tr>
</tbody>
</table>
3. Click OK.

Outlet Boundary

1. Create a new boundary condition named `out`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>out</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Average Static Pressure</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>$6 \text{ m s}^{-1}$</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Static Temperature</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Static Temperature</td>
<td>$300 \text{ K}$</td>
</tr>
<tr>
<td>Component Details</td>
<td>O2</td>
<td></td>
</tr>
<tr>
<td>Component Details &gt; O2 &gt; Mass Fraction</td>
<td>$0.232^*$</td>
<td></td>
</tr>
</tbody>
</table>

3. Click OK.

Vanes Boundary The vanes above the main air inlet are to be modeled as thin surfaces. To create a vane as a thin surface in ANSYS CFX-Pre, you must specify a wall boundary condition on each side of the vanes. The **Create Thin Surface Partner** feature in ANSYS CFX-Pre will automatically match the other side of a thin surface if you pick just a single side.

You will first create a new region which contains one side of each of the eight vanes, then use the **Create Thin Surface Partner** feature to match the other side.

1. Create a new composite region named `Vane Surfaces`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Dimension (Filter)</td>
<td>2D$^*$</td>
</tr>
<tr>
<td></td>
<td>Region List</td>
<td>F129.152, F132.152, F136.152, F138.152, F141.152, F145.152, F147.152, F150.152</td>
</tr>
</tbody>
</table>

3. Click OK.

4. Create a new boundary condition named `vanes`.
5. Apply the following settings

* The remaining mass fraction at the inlet will be made up from the constraint component, N2.
6. Click OK.

**Default Wall Boundary**

The default boundary condition for any undefined surface in ANSYS CFX-Pre is a no-slip, smooth, adiabatic wall.

- For radiation purposes, the wall is assumed to be a perfectly absorbing and emitting surface (emissivity = 1).
- The wall is non-catalytic, i.e., it does not take part in the reaction.

Since this tutorial serves as a basic model, heat transfer through the wall is neglected. As a result, no further boundary conditions need to be defined.

**Setting Initial Values**

1. Click Global Initialization.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U [m s^{-1}]</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V [m s^{-1}]</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W [m s^{-1}]</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation (Selected)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation &gt; Option</td>
<td>Automatic</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details O2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details O2 &gt; Mass Fraction</td>
<td>0.232*</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details CO2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details CO2 &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details CO2 &gt; Mass Fraction</td>
<td>0.01</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details H2O</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details H2O &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Component Details H2O &gt; Mass Fraction</td>
<td>0.01</td>
</tr>
</tbody>
</table>
Tutorial 18: Combustion and Radiation in a Can Combustor: Obtaining a Solution using ANSYS CFX-Solver Manager

3. Click **OK**.

**Setting Solver Control**

1. Click **Solver Control**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Max. Iterations</td>
<td>100</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Timescale Control</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Physical Timescale</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control &gt; Physical Timescale</td>
<td>0.025 [s]</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Writing the Solver (.def) File**

1. Click **Write Solver File**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>CombustorEDM.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file.

**Obtaining a Solution using ANSYS CFX-Solver Manager**

The ANSYS CFX-Solver Manager will be launched after ANSYS CFX-Pre saves the definition file. You will be able to obtain a solution to the CFD problem by following the instructions below.

**Note:** If a fine mesh is used for a formal quantitative analysis of the flow in the combustor, the solution time will be significantly longer than for the coarse mesh. You can run the simulation in parallel to reduce the solution time. For details, see **Obtaining a Solution in Parallel** (p. 116).

1. Ensure **Define Run** is displayed.
2. **Definition File** should be set to **CombustorEDM.def**.
Tutorial 18: Combustion and Radiation in a Can Combustor: Viewing the Results in ANSYS CFX-Post

2. Click Start Run.
   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed stating that the run has finished.
3. Click Yes to post-process the results.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

When ANSYS CFX-Post opens, experiment with the Edge Angle setting for the Wireframe object and the various rotation and zoom features in order to place the geometry in a sensible position. A setting of about 8.25 should result in a detailed enough geometry for this exercise.

Temperature Within the Domain

1. Create a new plane named Plane 1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Method</td>
<td>ZX Plane</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Mode Variable</td>
<td>Temperature</td>
</tr>
</tbody>
</table>

3. Click Apply.
   The large area of high temperature through most of the vessel is due to forced convection.

Note: Later in this tutorial (see Laminar Flamelet and Discrete Transfer Models (p. 311)), the Laminar Flamelet combustion model will be used to simulate the combustion again, resulting in an even higher concentration of high temperatures throughout the combustor.

The NO Concentration in the Combustor

In the next step you will color Plane 1 by the mass fraction of NO to view the distribution of NO within the domain. The NO concentration is highest in the high temperature region close to the outlet of the domain.

1. Modify the plane named Plane 1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode Variable</td>
<td>NO.Mass Fraction</td>
</tr>
</tbody>
</table>

3. Click Apply.
Printing a Greyscale Graphic

Here you will change the color map (for Plane 1) to a greyscale map. The result will be a plot with different levels of grey representing different mass fractions of NO. This technique is especially useful for printing, to a black and white printer, any image that contains a color map. Conversion to greyscale by conventional means (i.e., using graphics software, or letting the printer do the conversion) will generally cause color legends to change to a non-linear distribution of levels of grey.

1. Modify the plane named Plane 1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Color Map</td>
<td>Inverse Greyscale</td>
</tr>
</tbody>
</table>

3. Click Apply.

Calculating NO Mass Fraction at the Outlet

The emission of pollutants into the atmosphere is always a design consideration for combustion applications. In the next step, you will calculate the mass fraction of NO in the outlet stream.

1. Select Tools > Function Calculator or click the Tools tab and select Function Calculator.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td>Function</td>
<td>massFlowAve</td>
</tr>
<tr>
<td>Location</td>
<td>Location</td>
<td>out</td>
</tr>
<tr>
<td>Variable</td>
<td>Variable</td>
<td>NO.Mass Fraction</td>
</tr>
</tbody>
</table>

3. Click Calculate.

A small amount of NO is released from the outlet of the combustor. This amount is lower than can normally be expected, and is mainly due to the coarse mesh and the short residence times in the combustor.

Viewing Flow Field

To investigate the reasons behind the efficiency of the combustion process, you will next look at the velocity vectors to show the flow field. You may notice a small recirculation in the center of the combustor. Running the problem with a finer mesh would show this region to be a larger recirculation zone. The coarseness of the mesh in this tutorial means that this region of flow is not accurately resolved.

1. Select the Outline tab.
2. Under User Locations and Plots, clear Plane 1.

Plane 1 is no longer visible.
3. Create a new vector named Vector 1.
4. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>Plane 1</td>
</tr>
<tr>
<td>Symbol</td>
<td>Symbol Size</td>
<td>2</td>
</tr>
</tbody>
</table>

5. Click Apply.
6. Create a new plane named Plane 2.
7. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>XY Plane</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Z</td>
<td>0.03</td>
</tr>
<tr>
<td>Plane Bounds</td>
<td>Type</td>
<td>Rectangular</td>
</tr>
<tr>
<td>Plane Bounds</td>
<td>X Size</td>
<td>0.5 [m]</td>
</tr>
<tr>
<td>Plane Bounds</td>
<td>Y Size</td>
<td>0.5 [m]</td>
</tr>
<tr>
<td>Plane Type</td>
<td>Sample</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Plane Type</td>
<td>X Samples</td>
<td>30</td>
</tr>
<tr>
<td>Plane Type</td>
<td>Y Samples</td>
<td>30</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

8. Click Apply.
10. Apply the following setting

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Locations</td>
<td>Plane 2</td>
</tr>
</tbody>
</table>

11. Click Apply.

To view the swirling velocity field, right-click in the viewer and select Predefined Camera > View Towards -Z.

You may also want to turn off the wireframe visibility. In the region near the fuel and air inlets, the swirl component of momentum (theta direction) results in increased mixing with the surrounding fluid and a higher residence time in this region. As a result, more fuel is burned.

Viewing Radiation

Try examining the distribution of Incident Radiation and Radiation Intensity throughout the domain.

When you are finished, quit ANSYS CFX-Post.
In this second part of the tutorial, you will start with the simulation from the first part of the tutorial and modify it to use the Laminar Flamelet combustion and Discrete Transfer radiation models. Running the simulation a second time will demonstrate the differences in the combustion models, including the variance in carbon dioxide distribution, which is shown below.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select **Session > Play Tutorial** from the menu in ANSYS CFX-Pre, then run the session file: `CombustorFlamelet.pre`. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution (p. 314).

Creating a New Simulation

1. If you have not completed the first part of this tutorial, or otherwise do not have the simulation file from the first part, start ANSYS CFX-Pre and then play the session file `CombustorEDM.pre`. The simulation file `CombustorEDM.cfx` will be created.
2. Start ANSYS CFX-Pre (unless it is already running).
3. Select **File > Open Simulation**.
4. Load the simulation named `CombustorEDM.cfx`.
   The simulation from the first part of this tutorial is loaded.
5. Select **File > Save Simulation As**.
Tutorial 18: Combustion and Radiation in a Can Combustor: Laminar Flamelet and Discrete Transfer Models

6. Save the simulation as CombustorFlamelet.cfx.

   This creates a separate simulation file which will be modified to use the Laminar Flamelet and Discrete Transfer models.

Modifying the Reacting Mixture

A flamelet library will be used to create the variable composition mixture.

1. Expand Materials and open Methane Air Mixture for editing.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Reactions List</td>
<td>Methane Air FLL STP and NO PDF</td>
</tr>
</tbody>
</table>

   *. Click to display the Reactions List dialog box, then click Import Library Data and select the appropriate reaction to import.

3. Click OK.

   Note: Some physics validation messages appear after this reaction is selected. In this situation, the messages can be safely ignored as the physics will be corrected once the domains and boundary conditions are modified.

Modifying the Domain

1. Double-click the Default Domain.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid Models</td>
<td>Reaction or Combustion</td>
<td>PDF Flamelet</td>
</tr>
<tr>
<td></td>
<td>Thermal Radiation Model</td>
<td>Discrete Transfer</td>
</tr>
<tr>
<td>Component Details</td>
<td>N2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; N2</td>
<td>Constraint</td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; NO</td>
<td>Transport Equation</td>
</tr>
<tr>
<td></td>
<td>Component Details</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Component Details &gt; (All other components)</td>
<td>Automatic</td>
</tr>
</tbody>
</table>

   *. Select these one at a time and check each of them.

3. Click OK.

Modifying the Boundary Conditions

**Fuel Inlet Boundary**

1. Modify the boundary condition named fuelin.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
3. Click OK.

**Bottom Air Inlet Boundary**

1. Modify the boundary condition named `airin`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td></td>
</tr>
<tr>
<td>Mixture &gt; Option</td>
<td>Fuel</td>
</tr>
<tr>
<td>Component Details</td>
<td>NO</td>
</tr>
<tr>
<td>Component Details &gt; NO &gt; Option</td>
<td>Mass Fraction</td>
</tr>
<tr>
<td>Component Details &gt; NO &gt; Mass Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click OK.

**Side Air Inlet Boundary**

1. Modify the boundary condition named `secairin`.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td></td>
</tr>
<tr>
<td>Mixture &gt; Option</td>
<td>Oxidiser</td>
</tr>
<tr>
<td>Component Details</td>
<td>NO</td>
</tr>
<tr>
<td>Component Details &gt; NO &gt; Option</td>
<td>Mass Fraction</td>
</tr>
<tr>
<td>Component Details &gt; NO &gt; Mass Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click OK.

**Setting Initial Values**

1. Click *Global Initialization*.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td></td>
</tr>
<tr>
<td>Initial Conditions &gt; Component Details</td>
<td>NO</td>
</tr>
<tr>
<td>Initial Conditions &gt; Component Details &gt; NO &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td>Initial Conditions &gt; Component Details &gt; NO &gt; Mass Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click OK.
Tutorial 18: Combustion and Radiation in a Can Combustor: Laminar Flamelet and Discrete Transfer Models

Setting Solver Control

To reduce the amount of CPU time required for solving the radiation equations, you can select to solve them only every 10 iterations.

1. Click **Solver Control**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Options</td>
<td>Dynamic Model Control &gt; Global Dynamic Model Control</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermal Radiation Control</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermal Radiation Control &gt; Iteration Interval</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermal Radiation Control &gt; Iteration Interval &gt; Iteration Interval</td>
<td>10</td>
</tr>
</tbody>
</table>

3. Click **OK**.

Writing the Solver (.def) File

1. Click **Write Solver File**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>CombustorFlamelet.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure **Start Solver Manager** is selected and click **Save**.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution

When ANSYS CFX-Pre has shut down and the ANSYS CFX-Solver Manager has started, obtain a solution to the CFD problem by following the instructions below.

1. Ensure **Define Run** is displayed.
   - **Definition File** should be set to **CombustorFlamelet.def**.
2. Click **Start Run**.
   - ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
3. Click **Yes** to post-process the results.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
Tutorial 18: Combustion and Radiation in a Can Combustor: Laminar Flamelet and Discrete Transfer Models

Viewing the Results

Viewing Temperature within the Domain

1. Create a new plane named Plane 1.

Note: If ANSYS CFX-Post was not closed since CombustorEDM.def was processed, all meshes and locators from that session will be retained and updated when the CombustorFlamelet.def is opened. In this way Plane 1 does not need to be remade.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>ZX Plane</td>
</tr>
<tr>
<td></td>
<td>Definition &gt; Y</td>
<td>0</td>
</tr>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td></td>
<td>Mode &gt; Variable</td>
<td>Temperature</td>
</tr>
</tbody>
</table>

3. Click Apply.

Viewing the NO concentration in the Combustor

1. Modify the plane named Plane 1.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode &gt; Variable</td>
<td>NO.Mass Fraction</td>
</tr>
</tbody>
</table>

3. Click Apply.

Calculating NO Concentration

The next calculation shows the amount of NO at the outlet.

1. Select Tools > Function Calculator or click the Tools tab and select Function Calculator.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function Calculator</td>
<td>Function</td>
<td>massFlowAve</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>out</td>
</tr>
<tr>
<td></td>
<td>Variable</td>
<td>NO.Mass Fraction</td>
</tr>
</tbody>
</table>

3. Click Calculate.

Viewing CO Concentration

The next plot will show the concentration of CO (carbon monoxide), which is a by-product of incomplete combustion and is poisonous in significant concentrations. As you will see, the highest values are very close to the fuel inlet and in the regions of highest temperature.

1. Modify the plane named Plane 1.

2. Apply the following settings
Calculating CO Mass Fraction at the Outlet

In the next step, you will calculate the mass fraction of CO in the outlet stream.

1. Select Tools > Function Calculator or click the Tools tab and select Function Calculator.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td>Function</td>
<td>massFlowAve</td>
</tr>
<tr>
<td>Location</td>
<td></td>
<td>out</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
<td>CO.Mass Fraction</td>
</tr>
</tbody>
</table>

3. Click Calculate.

There is approximately 0.4% CO by mass in the outlet stream.

Further Postprocessing

1. Try putting some plots of your choice into the Viewer. You can plot the concentration of other species and compare values to those found for the Eddy Dissipation model.
2. Examine the distribution of Incident Radiation and Radiation Intensity throughout the domain.
3. Load one combustion model, then load the other using the Add to current results option in the Load Results File dialog box. You can compare both models in the viewer at once, in terms of mass fractions of various materials, as well as total temperature and other relevant measurements.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode &gt; Variable</td>
<td>CO.Mass Fraction</td>
</tr>
<tr>
<td>Range</td>
<td></td>
<td>Local</td>
</tr>
</tbody>
</table>
Tutorial 19: Cavitation Around a Hydrofoil

Introduction

This tutorial includes:

- Tutorial 19 Features (p. 318)
- Overview of the Problem to Solve (p. 319)
- Creating an Initial Simulation (p. 319)
- Obtaining an Initial Solution using ANSYS CFX-Solver Manager (p. 323)
- Viewing the Results of the Initial Simulation (p. 324)
- Preparing a Simulation with Cavitation (p. 326)
- Obtaining a Cavitation Solution using ANSYS CFX-Solver Manager (p. 328)
- Viewing the Results of the Cavitation Simulation (p. 328)

If this is the first tutorial you are working with it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 319).

Sample files referenced by this tutorial include:

- HydrofoilExperimentalCp.csv
- HydrofoilGrid.def
- HydrofoilIni.pre
- Hydrofoil.pre
- HydrofoilIni_001.res
Tutorial 19: Cavitation Around a Hydrofoil: Tutorial 19 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Multiphase</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Symmetry Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Free-Slip</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
<tr>
<td>ANSYS CFX-Solver Manager</td>
<td>Restart</td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Contour</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Line Locator</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Polyline</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Slice Plane</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Streamline</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Vector</td>
</tr>
<tr>
<td></td>
<td>Other</td>
<td>Chart Creation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Data Export</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Printing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Title/Text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Variable Details View</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Modeling flow with cavitation.
- Using vector reduction in ANSYS CFX-Post to clarify a vector plot with many arrows.
- Importing and exporting data along a polyline.
- Plotting computed and experimental results.
Overview of the Problem to Solve

This example demonstrates cavitation in the flow of water around a hydrofoil. A two-dimensional solution is obtained by modeling a thin slice of the hydrofoil and using two symmetry boundary conditions.

In this tutorial, an initial solution with no cavitation is generated to provide an accurate initial guess for a full cavitation solution, which is generated afterwards.

Creating an Initial Simulation

This section describes the step-by-step definition of the flow physics in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: HydrofoilIni.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining an Initial Solution using ANSYS CFX-Solver Manager (p. 323).

Defining the Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type HydrofoilIni.
6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh. The Import Mesh dialog box appears.
2. Apply the following settings
3. Click **Open**.
4. Right-click a blank area in the viewer and select **Predefined Camera > View Towards -Z**.

### Loading Materials

Since this tutorial uses *Water Vapour at 25 C* and *Water at 25 C* you need to load these materials.

1. In the **Outline** tree view, right-click **Materials** and select **Import Library Data**. The **Select Library Data to Import** dialog box is displayed.
2. Expand **Water Data**.
4. Click **OK**.

### Creating the Domain

The fluid domain used for this simulation contains liquid water and water vapour. The volume fractions are initially set so that the domain is filled entirely with liquid.

1. Right click **Simulation** in the **Outline** tree view and ensure that **Automatic Default Domain** is selected. A domain named **Default Domain** should now appear under the **Simulation** branch.
2. Double click **Default Domain** and apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Options</strong></td>
<td>Basic Settings &gt; Fluids List*</td>
<td>Water at 25 C, Water Vapour at 25 C</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>0 [atm]</td>
</tr>
<tr>
<td><strong>Fluid Models</strong></td>
<td>Multiphase Options &gt; Homogeneous Model</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Option</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fluid Temperature</td>
<td>300 [K]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>k-Epsilon</td>
</tr>
</tbody>
</table>

* These two fluids have consistent reference enthalpies.

3. Click **OK**.

### Creating the Boundary Conditions

The simulation requires inlet, outlet, wall and symmetry plane boundary conditions. The regions for these boundary conditions were imported with the grid file.
Inlet Boundary

1. Create a new boundary condition named "Inlet."
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Inlet</td>
</tr>
<tr>
<td>Location</td>
<td>IN</td>
<td></td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Normal Speed</td>
<td>16.91 [m s⁻¹]</td>
</tr>
<tr>
<td>Turbulence</td>
<td>Option</td>
<td>Intensity and Length Scale</td>
</tr>
<tr>
<td>Turbulence</td>
<td>Value</td>
<td>0.03</td>
</tr>
<tr>
<td>Turbulence</td>
<td>Eddy Len. Scale</td>
<td>0.0076 [m]</td>
</tr>
<tr>
<td>Fluid Values</td>
<td>Boundary Conditions</td>
<td>Water at 25°C</td>
</tr>
<tr>
<td>Boundary Conditions</td>
<td>Water at 25°C &gt; Volume Fraction</td>
<td>1</td>
</tr>
<tr>
<td>Boundary Conditions</td>
<td>Water Vapour at 25°C &gt; Volume Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click OK.

Outlet Boundary

1. Create a new boundary condition named "Outlet."
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Outlet</td>
</tr>
<tr>
<td>Location</td>
<td>OUT</td>
<td></td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Static Pressure</td>
</tr>
<tr>
<td>Mass and Momentum</td>
<td>Relative Pressure</td>
<td>51957 [Pa]</td>
</tr>
</tbody>
</table>

3. Click OK.

Free Slip Wall Boundary

1. Create a new boundary condition named "SlipWalls."
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td>Location</td>
<td>BOT, TOP</td>
<td></td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence on Flow</td>
<td>Free Slip</td>
</tr>
</tbody>
</table>

3. Click OK.

Symmetry Plane Boundaries

1. Create a new boundary condition named "Sym1."
2. Apply the following settings
Tutorial 19: Cavitation Around a Hydrofoil: Creating an Initial Simulation

3. Click OK.

1. Create a new boundary condition named Sym2.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SYM1</td>
</tr>
</tbody>
</table>

3. Click OK.

Setting Initial Values

1. Click Global Initialization.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>16.91 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s⁻¹]</td>
</tr>
<tr>
<td>Fluid Settings</td>
<td>Fluid Specific Initialization</td>
<td>Water at 25 C</td>
</tr>
<tr>
<td></td>
<td>Fluid Specific Initialization &gt; Water at 25 C</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Fluid Specific Initialization &gt; Water at 25 C &gt; Initial Conditions &gt; Volume Fraction &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Fluid Specific Initialization &gt; Water at 25 C &gt; Initial Conditions &gt; Volume Fraction &gt; Volume Fraction</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Fluid Specific Initialization</td>
<td>Water Vapour at 25 C</td>
</tr>
<tr>
<td></td>
<td>Fluid Specific Initialization &gt; Water Vapour at 25 C</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Fluid Specific Initialization &gt; Water Vapour at 25 C &gt; Initial Conditions &gt; Volume Fraction &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Fluid Specific Initialization &gt; Water Vapour at 25 C &gt; Initial Conditions &gt; Volume Fraction &gt; Volume Fraction</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Click OK.
Setting Solver Control

1. Click Solver Control.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Max. Iterations</td>
<td>35</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control</td>
<td>Timescale Control</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Fluid Timescale Control</td>
<td>Timescale Control</td>
</tr>
</tbody>
</table>

**Note:** For the Convergence Criteria, an RMS value of at least $1 \times 10^{-5}$ is usually required for adequate convergence, but the default value is sufficient for demonstration purposes.

3. Click OK.

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>HydrofoilIni.def</td>
</tr>
<tr>
<td>Quit CFX-Pre</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. Quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining an Initial Solution using ANSYS CFX-Solver Manager

While the calculations proceed, you can see residual output for various equations in both the text area and the plot area. Use the tabs to switch between different plots (e.g., Momentum and Mass, Turbulence Quantities, etc.) in the plot area. You can view residual plots for the fluid and solid domains separately by editing the workspace properties.

1. Ensure that the Define Run dialog box is displayed.
2. Click Start Run.

ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.

3. Click Yes to post-process the results.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
Viewing the Results of the Initial Simulation

The following topics will be discussed:

- Plotting Pressure Distribution Data (p. 324)
- Exporting Pressure Distribution Data (p. 325)
- Saving the Post-Processing State (p. 326)

Plotting Pressure Distribution Data

In this section, you will create a plot of the pressure coefficient distribution around the hydrofoil. The data will then be exported to a file for later comparison with data from the cavitating flow case, which will be run later in this tutorial.

1. Right-click a blank area in the viewer and select **Predefined Camera > View Towards -Z**.
2. Insert a new plane named **Slice**.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Definition &gt; Method</td>
<td>XY Plane</td>
</tr>
<tr>
<td>Geometry</td>
<td>Definition &gt; Z</td>
<td>5e-5 [m]</td>
</tr>
<tr>
<td>Render</td>
<td>Draw Faces</td>
<td>(Cleared)</td>
</tr>
</tbody>
</table>

4. Click **Apply**.
5. Create a new polyline named **Foil** by selecting **Insert > Location > Polyline** from the main menu.
6. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>Method</td>
<td>Boundary Intersection</td>
</tr>
<tr>
<td>Boundary List</td>
<td>Default Domain Default</td>
<td></td>
</tr>
<tr>
<td>Intersect With</td>
<td>Slice</td>
<td></td>
</tr>
</tbody>
</table>

7. Click **Apply**.
   Zoom in on the center of the hydrofoil (near the cavity) to confirm the polyline wraps around the hydrofoil.
8. Create a new variable named **Pressure Coefficient**.
9. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expression</td>
<td>(Pressure-51957[Pa])/(0.5*996.2[kg m^-3]*16.91[m s^-1]^2)</td>
</tr>
</tbody>
</table>

10. Click **Apply**.
11. Create a new variable named **Chord**.
12. Apply the following settings
This creates a normalized chord, measured in the X direction, ranging from 0 at the leading edge to 1 at the trailing edge of the hydrofoil.

13. Click **Apply**.

**Note:** Although the variables that were just created are only needed at points along the polyline, they exist throughout the domain.

Now that the variables **Chord** and **Pressure Coefficient** exist, they can be associated with the previously defined polyline (the locator) to form a chart line. This chart line will be added to the chart object, which is created next.

1. Select **Insert > Chart** from the main menu.
2. Set the name to **Pressure Coefficient Distribution**.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expression</td>
<td>((X-\text{minVal}(X)@\text{Foil})/(\text{maxVal}(X)@\text{Foil}-\text{minVal}(X)@\text{Foil}))</td>
</tr>
</tbody>
</table>

4. Click **Apply**.
5. The chart appears on the **Chart Viewer** tab.

### Exporting Pressure Distribution Data

You will now export the chord and pressure coefficient data along the polyline. This data will be imported and used in a chart later in this tutorial for comparison with the results for when cavitation is present.

1. Select **File > Export**. The **Export** dialog box appears
2. Apply the following settings
### Saving the Post-Processing State

You will need to save the post-processing state for use later in this tutorial.

1. Select **File > Save State As**.
2. Under **File name** type `cp_plot`, then click **Save**.

In the next part of this tutorial, the solver will be run with cavitation turned on. Similar post-processing follows, and the effect of cavitation on the pressure distribution around the hydrofoil will be illustrated in a chart.

### Preparing a Simulation with Cavitation

Earlier in this tutorial, you ran a simulation without cavitation. The solution from that simulation will serve as the starting point for the next simulation, which involves cavitation.

### Playing a Session File

This section describes the step-by-step definition of the flow physics in ANSYS CFX-Pre. If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select **Session > Play Tutorial** from the menu in ANSYS CFX-Pre, then run the session file: `Hydrofoil.pre`. After you have played the session file as described in earlier tutorials under **Playing the Session File and Starting ANSYS CFX-Solver Manager** (p. 87), proceed to **Obtaining a Cavitation Solution using ANSYS CFX-Solver Manager** (p. 328).

### Modifying the Initial Simulation

1. Start ANSYS CFX-Pre.
2. Select **File > Open Simulation**.
3. Select `HydrofoilIni_001.res` and click **Open**.
4. Save the simulation as `Hydrofoil.cfx`.

### Tab | Setting | Value
---|---|---
Options | File | NoCavCpData.csv
| Locations | Foil
| Export Geometry Information | (Selected)*
| Select Variables | Chord, Pressure Coefficient

* This causes X, Y, Z data to be included in the export file.

3. Click **Save**.

The file `NoCavCpData.csv` will be written in the working directory.
Adding Cavitation

1. Double-click Default Domain in the Outline tree view.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Fluid Pairs &gt; Water at 25 C</td>
<td>Water Vapour at 25 C &gt; Mass Transfer &gt; Cavitation &gt; Saturation Pressure</td>
</tr>
<tr>
<td></td>
<td>Fluid Pairs &gt; Water at 25 C</td>
<td>Water Vapour at 25 C &gt; Mass Transfer &gt; Cavitation &gt; Saturation Pressure</td>
</tr>
</tbody>
</table>

^* Although saturation pressure is optional, it must be set for this example. It is optional because saturation pressure can also be set by setting a homogeneous binary mixture, but one has not been used in this tutorial.

3. Click OK.

Modifying Solver Control

1. Click Solver Control.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Convergence Control &gt; Max. Iterations</td>
<td>150*</td>
</tr>
</tbody>
</table>

^* This allows up to 150 further iterations.

3. Click OK.

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Hydrofoil.def</td>
</tr>
<tr>
<td>Quit CFX-Pre</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

^* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.
Obtaining a Cavitation Solution using ANSYS CFX-Solver Manager

1. Ensure the Define Run dialog box is displayed. Definition File should be set to Hydrofoil.def.
2. Set Initial Values File to HydrofoilIni_001.res. This is the solution from the starting-point run.
3. Click Start Run.
4. You may see a notice that the mesh from the initial values file will be used. This mesh is the same as in the definition file. Click OK to continue. ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
5. Click Yes to post-process the results.
6. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results of the Cavitation Simulation

You will restore the state file saved earlier in this tutorial while preventing the first solution (which has no cavitation) from loading. This will cause the plot of pressure distribution to use data from the currently loaded solution (which has cavitation). Data from the first solution will be added to the chart object by importing NoCavCpData.csv (the file that was exported earlier). A file containing experimental data will also be imported and added to the plot. The resulting chart will show all three sets of data (solver data with cavitation, solver data without cavitation, and experimental data).

Note: The experimental data is provided in <CFXROOT>/examples/HydrofoilExperimentalCp.csv which must be copied to your working directory before proceeding with this part of the tutorial.

Note: If using ANSYS Workbench, the second results file will be loaded into the initial state file, so you will not need to load the initial state file and you may skip the first few steps related to loading Cp_plot.cst.

1. Select File > Load State.
2. Clear Load results.
3. Select Cp_plot.cst.
4. Click Open.
5. Click the Chart Viewer tab.
6. In the Outline workspace, select Report and double-click Pressure Coefficient Distribution.
7. Click the Chart Line 1 tab.
8. Apply the following setting
Tutorial 19: Cavitation Around a Hydrofoil: Viewing the Results of the Cavitation Simulation

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Line 1</td>
<td>Line Name</td>
<td>Solver Cp - with cavitation</td>
</tr>
</tbody>
</table>

This reflects the fact that the user-defined variable Pressure Coefficient is now based on the current results.

9. Click **Apply** to update Chart Line 1.

You will now add the chart line from the first simulation.

10. Create a new polyline named NoCavCpPolyline.

11. Apply the following setting

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Geometry</td>
<td>File</td>
<td>NoCavCpData.csv</td>
</tr>
</tbody>
</table>

12. Click **Apply**.

The data in the file is used to create a polyline with values of Pressure Coefficient and Chord stored at each point on it.

13. In the Outline workspace, select Report and double-click Pressure Coefficient Distribution.

14. Click the Chart Line 1 tab.

15. Click **New Line**.

A new tab named Chart Line 2 replaces the Chart Line 1 tab.

16. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Line 2</td>
<td>Line Name</td>
<td>Solver Cp - no cavitation</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>NoCavCpPolyline</td>
</tr>
<tr>
<td></td>
<td>X Axis &gt; Variable</td>
<td>Chord on NoCavCpPolyline</td>
</tr>
<tr>
<td></td>
<td>Y Axis &gt; Variable</td>
<td>Pressure Coefficient on NoCavCpPolyline</td>
</tr>
</tbody>
</table>

17. Click **Apply**.

The chart line (containing data from the first solution) is created, added to the chart object, and displayed on the Chart Viewer tab.

You will now add a chart line to show experimental results.

18. Click **New Line**.

19. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Line 3</td>
<td>Type</td>
<td>From File</td>
</tr>
<tr>
<td></td>
<td>Line Name</td>
<td>Experimental Cp - with cavitation</td>
</tr>
<tr>
<td></td>
<td>File</td>
<td>HydrofoilExperimentalCp.csv</td>
</tr>
<tr>
<td></td>
<td>Appearance &gt; Line Style</td>
<td>None</td>
</tr>
</tbody>
</table>
20. Click **Apply**.

   The chart line (containing experimental data) is created, added to the chart object, and displayed on the **Chart Viewer** tab.

21. If you wish to print the chart, select **File > Print** from the main menu while the **Chart Viewer** tab is selected. This will allow you to print the chart to an image file.

22. When you are finished, close ANSYS CFX-Post.
Tutorial 20: Fluid Structure Interaction and Mesh Deformation

Introduction

This tutorial includes:

- Tutorial 20 Features (p. 332)
- Overview of the Problem to Solve (p. 333)
- Using CEL Expressions to Govern Mesh Deformation (p. 334)
- Using a Junction Box Routine to Govern Mesh Deformation (p. 343)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:

- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 334).

Sample files referenced by this tutorial include:

- valvefsi
  Copy the contents of this directory (but not the directory itself) into your working directory.
- ValveFSI.pre
- ValveFSI_expressions.ccl
- ValveFSIUserF.pre
- ValveFSI.out
Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Tutorial 20 Features

Tutorial 20 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>None</td>
</tr>
<tr>
<td>Output Control</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CEL (CFX Expression Language)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User Fortran</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Boundary Conditions</td>
<td>Opening</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Symmetry</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall</td>
<td></td>
</tr>
<tr>
<td>Timestep</td>
<td>Transient</td>
<td></td>
</tr>
<tr>
<td>Transient Results File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Animation</td>
</tr>
<tr>
<td></td>
<td>Point</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Slice Plane</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Vector</td>
<td></td>
</tr>
<tr>
<td>Other</td>
<td>Opening</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Symmetry Plane</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall: No Slip</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall: Moving</td>
<td></td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Moving mesh
- Fluid-solid interaction (without modeling solid deformation)
- MPEG creation
- Monitoring points.
Overview of the Problem to Solve

This tutorial involves a moving mesh and a two-way fluid-structure interaction (FSI) between a ball and a fluid in a check valve. The geometry, modeled as a 2-D slice (0.1 mm thick), is displayed below.

Check valves are commonly used to allow uni-directional flow. The check-valve in this tutorial is located on the top of a tank, and acts as a pressure-relieving valve by moving to allow fluid to leave. The ball is connected to a spring that acts to push the ball downward when the ball is raised above the y=0 position. The forces on the ball are the force due to the spring and the force due to fluid flow. Gravity is neglected here for simplicity. The ball is represented as a cavity region in the mesh. The deformation of the ball is not modeled.

The tutorial is divided into two parts. In the first part, the motion of the ball is controlled by CEL expressions which account for the forces acting on the ball, including the force imparted by the flow. In the second part of the tutorial, the motion of the ball is controlled by a Junction Box Routine that updates the ball position at the start of each timestep by loading mesh coordinate files from a set of such files. The mesh coordinate files and required Fortran routines are provided with this tutorial.
Using CEL Expressions to Govern Mesh Deformation

The following topics will be discussed:

- Setting up the Simulation in ANSYS CFX-Pre (p. 334)
- Modeling the Ball Dynamics (p. 334)
- Creating a New Simulation (p. 335)
- Importing the Mesh (p. 335)
- Importing the Required Expressions (p. 336)
- Setting the Simulation Type (p. 336)
- Creating the Domain (p. 336)
- Creating the Subdomain (p. 337)
- Creating the Boundary Conditions (p. 338)
- Setting Initial Values (p. 339)
- Setting Solver Control (p. 340)
- Setting Output Control (p. 340)
- Writing the Solver (.def) File (p. 341)
- Obtaining a Solution using the ANSYS CFX-Solver (p. 341)
- Viewing the Results in ANSYS CFX-Post (p. 341)

Setting up the Simulation in ANSYS CFX-Pre

This section describes the step-by-step definition of the flow physics in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: ValveFSI.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using the ANSYS CFX-Solver (p. 341).

Modeling the Ball Dynamics

When defining your own simulations, the mesh motion may already be known. In such cases, it can be specified explicitly using the CEL. In this tutorial, the mesh motion is not known a-priori, and will be calculated using the forces that act on the ball. The dynamics equation that describes the motion of the ball is considered before setting up the simulation.

According to Newton’s Second Law, the time rate of change in the ball’s linear momentum is proportional to the net force acting on the ball. In differential form, the equation to be solved for the motion of the ball is:

\[ m_{\text{Ball}} \frac{d}{dt}(\text{vel}_{\text{Ball}}) = F_{\text{Flow}} - F_{\text{Spring}} \]  

(Eqn. 1)
where $m_{\text{Ball}}$ is the mass of the ball (which is constant), $v_{\text{elBall}}$ is the velocity of the ball in the y coordinate direction, $F_{\text{Flow}}$ is the flow (viscous and drag) force acting on the ball, and $F_{\text{Spring}}$ is the spring force acting on the ball.

The left hand side of the equation is discretized to include an expression for the new displacement of the ball (relative to the spring’s neutral position). The time derivative of the ball velocity is discretized as:

$$\frac{d(vel_{\text{Ball}})}{dt} = \frac{vel_{\text{Ball,New}} - vel_{\text{Ball,Old}}}{t_{\text{Step}}}$$  \hspace{1cm} \text{(Eqn. 2)}$$

where $vel_{\text{Ball,New}}$ is further discretized as:

$$vel_{\text{Ball,New}} = \frac{d_{\text{Ball,New}} - d_{\text{Ball,Old}}}{t_{\text{Step}}}$$  \hspace{1cm} \text{(Eqn. 3)}$$

The new displacement of the ball also appears in the expression for spring force:

$$F_{\text{Spring}} = k_{\text{Spring}} \times d_{\text{Ball,New}}$$  \hspace{1cm} \text{(Eqn. 4)}$$

The discrete form of the equation of motion for the ball is re-assembled, and the ball displacement is isolated as:

$$d_{\text{Ball,New}} = \left(\frac{F_{\text{Flow}} + \left(\frac{m_{\text{Ball}} \times vel_{\text{Ball,Old}}}{t_{\text{Step}}} + \frac{m_{\text{Ball}} \times d_{\text{Ball,Old}}}{t_{\text{Step}}^2}\right)}{k_{\text{Spring}} + \frac{m_{\text{Ball}}}{t_{\text{Step}}^2}}\right)$$  \hspace{1cm} \text{(Eqn. 5)}$$

No further substitutions are required because all of these quantities are available through the CFX Expression Language as presented below.

Creating a New Simulation
1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type ValveFSI.
6. Click Save.

Importing the Mesh
1. Right-click Mesh and select Import Mesh.
2. Apply the following settings
Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using CEL Expressions to Govern Mesh Deformation

3. Click Open.

Importing the Required Expressions

The expressions created in this step will determine the motion of the ball. These expressions are provided in a CCL file. By importing the expression, you avoid the need to type each of the expressions by hand.

1. Select File > Import CCL.

This file is located in the working directory.

2. Select ValveFSI_expressions.ccl

3. Click Open.

You can review the imported expressions in the tree view.

Setting the Simulation Type

1. Click Simulation Type.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Simulation Type &gt; Option</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Duration &gt; Total Time</td>
<td>tTotal</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Steps &gt; Timesteps</td>
<td>tStep</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Initial Time &gt; Time</td>
<td>0 [s]</td>
</tr>
</tbody>
</table>

3. Click OK.

Note: You may ignore the physics validation message regarding the lack of transient results files. You will set up transient results files later.

Creating the Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.

2. Double click Default Domain and apply the following settings
### Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using CEL Expressions to Govern Mesh Deformation

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>CV3D REGION, CV3D SUB</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Domain Type</td>
<td>Fluid Domain</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Fluids List</td>
<td>Methanol CH4O°</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Mesh Deformation &gt; Option</td>
<td>Regions of Motion Specified</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>Isothermal</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer &gt; Fluid Temperature</td>
<td>25 C</td>
</tr>
</tbody>
</table>

3. **Expand Mesh Motion Model** and ensure that **Mesh Stiffness > Option** is set to **Increase Near Small Volumes**.

4. **Click OK**.

Mesh motion specifications are applied to two and three dimensional regions of the domain (that is, boundaries and subdomains, respectively) as follows:

- The mesh motion specification for the ball will be displacement in the y-direction according to the CEL expression `dBallNew` (which happens to be a single CEL variable).
- The mesh motion specification for the walls of the valve housing will be **Unspecified**. This setting allows the mesh nodes to move freely. The motion of the mesh points on this boundary will be strongly influenced by the motion of the ball. Since the ball moves vertically, the surrounding mesh nodes will also move vertically and will therefore remain on the valve housing. This mesh motion specification helps to preserve the quality of the mesh on the upper surface of the ball.
- The mesh motion specifications for the tank opening and tank volume will be **Stationary**. The stationary tank volume ensures that the mesh does not fold at the sharp corner that exists where the valve joins the tank. The stationary mesh for the tank opening prevents the mesh nodes from moving (if the tank opening had unspecified mesh motion, the mesh nodes on this boundary would move vertically and separate from the non-vertical parts of the boundary.).

### Creating the Subdomain

1. Create a new subdomain named `Tank`.

2. Apply the following settings
Creating the Boundary Conditions

**Ball Boundary**

1. Create a new boundary condition named Ball.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>BALL</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence On Flow &gt; Wall Velocity Relative To</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Wall Influence On Flow &gt; Wall Velocity Relative To &gt; Wall Vel. Rel. To</td>
<td>Mesh Motion</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; Option</td>
<td>Specified Displacement</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; X Component</td>
<td>0 [m]</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; Y Component</td>
<td>dBallNew</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; Z Component</td>
<td>0 [m]</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Symmetry Boundary**

Since a 2D representation of the flow field is being modeled (using a 3D mesh with one element thickness in the Z direction) symmetry boundaries will be created on the low and high Z 2D regions of the mesh.

1. Create a new boundary condition named Sym.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>SYMP1, SYMP2</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Vertical Valve Wall Boundary condition**

1. Create a new boundary condition named ValveVertWalls.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>VPIPE HIGHX, VPIPE LOWX</td>
</tr>
</tbody>
</table>
**Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using CEL Expressions to Govern Mesh Deformation**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td>Wall Influence On Flow &gt; Wall Velocity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Relative To</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall Influence On Flow &gt; Wall Velocity</td>
<td>Boundary Frame</td>
</tr>
<tr>
<td></td>
<td>Relative To &gt; Wall Vel. Rel. To</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; Option</td>
<td>Unspecified</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Tank Opening Boundary**

1. Create a new boundary condition named TankOpen.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>BOTTOM</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Static Pres. (Entrain)</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>6 [atm]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Zero Gradient</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Valve Opening Boundary**

1. Create a new boundary condition named ValveOpen.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>TOP</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass and Momentum &gt; Option</td>
<td>Static Pres. (Entrain)</td>
</tr>
<tr>
<td></td>
<td>Mass and Momentum &gt; Relative Pressure</td>
<td>0 [atm]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Zero Gradient</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; Option</td>
<td>Stationary</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Note:** Opening boundary types are used to allow the flow to leave and re-enter the domain across the inflow and outflow boundaries. This behavior is expected due to the oscillatory motion of the ball and due to the potentially large region of flow re-circulation that will occur on the downstream side of the ball.

**Setting Initial Values**

Since a transient simulation is being modeled, initial values are required for all variables.

1. Click **Global Initialization**
2. Apply the following settings
3. Click **OK**.

### Setting Solver Control

1. Click **Solver Control**.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>0 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0.1 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s⁻¹]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Static Pressure &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Setting Output Control

This step sets up transient results files to be written at set intervals.

1. Click **Output Control**.
2. Click the **Trn Results** tab.
3. Create a new transient result with the default name.
4. Apply the following settings to **Transient Results 1**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Selected Variables</td>
</tr>
<tr>
<td>Output Variables List</td>
<td>Pressure, Velocity</td>
</tr>
<tr>
<td>Output Frequency &gt; Option</td>
<td>Time Interval</td>
</tr>
<tr>
<td>Output Frequency &gt; Time Interval</td>
<td>tStep</td>
</tr>
</tbody>
</table>

5. Click the **Monitor** tab.
6. Select **Monitor Options**.
7. Under **Monitor Points and Expressions**:
Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using CEL Expressions to Govern Mesh Deformation

a. Click Add new item.
b. Set Name to Ball Displacement.
c. Set Option to Expression.
d. Set Expression Value to \( d_{BallOld} \).

8. Click OK.

Writing the Solver (.def) File

1. Click Write Solver File.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>ValveFSI.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If you are notified the file already exists, click Overwrite.
   This file is provided in the tutorial directory and may exist in your working folder if you have copied it there.
5. Quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using the ANSYS CFX-Solver

1. Ensure Define Run is displayed.
2. Click Start Run.
   ANSYS CFX-Solver runs and attempts to obtain a solution. This can take a long time depending on your system. Eventually a dialog box is displayed.
3. Click Yes to post-process the results.
4. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

Creating User Locations and Plots

In the following steps, you will create an XY plane that lies midway between the two symmetry planes. The plane will be used to show mesh movement; it will also serve as a locator for a vector plot that will be used in an animation.

Creating a slice plane

1. Right-click a blank area in the viewer and select Predefined Camera > View Towards -Z.
2. Create a new plane and accept the default name.
3. Apply the following settings
Creating a Point

1. Create a point at \((0, 0.0003, 0.0001)\) using the XYZ method.
   This is a reference point for the low Y point of the ball at timestep 0. Click **Apply**.

2. Click **Timestep Selector** and load the results for a few different timesteps (for example: 0, 10, 20, 50, 90).
   You will see the ball in different positions. The mesh deformation will also be visible.

   The maximum displacement occurs at around 20 timesteps (as was shown in the ANSYS CFX-Solver Manager), which is before the ball reaches equilibrium.

Creating an Animation with Velocity Vectors

You will create a vector plot and create an animation showing the velocity in the domain as the ball is displaced.

1. Clear the visibility check box next to **Plane 1**.

2. Create a vector plot, set **Locations** to **Plane 1** and leave **Variable** set to **Velocity**. Click **Apply**.

3. Using the timestep selector, load time value 0.

4. Click **Animation** found in the toolbar.
   The **Animation** dialog box appears.

5. In the **Animation** dialog box:
   a. Select **Keyframe Animation**.
   b. Click **New** to create **KeyframeNo1**.
   c. Highlight **KeyframeNo1**, then change **# of Frames** to 148.
      This will produce an animation keyframe at each timestep, resulting in an MPEG that plays for just over six seconds.

6. Load the last timestep (150) using the timestep selector.

7. In the **Animation** dialog box:
   a. Click **New** to create **KeyframeNo2**.
      The **# of Frames** parameter has no effect for the last keyframe, so leave it at the default value.
   b. Click **More Animation Options** to expand the **Animation** dialog box.
   c. Click the **Options** button.
   d. On the **Options** tab, change **MPEG Size** to **720 X 480** (NTSC).
   e. Click the **Advanced** tab, then set **Quality** to **Custom**.
   f. Clear **Variable Bit Rate** and set **Bit Rate** to **3000000**.
This limits the bit rate so that the movie will play in most players. You can lower this value if your player cannot handle this bit rate.

g. Click **OK**.

h. Select **Save MPEG**.

i. Click **Browse** next to the MPEG file name and set a file name for the MPEG file. If the file path is not given, the file will be saved in the working directory.

j. Click **Save**. This sets the MPEG file name and path, but does not create the MPEG.

k. Frame 1 is not loaded (The loaded frame is shown in the middle of the **Animation** dialog box, beside **F:**). Click **To Beginning** to load it, then wait a few seconds for the frame to load.

l. Click **Play the animation**.

The MPEG is created as the animation proceeds. This will be slow, since a timestep must be loaded and objects must be created for each frame. To view the MPEG file, you need to use a viewer that supports the MPEG format.

8. When you have finished, exit from ANSYS CFX-Post.

### Using a Junction Box Routine to Govern Mesh Deformation

In this part of the tutorial, a Junction Box Routine will be used to read in a sequence of meshes, causing a sinusoidal motion of the ball. The meshes are provided for convenience; they were generated based on the following expression for displacement of the ball in the y direction as a function of time:

\[ \text{1[mm]} \times (1 - \cos(2\pi \cdot t / (20 \times \text{tStep}))) \]

This is an alternative to using CEL expressions to govern mesh deformation.

**Important:** You must have the required Fortran compiler installed and set in your system path in order to run this part of the tutorial. For details on which Fortran compiler is required for your platform, see the applicable ANSYS, Inc. installation guide. If you are not sure which Fortran compiler is installed on your system, try running the `cfx5mkext` command (found in `<CFXROOT>/bin`) from the command line and read the output messages.

The following topics will be discussed:

- Setting up the Simulation in ANSYS CFX-Pre (p. 344)
- Creating a New Simulation (p. 345)
- Creating the Required Expressions (p. 345)
- Importing the Initial Mesh (p. 346)
- Defining the Junction Box Routine (p. 346)
- Setting Up the Junction Box Routine (p. 347)
- Setting the Simulation Type (p. 347)
- Creating the Domain (p. 348)
- Creating the Boundary Conditions (p. 348)
- Setting Initial Values (p. 350)
Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using a Junction Box Routine to Govern Mesh

- Setting Solver Control (p. 350)
- Setting Output Control (p. 350)
- Writing the Solver (.def) File (p. 351)
- Obtaining a Solution using the ANSYS CFX-Solver (p. 351)
- Analyzing the Fluid Flow Force on the Ball (p. 351)

Setting up the Simulation in ANSYS CFX-Pre

This section describes the step-by-step definition of the flow physics in ANSYS CFX-Pre.

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: ValveFSIUserF.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using the ANSYS CFX-Solver (p. 351).

Important: You must have the required Fortran compiler installed and set in your system path in order to run the session file successfully. For details on which Fortran compiler is required for your platform, see the applicable ANSYS, Inc. installation guide. If you are not sure which Fortran compiler is installed on your system, try running the cfx5mkext command (found in <CFXROOT>/bin) from the command line and read the output messages.

Preparing the Working Directory

To prepare the working directory, copy the files and sub-directories contained in <CFXROOT>/examples/valvefsi into your working directory (Do not copy the valvefsi directory itself).

The working directory should now contain the initial mesh file (ValveFSI.out), plus two sub-directories. The meshes sub-directory contains meshes for one period of ball motion, with an amplitude of 1 mm, in the sequence of files DefaultDomain.0 to DefaultDomain.19. The juncbox sub-directory contains the Fortran source files that are used in the Junction Box Routine that will read the sequence of mesh files. The subroutines contained in these files are summarized as follows:

- update_mesh_user: Highest level Junction Box Routine that is responsible for replacing the mesh coordinates inside ANSYS CFx with the updated coordinates read in or defined by the low level routine, set_mesh_user.
- set_mesh_user: Low level routine that defines the updated mesh coordinates. In this tutorial, this is done by reading mesh files. In other applications, however, this could be done by using a set of Fortran commands that directly modify the existing mesh coordinates.
- update_crdvx_user and upd_crdvx_user: Routines to call for the generation of a node map between the initial mesh and the first user-defined mesh, and to repeatedly use this map to replace the mesh inside ANSYS CFX with the remaining sequence of user-defined meshes.

Two important attributes of the sequence of meshes read by the SET_MESH_USER routine warrant highlighting:
1. The coordinates of the first mesh in the sequence must be identical to the initial solver-internal mesh coordinates. This ensures that a node map between the user and initial solver-internal mesh coordinates can be generated.

2. The topology (i.e., connectivity) of all meshes in the sequence does not change. This ensures that the map between the user and solver-internal mesh coordinate can be re-used.

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select **File > New Simulation**.
3. Select **General** and click **OK**.
4. Select **File > Save Simulation As**.
5. Under **File name**, type `ValveFSIUser`.
6. Click **Save**.

Creating the Required Expressions

The expressions created in this step are used for the simulation setup and for monitoring values during the solution process.

**Force on the ball due to fluid flow**

The creation of this expression is very simple, as CFX Expression Language (CEL) provides a way to calculate directional force on any region.

1. Click **Expression**.
2. Set **Name** to `FFlow` then click **OK**.
3. Under **Definition**, enter the following expression:
   `force_y()@Ball`
4. Click **Apply**.

**Total simulation time**

The period of oscillation for the ball will be 1e-3 s (20 timesteps of 5e-5 s each), and a total of two periods will be simulated.

1. Click **Expression**.
2. Set **Name** to `tTotal` then click **OK**.
3. Under **Definition**, enter the following expression:
   `2e-3 [s]`
4. Click **Apply**.

**Timestep**

1. Click **Expression**.
2. Set **Name** to `tStep` then click **OK**.
3. Under **Definition**, enter the following expression:
   `5e-5 [s]`
4. Click **Apply**.
Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using a Junction Box Routine to Govern Mesh

Importing the Initial Mesh

1. On the Outline tab, right-click Mesh and select Import Mesh.
2. Change File type to PATRAN Neutral.
3. Select the file ValveFSI.out and change Mesh Units to [mm].
4. Click Open.

Defining the Junction Box Routine

In this part of the tutorial, you will run the cfx5mkext command to compile and link the provided Fortran routines. The resulting objects and libraries will be used later by ANSYS CFX-Solver.

*Important:* You must have the required Fortran compiler installed and set in your system path in order to run the cfx5mkext command successfully. For details on which Fortran compiler is required for your platform, see the applicable ANSYS, Inc. installation guide. If you are not sure which Fortran compiler is installed on your system, try running the cfx5mkext command (found in `<CFXROOT>/bin`) from the command line and read the output messages.

1. Select Tools > Command Editor.
2. Type the following in the Command Editor dialog box (make sure you do not miss the semi-colon at the end of the line):

```
! system ('cfx5mkext -name meshread juncbox/*.F') < 1 or die;
```

   - This is equivalent to executing the following at an OS command prompt:
     
     cfx5mkext -name meshread juncbox/*.F
   
   - The ! indicates that the following line is to be interpreted as power syntax and not CCL. Everything after the ! symbol is processed as Perl commands.
   
   - system is a Perl function to execute a system command.
   
   - < 1 or die will cause an error message to be returned if, for some reason, there is an error in processing the command.

3. Click Process to compile the subroutine.
4. Click Clear to remove all text from the command editor.

A subdirectory whose name is system dependent will be created in your working directory (For example, on IRIX a subdirectory named irix will be created in your working directory.). This subdirectory contains the shared object library named meshread.

*Note:* You can introduce the -double option to compile the subroutines for use with double precision ANSYS CFX-Solver executables.

*Note:* If you are running problems in parallel over multiple platforms then you will need to create these subdirectories using the cfx5mkext Command for each different platform.

The following steps create a CCL object that specifies the path to the meshes directory and the number of meshes. The Fortran subroutine later looks up the values contained in this object so that it can determine where the meshes are located, and how many exist.
5. Type the following CCL into the Command Editor dialog box, replacing <filepath> with the path to your current directory.

    USER:
    MeshDir = <filepath>/meshes
    NMeshes = 20
    END

6. Click Process.

Setting Up the Junction Box Routine

1. Click User Routine.
2. Set Name to Mesh Read then click OK.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>Junction Box Routine</td>
</tr>
<tr>
<td></td>
<td>Calling Name</td>
<td>update_mesh_user</td>
</tr>
<tr>
<td></td>
<td>Library Name</td>
<td>meshread</td>
</tr>
<tr>
<td></td>
<td>Library Path</td>
<td>(current working directory)</td>
</tr>
<tr>
<td></td>
<td>Junction Box Location</td>
<td>Start of Time Step</td>
</tr>
</tbody>
</table>

4. Click OK.

Setting the Simulation Type

1. Click Simulation Type.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Simulation Type &gt; Option</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Duration &gt; Option</td>
<td>Total Time</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Duration &gt; Total Time</td>
<td>tTotal</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Steps &gt; Option</td>
<td>Timesteps</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Steps &gt; Timesteps</td>
<td>tStep</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Initial Time &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Initial Time &gt; Time</td>
<td>0 [s]</td>
</tr>
</tbody>
</table>

3. Click OK.

Note: Instead of saving transient results files, you will use a monitor point to track the force on ball due to the flow. For this reason, you may ignore the physics validation message regarding the lack of transient results files.
Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using a Junction Box Routine to Govern Mesh

Creating the Domain

1. Right click Simulation in the Outline tree view and ensure that Automatic Default Domain is selected. A domain named Default Domain should now appear under the Simulation branch.
2. Double click Default Domain and apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Basic Settings &gt; Location</td>
<td>CV3D REGION, CV3D SUB</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Domain Type</td>
<td>Fluid Domain</td>
</tr>
<tr>
<td></td>
<td>Basic Settings &gt; Fluids List</td>
<td>Methanol CH4O*</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Pressure</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Mesh Deformation &gt;</td>
<td>Junction Box Routine</td>
</tr>
<tr>
<td></td>
<td>Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Mesh Deformation &gt;</td>
<td>Mesh Read</td>
</tr>
<tr>
<td></td>
<td>Junction Box Routine</td>
<td></td>
</tr>
</tbody>
</table>

* Click the Ellipsis icon to open the Fluids List dialog box, then click Import Library Data to open the Select Library Data to Import dialog box. In that dialog box, expand Constant Property Liquids in the tree, then select Methanol CH4O and click OK. Next, select Methanol CH4O in the Fluids List dialog box and click OK.
3. Click OK.

Creating the Boundary Conditions

**Boundary for the ball**

1. Create a new boundary condition named Ball.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>BALL</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall Influence on Flow &gt; Option</td>
<td>No Slip</td>
</tr>
<tr>
<td></td>
<td>Wall Velocity Relative To</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Wall Velocity Relative To &gt; Wall Vel. Rel. To</td>
<td>Mesh Motion</td>
</tr>
</tbody>
</table>

3. Click OK.

**Symmetry Boundary**

Since a 2D representation of the flow field is being modeled (using a 3D mesh with one element thickness in the Z direction) symmetry boundaries will be created on the low and high Z 2D regions of the mesh.
1. Create a new boundary condition named Sym.
2. Apply the following settings
3. Click OK.

### Tank Opening Boundary
1. Create a new boundary condition named TankOpen.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>BOTTOM</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass And Momentum &gt; Option</td>
<td>Static Pres. (Entrain)</td>
</tr>
<tr>
<td></td>
<td>Relative Pressure</td>
<td>6 [atm]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Zero Gradient</td>
</tr>
</tbody>
</table>

3. Click OK.

### Valve Opening Boundary
1. Create a new boundary condition named ValveOpen.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Opening</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>TOP</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mass And Momentum &gt; Option</td>
<td>Static Pres. (Entrain)</td>
</tr>
<tr>
<td></td>
<td>Relative Pressure</td>
<td>0 [atm]</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>Zero Gradient</td>
</tr>
</tbody>
</table>

3. Click OK.

**Note:** Opening boundary types are used to allow the flow to leave and re-enter the domain across the inflow and outflow boundaries. This behavior is expected due to the oscillatory motion of the ball and due to the potentially large region of flow re-circulation that will occur on the downstream side of the ball.

### Remaining Wall Boundary
1. On the Outline tab, double-click Default Domain Default.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Details</td>
<td>Wall Influence on Flow &gt; Option</td>
<td>No Slip</td>
</tr>
<tr>
<td></td>
<td>Wall Velocity Relative To</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Wall Velocity Relative To &gt; Wall Vel. Rel. To</td>
<td>Boundary Frame</td>
</tr>
</tbody>
</table>

3. Click OK.
Tutorial 20: Fluid Structure Interaction and Mesh Deformation: Using a Junction Box Routine to Govern Mesh

Setting Initial Values

1. Click Global Initialization.

   Since a transient simulation is being modeled, initial values are required for all variables.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0.1 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Static Pressure &gt; Option</td>
<td>Automatic with Value</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Static Pressure &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Turbulence Eddy Dissipation &gt; Option</td>
<td>Automatic with Value</td>
</tr>
</tbody>
</table>

3. Click OK.

Setting Solver Control

1. Click Solver Control.

2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Transient Scheme &gt; Option</td>
<td>Second Order Backward Euler</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Minimum Number of Coefficient Loops</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Minimum Number of Coefficient Loops &gt; Min. Coeff. Loops</td>
<td>2^*</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Max. Coeff. Loops</td>
<td>5</td>
</tr>
</tbody>
</table>

* This setting is optional. The default value of 1 is also acceptable.

3. Click OK.

Setting Output Control

A monitor point will be used to monitor the values of Flow at each timestep.

1. Click Output Control.

2. Click the Monitor tab.
3. Select Monitor Options.
4. Under Monitor Points and Expressions:
   a. Click New.
   b. Set Name to force on ball due to flow.
   c. Set Option to Expression and Expression Value to FFlow.
5. Click OK.

Writing the Solver (.def) File

1. Click Write Solver File.
   
   **Note:** Transient results files are not required for this specific simulation, so you may disregard the physics validation message and click Yes in the summary dialog box.

2. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>ValveFSIUserF.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

   * If using ANSYS CFX-Pre in Standalone Mode.

3. Ensure Start Solver Manager is selected and click Save.
4. If using Standalone Mode, quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.

Obtaining a Solution using the ANSYS CFX-Solver

   When the ANSYS CFX-Solver Manager starts:
   1. Click Start Run. The ANSYS CFX-Solver will calculate the solution.
   2. Click Yes to post-process the results when the completion message appears at the end of the run.
   3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Analyzing the Fluid Flow Force on the Ball

   In the ANSYS CFX-Solver Manager, click the User Points tab and observe the plot for the monitored value of FFlow (force imparted on the ball by the flow) as the solution develops. Using the mouse, click on various points on the curve.
Tutorial 21: Oscillating Plate with Two-Way Fluid-Structure Interaction

Introduction

This tutorial includes:
- Tutorial 21 Features (p. 354)
- Overview of the Problem to Solve (p. 355)
- Setting up the Solid Physics in Simulation (ANSYS Workbench) (p. 355)
- Setting up the Fluid Physics and ANSYS Multi-field Settings in ANSYS CFX-Pre (p. 358)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 364)
- Viewing Results in ANSYS CFX-Post (p. 365)

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Unless you plan on running a session file, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 358).

Sample files referenced by this tutorial include:
- OscillatingPlate.pre
- OscillatingPlate.agdb
- OscillatingPlate.gtm
- OscillatingPlate.inp
Tutorial 21: Oscillating Plate with Two-Way Fluid-Structure Interaction: Tutorial 21 Features

Tutorial 21 Features

This tutorial addresses the following features of ANSYS CFX.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>General Mode</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ANSYS Multi-field</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>Laminar</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>None</td>
</tr>
<tr>
<td>Output Control</td>
<td>Monitor Points</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Transient Results File</td>
<td></td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Wall: Mesh Motion = ANSYS MultiField</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall: No Slip</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wall: Adiabatic</td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Plots</td>
<td>Animation</td>
</tr>
<tr>
<td></td>
<td>Plots</td>
<td>Contour</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Vector</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:
- Moving mesh
- Fluid-solid interaction (including modeling solid deformation using ANSYS)
- Running an ANSYS Multi-field (MFX) simulation
- Post-processing two results files simultaneously.

Overview of the Problem to Solve

This tutorial uses a simple oscillating plate example to demonstrate how to set up and run a simulation involving two-way Fluid-Structure Interaction, where the fluid physics is solved in ANSYS CFX and the solid physics is solved in the FEA package ANSYS. Coupling between the two solvers is required throughout the solution to model the interaction between fluid and solid as time progresses, and the framework for the coupling is provided by the ANSYS Multi-field solver, using the MFX setup.
The geometry consists of a 2D closed cavity. A thin plate is anchored to the bottom of the cavity as shown below:

An initial pressure of 100 Pa is applied to one side of the thin plate for 0.5 seconds in order to distort it. Once this pressure is released, the plate oscillates backwards and forwards as it attempts to regain its equilibrium (vertical) position. The surrounding fluid damps the oscillations, which therefore have an amplitude that decreases in time. The CFX Solver calculates how the fluid responds to the motion of the plate, and the ANSYS Solver calculates how the plate deforms as a result of both the initial applied pressure and the pressure resulting from the presence of the fluid. Coupling between the two solvers is required since the solid deformation affects the fluid solution, and the fluid solution affects the solid deformation.

The tutorial describes the setup and execution of the calculation including the setup of the solid physics in Simulation (within ANSYS Workbench) and the setup of the fluid physics and ANSYS Multi-field settings in ANSYS CFX-Pre. If you do not have ANSYS Workbench, then you can use the provided ANSYS input file to avoid the need for Simulation.

Setting up the Solid Physics in Simulation (ANSYS Workbench)

This section describes the step-by-step definition of the solid physics in Simulation within ANSYS Workbench that will result in the creation of an ANSYS input file OscillatingPlate.inp. If you prefer, you can instead use the provided OscillatingPlate.inp file and continue from Setting up the Fluid Physics and ANSYS Multi-field Settings in ANSYS CFX-Pre (p. 358).

Creating a New Simulation

1. If required, launch ANSYS Workbench.
2. Click Empty Project. The Project page appears displaying an unsaved project.
3. Select File > Save or click Save .
4. If required, set the path location to a different folder. The default location is your working directory. However, if you have a specific folder that you want to use to store files created during this tutorial, change the path.
5. Under File name, type OscillatingPlate.
Creating the Solid Material

1. When Simulation opens, expand Geometry in the project tree at the left hand side of the Simulation window.
2. Select Solid, and in the Details view below, select Material.
3. Use the arrow that appears next to the material name Structural Steel to select New Material.
4. When the Engineering Data window opens, right-click New Material from the tree view and rename it to Plate.

5. Enter 2.5e06 for Young’s Modulus, 0.35 for Poisson’s Ratio and 2550 for Density. Note that the other properties are not used for this simulation, and that the units for these values are implied by the global units in Simulation.

6. Click the Simulation tab near the top of the Workbench window to return to the simulation.

Basic Analysis Settings

The ANSYS Multi-field simulation is a transient mechanical analysis, with a timestep of 0.1 s and a time duration of 5 s.

1. Select New Analysis > Flexible Dynamic from the toolbar.
2. Select Analysis Settings from the tree view and in the Details view below, set Auto Time Stepping to Off.
3. Set **Time Step** to 0.1.
4. Under **Tabular Data** at the bottom right of the window, set **End Time** to 5.0 for the **Steps = 1** setting.

Inserting Loads

Loads are applied to an FEA analysis as the equivalent of boundary conditions in ANSYS CFX. In this section, you will set a fixed support, a fluid-solid interface, and a pressure load.

**Fixed Support**

The fixed support is required to hold the bottom of the thin plate in place.

1. Right-click **Flexible Dynamic** in the tree and select **Insert > Fixed Support** from the shortcut menu.
2. Rotate the geometry using the **Rotate** button so that the bottom (low-y) face of the solid is visible, then select **Face** and click the low-y face. That face should be highlighted to indicate selection.
3. Ensure **Fixed Support** is selected in the **Outline** view, then, in the **Details** view, select **Geometry** and click **1 Face** to make the **Apply** button appear (if necessary). Click **Apply** to set the fixed support.

**Fluid-Solid Interface**

It is necessary to define the region in the solid that defines the interface between the fluid in CFX and the solid in ANSYS. Data is exchanged across this interface during the execution of the simulation.

1. Right-click **Flexible Dynamic** in the tree and select **Insert > Fluid Solid Interface** from the shortcut menu.
2. Using the same face-selection procedure described earlier, select the three faces of the geometry that form the interface between the solid and the fluid (low-x, high-y and high-x faces) by holding down <Ctrl> to select multiple faces. Note that this load is automatically given an interface number of 1.

**Pressure Load**

The pressure load provides the initial additional pressure of 100 [Pa] for the first 0.5 seconds of the simulation. It is defined using a step function.

1. Right-click **Flexible Dynamic** in the tree and select **Insert > Pressure** from the shortcut menu.
2. Select the low-x face for **Geometry**.
3. In the **Details** view, select **Magnitude**, and using the arrow that appears, select **Tabular (Time)**.
4. Under **Tabular Data**, set a pressure of 100 in the table row corresponding to a time of 0.

**Note:** The units for time and pressure in this table are the global units of [s] and [Pa], respectively.
5. You now need to add two new rows to the table. This can be done by typing the new time and pressure data into the empty row at the bottom of the table, and Simulation will automatically re-order the table in order of time value. Enter a pressure of 100 for a time value of 0.499, and a pressure of 0 for a time value of 0.5.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Time</th>
<th>Pressure</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>100.0</td>
</tr>
<tr>
<td>2</td>
<td>0.499</td>
<td>100.0</td>
</tr>
<tr>
<td>3</td>
<td>0.5</td>
<td>0.0</td>
</tr>
<tr>
<td>4</td>
<td>5.0</td>
<td>0.0</td>
</tr>
</tbody>
</table>

This gives a step function for pressure that can be seen in the chart to the left of the table.

Writing the ANSYS Input File

The Simulation settings are now complete. An ANSYS Multi-field run cannot be launched from within Simulation, so the Solve buttons cannot be used to obtain a solution.

1. Instead, highlight Solution in the tree, select Tools > Write ANSYS Input File and choose to write the solution setup to the file OscillatingPlate.inp.
2. The mesh is automatically generated as part of this process. If you want to examine it, select Mesh from the tree.
3. Save the Simulation database, use the tab near the top of the Workbench window to return to the Oscillating Plate [Project] tab, and save the project itself.

Setting up the Fluid Physics and ANSYS Multi-field Settings in ANSYS CFX-Pre

This section describes the step-by-step definition of the flow physics and ANSYS Multi-field settings in ANSYS CFX-Pre.

Playing a Session File

If you want to skip past these instructions and to have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: OscillatingPlate.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 364).

Creating a New Simulation

1. Start ANSYS CFX-Pre.
2. Select File > New Simulation.
3. Select General and click OK.
4. Select File > Save Simulation As.
5. Under File name, type OscillatingPlate.
6. Click Save.

Importing the Mesh

1. Right-click Mesh and select Import Mesh.
2. Select the provided mesh file, OscillatingPlate.gtm and click Open.

**Note:** The file that was just created in Simulation, OscillatingPlate.inp, will be used as an input file for the ANSYS Solver.

Setting the Simulation Type

A transient ANSYS Multi-field run executes as a series of timesteps. The Simulation Type tab is used both to enable an ANSYS Multi-field run and to specify the time-related settings for it (in the External Solver Coupling settings). The ANSYS input file is read by ANSYS CFX-Pre so that it knows which Fluid Solid Interfaces are available.

Once the timesteps and time duration are specified for the ANSYS Multi-field run (coupling run), ANSYS CFX automatically picks up these settings and it is not possible to set the timestep and time duration independently. Hence the only option available for Time Duration is Coupling Time Duration, and similarly for the related settings Time Step and Initial Time.

1. Click Simulation Type.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>External Solver Coupling &gt; Option</td>
<td>ANSYS MultiField</td>
</tr>
<tr>
<td></td>
<td>External Solver Coupling &gt; ANSYS Input File</td>
<td>OscillatingPlate.inp*</td>
</tr>
<tr>
<td></td>
<td>Coupling Time Control &gt; Coupling Time Duration &gt; Total Time</td>
<td>5 [s]</td>
</tr>
<tr>
<td></td>
<td>Coupling Time Control &gt; Coupling Time Steps &gt; Option</td>
<td>Timesteps</td>
</tr>
<tr>
<td></td>
<td>Coupling Time Control &gt; Coupling Time Steps &gt; Timesteps</td>
<td>0.1 [s]</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Option</td>
<td>Transient</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Duration &gt; Option</td>
<td>Coupling Time Duration</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Time Steps &gt; Option</td>
<td>Coupling Time Steps</td>
</tr>
<tr>
<td></td>
<td>Simulation Type &gt; Initial Time &gt; Option</td>
<td>Coupling Initial Time</td>
</tr>
</tbody>
</table>

* This file is located in your working directory.
3. Click OK.

**Note:** You may see a physics validation message related to the difference in the units used in ANSYS CFX-Pre and the units contained within the ANSYS input file. While it is important to review the units used in any simulation, you should be aware that, in this specific case, the message is not crucial as it is related to temperature units and there is no heat transfer in this case. Therefore, this specific tutorial will not be affected by the physics message.

### Creating the Fluid

A custom fluid is created with user-specified properties.

1. Click **Material**.
2. Set the name of the new material to **Fluid**.
3. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Option</td>
<td>Pure Substance</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Thermodynamic State &gt; Thermodynamic State</td>
<td>Liquid</td>
</tr>
<tr>
<td>Material Properties</td>
<td>Equation of State &gt; Molar Mass</td>
<td>1 [kg kmol(^{-1})]</td>
</tr>
<tr>
<td></td>
<td>Equation of State &gt; Density</td>
<td>1 [kg m(^{-3})]</td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Dynamic Viscosity</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Transport Properties &gt; Dynamic Viscosity &gt; Dynamic Viscosity</td>
<td>0.2 [Pa s]</td>
</tr>
</tbody>
</table>

4. Click **OK**.

### Creating the Domain

In order to allow the ANSYS Solver to communicate mesh displacements to the CFX Solver, mesh motion must be activated in CFX.

1. Right click **Simulation** in the Outline tree view and ensure that **Automatic Default Domain** is selected. A domain named Default Domain should now appear under the Simulation branch.
2. Double click **Default Domain** and apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Options</td>
<td>Fluid List</td>
<td>Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Pressure &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td></td>
<td>Domain Models &gt; Mesh Deformation &gt; Option</td>
<td>Regions of Motion Specified</td>
</tr>
<tr>
<td>Fluid Models</td>
<td>Heat Transfer &gt; Option</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Turbulence &gt; Option</td>
<td>None (Laminar)</td>
</tr>
</tbody>
</table>

3. Click **OK**.
Creating the Boundary Conditions

In addition to the symmetry conditions, another type of boundary condition corresponding with the interaction between the solid and the fluid is required in this tutorial.

The interface between ANSYS and CFX is defined as an external boundary in CFX that has its mesh displacement being defined by the ANSYS Multi-field coupling process. When an ANSYS Multi-field specification is being made in ANSYS CFX-Pre, it is necessary to provide the name and number of the matching Fluid Solid Interface that was created in Simulation. Since the interface number in Simulation was 1, the name in question is FSIN_1. (If the interface number had been 2, then the name would have been FSIN_2, and so on.) On this boundary, CFX will send ANSYS the forces on the interface, and ANSYS will send back the total mesh displacement it calculates given the forces passed from CFX and the other defined loads.

1. Create a new boundary condition named Interface.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Wall</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Interface</td>
</tr>
<tr>
<td>Boundary Details</td>
<td>Mesh Motion &gt; Option</td>
<td>ANSYS MultiField</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; Receive From ANSYS</td>
<td>Total Mesh</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; ANSYS Interface</td>
<td>FSIN_1</td>
</tr>
<tr>
<td></td>
<td>Mesh Motion &gt; Send to ANSYS</td>
<td>Total Force</td>
</tr>
</tbody>
</table>

3. Click OK.

Since a 2D representation of the flow field is being modeled (using a 3D mesh with one element thickness in the Z direction) symmetry boundaries will be created on the low and high Z 2D regions of the mesh.

1. Create a new boundary condition named Sym1.
2. Apply the following settings

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Sym1</td>
</tr>
</tbody>
</table>

3. Click OK.
4. Create a new boundary condition named Sym2.
5. Apply the following settings
6. Click OK.

Setting Initial Values

Since a transient simulation is being modeled, initial values are required for all variables.

1. Click Global Initialization.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Boundary Type</td>
<td>Symmetry</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>Sym2</td>
</tr>
<tr>
<td>Global Settings</td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; U</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; V</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Cartesian Velocity Components &gt; W</td>
<td>0 [m s^-1]</td>
</tr>
<tr>
<td></td>
<td>Initial Conditions &gt; Static Pressure &gt; Relative Pressure</td>
<td>0 [Pa]</td>
</tr>
</tbody>
</table>

3. Click OK.

Setting Solver Control

Various ANSYS Multi-field settings are contained under Solver Control under the External Coupling tab. Most of these settings do not need to be changed for this simulation.

Within each timestep, a series of “coupling” or “stagger” iterations are performed to ensure that CFX, ANSYS and the data exchanged between the two solvers are all consistent. Within each stagger iteration, ANSYS and CFX both run once each, but which one runs first is a user-specifiable setting. In general, it is slightly more efficient to choose the solver that drives the simulation to run first. In this case, the simulation is being driven by the initial pressure applied in ANSYS, so ANSYS is set to solve before CFX within each stagger iteration.

1. Click Solver Control.
2. Apply the following settings:
3. Click **OK**.

### Setting Output Control

This step sets up transient results files to be written at set intervals.

1. Click **Output Control**.
2. On the **Trn Results** tab, create a new transient result with the default name.
3. Apply the following settings to **Transient Results 1**:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Settings</td>
<td>Transient Scheme &gt; Option</td>
<td>Second Order Backward Euler</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Minimum Number of Coefficient Loops</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Minimum Number of Coefficient Loops &gt; Min. Coeff. Loops</td>
<td>2*</td>
</tr>
<tr>
<td></td>
<td>Convergence Control &gt; Max. Coefficient Loops</td>
<td>3</td>
</tr>
<tr>
<td>External Coupling</td>
<td>Coupling Step Control &gt; Solution</td>
<td>Before CFX Fields</td>
</tr>
<tr>
<td></td>
<td>Sequence Control &gt; Solve ANSYS Fields</td>
<td></td>
</tr>
</tbody>
</table>

* This setting is optional. The default value of 1 is also acceptable.

4. Click the **Monitor** tab.
5. Select **Monitor Options**.
6. Under **Monitor Points and Expressions**:
   a. Click **Add new item** and accept the default name.
   b. Set **Option** to **Cartesian Coordinates**.
   c. Set **Output Variables List** to **Total Mesh Displacement X**.
   d. Set **Cartesian Coordinates** to **[0, 1, 0]**.
7. Click **OK**.

### Writing the Solver (.def) File

1. Click **Write Solver File**.
2. If the **Physics Validation Summary** dialog box appears, click **Yes** to proceed.
3. Apply the following settings
### Obtaining a Solution using ANSYS CFX-Solver Manager

The execution of an ANSYS Multi-field simulation requires both the CFX and ANSYS solvers to be running and communicating with each other. ANSYS CFX-Solver Manager can be used to launch both solvers and to monitor the output from both.

1. Ensure the Define Run dialog box is displayed.
   - There is a new MultiField tab which contains settings specific for an ANSYS Multi-field simulation.
2. On the MultiField tab, check that the ANSYS input file location is correct (the location is recorded in the definition file but may need to be changed if you have moved files around).
3. On UNIX systems, you may need to manually specify where the ANSYS installation is if it is not in the default location. In this case, you must provide the path to the v110/ansys directory.
4. Click Start Run.

The run begins by some initial processing of the ANSYS Multi-field input which results in the creation of a file containing the necessary multi-field commands for ANSYS, and then the ANSYS Solver is started. The CFX Solver is then started in such a way that it knows how to communicate with the ANSYS Solver.

After the run is under way, two new plots appear in ANSYS CFX-Solver Manager:

- **ANSYS Field Solver (Structural)** This plot is produced only when the solid physics is set to use large displacements or when other non-linear analyses are performed. It shows convergence of the ANSYS Solver. Full details of the quantities are described in the ANSYS user documentation. In general, the CRIT quantities are the convergence criteria for each relevant variable, and the L2 quantities represent the L2 Norm of the relevant variable. For convergence, the L2 Norm should be below the criteria. The x-axis of the plot is the cumulative iteration number for ANSYS, which does not correspond to either timesteps or stagger iterations. Several ANSYS iterations will be performed for each timestep, depending on how quickly ANSYS converges. You will usually see a somewhat “spiky” plot, as each quantity will be unconverged at the start of each timestep, and then convergence will improve.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>OscillatingPlate.def</td>
</tr>
<tr>
<td>Quit CFX-Pre*</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>

* If using ANSYS CFX-Pre in Standalone Mode.

4. Ensure **Start Solver Manager** is selected and click **Save**.
5. If you are notified the file already exists, click **Overwrite**. This file is provided in the tutorial directory and will exist in your working folder if you have copied it there.
6. Quit ANSYS CFX-Pre, saving the simulation (.cfx) file at your discretion.
Tutorial 21: Oscillating Plate with Two-Way Fluid-Structure Interaction: Viewing Results in ANSYS CFX-Post

- **ANSYS Interface Loads (Structural)** This plot shows the convergence for each quantity that is part of the data exchanged between the CFX and ANSYS Solvers. In this case, four lines appear, corresponding to two force components (FX and FY) and two displacement components (UX and UY). Since the analysis is 2D, FZ and UZ are not exchanged. Each quantity is converged when the plot shows a negative value. The x-axis of the plot corresponds to the cumulative number of stagger iterations (coupling iterations) and there are several of these for every timestep. Again, a spiky plot is expected as the quantities will not be converged at the start of a timestep.

The ANSYS out file is displayed in ANSYS CFX-Solver Manager as an extra tab. Similar to the CFX out file, this is a text file recording output from ANSYS as the solution progresses.

1. Click the **User Points** tab and watch how the top of the plate displaces as the solution develops.
2. When the solvers have finished and ANSYS CFX-Solver Manager puts up a dialog box to tell you this, click **Yes** to post-process the results.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

**Viewing Results in ANSYS CFX-Post**

For an ANSYS Multi-field run, both the CFX and ANSYS results files will be opened up in ANSYS CFX-Post by default if ANSYS CFX-Post is started from a finished run in ANSYS CFX-Solver Manager.

**Plotting Results on the Solid**

When ANSYS CFX-Post reads an ANSYS results file, all the ANSYS variables are available to plot on the solid, including stresses and strains. The mesh regions available for plots by default are limited to the full boundary of the solid, plus certain named regions which are automatically created when particular types of load are added in Simulation. For example, any Fluid Solid Interface will have a corresponding mesh region with a name such as FSIN1. In this case, there is also a named region corresponding to the location of the fixed support, but in general pressure loads do not result in a named region.

You can add extra mesh regions for plotting by creating named selections in Simulation - see the Simulation product documentation for more details. Note that the named selection must have a name which contains only English letters, numbers and underscores for the named mesh region to be successfully created.

Note that when ANSYS CFX-Post loads an ANSYS results file, the true global range for each variable is not automatically calculated, as this would add a substantial amount of time onto how long it takes to load such a file (you can turn on this calculation using **Edit > Options** and using the **Pre-calculate variable global ranges** setting under **CFX-Post > Files**). When the global range is first used for plotting a variable, it is calculated as the range within the current timestep. As subsequent timesteps are loaded into ANSYS CFX-Post, the Global Range is extended each time variable values are found outside the previous Global Range.
1. Turn on the visibility of Boundary ANSYS (under ANSYS > Domain ANSYS).

2. Right-click a blank area in the viewer and select Predefined Camera > View Towards -Z. Zoom into the plate to see it clearly.

3. Apply the following settings to Boundary ANSYS:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td>Variable</td>
<td>Von Mises Stress</td>
<td></td>
</tr>
</tbody>
</table>

4. Click Apply.

5. Select Tools > Timestep Selector from the task bar to open the Timestep Selector dialog box. Notice that a separate list of timesteps is available for each results file loaded, although for this case the lists are the same. By default, Sync Cases is set to By Time Value which means that each time you change the timestep for one results file, ANSYS CFX-Post will automatically load the results corresponding to the same time value for all other results files.


7. Change to a time value of 1 [s] and click Apply.

The corresponding transient results are loaded and you can see the mesh move in both the CFX and ANSYS regions.

1. Clear the visibility check box of Boundary ANSYS.

2. Create a contour plot, set Locations to Boundary ANSYS and Sym2, and set Variable to Total Mesh Displacement. Click Apply.

3. Using the timestep selector, load time value 1.1 [s] (which is where the maximum total mesh displacement occurs).

This verifies that the contours of Total Mesh Displacement are continuous through both the ANSYS and CFX regions.

Many FSI cases will have only relatively small mesh displacements, which can make visualization of the mesh displacement difficult. ANSYS CFX-Post allows you to visually magnify the mesh deformation for ease of viewing such displacements. Although it is not strictly necessary for this case, which has mesh displacements which are easily visible unmagnified, this is illustrated by the next few instructions.

1. Using the timestep selector, load time value 0.1 [s] (which has a much smaller mesh displacement than the currently loaded timestep).

2. Place the mouse over somewhere in the viewer where the background color is showing. Right-click and select Deformation > Auto. Notice that the mesh displacements are now exaggerated. The Auto setting is calculated to make the largest mesh displacement a fixed percentage of the domain size.

3. To return the deformations to their true scale, right-click and select Deformation > True Scale.

Creating an Animation

1. Using the Timestep Selector dialog box, ensure the time value of 0.1 [s] is loaded.
2. Clear the visibility check box of Contour 1.
3. Turn on the visibility of Sym2.
4. Apply the following settings to Sym2.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Mode</td>
<td>Variable</td>
</tr>
<tr>
<td>Variable</td>
<td>Pressure</td>
<td></td>
</tr>
</tbody>
</table>

5. Click Apply.
6. Create a vector plot, set Locations to Sym1 and leave Variable set to Velocity. Set Color to be Constant and choose black. Click Apply.
7. Select the visibility check box of Boundary ANSYS, and set Color to a constant blue.
8. Click Animation.
   The Animation dialog box appears.
9. Select Keyframe Animation.
10. In the Animation dialog box:
    a. Click New to create KeyframeNo1.
    b. Highlight KeyframeNo1, then change # of Frames to 48.
    c. Load the last timestep (50) using the timestep selector.
    d. Click New to create KeyframeNo2.
       The # of Frames parameter has no effect for the last keyframe, so leave it at the default value.
    e. Select Save MPEG.
    f. Click Browse next to the MPEG file data box to set a path and file name for the MPEG file.
       If the file path is not given, the file will be saved in the directory from which ANSYS CFX-Post was launched.
    g. Click Save.
       The MPEG file name (including path) will be set, but the MPEG will not be created yet.
    h. Frame 1 is not loaded (The loaded frame is shown in the middle of the Animation dialog box, beside F). Click To Beginning to load it then wait a few seconds for the frame to load.
    i. Click Play the animation.
       The MPEG will be created as the animation proceeds. This will be slow, since a timestep must be loaded and objects must be created for each frame. To view the MPEG file, you need to use a viewer that supports the MPEG format.
11. When you have finished, exit ANSYS CFX-Post.
Tutorial 22: Optimizing Flow in a Static Mixer

Introduction

ANSYS DesignXplorer (DX) is a Workbench component that you can use to examine the effect of changing parameters in a system. In this example, you will see how changing the geometry of the mixer and the input velocity of two fluids at two different temperatures into the mixer changes the effectiveness of the mixing. The measure of the mixing will be the output temperature.

DesignXplorer is a demonstration feature in this release. Refer to the ANSYS CFX Release Notes for more information about using DesignXplorer.

This tutorial includes:
- Tutorial 22 Features (p. 370)
- Overview of the Problem to Solve (p. 370)
- Creating the Project (p. 371)
- Creating the Mesh (p. 377)
- Overview of ANSYS CFX-Pre (p. 380)
- Running Design Studies in DesignXplorer (p. 387).

If this is the first tutorial you are working with, it is important to review the following topics before beginning:
- Setting the Working Directory (p. 1)
- Changing the Display Colors (p. 2)

Sample files referenced by this tutorial include:
- StaticMixerDX.pre
- StaticMixerDX.cmdb
Tutorial 22: Optimizing Flow in a Static Mixer: Tutorial 22 Features

Tutorial 22 Features

This tutorial addresses the following features of ANSYS CFX:

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Modeler</td>
<td>Geometry Creation</td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Mesh</td>
<td>Mesh Creation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Named Selections</td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>Quick Setup Wizard</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Fluid Type</td>
<td>General Fluid</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Turbulence Model</td>
<td>k-Epsilon</td>
</tr>
<tr>
<td></td>
<td>Heat Transfer</td>
<td>Thermal Energy</td>
</tr>
<tr>
<td></td>
<td>Boundary Conditions</td>
<td>Inlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Outlet (Subsonic)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: No-Slip</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wall: Adiabatic</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Time Scale</td>
</tr>
</tbody>
</table>

In this tutorial you will learn about:

- Creating a geometry in DesignModeler and a mesh in CFX-Mesh.
- Using Quick Setup mode in ANSYS CFX-Pre to set up a problem.
- Using DesignXplorer to vary characteristics of the problem to see how you can improve the results.

Note: This tutorial assumes that you are familiar with the controls that enable you to change the orientation of the object in the Graphics window. If this is not the case, you should review Tutorial 1: Simulating Flow in a Static Mixer Using CFX in Standalone Mode.

Overview of the Problem to Solve

This tutorial simulates a static mixer consisting of two inlet pipes delivering water into a mixing vessel; the water exits through an outlet pipe. A general workflow is established for analyzing the flow of fluid into and out of a mixer.

Initially, water enters through both pipes at the same rate but at different temperatures. The first entry is at a variable rate that has an initial value of 2 m/s and a temperature of 315 K. The second entry is at a variable rate that also has an initial value of 2 m/s at a temperature of 285 K. The radius of the mixer is 2 m.
Creating the Project

To create the project:

1. In your file system, create a working directory for your project files.
2. Open ANSYS Workbench, go to Start > All Programs > ANSYS 11.0 > ANSYS Workbench.
   Workbench displays the Start Page.
   DesignXplorer is available only on Windows.
3. From the bottom of the Start dialog, under Tools, select Options.
4. Select Common Settings > Geometry Import.
   Set the following four values to make named selections and parameters available to DesignXplorer:
   - Parameter Processing = Yes
   - Personal Parameter Key = <blank>
   - Named Selection Processing = Yes
   - Named Selection Prefixes = <blank>
5. Select Meshing > CFX-Mesh Options > Volume Mesh and confirm that Volume Mesh Output is set to ADD to CMDB File.
7. Click OK.
8. Restart Workbench to apply the new settings.
9. When Workbench restarts, create a new project by selecting Empty Project from the New section of the Start Page. (Depending on which modules are available, you may find that you need to scroll down to see the Empty Project icon.)

![Static Mixer with 2 Inlet Pipes and 1 Outlet Pipe](image)

This tutorial begins by showing geometry creation and meshing. The following features are illustrated:

- Basic geometry creation, including Revolve and Extrude operations
- Basic meshing operations.
Tutorial 22: Optimizing Flow in a Static Mixer: Creating the Geometry

The Project Page appears, containing an unsaved project.
10. The next step is to save your project. Select File > Save As, and save the project as StaticMixerDX.wbldb in your working directory. This directory will be the default location for all of the project file that you create during the tutorial.

Creating the Geometry

Now you can open DesignModeler in order to start creating the geometry.

Opening DesignModeler

1. In the left pane of the Project Page, click New geometry (under Create DesignModeler Geometry).

DesignModeler loads and displays a window for selecting the desired length unit.
2. In the popup window, select Meter as the desired length unit and click OK. (Note that this window will not appear if you have previously set a default unit of measurement.)

Creating the Solid

You create geometry in DesignModeler by creating two dimensional sketches and extruding, revolving, sweeping, or lofting these to add or remove material. To create the main body of the Static Mixer, you draw a sketch of a cross-section and revolve it.

1. In the Tree Outline, click ZXPlane.

Each sketch is created in a plane. By selecting ZXPlane before creating a sketch, you ensure that the sketch you are about to create is based on the ZXPlane.
2. Click New Sketch on the Active Plane/Sketch Toolbar, which is located above the Graphics window.
3. In the Tree Outline, click Sketch1.
4. Select the Sketching tab (below the Tree Outline) to view the available Sketching ToolBoxes.

Setting Up the Grid

Before starting your sketch, it helps to set up a grid of lines on the plane in which the sketch will be drawn. The presence of the grid allows the precise positioning of points (when Snap is enabled).

1. Click Settings (in the Sketching tab) to open the Settings Toolbox.
2. Click Grid and select Show in 2D and Snap.
3. Click Major Grid Spacing and set it to 1.
4. Click Minor-Steps per Major and set it to 2.
5. To see the effect of changing Minor-Steps per Major, click the right-mouse button to the top left of the plane center in the Graphics window and drag a box over the origin to zoom into the middle of the grid. When you release the mouse button, the model is magnified to show the selected area.

![Image](image-url)

You now have a grid of squares with the smallest squares being 50 cm across. Because Snap is enabled, you can select only points that are on this grid to build your geometry; this can often help to position objects correctly.

Creating the Basic Geometry

Start by creating the main body of the mixer:

1. From the Sketching tab, select the Draw Toolbox.
2. Click Polyline and then create the shape shown below as follows:
   a. Click on the grid in the position where one of the points from the shape needs to be placed (it does not matter which point, but a suggested order is given in the graphic below).
   b. Click on each successive point to make the shape.
      If at any point you click on the wrong place, click with the right-mouse button over the Graphics window and select Back from the shortcut menu to undo the point selection.
   c. To close the polyline after selecting the last point, right-click and choose Closed End from the shortcut menu.

The information of the new sketch, Sketch1, appears in the Details View. Note that the longest straight line (4 m long) in the diagram below is along the z-axis (located at x = 0 m).
Revolving the Sketch

You will now create the main body of the mixer by revolving the new sketch around the Z-axis.

1. Click Revolve from the toolbar above the Graphics window.
   Details of the Revolve operation are shown in the Details View at the bottom left of the window. Leave the name of the Revolve as the default, Revolve1. The Base Object defines the sketch to be revolved. Select Sketch1.

2. In the Details View you should see Apply and Cancel buttons next to the Axis parameter; if those buttons are not displayed, click on the word Axis.
   In the Graphics window, click on the grid line that is aligned with the X-axis of the plane represented by a red arrow (the X-axis of the plane is aligned with the global Z-axis), then click Apply in the Details View. The text next to Axis now changes to Selected.

3. Leave Operation set to Add Material because you need to create a solid. Ensure that Angle is set to 360 degrees and leave the other settings at their defaults.

4. To activate the revolve operation, click Generate. You can select this from the 3D Features Toolbar or from the shortcut menu by right-clicking in the graphics window.

After generation, you should find you have a solid as shown below.

Create the First Inlet Pipe

To create the inlet pipes, you will create two sketches and extrude them. For clear viewing of the grid during sketching, you will hide the previously created geometry.

1. In the Tree Outline, click on the plus sign next to 1 Part, 1 Body to expand the tree structure.

2. Right-click on Solid and select Hide Body.

3. Select ZXPlane in the Tree Outline.

4. Click New Sketch on the Active Plane/Sketch Toolbar.

5. Select the Sketching tab.

6. Create a circle as shown in the figure below:
   a. Select the Draw Toolbox.
   b. Select Circle, click on the grid to mark the center of the circle and then drag the mouse to define the radius. You may select an arbitrary radius.
7. Select the **Dimensions** Toolbox, select **General**, click on the circle in the sketch, then click near the circle to set a dimension. In the **Details View**, click the checkbox beside **D1**. When prompted, rename the parameter to **in1diameter** and click **OK**. This dimension will be a parameter that is modified in DesignXplorer.

Extrude the First Side-pipe

To create the first side-pipe extrude the sketch:

1. Click **Extrude** from the 3D Features tool bar, located above the Graphics window.
2. In the Details View, change **Direction** to **Reversed**. Changing this parameter reverses the direction of the extrusion.
3. Change **Depth** to **3** (meters) and press Enter to set this value. All other settings can remain at their default values. The **Add Material** setting indicates that material is added to the existing solid, rather than a new solid being created.
4. To perform the extrude operation, click **Generate**.

Make the Solid Visible

To see the result of the previous operation, make the solid visible again:

1. In the Tree Outline, right-click **Solid** and select **Show Body**.
2. Click and hold the middle mouse button over the middle of the Graphics window and drag the mouse to rotate the model. The solid should be similar to the one shown below. A discrepancy with the size of the inlet pipe diameters may be visible but is not of concern.

3. Right-click **Solid** and select **Hide Body**.
Create the Second Inlet Pipe

You will create the second inlet so that the relative angle between the two inlets is controlled parametrically, enabling you to evaluate the effects of different relative inlet angles:

1. In the Tree Outline, select ZXPlane.
2. Click New Plane. The new plane (Plane4) appears in the Tree Outline.
3. In the Details View, click beside Transform 1 (RMB) and choose the axis about which you want to rotate the inlet: Rotate about X.
4. Click the checkbox in the FD1, Value 1 field. This sets the angle of rotation of this plane as a new design parameter. When prompted, set the name to in2angle and click OK.
5. Click Generate.
6. In the Tree Outline click on Plane4, then create a new sketch (sketch 3) based on this plane by clicking New Sketch on the Active Plane/Sketch Toolbar.
7. Select the Sketching tab.
8. Click on Settings (in the Sketching tab) to open the Settings Toolbox.
9. Click on Grid and select Show in 2D and Snap.
10. Click on Major Grid Spacing and set it to 1.
11. Click on Minor-Steps per Major and set it to 2.
12. Right-click over the Graphics window and select Isometric View to put the sketch back into a sensible viewing position.
13. From the Draw Toolbox, select Circle and create a circle as shown below:

```
14. Select the Dimensions Toolbox, click General, click on the circle in the sketch, then click near the circle to set a dimension. In the Details View, click the checkbox under Dimensions. When prompted to create a new design parameter, name the parameter in2diameter and click OK.
15. Click Extrude from the 3D Features Toolbox.
16. In the Details View, ensure Direction is set to Normal in order to extrude in the same direction as the plane normal.
17. Ensure that Depth is set to 3 (meters). Leave the other settings at their defaults.
```
18. To activate the extrude operation, click Generate.
19. Right-click Solid in the Tree Outline and select Show Body.
   The geometry is now complete.
20. Select File > Save and type in StaticMixerDX.agdb, then click Save.

**Experiment with the Second Inlet Pipe**

You can rotate the axis of the new plane manually to see the mixer with a range of different inlet angles for the second inlet:

1. In the Tree Outline, click on Plane4.
2. In the Details View, clear the check box in the FD1, Value 1 field, then type in a value of 45 and click Generate to see the new orientation of the second inlet.
3. Repeat the previous step with a value of -45.
4. Re-enable the check box in the FD1, Value 1 field and click Generate; the value automatically resets to 0.

**Create Named Selections**

To create the Named Selections:

1. Orient the static mixer so that you can see the inlet that has the lowest value of Y-coordinate. (You can rotate the mixer by holding down the middle-mouse button or the mouse scroll wheel.)
2. Highlight the inlet by left-clicking the inlet face, then right-click on the inlet and select Named Selection.
3. In the Details View, click Apply, then rename the Named Selection to: in1
4. Click Generate.
5. Orient the static mixer so that you can see the inlet that has the highest value of Y-coordinate.
6. Highlight the inlet by left-clicking the inlet face, then right-click on the inlet and select Named Selection.
7. In the Details View, click Apply, then rename the Named Selection to: in2
8. Click Generate.
9. Orient the static mixer so that you can see the outlet.
10. Highlight the outlet by left-clicking the outlet face, then right-click on the outlet and select Named Selection.
11. In the Details View, click Apply, then rename the Named Selection to: out
12. Click Generate.
13. Click File > Save.

**Creating the Mesh**

In order to create a mesh using CFX-Mesh, you take a geometry from DesignModeler then:

1. Define the Mesh Attributes.
2. Create the Surface Mesh (this is optional).
3. Create the Volume Mesh.

The creation of the surface mesh is optional; if it is not created explicitly, then it will be
generated as part of the creation of the volume mesh.

Starting CFX-Mesh

To start CFX-Mesh:
1. At the top of the ANSYS Workbench window, click StaticMixerDX [Project] to return to
the Project Page.
2. Ensure that the Design Modeler Geometry object (the .agdb file) is selected.
3. In the left pane, near the top under DesignModeler Tasks, click New Mesh.
[Meshing] opens, then [CFX-Mesh] opens. At first glance, [CFX-Mesh] looks very
similar to DesignModeler.

Define the Mesh Attributes

You will set a single size for all of the elements in this tutorial:
1. In the Tree View, in Mesh > Spacing, click Default Body Spacing.
2. In the Details View, confirm that Maximum Spacing is set to 0.3 m. This is a coarse
length scale for this model, but is reasonable for a first run to generate an approximate
solution and to test that the model is working correctly.

If you had to change the setting, select the new value, press Enter to set it, then press
Enter again to commit the new value.

Generate the Surface Mesh

You will now have a look at the surface mesh to see the effect of the chosen length scale.
1. In the Tree View, click on the plus sign next to Preview to open it up.
2. Right-click Default Preview Group and select Generate Surface Meshes. The Default
Preview Group always contains all faces in the geometry, so the mesh will be generated
everywhere.

During the generation of the surface mesh, the progress displays in the status bar in the
bottom right of the CFX-Mesh window.

Note: You can modify the way that the mesh is displayed by clicking on Preview in the Tree
View and changing the options shown in the Details View. For example, by changing the
Display Mode you can switch to display the mesh in Wire Mesh rather than with solid faces.
Simply click on the name Default Preview Group to redisplay the surface mesh using the
new settings.
It is not necessary to create the surface mesh within CFX-Mesh because it will be generated automatically when you create the volume mesh. However, it is generally a good idea to check the surface mesh before creating the volume mesh, to ensure that any settings you have made have the desired effect.

The volume mesh and all of the region information required for ANSYS CFX-Pre is stored in a Meshing file that has a `.cmdb` file extension. This file is read into ANSYS CFX-Pre at the start of the simulation definition.

To generate the volume mesh:

1. In the Tree View, right-click on Mesh and select Generate Volume Mesh.

   During the generation of the volume mesh, the progress displays in the status bar in the bottom right of the CFX-Mesh window. When the volume mesh is complete, the status bar disappears and you will be able to take control of the user interface again.

   The mesh is now complete.

2. Select File > Save to save the meshing database as `StaticMixerDX.cmdb` in the same directory as the other project files.

3. Click StaticMixerDX [Project] to return to the Project page.

4. Select File > Save All to save all the project files used in this tutorial.
Because you are starting with the mesh you just created, you can immediately use ANSYS CFX-Pre to define the simulation. This is how ANSYS CFX-Pre looks with an imported mesh:

In the image above, the left pane of ANSYS CFX-Pre displays the **Simulation Definition**.

**Note:** In this documentation, the details view can also be referenced by the name of the object being edited, followed by the word “details view” (for example, if you double-click the **Wireframe** object, the **Wireframe details view** appears).

**Creating a New Simulation**

Before importing and working with a mesh, a simulation needs to be started. You can define a simulation quickly by using Quick Setup mode:

1. Click on the StaticMixerDX workbench project (the .wbdb file on the project page), then in the left pane under **Advanced CFD**, click **Start CFX-Pre**. After a few moments, the [**Advanced CFD**] tab appears.
2. Select **File > New Simulation**.
3. In the **New Simulation** dialog, select **Quick Setup** and click **OK**. If an information popup appears, click **OK**.
4. Select **File > Save Simulation As**.
5. Under **File name**, type: `StaticMixerDX.cfx` and click **Save**.
Tutorial 22: Optimizing Flow in a Static Mixer: Overview of ANSYS CFX-Pre

The tab name changes to StaticMixerDX [Advanced CFD].

Setting the Physics Definition and Importing the Mesh

You need to specify the use of a prepared fluid, Water, which is defined to be water at 25°C, then select the mesh to import:

1. Ensure that Simulation Definition is displayed at the top of the Details View.
2. Under Fluid Data > Fluid select Water.
   The Import Mesh dialog box appears.
5. From your working directory, select StaticMixerDX.cmdb.
6. Click Open.
   The mesh loads.
7. Click Next.

Defining Model Data

You need to define the type of flow and the physical models to use in the fluid domain. Turbulence is modeled using the $k$-$\varepsilon$ turbulence model and heat transfer using the thermal energy model. The $k$-$\varepsilon$ turbulence model is a commonly used model and is suitable for a wide range of applications. The thermal energy model neglects high speed energy effects and is therefore suitable for low speed flow applications.

1. Ensure that Physics Definition is displayed.
2. Under Model Data, set Reference Pressure to 1 [atm].
   All other pressure settings are relative to this reference pressure.
4. Set Turbulence to $k$-Epsilon.
5. Click Next.

Defining Boundaries

The CFD model requires the definition of conditions on the boundaries of the domain. Define two inlet boundaries and one outlet boundary based on Figure 1 (p. 371).

1. Ensure that Boundary Definition is displayed.
2. If Inlet is displayed, right-click and select Delete.
3. Right-click in the selector area, then select New.
4. Set Name to in1.
5. Click OK.
   The boundary is created and, when selected, properties related to that boundary are displayed.
Setting Boundary Data

Once boundaries are created, you need to set the associated data. Based on Figure 1 (p. 371), define the first inlet boundary:

1. Ensure that **Boundary Data** is displayed.
2. Set **Boundary Type** to *Inlet*.
3. Set **Location** to *in1*.

Once boundary data is defined, the boundary needs to have the flow specification assigned. The first inlet boundary condition has a velocity that you will set to a variable called *in1Vel*.

1. Ensure that **Flow Specification** is displayed.
2. Set **Option** to *Normal Speed*.
3. Set **Normal Speed** to as follows:
   a. Click on the input field to display the *Enter Expression* icon .
   b. Click *Enter Expression*.
   c. Type in: *in1Vel*

Once flow specification is defined, the boundary needs to have temperature assigned. Set the first inlet boundary condition to have a temperature of 315 [K] at one of the side inlets:

1. Ensure that **Temperature Specification** is displayed.
2. Set **Static Temperature** to 315 [K].

Review the boundary *in1* settings for accuracy. They should be as follows:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>in1</td>
</tr>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td></td>
<td>Normal Speed</td>
<td><em>in1Vel</em></td>
</tr>
<tr>
<td>Temperature Specification</td>
<td>Static Temperature</td>
<td>315 [K]</td>
</tr>
</tbody>
</table>

Creating the Second Inlet Boundary Definition

Now that the first boundary has been created, the same concepts can be applied to specifying the second inlet boundary. Based on Figure 1 (p. 371), you know the second inlet boundary condition consists of a velocity of *in2Vel* and a temperature of 285 K at the other of the side inlets. Define that now:

1. Under **Boundary Definition**, right-click in the selector area and select **New**.
2. Create a new boundary named *in2* with these settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Data</td>
<td>Boundary Type</td>
<td>inlet</td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>in2</td>
</tr>
</tbody>
</table>
3. There are no further boundary conditions that need to be set; click Next.

Moving to General Mode

You will now switch to general mode and make further adjustments to the simulation definition before saving the solver definition file.

1. Set Operation to Enter General Mode and click Finish.

The three boundary conditions are displayed in the viewer as sets of arrows at the boundary surfaces. Inlet boundary arrows are directed into the domain. Outlet boundary arrows are directed out of the domain.

There are error messages about "Bad expression values".

2. When the Outline workspace appears, right-click Default Domain and select Rename from the shortcut menu.

3. Set the name to StaticMixerDX and click OK.

Create the Expressions

You have parameters set to variables, but those variables have not yet been defined. This has resulted in error messages under the Graphics window.

Define the variables as expressions as follows:

1. Create two new expressions named in1Vel and in2Vel:
   a. In the Tree Outline, expand Expressions, Functions and Variables and right-click Expression > Insert > Expression.
   b. Give the new expression the name: in1Vel
   c. In the Definition area, type: 2 [m s^{-1}]
      Click Apply.
   d. Right-click on in1Vel tab and select Duplicate. Name the new expression in2Vel.
      When you click OK, notice that the error messages disappear.

2. Right-click in1Vel and select Use as DX Parameter. Do the same for in2Vel. A small "P" appears on each expression’s icon.

Setting the Solver Controls

Solver Control parameters control aspects of the numerical solution generation process.

While an upwind advection scheme is less accurate than other advection schemes, it is also more robust. This advection scheme is suitable for obtaining an initial set of results, but in general should not be used to obtain final results.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flow Specification</td>
<td>Option</td>
<td>Normal Speed</td>
</tr>
<tr>
<td>Normal Speed</td>
<td>in2Vel</td>
<td></td>
</tr>
<tr>
<td>Temperature Specification</td>
<td>Static Temperature</td>
<td>285 [K]</td>
</tr>
</tbody>
</table>
Tutorial 22: Optimizing Flow in a Static Mixer: Overview of ANSYS CFX-Pre

The time scale can be calculated automatically by the solver or set manually. The Automatic option tends to be conservative, leading to reliable, but often slow, convergence. It is often possible to accelerate convergence by applying a time scale factor or by choosing a manual value that is more aggressive than the Automatic option. In this tutorial, you will select a physical time scale, leading to convergence that is twice as fast as the Automatic option.

1. Click Solver Control.
2. On the Basic Settings tab, set Advection Scheme > Option to Upwind.
3. Set Convergence Control > Fluid Timescale Control > Timescale Control to Physical Timescale and set the physical timescale value to 2 [s].
4. Click OK.

Writing the Solver (.def) File

You are now ready to write the definition file (which contains the information required by the ANSYS CFX-Solver for this CFD analysis), save the simulation file (File > Save Simulation) and start ANSYS CFX-Solver Manager. The simulation file, StaticMixerDX.cfx, contains the simulation definition in a format that can be loaded by ANSYS CFX-Pre, allowing you to complete (if applicable), restore, and modify the simulation definition. The simulation file differs from the definition file in two important ways:

• The simulation file can be saved at any time while defining the simulation.
• Mesh data is not contained in the simulation file; the simulation file references the original mesh file(s).

1. Click File > Save Simulation to save StaticMixerDX.cfx, the simulation file.
2. Click Write Solver File.
   The Write Solver File dialog box is displayed.
3. If required, set File name to StaticMixerDX.def.
4. Ensure that Start Solver Manager is selected.
5. Click Save.
6. If you are notified the file already exists, click Overwrite.
7. If prompted, click Yes to save StaticMixer.cfx.
   The definition file (StaticMixer.def) and the simulation file (StaticMixer.cfx) are created. ANSYS CFX-Solver Manager automatically starts and the definition file is set in the Define Run dialog box.

Starting the Run

The Define Run dialog box allows configuration of a run for processing by ANSYS CFX-Solver.
When ANSYS CFX-Solver Manager is launched automatically from ANSYS CFX-Pre, all of the information required to perform a new serial run (on a single processor) is entered automatically. You do not need to alter the information in the Define Run dialog box. This is a very quick way to launch into ANSYS CFX-Solver without having to define settings and values.

1. Ensure that the Define Run dialog box is displayed.
2. Click Start Run.
   ANSYS CFX-Solver launches and a split screen appears and displays the results of the run graphically and as text. The panes continue to build as ANSYS CFX-Solver Manager operates.

Note: Once the second iteration appears, data begins to plot. Plotting may take a long time depending on the amount of data to process. Let the process run.

3. When ANSYS CFX-Solver is finished, click Yes to post-process the results.

Your project opens in CFX-Post.
When ANSYS CFX-Post starts, the viewer and **Outline** workspace are displayed.

The viewer displays an outline of the geometry and other graphic objects. You can use the mouse or the tool bar icons to manipulate the view, exactly as in ANSYS CFX-Pre.

You need to create an expression for the response parameter to be examined (Outlet Temperature) called OutTemp:

1. On the **Quantitative** tab, right-click on **Expressions > New**.
2. Type **OutTemp** and click **OK**.
3. In the **Definition** area:
   a. Right-click **Functions > CFX-Post > areaAve**.
   b. With the cursor between the parentheses, right-click and select **Variables > Temperature**.
   c. Left-click after the @, then right-click and select **Locations > Outlet**.
   d. Click **Apply**.
4. Open the **Expressions** branch. Right-click **OutTemp** and select **Use as DX Parameter**. A small "P" appears on the expression’s icon.
5. Click **File > Save State As**. In the dialog that appears, ensure that **StaticMixerDX.cst** is the file name and click **Save**.

**Important:** The expression you created is written in CEL (CFX Expression Language). There is some CEL that works in CFX-Pre and CFX-Solver, but not in CFX-Post, so you should create all expressions for DesignXplorer output parameters in CFX-Post. Any expression created in CFX-Pre and used as a DesignXplorer output parameter could potentially cause fatal errors during the DesignXplorer run.
Running Design Studies in DesignXplorer

Create the DesignXplorer Info File


   The Set up CFX/Design Explorer Study dialog appears.

2. Select the Specify Geometry Settings checkbox. This enables you to vary both inlets sizes and the second inlet’s orientation using the design parameters you created.

3. Specify the .def and state files that include the DX parameters selected earlier (these fields should already be filled).

   For the CFX/DX Info File, input a name such as TempStudy.cfdx and click Create CFX/DX Info File.

4. A pop-up informs you that the file was written. Click OK.

DesignXplorer Studies

From the DesignXplorer Startup Wizard you can configure:

• A What-if Scenario
• A Deterministic Design of Experiments Scenario
• A Six Sigma Design of Experiments Scenario
• A Robust Design Scenario.

The sections that follow provide examples of the first two of these studies. For more information, refer to the DesignXplorer help that is available from the Workbench project’s Help menu.

Configuring a What-if Scenario

1. On the StaticMixerDX[Project] page, highlight the .cfdx file and from the left pane click Run CFX/DX Study.

2. From the DesignXplorer Startup Wizard, choose What-if. Click Finish.

3. On the What-if Design Points page, click Sweep Input Parameters, which is near the bottom of the page.

4. Select the in1Vel input parameter from the dropdown list and select Uniform Sweep.

5. Specify the Start Value as 0 and the End Value as 3.
6. Specify the **Number of Points** = 3. (The number of CFD solver runs increases with number of points: with two input variables and three points each, nine solver runs are performed.)

7. Select the in2Vel input parameter and repeat the previous steps, but choose a **Start Value** of 1. Setting one input velocity to zero as a design point gives you a chance to confirm that the simulation provides reasonable results: if in1Vel is 0, the output temperature should be roughly the same as the temperature of in2Vel (even at 0 input velocity, in1 does have a small affect on the water temperature in the mixer).

8. Click **Preview**.

9. Click **Generate** to insert the design points into the DX study.
10. Select Run > Run Design Points. The status bar at the bottom of the window shows the progress of the operation.

11. When the Solver runs are complete, post-process the results by clicking Views > What-if Charts.

12. In the left pane click Views > Report to ensure the outputs are reasonable.

13. Save the DesignXplorer study and click on the X to close DesignXplorer.

Configuring a Design of Experiments Scenario

1. On the Project page, highlight the .cfdx file and from the left pane click Run CFX/DX Study.

2. From the DesignXplorer Startup Wizard, choose Deterministic, click Next, select Design of Experiments, and click Finish.

3. If asked to save your data, select Yes.

4. On the Parameters page, under Parameter Properties, enter a lower- and upper-bound for the input parameters. (Select the parameters in the left pane to do this.)

5. Click the lightning icon: Run > Run Design Points.

6. Once the solver runs have completed, click the Save icon to save the DesignXplorer Study.

Post-Process Results: Design of Experiments

Response Charts

1. Click Views > Responses, then Responses > Response Charts.
Here a response surface showing the variation of OutTemp with input various input parameters is displayed:

You can use the slide bars on the left to see how the output parameter varies with the changes you make to the input variables. This can be important when deciding the level of influence of input parameters over the response.

2. Create a figure (snapshot) for use in a report by clicking Insert Snapshot.
3. Click Views > Report in the left pane to see the figure in a report.
**Single-Parameter Sensitivity**

From the left pane select **Views > Responses**, then **Responses > Single Parameter Sensitivities**. You can use the sliders to examine the sensitivity of the outlet temperature to each of the inlet conditions:

![Image of ANSYS Workbench showing Single Parameter Sensitivities](image)

**Min/Max Search**

1. In the tool bar, click **Perform Min/Max Search**. The minimum and maximum values of the output parameter curvefit are returned.

**Goal-Driven Optimisation**

The objective in this set up is to maximise **OutTemp** while minimising the **in1diameter**.

1. Select **Goal Driven Optimisation** from the left pane.
2. In the right pane under **Input Parameter Goals**, set:
   - **in1diameter Desired Value** = Near Lower Bound, **Importance** = Higher
Tutorial 22: Optimizing Flow in a Static Mixer: Running Design Studies in DesignXplorer

- OutTemp Desired Value = Maximum Possible, Importance = Higher.

**Note:** If you have chosen different parameter boundaries, the values in the graphic will differ from the values you see on your screen.

**Input Parameter Goals**
Click rows in this table to assign design goals to input parameters.

<table>
<thead>
<tr>
<th>Name</th>
<th>Lower Bound</th>
<th>Upper Bound</th>
<th>Target</th>
<th>Desired Value</th>
<th>Importance</th>
</tr>
</thead>
<tbody>
<tr>
<td>In1diameter</td>
<td>1.8</td>
<td>2.2</td>
<td>Near Lower Bound</td>
<td>Higher</td>
<td></td>
</tr>
<tr>
<td>In2angle</td>
<td>-11</td>
<td>-9</td>
<td>No Preference</td>
<td>Default</td>
<td></td>
</tr>
<tr>
<td>In1Vel</td>
<td>2.7</td>
<td>3.3</td>
<td>No Preference</td>
<td>Default</td>
<td></td>
</tr>
<tr>
<td>In2Vel</td>
<td>2.7</td>
<td>3.3</td>
<td>No Preference</td>
<td>Default</td>
<td></td>
</tr>
</tbody>
</table>

**Response Parameter Goals**
Click rows in this table to assign design goals to response parameters. Defining a target value is optional.

<table>
<thead>
<tr>
<th>Name</th>
<th>Target</th>
<th>Desired Value</th>
<th>Importance</th>
<th>TradeOff</th>
</tr>
</thead>
<tbody>
<tr>
<td>OutTemp</td>
<td>-</td>
<td>Minimum Possible</td>
<td>Default</td>
<td>On</td>
</tr>
</tbody>
</table>

**Candidate Designs**
Generate or update candidate designs based on the current goals

3. In the Sample Generation section of the left pane, click Generate.

4. Click Generate or update candidate designs based on current goals.
   A list of possible design solutions appears:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Candidate A</th>
<th>Candidate B</th>
<th>Candidate C</th>
</tr>
</thead>
<tbody>
<tr>
<td>In1diameter</td>
<td>1.614</td>
<td>1.838</td>
<td>1.818</td>
</tr>
<tr>
<td>In2angle</td>
<td>-8.465</td>
<td>-8.966</td>
<td>-10.74</td>
</tr>
<tr>
<td>In1Vel</td>
<td>2.7667</td>
<td>2.7262</td>
<td>2.9637</td>
</tr>
<tr>
<td>In2Vel</td>
<td>3.063</td>
<td>3.307</td>
<td>3.183</td>
</tr>
<tr>
<td>OutTemp</td>
<td>307.96</td>
<td>307.74</td>
<td>306.14</td>
</tr>
</tbody>
</table>

Another important analysis is to optimize certain values of your design to obtain a required response. The table above shows the recommended input values when trying to aim for a specific output when using certain input parameters.

5. Select the most appropriate design candidate and click Insert selected candidate as a soft design.
   The chosen design is entered as a design point (under Custom Design Points in the left pane).

6. In the right pane under Tasks, click Generate a hard reference design based on this design.
   The solver starts with boundary conditions supplied to match the current design point, and then a new reference design based on the soft design is inserted into the tree. You can then rate the chosen design and choose whether to accept or reject this candidate.

7. Repeat the process as necessary until a suitable final design can be selected.

**Creating a Report**
1. In the left pane, click Report. The Design Parameters, Responses, Min/Max Search Results, Reference Design Points (with their ratings), and any figures generated during post-processing all appear in the report.

2. Click Publish Report in the tool bar to output the report as an HTML file.
If You Make Changes to Parameters...

If after running DesignXplorer tests you make changes to the parameters in the .cfx, .def, or .cst files, you need to recreate the .cfdx file in order to update the Parameter Manager. See Create the DesignXplorer Info File (p. 387).

Exiting

When finished, select **File > Exit**. If prompted to save, select **No** (because you do not want to save the parameter data).
Tutorial 23:
Aerodynamic & Structural Performance of a Centrifugal Compressor

Introduction

This tutorial includes:

- Tutorial 23 Features (p. 396)
- Overview of the Problem to Solve (p. 397)
- Reviewing the Centrifugal Compressor Design (p. 397)
- Creating the Mesh in ANSYS TurboGrid (p. 398)
- Defining the Aerodynamic Simulation in ANSYS CFX-Pre (p. 401)
- Obtaining a Solution using ANSYS CFX-Solver Manager (p. 403)
- Viewing the Results in ANSYS CFX-Post (p. 404)
- Importing Geometry into DesignModeler (p. 405)
- Simulating Structural Stresses Due to Pressure Loads (p. 406)
- Simulating Structural Stresses Due to Rotation (p. 407)

Note: This tutorial is intended to be run on Windows-based machines only.

If this is the first tutorial you are working with, it is important to review the following topic before beginning:

- Setting the Working Directory (p. 1)

BladeModeler requires an ANSYS license to use, although BladeGen will run in "demonstration" mode without the license (no saving or exporting is possible in this mode). Please contact your ANSYS representative to obtain a license for BladeModeler, if you do not already have one. To learn how to configure your licenses, see Configuring the BladeModeler License in the BladeModeler Help.

Unless you plan on running a session file for ANSYS CFX-Pre, you should copy the sample files used in this tutorial from the installation folder for your software (<CFXROOT>/examples/) to your working directory. This prevents you from overwriting source files provided with your installation. If you plan to use a session file, please refer to Playing a Session File (p. 402).

If you want, you may skip the mesh creation sections and proceed directly to Defining the Aerodynamic Simulation in ANSYS CFX-Pre (p. 401), using the provided Centrifugal_Compressor.gtm file.

Sample files referenced by this tutorial include:
- Centrifugal_Compressor.bgd
- Centrifugal_Compressor.gtm
- Centrifugal_Compressor.pre

Tutorial 23 Features

This tutorial addresses the following features of ANSYS Workbench.

<table>
<thead>
<tr>
<th>Component</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS BladeGen</td>
<td>Export</td>
<td>TurboGrid Input Files</td>
</tr>
<tr>
<td>ANSYS TurboGrid</td>
<td>Creating the Topology</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modifying the Topology</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modifying Control Points on Hub</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modifying Control Points on Shroud</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Setting Mesh Parameters</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mesh Size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Passage</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Inlet/Outlet</td>
<td></td>
</tr>
<tr>
<td>ANSYS CFX-Pre</td>
<td>User Mode</td>
<td>Turbomachinery</td>
</tr>
<tr>
<td></td>
<td>Machine Type</td>
<td>Centrifugal Compressor</td>
</tr>
<tr>
<td></td>
<td>Component Type</td>
<td>Rotating</td>
</tr>
<tr>
<td></td>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td></td>
<td>Boundary Template</td>
<td>P-Total Inlet Mass Flow Outlet</td>
</tr>
<tr>
<td></td>
<td>Flow Direction</td>
<td>Cylindrical Components</td>
</tr>
<tr>
<td></td>
<td>Domain Type</td>
<td>Single Domain</td>
</tr>
<tr>
<td></td>
<td>Timestep</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td>ANSYS CFX-Post</td>
<td>Report</td>
<td>Computed Results Table</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Blade Loading Span 50</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Streamwise Plot of Pt and P</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Velocity Streamlines Stream</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Blade TE</td>
</tr>
<tr>
<td>ANSYS DesignModeler</td>
<td>Create Blades</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Create Shroud Clearance</td>
<td>Relative Layer</td>
</tr>
<tr>
<td></td>
<td>Create Fluid Zone</td>
<td>No</td>
</tr>
</tbody>
</table>
Overview of the Problem to Solve

The following tutorial demonstrates the scope of ANSYS software components which can be used for simulation of rotating machinery applications. A centrifugal compressor with 24 blades and shroud tip clearance, rotating about the z-axis is used as an example. This tutorial analyses both the aerodynamic and structural performance of the compressor.

To begin analysis of the aerodynamic performance, a mesh will be created in ANSYS TurboGrid using an existing design which is to be reviewed beforehand in BladeModeler. Once the mesh has been created, initial parameters defining the aerodynamic simulation will be set in ANSYS CFX-Pre and then solved in ANSYS CFX-Solver. The aerodynamic solution from the solver will then be processed and displayed in ANSYS CFX-Post.

To simulate structural stresses on the blade due to pressure loads from the aerodynamic analysis, as well as rotationally induced inertial effects, the existing geometry must be imported to ANSYS Simulation. Here these simulations can be defined and run. The final results will be animated to display the blade distortion.

Reviewing the Centrifugal Compressor Design

This section involves using BladeGen in ANSYS Workbench. BladeGen is a geometry creation tool specifically designed for turbomachinery blades. Since there is already a geometry created for this tutorial, this section will only require you to review the blade design.

1. Start ANSYS Workbench.
2. Click **Empty Project**.
   The Project page appears.
3. Select **File > Save As** from the main menu and set an appropriate working directory for the simulation.
4. Save the project as **Centrifugal_Compressor.wbdb**.
5. Under **BladeGen**, click **Start BladeGen**.
6. When BladeGen opens select **File > Open** from the main menu and load the provided file, **Centrifugal_Compressor.bgd**.
7. Select **File > Export > TurboGrid Input Files** from the main menu. Ensure the working directory is set correctly and click **OK** to accept the default file names in the dialog box which appears.
Tutorial 23: Aerodynamic & Structural Performance of a Centrifugal Compressor: Creating the Mesh in ANSYS

Creating the Mesh in ANSYS TurboGrid

Using ANSYS TurboGrid a preliminary topology will be created and modified in order to eliminate overly large or small angles in the mesh. From this topology a final mesh will be created and imported into ANSYS CFX-Pre. If you wish, you can instead use the provided file, Centrifugal_Compressor.gtm and continue from Defining the Aerodynamic Simulation in ANSYS CFX-Pre (p. 401)

Defining the Shroud Tip

For this compressor the shroud is stationary and a tip gap exists between the blade and shroud. To define this accordingly:
1. Return to the Project page and locate Centrifugal_Compressor.inf. Double-click the entry associated with this file to load the input file in ANSYS TurboGrid.
2. Expand Geometry > Blade Set > Shroud Tip and double click to edit.
3. Set Clearance Type > Tip Option to Profile Number and specify the tip profile number as 2. Click Apply.

Creating the Topology

In ANSYS TurboGrid, you may choose a topology pattern based on the type of machine being analyzed. For this geometry, the H/J/C/L-Grid topology will be used.
1. Apply the following settings by opening Topology Set from the Objects:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Topology Definition &gt; Method</td>
<td>H/J/C/L-Grid</td>
</tr>
<tr>
<td>Include O-Grid &gt; Width Factor</td>
<td>0.2</td>
</tr>
<tr>
<td>Tip Topology &gt; Shroud</td>
<td>H-Grid Not Matching</td>
</tr>
</tbody>
</table>
2. Click Apply, then click Freeze to prevent unintended automatic changes to the topology.

Modifying the Topology

There are areas in the mesh which have small angles. These areas will be made more orthogonal by moving and inserting control points thereby increasing these angles.
1. From the main menu, select Display > Blade-to-Blade View > Use Passage Excluding Tip Transform.
2. Right-click a blank area in the viewer and select Transformation > Blade-to-Blade (Theta-M').
3. Click Hide all geometry objects and clear the visibility check box next to Layers > Shroud Tip to make the hub topology more visible.
4. Open Layers > Hub in the details view and double-click Minimum Face Angle to view the problem areas of the mesh.
5. Zoom in on the area of the mesh near the leading edge shown in Figure 1.
6. Select and move the control points as shown by the displacement vectors in Figure 1.

Figure 1     Modifying Control Points on the Hub

7. Confirm that the mesh statistics have improved for the Hub layer. Make further adjustments to the control points as necessary.

Modifying Control Points on the Shroud Layer

1. Clear the visibility check box of Layers > Hub and make Layers > Shroud Tip visible.
2. Open Layers > Shroud Tip in the details view and double-click Minimum Face Angle to view the problem areas of the mesh.
3. Select and move the two existing control points as shown by the black displacement vectors in Figure 2.

Figure 2 Modifying Control Points on the Shroud

4. Right click the area indicated by the tail of the white direction vector without a control point and select **Control Point > Insert Master**. Move this point in the direction and distance indicated.

5. Confirm that the mesh statistics have improved for the Shroud layer. Make further adjustments to the control points as necessary.

Setting up the Mesh Parameters

1. Open **Mesh Data** for editing under **Objects**.
2. Apply the following settings:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mesh Size</td>
<td>Node Count</td>
<td>Medium (100000)</td>
</tr>
<tr>
<td></td>
<td>Inlet Domain</td>
<td>(Selected)</td>
</tr>
<tr>
<td></td>
<td>Outlet Domain</td>
<td>(Selected)</td>
</tr>
</tbody>
</table>
3. Click **Apply**.

**Note:** Your mesh quality could decrease slightly after the node count is increased. If so, you might need to make minor adjustments to the hub and shroud control points to maintain the quality of your mesh before saving it and using it in the aerodynamic simulation that follows.

4. Open **Layers** for editing.
5. Right-click **Hub** and select **Insert Layer After** to insert a layer midway between the hub and shroud layers.
6. Select **File > Save State As** from the main menu and save the state as **Centrifugal_Compressor** in your working directory.

### Creating and Saving the Mesh

With the topology and mesh data defined, the next step is to create and save a medium node count mesh based on this data.

1. Click **Create Mesh** to create the mesh.
2. Select **File > Save Mesh As** from the main menu to open the **Save Mesh** dialog box.
3. Select **Combined in one domain, one file** under **Solver Type**.
   This selection is required to properly format the mesh for subsequent steps in the Turbomachinery wizard in ANSYS CFX-Pre.
4. Ensure the working directory is set correctly and save the mesh file as **Centrifugal_Compressor.gtm**.

### Defining the Aerodynamic Simulation in ANSYS CFX-Pre

After creating the mesh in ANSYS TurboGrid, it can be used in an aerodynamic simulation in ANSYS CFX. This section describes the step-by-step procedure for defining the simulation using the Turbomachinery wizard in ANSYS CFX-Pre.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Passage</td>
<td>Spanwise Blade Distribution Parameters &gt; Method Element Count and Size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Spanwise Blade Distribution Parameters &gt; # of Elements</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td>Spanwise Blade Distribution Parameters &gt; Const Element</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>O-Grid &gt; Method Element Count and Size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>O-Grid &gt; # of Elements</td>
<td>5</td>
</tr>
<tr>
<td>Inlet/Outlet</td>
<td>Inlet Domain &gt; Override default # of Elements (Selected)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Inlet Domain &gt; # of Elements</td>
<td>50</td>
</tr>
<tr>
<td></td>
<td>Outlet Domain &gt; Override default # of Elements (Selected)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Outlet Domain &gt; # of Elements</td>
<td>25</td>
</tr>
</tbody>
</table>
Tutorial 23: Aerodynamic & Structural Performance of a Centrifugal Compressor: Defining the Aerodynamic

Playing a Session File

If you wish to skip past these instructions, and have ANSYS CFX-Pre set up the simulation automatically, you can select Session > Play Tutorial from the menu in ANSYS CFX-Pre, then run the session file: Centrifugal_Compressor.pre. After you have played the session file as described in earlier tutorials under Playing the Session File and Starting ANSYS CFX-Solver Manager (p. 87), proceed to Obtaining a Solution using ANSYS CFX-Solver Manager (p. 403).

Creating a New Simulation

This tutorial will use the Turbomachinery wizard in ANSYS CFX-Pre. This pre-processing mode is designed to simplify the setup of turbomachinery simulations.

1. Click on the Centrifugal_Compressor workbench project (the .wbdb file on the project page), then in the left pane under Advanced CFD, click Start CFX-Pre.
2. Select File > New Simulation.
3. Select Turbomachinery and click OK.
4. Select File > Save Simulation As.
5. Under File name, type Centrifugal_Compressor.
6. Click Save.
7. In Basic Settings define Machine Type as Centrifugal Compressor.
8. Click Next to advance to Component Definition.

Component Definition

A rotor component needs to be defined using the mesh in the Centrifugal_Compressor.gtm file.

1. In the blank area, right-click and select New Component.
2. Set the name to Rotor and click OK.
3. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component Type &gt; Type</td>
<td>Rotating</td>
</tr>
<tr>
<td>Component Type &gt; Value</td>
<td>22360 [rev min^-1]</td>
</tr>
<tr>
<td>Mesh &gt; File</td>
<td>Centrifugal_Compressor.gtm*</td>
</tr>
<tr>
<td>Mesh &gt; Available Volumes &gt; Volumes</td>
<td>Passage</td>
</tr>
<tr>
<td>Wall Configuration &gt; Tip Clearance at Shroud</td>
<td>Yes</td>
</tr>
</tbody>
</table>

* Select CFX Mesh (*gtm *cfx) as the File Type if Centrifugal_Compressor.gtm is not visible.

4. Click Next to advance to the Physics Definition panel.

Physics Definition

In this section, you will set properties of the fluid domain and solver parameters.
1. Apply the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fluid</td>
<td>Air Ideal Gas</td>
</tr>
<tr>
<td>Simulation Type</td>
<td>Steady State</td>
</tr>
<tr>
<td>Model Data &gt; Reference Pressure</td>
<td>1 [atm]</td>
</tr>
<tr>
<td>Boundary Templates &gt; P-Total Inlet Mass Flow Outlet</td>
<td>(Selected)</td>
</tr>
<tr>
<td>Boundary Templates &gt; P-Total</td>
<td>0 [atm]</td>
</tr>
<tr>
<td>Boundary Templates &gt; T-Total</td>
<td>20 [C]</td>
</tr>
<tr>
<td>Boundary Templates &gt; Mass Flow</td>
<td>Per Component</td>
</tr>
<tr>
<td>Boundary Templates &gt; Mass Flow Rate</td>
<td>0.167 [kg s⁻¹]</td>
</tr>
<tr>
<td>Boundary Templates &gt; Flow Direction</td>
<td>Cylindrical Components</td>
</tr>
<tr>
<td>Boundary Templates &gt; Inflow Direction (a, r, t)</td>
<td>1, 0, 0</td>
</tr>
<tr>
<td>Solver Parameters &gt; Convergence Control</td>
<td>Physical Timescale</td>
</tr>
<tr>
<td>Solver Parameters &gt; Physical Timescale</td>
<td>0.0002 [s]</td>
</tr>
</tbody>
</table>

2. Click Next to advance to the Interface Definition panel.

**Interface and Boundary Definition**

The default settings for the next two panels are sufficient for this tutorial and need not be changed.

1. Click Next to advance to the Boundary Definition panel.
2. Click Next to advance to the Final Operations panel.

**Final Operations**

Now that the solver parameters and boundary conditions have been set, a definition file needs to be written to be used in ANSYS CFX-Solver Manager to solve for the associated physical variables.

1. Set Operation to Start Solver and enter Centrifugal_Compressor for Solver File Name then click Finish.
   ANSYS CFX-Solver Manager opens.

**Obtaining a Solution using ANSYS CFX-Solver Manager**

The Define Run dialog box allows configuration of a run for processing by the ANSYS CFX-Solver.
Tutorial 23: Aerodynamic & Structural Performance of a Centrifugal Compressor: Viewing the Results in ANSYS

When ANSYS CFX-Solver Manager is launched automatically from ANSYS CFX-Pre, all of the information required to perform a new serial run (on a single processor) is entered automatically. You do not need to alter the information in the Define Run dialog box. This is a very quick way to launch into ANSYS CFX-Solver without having to define settings and values.

1. Click Start Run.
   ANSYS CFX-Solver launches and a split screen appears and displays the results of the run graphically and as text. The panes continue to build as ANSYS CFX-Solver Manager operates.
2. When ANSYS CFX-Solver is finished, click Yes in the dialog box that appears to post-process the results.
3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.

Viewing the Results in ANSYS CFX-Post

ANSYS CFX-Post automatically post-processes the results from the solver that can be viewed in a number of ways including tables, and both 2-D and 3-D plots. The options for displaying individual results can be selected through the Outline tab while a full summary in the form of a report can also be generated and exported for viewing externally.

1. When ANSYS CFX-Post loads, a dialog box will appear prompting the load of the Centrifugal Compressor Rotor Report. Click Yes.
2. In the Outline tab under Report double click Computed Results Table. This table presents measures of aerodynamic performance including required power and efficiencies.
3. In the Outline tab under Report double click Blade Loading Span 50. This is a plot of the pressure vs. streamwise distance along both the pressure and suction sides of the blade at mid-span.
4. In the Outline tab under Report double click Streamwise Plot of Pt and P. This is a plot of the streamwise variation of pressure and total pressure.
5. In the Outline tab under Report double click Velocity Streamlines Stream Blade TE View.
6. To view a fully inclusive report, click on the Report Viewer tab found near the bottom right of the window. A report will be generated (this may take a few minutes) to include all figures available under Report in the Outline tab. This report can be viewed in ANSYS CFX-Post or exported to be viewed externally as an .html or .txt file.

7. To export this report, click on the Publish button in the toolbar just above the Report Viewer.

8. In the window that appears click OK. By default the format is .html and the location is your working directory under the name CompressorRotorReport.html. The report may take a few minutes to generate and save.

9. Select File > Save State to save the Post State file as Centrifugal_Compressor.cst.

**Importing Geometry into DesignModeler**

In order to perform static structural analysis of the compressor blade, the geometry must be imported into DesignModeler.

1. At the top of the ANSYS Workbench window, click Centrifugal_Compressor [Project] to return to the Project Page.

2. Ensure that the Centrifugal_Compressor.wbdb file is selected.

3. In the left pane, near the top under Create DesignModeler Geometry, click New Geometry.

4. Accept the default unit of Millimeter.

5. Click the BladeEditor button located in the top-right portion of the window.

6. Open the file Centrifugal_Compressor.bg

7. In the Tree Outline select ImportBGD1.

8. In the Details view set Create Hub to 1, Create Blades to 1, Create Shroud Clearance to Relative Layer (to appropriately model the presence of the tip gap) and Create Fluid Zone to NO then click the Generate button in the toolbar.
Simulating Structural Stresses Due to Pressure Loads

This section describes the steps required to simulate structural stresses on the blade due to pressure loads from the aerodynamic analysis.

1. At the top of the ANSYS Workbench window, click Centrifugal_Compressor [Project] to return to the Project Page.
2. Select Tools > Options from the main menu.
3. Under Meshing > Meshing > Default Method ensure that CFX-Mesh is selected and click OK.
4. Make sure that Centrifugal_Compressor agdb is selected then on the left panel click New Simulation under DesignModeler Tasks.
5. Expand Mesh in the Outline view and click on CFX-Mesh Method.
6. In the Details view below set Definition > Method to Automatic, then right-click on Automatic Method in the Outline view and select Generate Mesh.
7. From the toolbar click on New Analysis > Static Structural.
8. In the Outline right click on Static Structural and select Insert > CFX Pressure.
9. Highlight the broad side of the blade in the viewer and click Apply, found next to Geometry in the Details View.
10. Under Definition in the Details View choose Import for the CFX Surface option.
11. If necessary browse to the CFX results file from your working directory and select Rotor Blade from the list of Surfaces and 0 s from the list of Time Values. Click OK.
   It may take a few seconds to apply these settings.
12. Right click on Static Structural in the Outline and select Insert > Fixed Support.
13. In the viewer, right-click on a blank area of the screen and select View > Top. Select the long thin face of the blade that is at the forefront of the displayed geometry and click Apply, next to Geometry in the Details section. This face is connected to the hub.
14. Right click Solution under Static Structural in the Outline and select Insert > Stress > Equivalent (von-Mises).
15. From the toolbar click the Solve button.
   When the solver has finished (this may take a few minutes) left click on Static Structural > Solution > Equivalent Stress to examine the results
16. To animate the physical deformation of the blade along with the associated von-Mises Stress, click the Play button in the Animate window below the Geometry Viewer.

Note: You may need to drag the viewer window up in order to see the Animate window.

17. Right click on Solution under Static Structural in the Outline and select Insert > Deformation > Total.
18. From the toolbar click the Solve button.
Simulating Structural Stresses Due to Rotation

This section describes the steps required to simulate structural stresses on the blade due to pressure loads from the aerodynamic analysis as well as the inertial effects due to rotation.

1. Right click Static Structural from the Outline and select Duplicate.
2. Right click on the newly created object, Static Structure 2 and rename it to With-Rotation.
3. Making sure that With-Rotation is selected from the Outline click the Inertial button in the toolbar and select from its option’s Rotational Velocity.
4. In the Details view for Rotational Velocity change Define By to Components.
5. Click on Units > RPM from the main menu.
6. In the Details view, enter a Z component of 22360 RPM.
7. Select Solution under With-Rotation from the Outline and click the Solve button on the toolbar.
8. To animate the Total Deformation or von-Mises Stress of the blade, select one found under Static Structural > Solution in the Outline and click the Play button in the Animate window below the Geometry Viewer.
9. Save simulation as Centrifugal_Compressor.dsdb and return to the Project Page.
10. Click on File > Save All from the main menu and exit Workbench.
Index

**Numerics**

2D primitives
  viewing 255

**A**

additional variables
  creating 228
  setting 97
  to model pH
  creating 228
airlift reactor example 269
animation
  plot animation 297
ANSYS Field Solver (Structural) plot 364
ANSYS Interface Loads (Structural) plot 365
ANSYS Out File tab 365
automotive catalytic converter tutorial 185
axi-symmetric modelling example 223

**B**

baffles example 253
blade, impeller 253
boundary condition profile file
  creating 84
boundary conditions
  for free surface flows 142
  modifying 101
buoyancy
  example 127
butterfly valve example 165

catalytic converter
  automotive 185
  example 185
cavity example 127
CEL limitations
  create DX expressions in CFX-Post 386
centrifugal compressor 395
CFX-Mesh Options
  configuring for DesignXplorer 371
chemical reaction example 223
CHT
  example 239
  CHT example 239
circular vent example 93
combustion
  calculating mass fractions 309, 316
  eddy dissipation model 301
  in a can combustor 299
  laminar flamelet model 311
  and multicomponent fluids 226
  variable composition mixture 302
  viewing concentrations 315
combustion efficiency 309
combustion models
  loading multiple 316
conjugate heat transfer
  example 239
Contour 318
Contour plots 354
contours
  adding to surface plot 24, 52
  contours, adding 24, 52
  create
    boundary conditions 113, 243, 338
    fluid domain 189
    isosurface 105
Index: D

pressure and volume fraction
expressions 142
subdomain 190
surface plot of y+ 123
vectors 121
creating and modifying streamlines 88

D

default
legend 19, 47
Define CFX/DesignXplorer study
how to 387
Design of Experiments scenarios
configuring 387, 389
design parameters
applying to a diameter 375
applying to a new plane 376
DesignXplorer
configuring Workbench for 371
how to create Min/Max reports 392
static mixer optimization 369
DesignXplorer parameter
creating a new 383
DesignXplorer projects
use wbdb project files 372
DesignXplorer studies
configuring 387, 389
diameter
making into a design parameter 375
domain
creating 231
DX parameter
creating a new 383

E

examples 1
2D model 127
2D modeling with 3D mesh 361
3D region subdomain 337
aerif reactor 269
axi-symmetric 223
buoyancy 127
butterfly valve 165
calculating mass fractions 309, 316
catalytic converter 185
chemical reaction 223
CHT 239
combustion eddy dissipation
model 301
combustion efficiency 309
combustion in a can combustor 299
combustion models 311
compiling a Fortran subroutine 287
configuring moving mesh 337, 338
conjugate heat transfer 239
controlling the output of transient
results 218
creating a boundary condition profile
file 84
creating a profile boundary
condition 84
creating a subdomain 190, 232, 243
creating additional variables 228
creating mesh adaption 146
creating minimal transient results
files 103
DesignXplorer 369
discrete transfer radiation model 311
exporting 2D stress 248
Fluid-Structure Interaction (FSI) 333
Fortran calling names, use lower-case
for 289
Fortran subroutines, compiling 173
free surface 139
gas-liquid flow in an airlift reactor 269
heat exchanger 239
loading multiple combustion
models 316
mixing tube 223
Monte Carlo thermal radiation
model 289
moving mesh, configuring 360, 361
multicomponent flow 223
multiphase flow 269
P1 radiation model 301
partitioned cavity 127
radiation 310
radiation in a can combustor 299
radiation modeling 291
radiation models 311
radiation P1 model 301
radiation properties 303
setting a transient case in
animations 107
setting additional variables 97
setting options for a transient
scheme 350
setting radiation flux 291
setting radiation intensity 293
setting the transient scheme 340
setting up a transient simulation 347
solid region 239
static mixer 3, 31
static mixer optimization 369
steady state simulation 223, 239
supersonic flow 155
thermal radiation controls 314
thermal radiation modeling 291
thermal radiation models 312
transient animation, creating 221
transient ANSYS multi-field run 359
transient file in animation 107
transient mechanical analysis 356
transient results files, creating 293
transient results files, writing at intervals 363
transient results, configuring 133
transient rotor-stator 216
transient scheme 293
transient scheme, setting solver controls for 362
transient simulation 100, 127
transient simulation requires initial values 350
transient simulation type, configuring 130
transient simulation, enables mesh deformation 336
transient simulation, requires initial values 339, 362
transient simulation, uses Automatic With Value option 132
user CEL functions, using Fortran subroutines with 174
using CEL expressions with a moving mesh 334
valve 165
vent 93
viewing 2D primitives 255
viewing concentrations 315
wing 155
writing transient result files at intervals 340
expression
creating a new 386
expression language
shear rate dependent viscosity 202
velocity profile 172
expression method for inlet velocity profile 172
expressions
create in CFX-Post for DX 386
expressions to model the reaction creating 231
External Coupling
how to choose 362
features
blade loading span 50 396
Centrifugal Compressor 396
CFX Pressure 397
computed results table 396
cylindrical components 396
fixed support 397
physical timescale 396
p-total inlet mass flow outlet 396
relative layer 396
steady state 396
streamwise plot of pt and p 396
total deformation 397
turbomachinery 396
velocity streamlines stream blade 396
Von-Mises stress 397
Field Solver (Structural) plot 364
fixed support
defining 357
flow example
gas-liquid 269
multicomponent 223
multiphase 269
supersonic 155
fluid subdomain
creating 232
fluid-solid interactions 354
fluid-solid interface
defining 357
Fluid-Structure Interaction (FSI)
example 333
small mesh displacements in 366
Fortran calling names
use lower-case for 289
Fortran compiler
determining 173, 285, 287, 346
Fortran subroutine
compiling 287
Index: G

Fortran subroutines
  compiling 173
free surface
  example 139
  setting boundary conditions 142

G

gas-liquid flow example 269
generating output files 106
Goal Driven Optimization
  how to run 391

H

heat exchanger example 239

I

impeller blade example 253
inlet (supersonic) 158
Interface Loads (Structural) plot 365

M

master control point 400
mesh adaption
  creating 146
mesh deformation
  requires transient simulations 336
mesh displacements
  magnifying 366
method for the inlet velocity profile, expression 172
mixer
  static mixer example 3, 31, 369
mixing tube example 223
model
  creating 61
modelling example
  2D 127
  axi-symmetric 223
modify
  streamlines 88
moving mesh
  configuring 337, 338, 360, 361
  example 333
  using CEL expressions with 334
multicomponent flow example 223
multiphase
  flow example 269
multiphase mixer example 251

N

Named Selection Prefixes
  configuring for DesignXplorer 371
Named Selection Processing
  configuring for DesignXplorer 371
new plane
  creating as a design parameter 376

O

obtaining a solution
  in parallel 117
  in serial 116
outlet (supersonic) 159
outline plot 16, 44
output files
  generating 106

P

P1 radiation model 301
parallel
  running 116
parallel solution example 219
Parameter Processing
  configuring for DesignXplorer 371
Personal Parameter Key
  configuring for DesignXplorer 371
pH, calculating 230
power syntax 125
pressure
  defining 357
printing greyscale 309
profile boundary condition
  creating 84
project
  creating in Workbench (DesignXplorer) 371
publish report 405
Index: R

R

radiation
  in a can combustor 299
  modeling at a window 291
  setting a Monte Carlo thermal model 289
  viewing 310
radiation flux
  setting 291
radiation intensity
  setting 293
radiation models
  discrete transfer 311
radiation properties
  setting 303
reaction
  defining 229
run
  in parallel 116
  monitoring 220
Run Design Points
  how to 389

S

set
  boundary conditions 290, 304
  buoyancy reference density 143
  initial values 161
  transient rotor-stator calculation 216
simulation example
  steady state 223, 239
  transient 127
simulations
  creating a solid material in 356
  creating solid physics in 355
solid
  region example 239
solid deformations
  modeling 354
solvers
  coupling two to model interactions 354
stagger iterations 362
static
  mixer example 3, 31
steady state simulation example 223, 239
streamlines
  creating and modifying 88
structural properties
  defining 356
subdomain
  a 3D region 337
  creating 190, 232, 243
superficial velocity 281
supersonic flow
  example 155
surface plot 124
syntax, power 125

text
  auto-annotation 106, 297
thermal radiation
  modeling at a window 291
thermal radiation controls
  setting 314
thermal radiation models
  setting 312
transient animation
  creating 221
transient ANSYS multi-field run
  executes as time steps 359
transient case
  setting in animations 107
transient file
  used in animations 107
transient mechanical analysis
  example 356
transient result files
  writing at intervals 340
transient results
  configuring 133
transient results files
  creating 293
  creating minimal 103
  writing at intervals 363
transient rotor-stator calculation 216
transient scheme
  setting 293, 340
  setting solver controls for 362
transient scheme, setting options for 350
transient simulation
  enables mesh deformation 336
  initial values required 350
  modifying the domain for 217
  requires initial values 362
  setting up 347
transient simulation type
  configuring 130
defining 100
transient simulation, uses Automatic With Value option 132
transient simulations
example 93, 127
require initial values 339
tutorial examples 1
<italic>see also examples
two-dimensional modelling example 127

U

user CEL functions
using Fortran subroutines with 174
user function names
must differ from user routine names 175
user routine names
must differ from user function names 175
using
cfx5mkext command 173, 288, 346
symmetry planes 119

V

valve
example 165
variables
user vector 163
velocity
superficial 281
vent example 93
viewing
inflated elements 72
mesh partitions (parallel only) 125
results 149

W

wall
boundary conditions 292, 306
free slip 113
wbdb files
using with DesignXplorer projects 372
What-If scenarios
configuring 387, 389
wing example 155
Workbench
configuring for DesignXplorer 371
starting on Windows 371